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As we release another issue I would like to introduce myself. 
I go by the handle everywhere on the Internet as historyb, 
my real name is Doug and I am the new Assistant Editor in 
Chief. 

I have been using Linux since Mandrake 8.1 (now known as 
Mandriva) and I love every minute of it. There have been 
bumps along the way such as my Hardware not being 
recognized at times and I googled and searched for help on 

the Internet, then I transferred to Mepis Linux. I was happy but there were problems and I 
found PCLinuxOS (PCLOS) which did what I always thought a Linux Distribution should 
do, work the first time all the time. 

PCLOS is the best beginner's distribution out there in my humbled opinion and I am very 
happy to be helping out with the wonderful Magazine that you are now reading. We have a 
very exciting issue this month with articles ranging from the continuing KDE User Guide to 
an NVidia FAQ.

Enjoy and keep using Linux (PCLinuxOS :) )
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Hello everybody.
         
I've been a pclos user for well over a year now and am just 
loving it. Making my first post because frankly, i haven't yet had 
the need to. I've always somehow managed to fix my errors with 
google and the help of this forum. Many hours of reading and 
playing. I just figure its time to thank everyone out there for 
providing the best distro for a windows refugee, and making it 
easy for the change. Tex, and all your developers, forum 
members, and everyone working in the background deserve a 
resounding "Thank You". Within the course of a year I've 
managed to convert my wife, two sons, 2 brothers and a few 
friends to PCLinux and they are all happy with the change, as 
am I.   Can't thank you all enough, happy holidays to all. One 
other thing, it's time to make that pass donation as well.

mikej

Hello

I started out with Mandrake several years ago, but gave up on it 
because of hardware compatibility issues.  Then a recent article 
in a PC World mag lead me to try Ubuntu.  I was thrilled to find 
that Linux had progressed to the point that a  novice like me 
could use it.  Then, after several months with Ubuntu, I read 
about PCLOS on distrowatch.  Ubuntu was great, but I've made 
the switch.  I will be with PCLOS for a long time, I believe.  Many 
thanks to all involved!

Waldo22 
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Even though I'm quite new in this community I would like to 
share with you some thoughts about PCLOS; I'll try to do it by 
telling you my story about becoming a PCLOS user...
So... After 8 long years of using Windows (lucky me: just 98SE 
and XP Pro SP2) as an average user on 5 or 6 different 
machines, at the end of November 2007 I felt an unexplained 
urge of switching to Linux...
Being a very methodical and logical person, I started surfing the 
net in search for the best suitable distro for a complete 
"innocent" like me... I found out quickly that they are hundreds of 
distros available, many of them being freeware and some of 
them not. I kind of got deceived by this because until then I was 
convinced that all the Linux distros are available free of 
charges... Ok, so I learned my first lesson!
Next I started filtering the long list of opportunities mainly by the 
live-CD criteria; then I downloaded 5 or 6 iso-s and burned them 
to cd-s or dvd-s. I'm speaking here about distros like Fedora 
core, Kubuntu, Ubuntu, Kiwi, etc. but not PCLOS yet! I tried 
every single one of them hoping to understand a minimum 
amount of knowledge about how they work. I simply just couldn't! 
Besides, without any exception, I could not even make any of 
them connect to the Internet...
But I am also a very persevering person so I returned to the Net 
and read hundreds of forum pages about everyone of them... 

Until one late night when I read a very praising post about 
PCLOS being the real solution (I think it was from an Ubuntu 
forum)... First thing next morning was to download the 2007 live-
cd; I restarted my laptop and... Could not believe my eyes: all my 
hardware was recognized and above all I was connected to the 
Internet!!! From that very moment I stopped searching for 
anything else.
Being not sure about resizing my XP partition I purchased an 
external hdd and I installed PCLOS. A real piece of cake, a 
genuine child play... In less than 20 minutes it was done!
The only problem I encountered was generated by my Windows-
lining ISP  Angry who assigns different IP-s for the Linux clients 
and for the Windows clients; every switch between these OS-s 
made my cable modem dizzy and had to restart it... I solved the 
problem by simply purchasing a router! Wink
About PCLOS what can I say that wasn't already been said on 
this forum?! It's strong, it's steady, it's friendly, it's modern, and 
most of all it's indeed
RADICALLY SIMPLE!
And for me that means lovely...

See you next post!
Regards,
Peter
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Hi Everyone

I've used linux as a desktop user since 2003 and have tried 
distros right, left and centre. I started with Suse linux which, 
frankly, was the only distribution I could get to load on my old 
PC.  It was great but at the time if you added any hardware, 
wanted to add software, etc, linux was a nightmare for a newbie. 
Being adventurous (-ish) I experimented with other distros and 
got to like the debian package management system.  Oddly 
enough, at the time Mandrake as it was then called had a 
newbie friendly reputation, but I found this not to be the case and 
as time has passed I've tried everything from Slackware to 
Puppy including some so obscure that you have to search hard 
to find them.   
As a computer hobbyist, I have picked up bits and pieces to help 
with the command line, learned all sorts of package systems and 
found bits of software that I like in all distributions.  I've learned 
to love linux. I can partition with the best of them and even have 
an idea of what is happening when my computer carries out an 

action (something I never knew as a Windows user).
However, I've always found something missing in most linux 
OS's. I wonder if anyone else has always had the feeling that 
they'd like good bits from various distros but one distro didn't do 
it? Well, after 5 years, I think I've found it!  I'm a bit shocked too 
as I'd tried PCLOS in the past and found it similar to Mandrake.
 Now I see it in a new light. I've found that things I had to 
struggle to make work elsewhere, work here without hassle. 
These are too numerous to list. I'm sure I will still play with other 
linuxes on a test box but I'm happy to use PCLOS everyday and 
look forward to a long mutually satisfying relationship with it. (Too 
gushing?)
Off to work out how to contribute in some way. Thanks to all 
involved. Looking forward to fun computing

Browneyman
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Dansguardian HowtoDansguardian Howto

Setting up Parental Controls

Use Synaptic to download the following packages and their 
dependencies:
DansGuardian
kdeadmin-ksysv
webmin
After Synaptic finishes downloading and installing the packages, 
you will need to edit some files.  Using PC-menu -> System -> 
File Tools -> File Manager - Super User Mode" is probably the 
easiest way to do this.
Edit /etc/squid/squid.conf (you can double-click the file and it will 
open up in Kwrite)
find the line
http_port 3128

and change it to
http_port 3128 transparent

then copy and paste these lines to the end of the file:
always_direct allow all

cache_effective_user squid

cache_effective_group squid

Edit /etc/dansguardian/dansguardian.conf
look for
filterip =

and change it to
filterip = 127.0.0.1

change
usernameidmethodproxyauth = on

to
usernameidmethodproxyauth = off

find the following lines in the text (near the bottom):
# daemonuser = 'nobody'

# daemongroup = 'nobody'

and replace them with (make sure to delete the # at the 
beginning of each line):
daemonuser = 'squid'
daemongroup = 'squid'
Edit /etc/rc.d/rc.local (NOTE: double-clicking this file will execute 
it, so instead, right-click -> Open With -> Kwrite)
Paste the following lines at the end of the file (make sure that 
wrapped lines in this document end up on one line in the text 
file):
iptables -t nat -A OUTPUT -p tcp --dport 80 -m owner --uid-
owner squid -j ACCEPT
iptables -t nat -A OUTPUT -p tcp --dport 3128 -m owner --uid-

by S. Christian Collins
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owner squid -j ACCEPT
iptables -t nat -A OUTPUT -p tcp --dport 80 -m 
owner --uid-owner root -j ACCEPT

iptables -t nat -A OUTPUT -p tcp --dport 80 -j 
REDIRECT --to-ports 8080

iptables -t nat -A OUTPUT -p tcp --dport 3128 -
j REDIRECT --to-ports 8080

Download the DansGuardian-webmin module from here: 
http://sourceforge.net/projects/dgwebminmodule/
Next, install the DansGuardian-webmin-module in Webmin by 
opening the following link in your browser: 
https://localhost:10000/webmin/edit_mods.cgi
Click "Webmin Modules", and you will choose to "Install module 
from local file."  Click the "..." to browse the file. If you saved it to 
your desktop, for example, the file will be at 
/home/user/Desktop/..., where user is your user name. After 
you've selected the file, click "Install Module". Now, click the 
"Servers" button at the top of your webmin browser and click 
"DansGuardian" to see the options.  DansGuardian isn't running 
yet, but you can still edit configuration files if you want.
Next, you need to make sure your PC has a so-called 
"hostname", or things might not work right. You can set the 
"hostname" by opening the PCLinuxOS Control Center and enter 
the tab "Network & Internet", section "Alter miscellaneous 
internet settings." Set a qualified hostname. You can invent 

something fancy but "mypc.mynetwork.net" will do fine for now. A 
fully qualified domain name is always in the form of 
name.network.net (or .com, or whatever). After changing the 
domain name, a dialog may suggest that you restart the session. 
Ignore it for now and proceed.
Now, as of this writing (12/01/07) PCLinuxOS seems to have a 
bug in the init script dependencies checking (see this thread: 
http://www.pclinuxos.com/index.php?option=com_smf&Itemid=26
&topic=35073.msg268580#msg268580). 
This means that the services required for the Internet filtering 
may not start in the correct order during boot, causing 
DansGuardian to not load. Until the bug is fixed, the following 
solution should work just fine.
Start KsysV (PC Menu -> System -> Configuration -> Boot and 
Init -> KsysV).  The first time you run KsysV, it will ask some 
questions. For your OS, select “Linux”, for distribution, select 
“Other”, then accept the default paths on the next screen.
The main control window will appear. Under “Runlevel 5”, scroll 
down until you see dansguardian on the list and make note of the 
number (it's 92 on my system). We need squid to start before 
dansguardian, and we need network and network-up to start 
before squid. On my system, squid, network and network-up are 
all no. 99. As you probably have guessed, the earlier numbered 
services start first. If your system already shows the correct 
order for the aforementioned services, then your setup is 
probably not affected by this bug.
Right-click on a service to change its sorting number. Use the up 
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and down arrows to select the new number, since typing it 
sometimes doesn't take effect for some reason. Here is how I 
have set my sorting numbers, and this works just fine:
70 network
70 network-up
80 squid
Click the save icon to save the configuration.
Restart your computer, so that the necessary services will start 
on boot. One way to tell if everything is booting in the right order 
is to watch the init script while booting. Do this by pressing the 
ESC key while the system loads. Make note of anything that says 
[FAILED] to the right. If the services don't load in the correct 
order, then DansGuardian will fail with the message “error 
connecting to parent proxy”. Please note that the following action 
could possibly reset the startup order. 

Action: Performing an upgrade of related system services 
through Synaptic, (the package chkconfig is responsible for this, I 
believe, but I'm not an expert in this area) meaning you may have 
to use KsysV again using the “Enable or disable system 
services” option in the PCLinuxOS Control Center.
If you avoid doing either of those things, you shouldn't have to 
worry. Otherwise, you will need to reset the order again.
To edit the configuration of your web filtering software, log onto 
Webmin with a browser using the address: 
https://localhost:10000. Click on Webmin Modules, and then 
DansGuardian to control the settings. Webmin can also be set up 
to allow remote administration from another computer.
Hope this brings everyone up to date on this very useful 
application.
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How to print to a shared Windows printerHow to print to a shared Windows printer
by Intoit

Source: PCLinuxOS Forums

I've read a few posts about setting up a printer connected to a 
Windows box. Having the printer connected to the windows box 
is an  easy way to share a printer on a home network. The 
following methods have worked for me and hopefully it will help 
someone else. This is for XP systems, but it may work for Vista 
as well. 

How to set up a printer in a Windows XP Workgroup. 

This tutorial will show you how to set up your printer from PCLOS 
and also assumes that you have installed PCLinuxOS, have your 
home network setup,  that you can communicate between your 
windows computers and your Linux computers and also that your 
printer is connected to one of the Windows computers in your 
home network. 

 On the Windows machine Make sure your printer is turned on. 
Next, you will need to set your printer to share. 
 Go to ->Start ->Control Panel ->Printers and Faxes 
Select your printer and right click on the Icon. This will give you a 
pop-up window. 

 Select ->Sharing. Another window will pop up. Select the 
Sharing tab. Select Share this printer and enter a share name. 

(You will need this name later so you should write it down). Press 
OK Use the back arrow (<) to get back to the Control Panel. 

Select ->System ->Computer Name. Make a note of the 
Workgroup (write it down, you will need it). Next, we need the IP 
address of the windows computer. Make sure you are plugged 
into your network. Go to ->Start ->All Programs ->Accessories -
>Command Prompt In the pop-up window type "ipconfig"and 
press enter

In the window you will see a line that reads 

IP Address.............:192.168.x.xxx. 

Write this number down (you will need it later). Type "exit" to 
close the window

On the Linux (PCLinuxOS 2007) computer

Open PCLinuxOS Control Center

Go to Hardware -> Set up the printer(s)

Select ->Add a new printer to the system
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Check the box beside "Auto detect printers connected to 
machines running Microsoft Windows"

Press Next

After searching, you will be presented with the printer choices, 
select the appropriate printer.

Press Next

Printerdrake will search for the appropriate driver. 

Select the correct model and press Next

A pop-up appears asking if you want to set the printer as default.

Make your choice and press Next

The next window will be for printing the test page. 

Make your choice and press Next

In the next window choose Yes or No

Press Next

Congratulations, you should now have a printer on your network.

Press Finish

How to set up a printer in a Windows 
XP Workgroup using KDE.

Make sure your printer is turned on.  Next, you will need to set 
your printer to share. 

(Windows machine)

Go to ->Start ->Control Panel ->Printers and Faxes
Select your printer and right click on the Icon. This will give you a 
pop-up window. 
Select ->Sharing. Another window will pop up. 

Select the Sharing tab.

Select Share this printer and enter a share name. (You will 
need this name later so maybe write it down).

Press OK

Use the back arrow to get back to the Control Panel. Select -
>System ->Computer Name. Make a note of the Workgroup 
(write it down, you will need it).
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Next, we need the IP address of the windows computer. Make 
sure you are plugged into your network.  

Go to ->Start ->All Programs ->Accessories ->Command 
Prompt In the pop-up window type "ipconfig" and press enter

In the window you will see a line that reads 

IP Address.............:192.168.x.xxx.

 Write this number down (you will need it later). Type exit to close 
the window On the PCLinuxOS computer Open KDE Control 
Center Go to Peripherals -> Printers Select ->Administration 
tab Enter your Root password Select -> Add. The printer 
configuration window will appear.

press Next

Select ->SMB shared printer (Windows)

press Next

I always use -Normal account- and enter root as user. I haven't 
encountered any problems going this route.

Press Next

Here we enter the information gathered previously. Workgroup 
name, IP address, Printer share name.

Press Next

KDE will build the printer driver database. This takes a  little time, 
be patient.

Here you select your printer manufacturer and model. (this is 
assuming that you don't require any special drivers)

press Next

You can now test your install. Select the Test button. If all went 
well you should have a test page printing in a few seconds.

Press Next> Next> Next. The next few windows are some 
configuration windows. I usually leave them at the defaults, you 
can set them to your personal preferences.

Give your printer a name.

Press Next

This is a summary of your configuration. Once you are satisfied, 
press Finish
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Your mouse went on a rampage and all your desktop icons 
and the kicker panel are gone. All you have to look at is a nice 
picture. How do you get your desktop back? Pretty simple 
really.

Press Alt+F2 on the keyboard and a Run box should pop up. 
Type in "kcontrol" and press the Enter (Return) button. When 
the KDE control panel appears just go through the Desktop 
settings and put everything to default. You can fine tune things 
later. In about five minutes your desktop will be back to normal.

How to recover your desktop
by DrDos

Hi All, 
I've been using a program called Floola. It can be found at 
www.floola.com. It is an open source application that has 
downloads for Windows, Linux, and Mac. You only have to 
download and extract  it to your Ipod's drive. You can then 
browse to the file and run it and you get a full featured Ipod 
manager. I have the Windows and Linux versions copied to 
it so that I can run it from any computer. 

Check it out,

xom4life

This is going to be a big help for people who have 
problems playing videos and are getting washed out colors 
with too much brightness. The dev people might want to 
look at this too. What I've found is that modifying the driver 
preferences for the X11 server will give much better quality 
with Kaffeine and Mplayer.

For Mplayer, to to Preferences, Video and choose the

X11 (Ximage/Shm) drivers.

For Kaffeine player go to Settings, Xine Engine Settings 
and choose the

opengl drivers.

I've tested all the available ones and these give the best 
results.

Improving Video Playback Quality
by DrDos

http://www.foola.com

http://www.floola.com
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pciids.sh

usbids.sh

Links to the scripts on PCLOs website

Updating Pci.ids and Usb.idsUpdating Pci.ids and Usb.ids

Firstly, what are pci.ids and usb.ids files? Well, they are the 
database files used by the 'lspci' and 'lsusb' commands. They 
contain all known ID's used in PCI and USB devices, that is, ID's 
of vendors, devices, subsystems and device classes. These files 
are constantly being updated so it is important to keep our 
copies similarly up to date, so let's do it.

These files reside in '/usr/share/'  and if you look you'll see you 
have a copy of each file there now - albeit probably out of date. 
To ensure regular updates of these files I use 'anacron'  to 
update them on a weekly basis. To achieve this, place your 
copies of the 'update-pciids.sh'  and 'update-usbids.sh'  scripts 
into the '/etc/cron.weekly/'  directory. You will need to be 'root' to 
do this. Now we just need to ensure that 'anacron'  is being 
started at boot. Open PCLinuxOS Control Centre (Administration 
Centre) and navigate to 'System -> Enable or Disable the 
System Services'. Ensure that 'anacron'  has the 'On Boot' box 
ticked. Job done.

Now, we don't want to wait a week to test the scripts, so let's 
navigate to '/etc/cron.weekly/' in Konqueror and then drop to a 
shell ( Press F4 ). Now su to root and type './update-

pciids.sh'. When it has completed we can then type './update-
usbids.sh'. You can then open the new files in a normal text 
editor to see the date of this particular snapshot (about thirteen 
lines down from the top of the page ). There, all up to date. If you 
ever need to update quickly, rather than wait for the anacron job, 
you can use this method.

I hope this has been informative. You can always visit the Linux 
PCI ID Repository at:

http://pciids.sourceforge.net/

and your Linux USB ID Repository at:

http://www.linuxusb.org/usb.ids#

by Phinger

http://www.pclosmag.com/html/Issues/200803/files/update-pciids.sh
http://www.pclosmag.com/html/Issues/200803/files/update-usbids.sh
http://pciids.sourceforge.net/
http://www.linux-usb.org/usb.ids
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Gary L. Ratliff Sr. <eronstuc@gmail.com>

This is from Snow White as we learned as children.  “Mirror, 
Mirror, on the wall who's the greatest of them all.  The purpose of 
this article is to introduce you to the video player: Miro.

I ran across this in an issue of Linux Magazine I had just 
purchased while working on the article for REALbasic.  This 
stated that it could play virtually any of the many video formats 
currently in use.

As it is nearly impossible to obtain a PC without having Windows 
pre-installed on it, I will make the assumption that you have 
viewed videos in some of the formats currently used in this and 
also in some of the viewers in use on Linux, and specifically 
PCLinuxOS.

There is Windows Media Player and the wmv format, Real Player 
and the rm format, Quicktime and the mov format. (As a funny 
aside in an earlier experience in obtaining software it seems that 
Windows kept trying to play my rpm file downloads in Real 
Player.)

In Linux there is the Totem movie player, Kaffeine, Xine, 
Gstreamer, mplayer, kmplayer, and the VLC player to name just a 
few. I am not familiar with the Apple viewers, my only experience 
was using an emulator on my Atari computer which let me run 

software for a very early version of the MAC. However, if you 
have used a MAC you know that it too is very capable of playing 
video files. Then of course there is the Flash player and the 
Shockwave player from Abode and the formats used on You 
Tube and Google Video.  

So wouldn't it be great to be able to use one video player 
regardless of whether you were running: Windows, MAC, or 
Linux? That is just what the Miro player promises and delivers.

How to obtain Miro

Shortly after reading the article in LM, I checked the Synaptic 
package manager to see if PCLinuxOS had a version of Miro 
available. And there it was. Previously we have shown how to 
use apt-get install to be a command line method for installing 
software. However, here we only recommend using Synaptic. 
Once you click on apply you will learn that the system will want to 
download 18 or more libraries in addition to the Miro package 
itself in order to correctly install this to your system. I also 
checked the Fluxbox version of PCLinuxOS and learned that this 
wanted to install 22 packages. My first attempt to download the 
system failed as the system reported that some of the libraries 
could not be found. The way to correct this is to go to the 
repositories section and select a different download site. 
Currently the default download site is from the University of 
Indiana. After choosing a different site, click the Reload button to 

MMiirroo  MMiirroo  oonn  tthhee  wwaallll
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download a list of all the available software. You should now be 
ready to install. Click on the Apply button and shortly you will 
have an install of Miro. To get this program for either Windows, or 
MAC, simply visit: 

http://www.getmiro.com

Then download and install the version for your system

Setting up to use Miro

On its initial run, Miro will ask if you want to have it run on 
startup. Then it will ask if you would like it to search your system 
for videos and where it should look to find your videos. As I use 
my MYBOOK for archiving most of my downloads I had it search 
there and was able to find the lessons from the REALbasic TV 
website and view them. Next, it will have a set of predefined 
channels for the new user. One of these channels is using Miro 
and one should download and view the instructions offered. The 
video on the basics of Miro will show that there were some 1508 
channels available. However, at present the system will report 
that there are now some 3500 channels from which you may 
chose to download videos. The program uses bit torrent for its 
method of download and will thus obtain videos in short order.

Because I like old movies the iMovie channel and the Public 
Domain Movies were some of my first selections. However, you 

will find channels for every taste.  Next, if you which to create a 
channel the system offers to search You Tube and Google 
Videos for videos on any subject for which you may conduct a 
search.  Then these search results are turned into a customized 
channel for you. (By searching for Linux I learned that there was 
a video demonstrating the PCLinuxOS is the fastest Linux install 
of all versions of Linux. This video runs just over 2 minutes and 
20 seconds and shows a live real time install of the system.)

The system will download the items as you select them. There 
are three settings once you select a desired channel:  NEW will 
only download the items which arrive as NEW to the channel. 
ALL will download ALL the items available in the channel. And 
OFF will stop downloading from the selected channel. (One 
might be wary of selecting ALL in a channel which has many 
videos available as it will load up your hard drive till virtually full. 
If so, in order to install additional software or burn Cd's you will 
need to go to the channel and delete several items to free up 
room so you may use your system for these tasks. Once you've 
done this you may wish to turn that channel to OFF.)

Other features of Miro

Once you have obtained some videos you are ready to view 
them. You are able to select delete if you no longer want the 
video once viewed. If you find an item useful just select keep. 
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Miro also lets you share a video with your friends. I sent a copy 
of an old movie: “Teenagers from Outer Space” to my brother in 
Nashville, Tennessee and also to the Editor of this magazine. Of 
course, as I wanted to learn how this worked, I also sent a copy 
to myself. Once the e-mail is opened it will contain a link. 
 Clicking on this link will open a player. The Windows system 
played the movie by opening my Quicktime player. Opening the 
same e-mail in PCLinuxOS opened mplayer and played the 
movie.  

Recommendation

So if you enjoy watching video on your computer and would like 
to explore what type of videos may be available the Miro player 
is hard to beat. Also it is possible to contribute to the developers 
of this system painlessly. There is an extension for the Firefox 
browser for Miro. This will set it up to contribute a percentage of 
any purchases you make from the Amazon web site to the 
developers of this software. This will allow you to contribute 
easily and also take advantage of the savings on books which 
Amazon offers.

Videos which have been downloaded as well as those which 
were found in the initial search of your system are placed in the 
Library. To play the video from the Library just click on the 
thumbnail of the video.

Here is a picture of me with my dog Liz. This is really my wife's 
dog but she doesn't seem to know that. So she begs to go with 
me where ever I go.
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Q: What nvidia driver should I use?

A: It depends on what nvidia gfx card you have. Please refer to the nvidia website http://www.nvidia.com/object/unix.html and 
the corresponding supported products list for each driver release. 

We currently provide 6 'stable' nvidia driver releases via our repositories. Both the nvidia_71xx and the nvidia_96xx drivers are now 
considered "legacy drivers'          
by nvidia. For an explanation of these legacy drivers, please refer to the following:
 
http://www.nvidia.com/object/IO_32667.html

As a general guide, the current drivers support the following cards:

nvidia_71xx

Use this NVIDIA driver for these products:
- RIVA TNT cards
- RIVA/Aladdin TNT2 series cards
- Vanta series cards
- GeForce 256/DDR cards
- GeForce2 GTS/Pro/Ti/Ultra cards
- original Quadro cards
- Quadro2 Pro cards

NNVViiddiiaa  DDrriivveerr  FFAAQQ

nvidia_96xx

Use this NVIDIA driver for these products:
GeForce2 MX/MX 400 0x0110 
GeForce2 MX 100/200 0x0111 
GeForce2 Go 0x0112 
Quadro2 MXR/EX/Go 0x0113 
GeForce4 MX 460 0x0170
GeForce4 MX 440 0x0171 
GeForce4 MX 420 0x0172 

http://www.nvidia.com/object/IO_32667.html
http://www.nvidia.com/object/unix.html
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GeForce4 MX 440-SE 0x0173 
GeForce4 440 Go 0x0174
GeForce4 420 Go 0x0175 
GeForce4 420 Go 32M 0x0176
GeForce4 460 Go 0x0177
Quadro4 550 XGL 0x0178
GeForce4 440 Go 64M 0x0179 
Quadro NVS 0x017A
Quadro4 500 GoGL 0x017C
GeForce4 410 Go 16M 0x017D
GeForce4 MX 440 with AGP8X 0x0181
GeForce4 MX 440SE with AGP8X 0x0182
GeForce4 MX 420 with AGP8X 0x0183 
GeForce4 MX 4000 0x0185 
Quadro4 580 XGL 0x0188

Quadro NVS 280 SD 0x018A 
Quadro4 380 XGL 0x018B
Quadro NVS 50 PCI 0x018C 
GeForce2 Integrated GPU 0x01A0
GeForce4 MX Integrated GPU 0x01F0
GeForce3 0x0200
GeForce3 Ti 200 0x0201
GeForce3 Ti 500 0x0202 Quadro DCC 0x0203 GeForce4 Ti 
4600 0x0250 GeForce4 Ti 4400 0x0251 GeForce4 Ti 4200 
0x0253 Quadro4 900 XGL 0x0258 Quadro4 750 XGL 0x0259 
Quadro4 700 XGL 0x025B GeForce4 Ti 4800 0x0280 GeForce4 
Ti 4200 with AGP8X 0x0281 GeForce4 Ti 4800 SE 0x0282 
GeForce4 4200 Go 0x0286 Quadro4 980 XGL 0x0288 Quadro4 
780 XGL 0x0289 Quadro4 700 GoGL 0x028C
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The material in this guide may be reproduced, republished and 
incorporated into further works provided acknowledgment is 
given to UNDP-APDIP.

This work is licensed under the Creative Commons Attribution 
License. To view a copy of this license, visit 
http://creativecommons.org/licenses/by/2.0/ or send a letter to 
Creative Commons, 559 Nathan Abbott Way, Stanford, California 
94305, USA.

This guide has been modified by Papawoob to reflect the Linux 
distribution of PCLinuxOS 2007. You will also find much of it to 
be relevant to most KDE Desktop Environments.

Preface

This user guide is meant as an introductory guide for a user to 
use a modern personal computer (PC) running the Linux 
operating system. The main aim is to provide a self-learning 

guide on how to use a modern Linux desktop system. It assumes 
that the user has no prior knowledge of Linux or PC usage.

After going through the guide the reader should be in a position 
to start using a Linux desktop for both personal and office use. In 
particular he/she should be able to:

access the Internet and use the WWW and Internet email
manipulate and manage files, folders and the file system
produce and print simple documents and presentation materials
advance to become a power user by further self-learning and 
exploring

Published by
the United Nations Development Programme’s

Asia-Pacific Development Information Programme (UNDP-APDIP)
Kuala Lumpur, Malaysia

Web: http://www.apdip.net/Email: info@apdip.net

KKDDEE  UUsseerrss  GGuuiiddee

http://www.apdip.net
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Chapter 1 – Getting Started

I've updated this guide to reflect the desktop environment called 
KDE. It's more "Windows" like, and it seems to have a few more 
bells and whistles. I've taken the screenshots from my computer, 
which isn't set up exactly the same as yours, but it's pretty close.

In order to start using your system you will usually have to 
perform what is known as a user login. This procedure is 
necessary to identify yourself to the system. The system allows 
multiple users to use it concurrently and so it has to be able to 
identify a user in order to grant them the necessary privileges 
and rights to use the system and applications. Each user, upon 
successful login, will be assigned to his home directory (folder).

Some systems may have been set up so that upon power-on, a 
default user is logged in automatically. If this is so, then you will 
not be presented with a login screen or prompt as described in 
the section below. You may skip on to the section entitled "Basic 
Navigation using the Mouse on the Desktop". I would however 
recommend reading this section in case you ever have to log out 
and log back in.

Note:
There is a special user called root or superuser (this user is 
usually created during the system installation) which has 
unlimited access and rights to all the system files and resources. 

You only need to login as root if certain system level 
administrative tasks are to be carried out. Otherwise there is 
usually no need for a normal user to login as root. This is to 
prevent accidentally damaging the system by deleting or 
modifying important system files.
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When you reach this screen, type in your user name and then 
type in your password and press enter. This will bring up a 
splash screen showing your desktop being loaded as seen below:

When the blue lights on the bottom finish lighting up the next 
thing you will see is your Kde desktop as seen below:

Text Based Login Prompt

To login, enter the user name followed by the ENTER key and 

when the password prompt appears, enter the password 
followed by the ENTER key.

Starting the Graphical Desktop

If you have logged in from the graphical login screen, the 
graphical desktop will be started automatically for you. The 
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graphical desktop presents a Graphical User Interface (GUI) for 
the user to interact with the system and run applications. If you 
have used the text-based screen login, you will have to start the 
graphical desktop manually by entering the command startx, 
followed by the ENTER key.

Note:
The graphical desktop that we will be using throughout most of 
this guide is called the KDE Desktop. There is another desktop 
environment in popular use on Linux systems – the GNOME 
Desktop. There is some coverage of GNOME later, comparing 
the similarities and differences between GNOME and KDE 
although we will not be covering the GNOME desktop in detail.

For the rest of this user guide, when we refer to the graphical 
desktop or Desktop we shall be talking about the KDE Desktop 
unless stated otherwise.

Using the Mouse on the Desktop

Proper usage of the mouse is essential in order to have a 
rewarding and productive experience on the graphical desktop. 
Most Linux graphical desktops are designed for use with a 3-
button mouse. If you are using a 2-button mouse, during 
installation, it should have been configured to emulate the 
middle-button of a 3-button mouse by pressing both buttons 
simultaneously.

To click on a mouse the left button is depressed. (A mouse 
configured for a left-handed user will will need to have its right 
button depressed.) The right (or left button for a left-handed 
mouse) and middle buttons are usually used to invoke special or 
specific features of the GUI and instructions to do so will be 
explicitly given.

The term "clicking on the mouse" means that you click on the 
mouse once.

The term "double clicking" means that you click twice in 
succession on the mouse.

To "select" an item means clicking it once with the mouse.

The term "drag and drop" means that you will have to click on an 
item and while continuing to hold the mouse button down, drag 
the item to another place and on reaching its destination drop it 
by releasing the mouse button.

Exercises

Open the home / My System folder  from the Desktop.
Close the home folder window by clicking on the close window 
button at the top right-hand corner.
Right-click on the trash icon, view its properties and close it back.
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Move the trash icon to another location on the desktop by using 
the mouse to drag it to the new location and releasing the mouse.

Main Components of the Desktop
There are 3 main components to a KDE desktop. They are:
The Menu System
The Panel
The Desktop Itself

The Menu System
The main menu can be accessed by clicking on the Main 
Menu button located at the extreme lower left hand corner of 
the desktop. It looks like this:

Clicking on this will bring up the Menu System as shown in the 
figure below.

Fig. The Menu System

From the Menu System you can start many of the applications 
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installed on your Linux system. Note that the Menu System 
consists of a Main Menu panel and sub-menu panels. Each entry 
in the Menu System which has an arrow on its right means that it 
is an entry point to a sub-menu, and there can be sub-menus 
within each sub-menu. In this way, applications in the Menu 
System can be organized and categorized for easy reference 
and access.

To access a the sub-menu associated with a menu entry, move 
the mouse and rest it on the menu entry in question and a sub-
menu panel will appear.

Fig. Main Menu and Sub-menu

Clicking once on a menu entry will cause an application 
associated with it to be launched, i.e. executed.

The Panel

The long bar across the bottom of the desktop screen is called 
the Panel. The Panel contains the Main Menu icon, the 
application launcher icons, a notification area and applets.

Fig. The Panel

Installed by default are several application launcher icons on the 
Panel. Clicking on one of these will run an application. 
Commonly accessed applications can be added to the Panel and 
those that are less frequently used can be taken off.

The notification area holds alert icons so that the user can be 
alerted to critical messages.

Applets are small applications that run on the Panel. These 
usually perform useful and informative tasks like setting the 
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sound level of the sound card, monitoring whether the system 
software needs an update, etc.

The Workspace Switcher

The graphical desktop can be regarded as a workspace drawing 
an analogy with the working area on a real physical tabletop. 
Programs are run, documents displayed  and files opened on the 
workspace. To cut down on workspace clutter and to enable the 
user to organize his workspace more efficiently, the graphical 
desktop environment allows the usage of multiple workspaces. 
Each workspace can be considered as a virtual desktop.

Fig. The Workspace Switcher

By default the user has 4 desktop workspace areas to work on. 
The workspace switcher represents each workspace as a small 
square and shows the applications running in each of them. To 
access a workspace click on the square with the mouse.

The Taskbar

The Taskbar applet is located next to the workspace switcher 
and shows the titles of all the running applications in a virtual 
desktop (a workspace).

The Desktop Space

The Desktop space refers to the rest of the screen. It contains 
icons which are graphical representations of short-cuts to 
application launchers, file folders, files and peripheral devices 
like floppy disks, CD-ROM drives and printers. Double-clicking on 
an icon representing an application will launch or execute the 
application. Commonly used applications and/or files/folders are 
usually placed on the desktop space.

Using the Window Manager

An interactive application that is run on the graphical desktop, is 
usually displayed inside a window. This window can be accessed 
and manipulated using the window manager.
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Fig. An Application Window Frame

The Titlebar

When an application is started an application window opens and 
a frame (see figure above) is placed around the window of the 
application. The top edge of the frame has a title bar that 
contains  the title of the application.

At the left hand corner of the title bar is the Window Menu 
button. Clicking on this button will open up the Window Menu.

You can perform operations such as 
minimize, (un)maximize, shade, move, 
resize and close the window from this 
menu. At the right edge of the title bar 
there are three buttons which allow 
you to minimize, (un)maximize and 
close the window.

To perform an operation in the 
Window Menu, open the menu by right 
clicking on the Window Menu button 
and then select the desired operation.

Manipulating the Window
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Some basic instructions to manipulate the windowing system are 
given here.  More details can be obtained by clicking on the Main 
Menu and then on More Applications, Documentation and then 
KDE Help Center. After the KDE Help Center opens choose KDE 
User Manual and scroll down to ¨Windows, How To Work Them.¨

Focus

In order for a window to receive input from the mouse and the 
keyboard it has to be the window "in focus". Only one window 
can have focus at a time. Windows that are not in focus have 
their title bars grayed-out. To focus on a window place the 
mouse on the title bar and click on it. (You can actually click 
anywhere within the window, but it is safer to click on the title bar 
since there is no possibility of accidentally clicking on some item 
selection or functionality of the application running within the 
window.) If the window is not visible, you can click on the 
Taskbar on the Panel at the bottom of the Desktop to bring into 
focus the window you want.

Maximize and Minimize

Maximizing a window means that the window is expanded to 
cover the whole desktop while minimizing it means that the 
window is taken off the desktop and it appears as an icon in the 
Taskbar on the Panel.

You can maximize a window which has focused from the 
Window Menu or by clicking on the maximize button on the title 
bar. You can similarly minimize the window. If the window does 
not have focus bring it into focus first by clicking on the Taskbar 
on the Panel.

Resize

You can resize a window, i.e. change its size, by placing the 
mouse at an edge of the window and then drag the window to 
the desired size.

Move

To move a window to another place on the desktop, place the 
mouse on the title bar and drag the window to the desired 
location.

Close
You can close a window which has focused from the Window 
Menu or by clicking on the close window button on the title bar. 
 If the window does not have focus bring it into focus first by 
clicking on the Taskbar on the Panel.

Note: Closing the window will terminate your application.

Move to Workspaces
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The Window Menu can be used to move the application currently 
opened to another workspace or to all the workspaces.

Exercises

Open your home folder from the Desktop. Perform the following 
operations on the opened window:
maximize it
minimize it
resize it
move it to another area of the desktop
place it on workspace 3
close it

Ending the Session

To end this chapter, you can exit your session on the desktop by 
performing what is known as a logout. If you do not want to use 
the system any more, you can turn it off by performing a system 
shutdown.

Logout

When you have finished working on the system, you will need to 
logout. Logging out will inform the system that you are no longer 

using the system's resources.  All the files opened and programs 
run by you will be closed and/or stopped unless you have 
specifically informed the system to keep them open or running 
for you.

To logout, at the Main Menu select: Main Menu -> Log Out
and at the dialog window select End Current Session and click 
OK.

Shutting Down the System

When you have finished using the computer and want to power it 
off, you will have to perform a system shutdown. To shutdown, at 
the Main Menu, perform a logout. Then at the graphical login 
screen select the "Turn Off Computer" option. You will also have 
the option to ¨Restart Computer.¨
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Note:
It is very important that a proper system shutdown is performed. 
You should not just turn off the power switch of the computer to 
shut it down. Failure to observe this may lead to system software 
and data corruption and failure.
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Straightforward Directions for Remasterme

Forum Link: Straightforward directions for Remasterme
http://www.pclinuxos.com/index.php?option=com_smf&Itemid=58&topic=39717.msg304113#msg304113

This procedure is for the more experienced PCLOS-er, and there may be some pitfalls for newer users. Remember to back 
up any important data before performing any major work on your system, particularly where full directories etc are to be 
deleted.

You'll be doing the majority of this from a root terminal. If you are new to Linux, to get a root terminal, either open a terminal and type 
'su' and return and enter your root password at the prompt, or go to:

Kmenu->System->Terminals->Terminal Program - Super User Mode

 and enter your root password at the prompt.

Note: The .iso file you are going to create will be saved in your /root directory. Make sure that you have enough room to 
create this file. One point to remember is that the image may be larger than a CD-full, so check there is plenty of space.

Step one: Unmount all unnecessary drives. For the default partition setup, that would mean everything except / and /home. There 
are several ways to do this. One good method is to open a terminal as root and type umount -a. If you opened a root terminal for 
this, leave the terminal open as you'll need it again. Another way is to open Konqueror and type system:/media in the address bar. 
Once there, any partitions/drives listed that show a little indicator on the icon the represents the partition/drive is mounted and it is 
not either your / or /home partition, right-click on it and choose 'unmount'. You'll need to leave your / and your /home directory 
mounted if you have a separate /home partition.

Step two: Go to your home directory and right-click on the /tmp directory and choose Actions->Open As Root. Select everything 
and delete it. You can only perform this action with root privileges. If you do not have that action service menu installed, you can 
either install 'DoAsRoot' via Synaptic, or go to: 

Straightforward Directions for Remasterme
bbyy  rruueell2244

http://www.pclinuxos.com/index.php?option=com_smf&Itemid=58&topic=39717.msg304113#msg304113
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Kmenu->System->File Tools->File Manager - Super User Mode 

and delete the contents from there.

If you do not wish to exclude /home from the remaster, and use it as a means for backup, you can skip step 3 and continue 
to step 4. 

Step three: In a root terminal, type kwrite /usr/bin/remasterme. Edit the file at the section that begins 'mklivecd'. There are two 
command line arguments in there that begin with two dashes (--). Between them, add the following: --nodir ^/home, making sure to 
leave a space between each of the, now 3, arguments. Also, make sure there is a space between the 'r' and the '^' in your new 
argument. It should look something like this:

mklivecd --splash silent --md5sum --nodir ^/home --fstab=rw,noauto pclinuxos-2007.iso

Save it and exit Kwrite. This will cause it to ignore your /home directory for the remaster. 

Step four: In your root terminal, type remasterme and wait. Assuming there are no errors, which usually is caused by typing errors 
while editing the remasterme script, it will produce a file called 'pclinuxos-2007.iso' in your /root directory. You can move it to your 
home directory from there.

Step five: Burn your new ISO to a CD or DVD and test it to make sure it works. It might be a good idea to try a complete install in a 
Virtualbox, VMware, Qemu, or Xen environment, as well, just to make sure everything works as you want it to.
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