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Welcome From The Chief Editor
WOW! It’s hard to believe, but this issue
marks a couple of milestones for The
PCLinuxOS Magazine. First, it was four years
ago this month that The PCLinuxOS
Magazine was “reborn.” Second, this month
marks my four year “anniversary” as the chief
editor of The PCLinuxOS Magazine. During
that time, we have managed to produce and
maintain a monthly publication schedule, and
we have produced a number of “Special
Editions” of the magazine. We accomplished
this after my predecessor reduced the
publication of the magazine to a quarterly
publication schedule (he said there wasn’t
enough to write about … huh?) and after he
tried to “kill off” the magazine during a period
of time when PCLinuxOS was going through
some turmoil.
Also during that time, I’ve overseen The
PCLinuxOS Magazine website’s move to a
new server, a complete redesign of that
website, the closure of the magazine’s
separate forum, a redesign of the magazine’s
layout, and the addition of many new columns
and regular features in the magazine. Some
of those new and regular features in the
magazine include a monthly Game Zone
column, ms_meme’s Nook, ms_meme’s
Forum Foibles, YouCanToo’s PCLinuxOS
Recipe Corner, and the PCLinuxOS Puzzled
Partitions puzzle pages. The journey hasn’t
always been a smooth one, but we
persevered
and
overcame
whatever
“obstacles” came our way.
PCLinuxOS Magazine

I am very proud of what we have
accomplished, and I believe that I’m dead-on
target when I say that the staff of The
PCLinuxOS Magazine is also equally proud of
their achievements. We only hope that you’ve
enjoyed the journey spanning the past four
years as much as we’ve enjoyed bringing it to
you.
OK … now don’t go reading anything into
what I just said. Nope. I’m not planning on
going anywhere for the foreseeable future. I
don’t think Meemaw is, either. Granted, a lot
of work goes into the production of each and
every issue of The PCLinuxOS Magazine.
The end of month has become known as
“crunch time” for those of us who put together
the next month’s issue of the magazine, each
and every month. For us, it’s our way of
contributing something back to the best damn
Linux distribution out there … PCLinuxOS!

In “other news,” June saw the return of the
Gnome 2 desktop, in a way, with the addition
of the Mate 1.6 desktop to the PCLinuxOS
repository. Texstar was successful in
compiling a fully functional Mate desktop that
users can now install on top of a PCLinuxOS
MiniMe or PCLinuxOS LXDE installation.
Unless the end user removes the LXDE or
KDE desktops and applications, the end user
can switch back and forth between the
different installed desktops, including the
Mate desktop. After all, Linux is all about
choice, and now PCLinuxOS users have yet
another choice to add to all the other choices
that are made available to them.
Also ... less than two months remain before
the arrival of our new baby! After seven years
of trying, to say that we (my wife and I) are
excited is the largest understatement of all
time. So, until next month, I wish you all
peace, happiness, serenity and prosperity.
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Xfce Power User Tips, Tricks & Tweaks:
File Utilities (Part One)

by Paul Arnote (parnote)

In the previous Xfce Power User Tips, Tricks &
Tweaks articles, we learned how to work with
graphics files, archive files, multimedia files, and
document files. Where these tips really shine,
though, is in the file utility area – so much so, that I’ll
need to break this up into two articles. This first part
deals with the only deficiency/annoyance of Thunar
that I can find – the improper reporting of file sizes.
Show Correct File Sizes In Thunar
It was the best of times, it was the worst of times, it was
the age of wisdom, it was the age of foolishness, it was the
epoch of belief, it was the epoch of incredulity, it was the
season of Light, it was the season of Darkness, it was the
spring of hope, it was the winter of despair, we had
everything before us, we had nothing before us … –
Charles Dickens, A Tale Of Two Cities.
I almost called this section “A Tale Of Two (Or More)
File Managers.” It’s a perfect description of the only
real “problem” I’ve encountered with Thunar. Indulge
me while I bring you up to speed on how I
discovered that Thunar isn’t reporting the correct file
sizes.
It’s no secret that my favorite Linux desktop is Xfce. I
love its simplicity, and find it to be a much more
“mature” desktop than LXDE. Xfce has been around
longer than LXDE, so it’s understandable that it has
had more time to “grow up.” For me, it has “just
enough” plugins available to allow me to tailor my
desktop how I want, without getting weighed down
with a bunch of unnecessary (and CPU cycle
hogging) eye candy. My “love affair” for Xfce started
when I discovered how nicely it ran on my older
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computers. As a result, I run Xfce on most of my
computers – even on my newest computer with a six
core AMD FX-8100 processor. I do have ONE
computer that uses the KDE desktop.

Every month, as you already know, I prepare each
new issue of The PCLinuxOS Magazine and
oversee the announcement of each new issue. For
several months in a row, Old-Polack would write me
back to tell me that I had listed the “wrong” file size
in my monthly release notice. As an example, the file
size for the June 2013 issue of The PCLinuxOS
Magazine was reported as 10.7 MB by Thunar.
However, checking the file size of the magazine PDF
file in KDE’s Dolphin file manager, the file size was
reported as 10.2 MB – a whole 0.5 MB difference! I
also discovered that the PCManFM and Nautilus file
managers also report the correct 10.2 MB file size.
As another example, in the image below, a video of
one of our sonograms is highlighted. Thunar reports
its file size as 105.9 MB, but every other file
manager in existence reports is as 100.98 MB. Even
if the file size is rounded up to 101.0 MB, that
represents a whopping 4.9 MB discrepancy between
what Thunar reports and the actual file size!

So I decided to file a “bug” report on the Xfce
Bugzilla page. Read the entire entry for yourself,
below.
Bug 9887 - Thunar displays incorrect file size
information in Thunar status bar
Status:

RESOLVED WONTFIX

Product:
Thunar
Component: general
Version:
1.4.0
Platform:
PC (x86) Linux
[snip]
Reported: 2013-03-03 18:09 CET by Paul Arnote
Modified:
2013-05-01 16:35 CEST (History)
CC List:
1 user (show)
Description Paul Arnote 2013-03-03 18:09:25 CET
Thunar is displaying the incorrect file size for a
single selected file, or a group of multiple files
selected. Thunar is reporting the MiB of the file as
the number of KiB/1000, which is the method that
hard drive manufacturers use to dupe us into
believing we're getting a larger hard drive than we
actually get.
The MiB file sizes should be based on the KiB/1024
measurement, which is how the OS sees a MiB. By
using a simple hand calculator, I can take the total
number of bytes listed in the file properties dialog
and divide by 1024. The result is the same number
of MiB that are reported by other file managers, such
as Dolphin under KDE, and by Firefox when I
download that same file. The larger the file, the
larger the discrepancy between what is reported by
Thunar as the file size and how every other
application sees the file size.
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Comment 1 Paul Arnote 2013-03-03 18:13:13 CET
BTW, I've found this same behavior on Thunar
versions 1.4.0 and 1.6.0.
Comment 2 Nick Schermer 2013-05-01 16:35:50
CEST
Yes, and that is the correct thing to do:
https://developer.gnome.org/glib/2.36/glibMiscellaneous-UtilityFunctions.html#GFormatSizeFlags explains why
Thunar uses G_FORMAT_SIZE_DEFAULT.
Well, DRATS! OK … I used somewhat different
verbiage, but you get the idea. Seriously? For
whatever reason, the Xfce developers are singularly
interpreting that GFormatSizeFlags should be based
on the 1,000 byte divisor, instead of the 1024 byte
divisor – as everyone else does. I find it funny that
the Xfce developers are the only ones adhering to
the stated GNOME standard. The last time I used
Nautilus, the GNOME file manager, even it was
reporting file sizes properly. Basically, using the
1,000 byte divisor describes more or less how much
hard drive space a file is using (disregarding disk
sector sizes), as opposed to how big the file actually
is.
You could compile a custom version of Thunar, with
the source code corrected to display the proper file
size, but that is something that is far beyond the
capabilities or knowledge of a typical user. In fact, I
wouldn’t recommend this “fix” for anyone but the
most experienced user with a programming
background. Fortunately, we can correct this error
with a Thunar Custom Action. The custom action
becomes the second best option, and for most
users, the only acceptable option.
To start with, open a plain text editor and type in (or
copy) the following bash script. Preferably, save it to
a location somewhere in your path. I store mine in
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my ~/Scripts directory, and call it file-size.sh. Special
thanks to Pete Kelly, a.k.a. critter, for his assistance
with this script. Don’t forget to make the file
“executable.”
#! /bin/bash

kb=$((2**10))
mb=$((2**20))

for file in $@; do
if [ ! -e $file ]; then
continue
fi
b1=`ls -l $file | cut -d" " -f5`
let "b += b1"
done
k=`echo -e "scale=2; $b/$kb" |
bc`
m=`echo -e "scale=2; $b/$mb" |
bc`

zenity --info --title="Actual File
Size" --width=300 --height=100 -text="$b bytes\n$k KB\n$m MB"
Provide a name and description for your new custom
action. I entered “Actual File Size” on the first line for
the name, and “Report the ACTUAL file size” on the
second line for the description. On the third line,
enter the following command:
$HOME/Scripts/file-size.sh %N
Select an icon for your new Thunar Custom
Command. Under the “Appearance Conditions” tab,
place a checkmark in front of every file type, and
keep the “File pattern” set to the default * value.
Now, whenever you select “Actual File Size” from
Thunar’s right click context menu, you will see a
dialog box similar to the one shown below. You can
select a single file or directory, or multiple files or
directories. If you select multiple “items,” the total file
size will be calculated for all of the files, added
together.

Enjoy the reporting of proper file sizes in Thunar.
This custom action should be in the arsenal of every
Xfce user, if you care at all about knowing the proper
size of your files. In the next Xfce Power User Tips,
Tricks & Tweaks article, I’ll show you several more
file utilities you can employ.

Page 5

Game Zone: Sacred Citadel
by daiashi

System requirements:
•Minimum:
• OS: Vista/Win7
• Processor: 2GHz Dual Core
• Memory: 2 GB RAM
• Graphics: Nvidia GeForce
8600 or better, ATI Radeon
HD 2600 or better
• DirectX: 9.0c
• Additional: GPU Memory:
256MB

About The Game
Three warriors unite against an evil
that threatens to enslave the once
peaceful world of Ancaria. Lord
Zane’s Ashen Empire has created
an army of Grimmocs, modified
Orc henchmen at war with the
Seraphim. Only when these heroes
unite and use their skills to support
each other they will stand a
chance.
There are four playable character classes, the
Seraphim Mage, Safiri Warrior, Ancarian Ranger and
the Khukuri Shaman, each with a different skill set
that can be further individualized through RPG
features and collectible items. Each character will
also have the ability to dual-wield two exchangeable
weapons and use combo attacks, all of which
combines into a fluid and unique arcade game
experience with sophisticated graphics and
spectacular effects. The player will also be able to
ride mounts, use war machines and spend his hard
earned cash in towns all over the world of Sacred
Citadel.
Sacred Citadel will also offer an engrossing
multiplayer mode. Up to three players can join forces
against their enemies in coop mode.
Sharpen your axe, string your bow, brew your
potions! Ancaria needs heroes like you. Grab your
friends to join the resistance!
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The once peaceful land of Ancaria is in grave
danger. The evil Ashen empire has enslaved its
population and is using the orc-like Grimmoc to wipe
out the Seraphim, who swore to protect it. In order to
defeat the empire you will have to prove yourself as
a warrior by riding terrifying mounts, acquiring earth
shattering skills and looting powerful weapons and
valuable treasures. Grab your friends and join the
resistance!
Key Features:
• Battle it out with up to 3 player co-op
• Take charge of 1 of 4 unique playable character
classes with their own set of skills
• Explore the vast world of Ancaria
• Ride thumping mounts and use devastating
war-machines
• Tons of loot!
• Define your own fighting style with different
weapon combinations
Software:

About The Company
Founded in 1998, Southend Interactive lays claim to
providing the video gaming community with the
absolute best in digital entertainment for over a
decade. They specialize in high-end console, PC,
and mobile games development. Over the years, the
have fortified their expertise in numerous gaming
platforms across multiple genres.
They believe that the main component to their
success is their passion for video games, combined
with their advanced, proprietary technology. They
take pride in their award winning games, ensuring
the public that their products are that of the highest
standards.
At Southend, they develop first class video games
for multiple platforms, including console, mobile and
PC. For them, there are three magical ingredients for
doing fun games: freedom for everyone to be
creative, kickbutt technology and love for games.

Playonlinux, Wine and Steam.
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Game Zone: Sacred Citadel
Some Gameplay Screenshots

Getting It To Run
This game was installed using Playonlinux, which is
available through Synaptic. After you have
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Playonlinux installed, click on the game tab to find
Steam. It should install Wine version 1.5.25. After
Wine is finished and Steam is updated, search for
the game in the store and download the demo. It ran

very well on my computer, with a 2.6 dual core AMD
processor and nVidia 9600 with 4 gigs of RAM.
You may have to set the game window to “on top,”
since my taskbar was visible until I did this.
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PCLinuxOS Recipe Corner

Slow Cooker Beef Stroganoff
Ingredients:
2 pounds beef stew meat.
1 cup chopped onion.
1 can (10 3/4 ounces) condensed cream of golden
mushroom soup.
1 can (10 3/4 ounces) condensed cream of onion
soup.
1 jar (6 ounces) sliced mushrooms, drained or use
fresh sliced.
1/4 teaspoon pepper.
1 package (8 ounces) cream cheese, cubed.
1 container (8 ounces) sour cream.
6 cups hot cooked noodles or rice.
Cooking Instructions:
1. In 3 1/2- to 4 1/2-quart slow cooker, mix beef,
onion, soups, mushrooms and pepper.
2. Cover and cook on low heat setting 8 to 10 hours
or until beef is very tender.
3. Stir cream cheese into beef mixture until melted.
Stir sour cream into beef mixture. Serve over
noodles.
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Inkscape Tutorial: A Torn Paper Effect
by Meemaw

photo (hold the Shift key to choose the photo), click
on Object > Clip > Set. Any corners outside the line
should now be gone.

If you are like me, you want all your projects to look
crisp and perfect, even around the edges. However,
sometimes you may want a “weathered” effect on
something you are creating. I scrapbook a bit - gotta
chronicle the growth of my grandchildren, and make
sure past memories are recorded for the future.
Sometimes your design calls for a more antique
effect. This tutorial is to give the effect of torn paper
on the edge of a printed photo.
Scan and save your photo. Open Inkscape and
import your photo. As it has been repeated many
times, always work on a copy so you don’t lose your
original, but once it is imported into Inkscape, you
are working on a copy, so your original will remain
unchanged.
Before you do anything, create a rectangle the same
size as your photo. Remember, when your photo is
chosen, the dimensions are in the bar above your
project. Just create a rectangle and change the
dimensions to the same height and width as your
photo. Make the Fill Black and Stroke none. Put it to
the side to use later.
Using the pencil tool, draw a box around your photo,
cutting across the corners or sides where you want
the edges to look torn. Draw a second one, and
overlap the line on the first box, so they are kind of
wavy back & forth. On my photo, the top right and
bottom left corners are going to be frayed the most.
Notice my lines cross in a few places (center, top).
The next step will be done to both lines. We want to
make our curves more jagged, so it will look like a
rougher tear. Choose both lines, then click
Extensions > Modify Path > Add Nodes. You will
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be asked whether you want to add by segment
length or segment number. Choose segment length
and change that to 5 px. Click Apply, then Close.
Then, with the same line chosen, click on
Extensions > Modify Path > Jitter Nodes. You will
be asked about displacement. I put 2 px in each
space and left the rest alone. Click Apply, then
Close. In the example below I have only done one
of them so you can see the difference.
We are going to use one of
these lines to “cut off” part of
our photo. Choose one of the
lines and duplicate it, setting
the duplicate aside. (We’ll do
enough duplicates here that
you can probably use the
keystroke <CTRL> + D faster
than you can click on Edit > Duplicate.) Choose the
same line that you just duplicated, and then the

Using the same line you just used, change the fill to
black and the stroke to none. Set the blur on it to
0.5, and send it down behind the original. Duplicate
it, and on the duplicate, change the fill to something
similar to your photo’s border, and change the stroke
to none. Align those two with the lighter one on top,
and slide them under your photo with the lines
matched up. That is going to give a little shadow to
the torn border of the
photo. These three objects
can be grouped so you
don’t have to line them up
over and over.
Just as a reminder, the
Selection toolbar, just
above your project, is
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activated when your Selection tool, or cursor is
chosen. It has the Levels buttons, so you can stack
things in a certain order. From left to right, you can
Lower to Bottom, Lower One Level, Raise One
Level, or Raise to Top. We’ll use these many times
while we’re working on this project.

Many photos have two layers of paper, and when
they tear, the layers tear in different spots. Using the
second line you created will give this effect.
Duplicate your photo, and the line, and slide the line
off to the side. Using this line and photo duplicate,
click Object > Clip > Set again to cut off the corners
in different spots. Slide it back over the photo you
did earlier. Then, click on the line duplicate you just
made, set the fill to something just a bit lighter than
the photo border, and the stroke to none. Duplicate it
again, and on the duplicate, set the fill to black,
stroke to none, and set the blur to 0.5. Line these
two up with the black underneath and group them,
then send them to the bottom. Then slide them
behind the photo where you want them. You can
group these as well.

Now you need to position these photos directly over
each other. I should be fairly easy with some of the
corners cut off, but you probably need to zoom in on
your edges and use your arrow keys to move a pixel
at a time.

Position the black rectangle you created earlier over
the photo and make sure everything is lined up.
Using your cursor only, click and drag around the
edges of your project to select everything, then click
on Object > Clip > Set again. Your photo should
now have straight sides again except for the torn
parts and the torn parts should look like they have a
little shadow around the edges..
Some of this may
have been a bit
difficult, and I
hope your photo
came out the way
you wanted it. As
with
anything,
practice helps.
This torn paper
effect can be
used other places
too. Your only
limit
is
your
imagination!
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Disclaimer

1.

All the contents of The PCLinuxOS Magazine are only for general
information and/or use. Such contents do not constitute advice
and should not be relied upon in making (or refraining from
making) any decision. Any specific advice or replies to queries in
any part of the magazine is/are the person opinion of such
experts/consultants/persons and are not subscribed to by The
PCLinuxOS Magazine.

2.

The information in The PCLinuxOS Magazine is provided on an
"AS IS" basis, and all warranties, expressed or implied of any
kind, regarding any matter pertaining to any information, advice
or replies are disclaimed and excluded.

3.

The PCLinuxOS Magazine and its associates shall not be liable,
at any time, for damages (including, but not limited to, without
limitation, damages of any kind) arising in contract, rot or
otherwise, from the use of or inability to use the magazine, or any
of its contents, or from any action taken (or refrained from being
taken) as a result of using the magazine or any such contents or
for any failure of performance, error, omission, interruption,
deletion, defect, delay in operation or transmission, computer
virus, communications line failure, theft or destruction or
unauthorized access to, alteration of, or use of information
contained on the magazine.

4.

No representations, warranties or guarantees whatsoever are
made as to the accuracy, adequacy, reliability, completeness,
suitability, or applicability of the information to a particular
situation. All trademarks are the property of their respective
owners.

5.

Certain links on the magazine lead to resources located on
servers maintained by third parties over whom The PCLinuxOS
Magazine has no control or connection, business or otherwise.
These sites are external to The PCLinuxOS Magazine and by
visiting these, you are doing so of your own accord and assume
all responsibility and liability for such action.

Material Submitted by Users
A majority of sections in the magazine contain materials submitted by
users. The PCLinuxOS Magazine accepts no responsibility for the
content, accuracy, conformity to applicable laws of such material.
Entire Agreement
These terms constitute the entire agreement between the parties with
respect to the subject matter hereof and supersedes and replaces all
prior or contemporaneous understandings or agreements, written or
oral, regarding such subject matter.
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ms_meme's nook: Sandbox Blues
Guess I'll check out the Forum tonight
See who's hanging around that site

Now you know just where to go
When your life is moving slow
The Sandbox is a special place
For you there's always space

The users are having a dull day
Begging meme come out and play

Your troubles share with who's ever there
No more Sandbox Blues

I really care about everyone there
I'll get rid of those Sandbox Blues

It's now just about half past five
Things are coming alive

Gonna post me a couple of rhymes
It will be just like old times

The Sandbox really gets my vote
And on that me you can quote

My post count will really rise
As tears fall from my eyes

Troubles I'll share with who's ever there
Get rid of those Sandbox Blues
It's now just about half past one
Starting to have a little fun

The Sandbox is a special place
For you there's always space

Your troubles share with who's ever there
Get rid of those Sandbox Blues

And I'd like for you to note
Everyone here is in the same boat

Your troubles share with who's ever there
No more Sandbox Blues

MP3
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Now you know just where to go
When your life is moving slow
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Linux vs. Windows
by Shamus Young
Reprinted with permission
from his blog, Twenty Sided
Recently, I installed both Windows and Linux in
some kind of dual-boot situation. So now I’ve had a
chance to use the two systems side-by-side so I can
make a proper apples-to-Macintosh type
comparison. I’ve installed both and I’ve used both,
and I’m ready to offer Linux some constructive
criticism. It’s a good attempt at an operating system,
but they need to make some changes if they want to
beat Windows.

there were critical updates, and asked to boot again.
Then once I installed my graphics drivers it wanted
another boot. I guess my only complaint is that it
stopped to ask about that fourth reboot. That was
kind of odd. I mean, why would I say no?
On the other hand, the Linux installer feels like it’s
missing parts or something. I ran the installer and it
rebooted just once, right into Linux. After that I
installed some updates, but the machine still didn’t
ask to reboot itself. It just sat there like it was ready
for me to start using it. I waited ten minutes just to be
sure, but it never did ask to restart.

Eventually I had to bring in the laptop and reboot
that, just so I could feel like the job was done
properly.
Linux Doesn’t Remind Me About Things
Look, I can’t be expected to keep track of all the
complicated stuff the computer needs me to do.
That’s what notification popups are for. I’ll be sitting
there, writing a document or surfing the web,
oblivious to the sea of problems going on behind the
scenes. Then a little popup appears to save me from

Linux Doesn’t Reboot Enough

I’m not sure how they managed to mess up
something as simple as rebooting. I mean, it’s just
restarting the computer. It’s like a blue screen of
death that skips the blue screen.
When I installed Windows the process worked
properly: The installer looked at my computer for a
long time, then copied some files and rebooted.
Then it had another long ponder before rebooting
again. Then it booted into Windows, announced
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Linux vs. Windows
my unbridled productivity and let me know that
there’s an update wizard waiting to be run, or that I
need to set up the update wizard so that it can
remind me to run it later. Or perhaps I need to
download and install the update wizard so that it can
remind me to set it up to remind me to run it. That’s
a lot of stuff to keep track of, and without
notifications I’d never be able to keep up.
Linux doesn’t do any of this for you. Oh sure, there’s
a little shield on the Panel (that’s what Linux people
call the taskbar) that shows a green check mark if
everything is okay and something else if it isn’t, but
you have to remember to look down there yourself.
Plus, that shield thing is only good for critical stuff
like software upgrades. It doesn’t ever help you out
with advice on desktop icon placement, or how you
manage your toolbar, and I guess I’m supposed to
keep track of virus scanners by myself and
remember to do my own backups? How can anyone
work like this?

Linux Software is Like, Weird and Stuff
I hope you’re not going to try to get anything done
on Linux, because it doesn’t have any software. You
want Internet Explorer? Nope. Notepad? Nope.
Minesweeper? Missing. New Hardware Detection
Setup and Driver Install Wizard? MIA.
Oh sure, Linux users will tell you about
“alternatives.” Instead of Internet Explorer they have
goofy off-brand programs like Firefox and Chrome.
And their Notepad knockoff is strange because it has
all these strange things like formatting, fonts, and
spell checking.

There’s this huge library of software out there that
you can download through their own proprietary
downloader. They don’t even charge you money for
it, which means it’s all pirated.
Linux Doesn’t Have the Genuine Advantage
For years I’ve been typing these huge codes into
Windows when I install it. Yes, they’re long and hard
to type and it’s kind of annoying, but that’s the cost
of getting a Genuine Advantage. Linux doesn’t have
anything like this. They couldn’t even be bothered to
add in a little one. Clearly Linux has no advantage at
all.

Linux Doesn’t Boot or Shutdown Properly
Everyone knows that properly booting a computer
takes several minutes, and shutting one down takes
a couple more. We don’t know why, and we don’t
know what sort of mysterious things are happening
when that red disk access light is flickering. All we do
know is that these things are terribly important.
Everyone knows this.
Everyone except the people running Linux
apparently, because they decided to cut some
corners when it comes to starting up and shutting
down. I’d say they got rid of half the stuff the
computer does at startup. And shutdown? They just
skip the whole thing. You tell the machine to shut
down and it just does it right then and there, without
sitting at a logo screen for a couple of minutes. It’s
like they thought we wouldn’t notice little details like
this.
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Linux vs. Windows
So that’s Linux. Frankly, with software this bad I
can’t imagine how Linux manages to stay in
business.

If you want to buy my books, look here.

About the author

If you’re nosy and want some personal info: I’m a
Christian, but an nontraditional one who is happy to live
harmoniously with other people without forcing my values
on them. I keep my politics to myself, because I’d rather
have friends than “win” arguments. I don’t have a degree.

I’m Shamus Young, a 40 year old writer and software
engineer and an enthusiastically married father of 3. In
my free time I tend to play videogames and write software
of dubious value. I also tend to write about these things
here.
If you’re looking to suggest or request an article on a
particular subject, look here.

If you’d like to contact me my email is: shamus -atshamusyoung dot com.

If you need more, you can read more than you ever
wanted to know about me in my autoblography.
Also, you can buy my books or buy my books.

Screenshot
Screenshot Showcase
Showcase

Posted by Artim, on 6/11/13, running e17.
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dmidecode: See What Your BIOS Has To Say
by Paul Arnote (parnote)

wonder about your computer’s hardware configuration? Well, with the dmidecode
command, you can find all of that sort of information your mind can ingest.

Linux, Unix and BSD users have it good. Real good. Especially when it comes to
polling their computer about its current BIOS settings.

dmidecode is already installed on your PCLinuxOS installation. Open a terminal
session, switch to the root user, and type dmidecode at the command line
prompt. You should be shown hundreds of lines of output that provides details
about most every aspect of your computer hardware. Below is a snippet of
information dmidecode is able to provide. This dmidecode output is from my IBM
Thinkpad T42 laptop.

BIOS stands for “Basic Input Output System,” and the computer’s BIOS acts like
a traffic cop or translator, making it possible for all of the different components
and parts of your computer hardware to talk with one another and interoperate in
harmony. Sometimes, your computer BIOS is also sometimes known as DMI,
which is an abbreviation for Desktop Management Interface.
Source: Wikipedia
How many times have you wondered about whether a certain setting was
available or enacted in your computer’s BIOS? Or, how many times did you
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# dmidecode 2.12
SMBIOS version fixup (2.33 -> 2.3).
SMBIOS 2.3 present.
61 structures occupying 2126 bytes.
Table at 0x000E0010.
Handle 0x0000, DMI type 0, 20 bytes
BIOS Information
Vendor: IBM
Version: 1RETDNWW (3.19 )
Release Date: 10/13/2005
Address: 0xDC000
Runtime Size: 144 kB
ROM Size: 1024 kB
Characteristics:
PCI is supported
PC Card (PCMCIA) is supported
PNP is supported
APM is supported
BIOS is upgradeable
BIOS shadowing is allowed
ESCD support is available
Boot from CD is supported
Selectable boot is supported
EDD is supported
3.5"/720 kB floppy services are supported (int 13h)
Print screen service is supported (int 5h)
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
AGP is supported
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BIOS boot specification is supported
Handle 0x0001, DMI type 1, 25 bytes
System Information
Manufacturer: IBM
Product Name: 23738TU
Version: ThinkPad T42
Serial Number: L32321Z
UUID: 56A11681-48B1-11CB-8DF4-B7968D3A47CB
Wake-up Type: Power Switch
Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
Manufacturer: IBM
Product Name: 23738TU
Version: Not Available
Serial Number: VJ0BV5CG145
Handle 0x0003, DMI type 3, 17 bytes
Chassis Information
Manufacturer: IBM
Type: Notebook
Lock: Not Present
Version: Not Available
Serial Number: Not Available
Asset Tag: No Asset Information
Boot-up State: Unknown
Power Supply State: Unknown
Thermal State: Unknown
Security Status: Unknown
OEM Information: 0x00000000
Handle 0x0004, DMI type 126, 17 bytes
Inactive
Handle 0x0005, DMI type 126, 17 bytes
Inactive
Handle 0x0006, DMI type 4, 35 bytes
Processor Information
Socket Designation: None
Type: Central Processor
Family: Pentium M
Manufacturer: GenuineIntel
ID: D6 06 00 00 BF F9 E9 AF
Signature: Type 0, Family 6, Model 13, Stepping 6
Flags:
FPU (Floating-point unit on-chip)
VME (Virtual mode extension)
DE (Debugging extension)
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PSE (Page size extension)
TSC (Time stamp counter)
MSR (Model specific registers)
MCE (Machine check exception)
CX8 (CMPXCHG8 instruction supported)
SEP (Fast system call)
MTRR (Memory type range registers)
PGE (Page global enable)
MCA (Machine check architecture)
CMOV (Conditional move instruction supported)
PAT (Page attribute table)
CLFSH (CLFLUSH instruction supported)
DS (Debug store)
ACPI (ACPI supported)
MMX (MMX technology supported)
FXSR (FXSAVE and FXSTOR instructions supported)
SSE (Streaming SIMD extensions)
SSE2 (Streaming SIMD extensions 2)
SS (Self-snoop)
TM (Thermal monitor supported)
PBE (Pending break enabled)
Version: Intel(R) Pentium(R) M processor
Voltage: 1.3 V
External Clock: 400 MHz
Max Speed: 1700 MHz
Current Speed: 1700 MHz
Status: Populated, Enabled
Upgrade: None
L1 Cache Handle: 0x000A
L2 Cache Handle: 0x000B
L3 Cache Handle: Not Provided
Serial Number: Not Specified
Asset Tag: Not Specified
Part Number: Not Specified
Handle 0x0007, DMI type 5, 20 bytes
Memory Controller Information
Error Detecting Method: None
Error Correcting Capabilities:
None
Supported Interleave: One-way Interleave
Current Interleave: One-way Interleave
Maximum Memory Module Size: 1024 MB
Maximum Total Memory Size: 2048 MB
Supported Speeds:
Other
Supported Memory Types:
DIMM
SDRAM
Memory Module Voltage: 2.9 V
Associated Memory Slots: 2
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0x0008
0x0009
Enabled Error Correcting Capabilities:
None
Handle 0x0008, DMI type 6, 12 bytes
Memory Module Information
Socket Designation: DIMM Slot 1
Bank Connections: 0 1
Current Speed: Unknown
Type: DIMM SDRAM
Installed Size: 1024 MB (Double-bank Connection)
Enabled Size: 1024 MB (Double-bank Connection)
Error Status: OK
Handle 0x0009, DMI type 6, 12 bytes
Memory Module Information
Socket Designation: DIMM Slot 2
Bank Connections: 2 3
Current Speed: Unknown
Type: DIMM SDRAM
Installed Size: 1024 MB (Double-bank Connection)
Enabled Size: 1024 MB (Double-bank Connection)
Error Status: OK

Yes, that’s a lot of information … and that’s just a fraction of the total amount of
information supplied. To be certain, that’s a lot of information to wade through if
you are looking for specific information about specific parts of your system.
Fortunately, there’s a way to limit the dmidecode output.
Looking through the dmidecode output listed above, notice how each “section” of
the output is labeled with a specific “DMI type.” By knowing what DMI type relates
to which section of hardware information, you can tailor dmidecode to show you
only the specific data you are seeking.
Here’s a list of the different DMI types you can specify:
0
1
2
3
5
6
7
8
9
10

BIOS
System
Base Board
Chassis 4 Processor
Memory Controller
Memory Module
Cache
Port Connector
System Slots
On Board Devices
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11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39

OEM Strings
System Configuration Options
BIOS Language
Group Associations
System Event Log
Physical Memory Array
Memory Device
32-bit Memory Error
Memory Array Mapped Address
Memory Device Mapped Address
Built-in Pointing Device
Portable Battery
System Reset
Hardware Security
System Power Controls
Voltage Probe
Cooling Device
Temperature Probe
Electrical Current Probe
Out-of-band Remote Access
Boot Integrity Services
System Boot
64-bit Memory Error
Management Device
Management Device Component
Management Device Threshold Data
Memory Channel
IPMI Device
Power Supply

To utilize the different DMI types, issue the command dmidecode -t x, where x is
the number of the DMI type you want to display. Thus, dmidecode -t 21 will
display the following information that provides details about the built-in pointing
devices on my Thinkpad T42:
dmidecode -t 21
# dmidecode 2.12
SMBIOS version fixup (2.33 -> 2.3).
SMBIOS 2.3 present.
Handle 0x0033, DMI type 21, 7 bytes
Built-in Pointing Device
Type: Track Point
Interface: PS/2
Buttons: 3
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Handle 0x0034, DMI type 21, 7 bytes
Built-in Pointing Device
Type: Touch Pad
Interface: PS/2
Buttons: 0

Thus, to display information about the memory
device, you would enter dmidecode -t 17. To display
information about the specific memory modules
installed in your computer, you could enter
dmidecode -t 6. You could continue with any of the
defined DMI types in the list above. If you come
across a DMI type that isn’t supported by your
particular BIOS, you will see the following:

dmidecode doesn’t poll the hardware itself. Instead,
it simply reports what the BIOS tells it.
Still, dmidecode is a very useful tool in any Linux
user’s arsenal. So, the next time you need to gather
information about your computer configuration,
dmidecode is one tool that can quickly provide that
necessary information.

Screenshot
Screenshot Showcase
Showcase

# dmidecode 2.12
SMBIOS version fixup (2.33 -> 2.3).
SMBIOS 2.3 present.

There is an alternate way to display DMI types, and
that is by using dmidecode keywords. Let’s say you
want to inspect all the information about the memory
installed in your computer. Instead of specifying DMI
types 5, 6, 16 and 17 separately, you could simply
type dmidecode -t memory. When you do, all the
information from the relevant sections will be
displayed all at once.
Here are the dmidecode keywords you can use,
followed by the sections that they relate to:
bios 0, 13
system 1, 12, 15, 23, 32
baseboard 2, 10
chassis 3
processor 4
memory 5, 6, 16, 17
cache 7
connector 8
slot 9
Is dmidecode perfect? Nope. In fact, dmidecode has
sometimes provided unreliable information. It has
nothing to do with any “flaws” in dmidecode. Rather,
it’s the nature of the beast. DMI data has been
proven to be too unreliable to be just trusted blindly.
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Posted by Daniel, on 6/7/13, running KDE4.
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LibreOffice Tips & Tricks, Part 1
by Meemaw
In 2010, this magazine did a series on OpenOffice.
Since then, the default office suite for PCLinuxOS
has become LibreOffice. However, the two programs
are almost identical in function, so it was very easy
for me to switch all my computers - even the ones at
work - to LibreOffice. This will be a series of Tips and
Tricks to help you use your office suite more
effectively. This time we will be using LibreOffice
instead of OpenOffice. I have updated LibreOffice on
my computers to Version 4.0.3. The first two articles
will focus on LO Writer.

a lot of documents with your MSOffice friends, you
can set LO to save in Office format. Go to
Load/Save > General in the Options window, and
configure each document type from that window.
You will see a drop-down containing each document
type - text, spreadsheet, presentation - and choose
your desired file format from the drop-down to the
right.

Configuring Options
One of the first things you can do when you open LO
is to configure your options. We’re going to review
them just to see if there is anything new. Clicking on
Tools > Options will bring up the options window.
Personalization? That’s new. What is it? When you
click this section you will find that you can add a
Firefox persona to your LO window. The
configuration window lets you open up the Firefox
extensions window and find a persona you like, then
add the link for it in the LO options window. This is
good if you have a continuous Internet connection,
but if you only connect occasionally with dial-up or
your connection is unreliable, you may want to skip
this. I found a nice persona called Groovy Blue. You
also want to be careful because adding a persona
does not change your menu bar, so if the persona is
too dark or detailed, you may not be able to see your
menu bar or toolbars.
Just as a reminder, you can set the default file
extensions on your documents. If you have to share
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containing many of the same items. You can center
or left-align your picture, turn wrap on and off, put a
border around it and even change the border’s
design.
If your image illustrates something in one of the
paragraphs, you should right-click and choose
Anchor > To Paragraph from the pop-up menu.
That way, your image will stay with the correct
paragraph as you edit your document. You can also
anchor to page (it should stay where you put it even
while you edit the document) or anchor as character
(puts it into your text as another character, and
moves with that part of the text as you edit).
Making Letterhead or a Reusable Document

Looking for Calc or Impress options? Open a blank
Calc or Impress document, and then go back to
options. We’ll look at a few of them in later articles.
Inserting Objects
One of the things you may do in a word processing
document is to insert a picture to bring some color to
your documents. While everyone may already know
how to do it, let’s review it anyway. Click on Insert >
Picture > From File, and in the pop up window,
navigate to the folder where your image is located,
choose it and click OK.
Your image will be inserted wherever your cursor is
located. If it is a large image, it will take over the
whole page, but you can resize it by grabbing one of
the handles on the corner and dragging it to the
desired size. When the image is selected, your text
formatting toolbar changes to a graphics toolbar

Wow! Stationery costs a lot these days! If you can
design your own letterhead satisfactorily, and can
get the paper you need, you can save some of the
money you would pay an outside company to print
that stationery. It’s an easy process. Open a blank
document and set your page formatting. For a onepage letter, go into Format > Page, go to the
Header tab and check the box that says “Header
On”. You can set the height of your header here, too.
Click Insert > Picture > From File and insert the
image. Then, enter the information you want on your
letterhead, and format it as you desire. Save it as
Letterhead.odt (next page, top left).
Any time you want to write a letter, open your
letterhead, re-save it with an appropriate filename,
and compose your letter. When you print it, the
letterhead will be on your letter.
Most companies have several form letters they send
to their customers. This could be a mailing about a
discount they offer once a year, or a specific letter
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you have saved the document in LO, export it to a
pdf file before you close LO. Open the pdf and print
from it.

about an unpaid bill they send out when appropriate.
At my office we sponsor some activities every year,
so instead of rewriting a letter every year, we draft
one, and then re-use it the next year, making the
necessary changes. The easiest way to do that, and
keep a record of past letters is to rename each one
for the current year. Opening a letter called
“EarthDayInvitation2012”, I can change the
information I need to change, then choose File >
Save As.... and save it as “EarthDayInvitation2013”.
I keep a separate folder for every year, which gives
me a history that I can use to keep track of anything
done differently from previous years and notes
reminding me what worked and what didn’t.
Export Labels to PDF
Labels are so fun to do! Well, maybe not, but I have
found that printing them can be easier if they have
been exported as a pdf. If you are doing a bigger
mailing, a pdf file may be easier to work with if any of
your pages print incorrectly. I did a 1200-label
mailing a few months ago where one of the label
sheets got pulled through before it was needed. I
had a page where the addresses printed over the
edges of the labels. A pdf file is more easily
searched to find the page(s) that should be
reprinted. When you finish making your labels, and
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I know - you are thinking that I’m making extra work
by saving two files, but sometimes in LO (AND in
Word) I have saved the labels and when I opened
them again, they were wrong or some were missing.
That has never happened with a pdf. It may have
been only my error, but I’ve done tons of labels in
the last few years, and printing them has been so
much easier since I started exporting them to a pdf
file. I have also had the bad luck to have a printer
quit and had to transfer the label file and print them
on another printer, and transporting the pdf file is
much easier than a writer document.
Thesaurus
How many times have you read something and the
writer seems to use the same descriptive word
several times? (Yes, I’m guilty of that too.) LO has a
nice thesaurus included. Just in case you aren’t sure
what a thesaurus is, it is a sort of specialized
dictionary: one that finds synonyms, or words
meaning the same thing as the word you are using.

To use the thesaurus, simply highlight your word and
click Tools > Language > Thesaurus or press
<CTRL> + F7.

Keyboard Shortcuts
Many of these are standard keyboard shortcuts, and
are available in other programs as well:
<CTRL> + X
<CTRL> + C
<CTRL> + V
<CTRL> + N

Cut
Copy
Paste
New
(in LO it is a new text document)
<CTRL> + O
Open (existing document)
<CTRL> + S
Save
(you can use <CTRL> + <SHIFT>
+ S for Save As....)
<CTRL> + Z
Undo
<CTRL> + Y
Redo
<CTRL> + P
Print
<CTRL> + Q
Quit (close the program)
<CTRL> + Scroll Wheel Zoom
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I have (finally) discovered that the shortcut <CTRL>
+ Scroll Wheel works in loads of programs! I have
used it in Chrome, Firefox, Thunderbird, Inkscape,
GIMP, Google Docs, most pdf readers and, of
course, LibreOffice. Pushing the scroll wheel forward
(away from you) will zoom in and pushing it
backward will zoom back out.
Many other useful shortcuts use the function keys
and can be used in LO:
<CTRL> + H
<CTRL> + F3
<CTRL> + F4
<CTRL> + F5
<CTRL> + F7

Find and Replace
Auto text
Close present document
Navigator
Thesaurus
(if you don’t have a word
highlighted, you can type one in)
<CTRL> + F10 Set non-printing characters
as visible
<CTRL> + F11 Styles and Formatting tool
<CTRL> + F12 Insert table

Screenshot
Screenshot Showcase
Showcase

You also need to remember that some of these keys
have a different function in Calc, Impress or Draw
Some of these are used without the <CTRL> button.
F1
F7

LO Help
Spelling & Grammar Check

I hope you have found a tip or two that helps you!
Next month we’ll look at a few more tips and tricks
for LibreOffice Writer.

Posted by Meemaw, on 6/1/13, running Xfce.
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Backup Your Gmail Account With getmail
by agmg (Antonis Komis)

server = pop. gmail. com
username = yourname@gmail. com
password = yourpassword
[ destination]
type = Mboxrd
path = ~/gmail-backup/gmailbackup. mbox
[ options]
verbose = 2
message_log = ~/. getmail/gmail. log

Backing up your data is always important. Even
when it comes to web-based emails. If you are a
Gmail user, you can use a simple command-line
program called getmail to backup up all your emails
to a single .mbox file. This file can then be imported
into most email clients (i.e. Thunderbird) and let you
have all your Gmail messages in a local folder.
getmail is not installed by default in PCLinuxOS, but
you can get it very easily using Synaptic Package
Manager. Just search for “getmail” and select it for
installation.
Before using getmail, you need to create a
configuration directory, a directory to store the .mbox
file, and the .mbox file itself. Open your favorite
terminal emulator (i.e. Konsole) and type the
following command:

mkdir $HOME/. getmail
and then the following command to set permissions
for the folder:

chmod -R 0700 $HOME/. getmail
(only owner can read, write and execute on that
folder).
The next step is to create a folder for the
downloaded messages to be stored in. I have
named it “gmail-backup” but you can use any name
you like:

mkdir $HOME/gmail-backup
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Don’t forget to set its permissions, like before:

chmod -R 0700 $HOME/gmail-backup
NOTE: Both “$HOME” and “~” refer to your home
directory at /home/<your name>
Now, you must create the .mbox file to contain the
downloaded messages because getmail does not
do this automatically. Type the following command at
the prompt to create the .mbox file inside the gmailbackup directory:

touch ~/gmail-backup/gmail-backup. mbox
Again, you can use any name you like for your
.mbox file.
Finally, you must create a configuration file for
getmail to use and read your Gmail account
information. Additionally, this configuration file will tell
getmail where to save your downloaded messages.
Open your favorite text editor (i.e. KWrite) and copypaste the following text in a file:

[ retriever]
type = SimplePOP3SSLRetriever

Change the username and password to the ones for
your Gmail account. If you used a different directory
and filename for the .mbox file, change the “path” in
the “destination” section to reflect your actual path
and filename.
NOTE 1: you have to enable POP3 support for your
Gmail account in order for getmail to be able to
successfully retrieve your messages.
More info:
https://support.google.com/mail/troubleshooter/1668
960?hl=en
NOTE 2: if you are using two-step verification for
your Gmail account, you need to authorize getmail
by generating an application-specific password and
use that instead of your main account password.
More info:
https://support.google.com/accounts/topic/28786?hl
=en&ref_topic=2373945
Once you have filled all the required data, save your
file as:

~/. getmail/getmailrc
Close your text editor and return to the terminal.
Type getmail
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You’ll see a long string of messages display in the
terminal window as getmail starts downloading the
contents of your Gmail account. You can stop it at
any time by typing Ctrl+C inside the terminal
window.
NOTE: If the script stops, don’t panic. Google has
some limits on how many messages can be
downloaded from an account at one time. To
continue downloading your messages, just run the
getmail command again and getmail will pick up
where it left off. See getmail’s FAQs for more
information about this issue.
Once getmail finishes downloading all your emails,
you will see an informative message and you will be
returned to the prompt. You can safely close the
terminal window.

Looking for an old article?
Can't find what you want? Try the

PCLinuxOS Magazine's
searchable index!

The
PCLinuxOS
Magazine
Created with
Scribus 1.4.1

Screenshot
Screenshot Showcase
Showcase

You can automate the process of backing up your
Gmail account by creating a shell script and setting it
to run on a schedule using a cron job that runs once
a day, once a week, or however often you feel is
necessary.
Official website: http://pyropus.ca/software/getmail/

Want To Help?

Would you like to help with the PCLinuxOS
Magazine? Opportunities abound. So get
involved!
You can write articles, help edit articles, serve
as a "technical advisor" to insure articles are
correct, create artwork, or help with the
magazine's layout.
Join us on our Google Group mailing list.
Posted by MerReady, on 6/16/13, running Mate.
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PCLinuxOS Puzzled Partitions

Tux Scrappler

TUX SCRAPPLER RULES

Follow the rules of Scrabble®. You can view
them here. You have seven (7) letter tiles with
which to make as long of a word as you possibly
can. Words are based on the English language.
Non-English language words are NOT allowed.
Red letters are scored double points.
Green letters are scored triple points.
Add up the score of all the letters that you used.
Unused letters are not scored. For red or green
letters, apply the multiplier when tallying up your
score. Next, apply any additional scoring
multipliers, such as double or triple word score.

Sudoku Rules: There is only one valid solution to each Sudoku
puzzle. The only way the puzzle can be considered solved correctly
is when all 81 boxes contain numbers and the other Sudoku rules
have been followed.
When you start a game of Sudoku, some blocks will be pre-filled for
you. You cannot change these numbers in the course of the game.
Each column must contain all of the numbers 1 through 9 and no two
numbers in the same column of a Sudoku puzzle can be the same.
Each block must contain all of the numbers 1 through 9 and no two
numbers in the same block of a Sudoku puzzle can be the same.
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Download Puzzle Solutions Here!

An additional 50 points is added for using all
seven (7) of your tiles in a set to make your
word. You will not necessarily be able to use all
seven (7) of the letters in your set to form a
“legal” word.

In case you are having difficulty seeing the point
value on the letter tiles, here is list of how they
are scored:
0 points: 2 blank tiles
1 point: E, A, I, O, N, R, T, L, S, U
2 points: D, G
3 points: B, C, M, P
4 points: F, H, V, W, Y
5 points: K
8 points: J, X
10 points: Q, Z

Optionally, a time limit of 60 minutes should
apply to the game, averaging to 12 minutes per
letter tile set.
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Graphics Terms

PCLinuxOS Puzzled Partitions
1. to convert an image and save it as
another file type
2. a tool used to apply a specific effect to an
object
3.

the intensity of color in a picture.

4. the difference in the color and brightness
of an object and other objects within the same
field of view.
5. to replace information for one part of a
picture with information from another part.
6. a type of memory organization or image
file format used to store digital images.
7. graphical image made to be displayed as
a background on a computer screen.
8. used in digital image editing to separate
different elements of an image.
9. painting tool used to fill an object with
color.
10. to cut out part of a picture to keep or
emphasize another part.
11. the lightness of a color.
12. the rapid display of a sequence of images
to create an illusion of movement.
13. the components of a layer separated into
red, green and blue colors.
14. one of the main properties of a color.

Download Puzzle Solutions Here!
PCLinuxOS Magazine

15. the adjustment of the intensity of colors.
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ANIMATION
BALANCE
BITMAP
BLACK
BLUE
BRIGHTNESS
BRUSH
CHANNEL
CLONE
COLOR
CONTRAST
COPY
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CYAN
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GRAPHICS
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IMPORT
JPEG
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LINE
MAGENTA
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PASTE
PHOTOGRAPH
PURPLE
RED
RESIZE
SATURATION
WALLPAPER
WHITE
YELLOW
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Want to keep up on the latest that's
going on with PCLinuxOS?
Follow PCLinuxOS on Twitter!
http://twitter.com/iluvpclinuxos

Screenshot
Screenshot Showcase
Showcase

Support PCLinuxOS! Get Your Official

PCLinuxOS

Merchandise Today!
Posted by Agust, on 6/20/13, running e17.
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My Mobile Home Park's WiFi Setup
by Grandpa

One went to the TV shack. We also have our own
cable TV system.

lines into a corner of the park, and from there, we
run them to every site.

Now, why would you be interested in my mobile
home park's WiFi setup? Maybe you and your
neighbors would like to share a fast Internet
connection and share the cost. I am sure you can
think of many reasons why this could be helpful. So,
having never tried to write anything like this before, I
will try to explain how we did it.
First a little background. I live in the Southern
California desert. Most of our residents are
“Snowbirds.” Snowbirds are people who live in the
Northern USA and Canada. In the winter months,
they come South where it is warmer. We all know
how a good fast, secure Internet connection is
needed in our lives today. Most connections like that
can be expensive. They also require a 12-month
contract. So we share 4 DSL connections with
100/120 people. We charge $25.00 a year. Yes, that
is $25.00 for 12 months of fast secure Internet.

So, from that box in the corner, we ran three new
lines to the office. We connected the three new and
the existing office DSL to these four Verizon routers.

How did we do this? The park already had 4 phone
lines coming into the Park. One line went to the gate
entry call box.

Another line goes to the 911 phone in the Spa area,
and the fax machine in the office. The office line had
DSL already on it. We had DSL put on the other
three. I guess here I should tell you that the park
owns the phone lines in the park. Verizon brings the
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After connecting an ethernet cable to each of them
we routed them up into the attic.
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My Mobile Home Park's WiFi Setup
One went to a Linksys WRT54g router, which had
the stock firmware replaced with DD-WRT firmware.
It was connected to an antenna on the front of the
clubhouse.

routers have very strong passwords. The users must
be given a password in order to use the router we
want them to use.
We use DD-WRT firmware because it is much more
programmable. It is open source software based on

Linux. I could go into detail how to install the
software. However, it is available on their website,
along with instructions to install and program. Their
information is very well written and easy to follow.

Screenshot
Screenshot Showcase
Showcase

The other three went through the attic, out the back,
under the street, to this pole, with three antennas
attached to it.

There is one omni and two directional antennas. You
can also see a box under them. In that box, there
are the circuit boards from three Linksys WRT54g
routers with DD-WRT firmware installed on them. All
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Posted by agmg, on 6/15/13, running KDE4.
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Running A Simple HTTPD Web Server
by YouCanToo
There are times that you want to test out a web
script or page, but you don’t want to install a
resource hungry web server, or don’t need to run a
mySQL database or a server side script. IE: PHP,
CGI, etc.
Here comes Python to the rescue. Python has a
module to run a mini web server on your system. It
takes no time to configure and eats up very little
system resources! With the help of this little HTTP
server you can turn any directory in your system into
your web server directory. The only thing you need
to have installed is Python, which is installed by
default in PCLinuxOS.
Starting your Simple Server from the command
line
Open up a terminal and go to the directory you
would like to start the web server:

[dwmoar@laptop SimpleServer]$ python -m
SimpleHTTPServer
Serving HTTP on 0.0.0.0 port 8000 …

If you want to run your Simple Server on another
port you need to start it using the following format.
python -m SimpleHTTPServer port number

Example:

[dwmoar@laptop SimpleServer]$ python -m
SimpleHTTPServer 8080
Serving HTTP on 0.0.0.0 port 8080 …

It even works using a public IP address:

Now open your favorite web browser and type the
following address
http://localhost:8000 or http://127.0.0.1:8000 or
using given port number that you chose to use.
If the directory has a file named "index.html", that file
will be served as the initial file (image below).

cd /home/somedirectory

In my example I called mine “SimpleServer”
[dwmoar@laptop ~]$ cd SimpleServer
[dwmoar@laptop SimpleServer]$
Now to start your Simple Server, we enter
python -m SimpleHTTPServer

That's it! Now your http server will start using the
default port 8000. You will see the following
message in the terminal window:
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If there is no "index.html", then the files in the
directory will be listed (image top of next column).

To quit the Simple Server, in the console window use
CTRL+C. This should also work on a Windows
machine running Python. And there you go. Happy
web serving!
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International Community
PCLinuxOS Sites

Linux Docs
Linux Man Pages

Netherlands

Turkey
Denmark

Czechoslovakia

Does your computer run slow?
Are you tired of all the "Blue Screens
of Death" computer crashes?

Are viruses,
adware, malware &
spyware slowing
you down?
Get your PC back
to good health
TODAY!
Get

Download your copy today! FREE!
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It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...

Italy

Poland

Brazil
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More Screenshot Showcase

Above: Posted by jogurtmen, on 6/9/13, running KDE4.
Below: Posted by Arctarus, on 6/24/13, running KDE4.
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Above: Posted by RobNJ, on 6/5/13, running e17.

Below: Posted by ghostbunny, on 6/23/13, running LXDE.
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