Firefox 29.0
You Either Like It, Or You Hate It
# Table Of Contents

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>3</strong></td>
<td><strong>Welcome From The Chief Editor</strong></td>
</tr>
<tr>
<td><strong>4</strong></td>
<td><strong>Screenshot Showcase</strong></td>
</tr>
<tr>
<td><strong>5</strong></td>
<td><strong>PCLinuxOS Family Member Spotlight: exploder</strong></td>
</tr>
<tr>
<td><strong>7</strong></td>
<td><strong>Firefox 29: You Either Love It, Or You Hate It</strong></td>
</tr>
<tr>
<td><strong>9</strong></td>
<td><strong>Screenshot Showcase</strong></td>
</tr>
<tr>
<td><strong>10</strong></td>
<td><strong>Firefox &amp; DRM: Anything To Worry About?</strong></td>
</tr>
<tr>
<td><strong>11</strong></td>
<td><strong>Screenshot Showcase</strong></td>
</tr>
<tr>
<td><strong>13</strong></td>
<td><strong>Unhappy With Firefox 29? Here Are 21 Alternatives</strong></td>
</tr>
<tr>
<td><strong>17</strong></td>
<td><strong>ms_meme's Nook: Sweetest Little OS</strong></td>
</tr>
<tr>
<td><strong>18</strong></td>
<td><strong>PCLinuxOS Puzzle Partitions</strong></td>
</tr>
<tr>
<td><strong>21</strong></td>
<td><strong>Handy Utilities To Organize Your Life, Part Three</strong></td>
</tr>
<tr>
<td><strong>23</strong></td>
<td><strong>PCLinuxOS Recipe Corner</strong></td>
</tr>
<tr>
<td><strong>24</strong></td>
<td><strong>GIMP Tutorial: Fire</strong></td>
</tr>
<tr>
<td><strong>27</strong></td>
<td><strong>Screenshot Showcase</strong></td>
</tr>
<tr>
<td><strong>28</strong></td>
<td><strong>Programming With Gtkdialog, Part Three</strong></td>
</tr>
<tr>
<td><strong>36</strong></td>
<td><strong>Game Zone: Running With Rifles</strong></td>
</tr>
<tr>
<td><strong>38</strong></td>
<td><strong>Screenshot Showcase</strong></td>
</tr>
<tr>
<td><strong>39</strong></td>
<td><strong>Installing Plex On Your PCLinuxOS System</strong></td>
</tr>
<tr>
<td><strong>41</strong></td>
<td><strong>Screenshot Showcase</strong></td>
</tr>
<tr>
<td><strong>42</strong></td>
<td><strong>Print Your Poster With Ease</strong></td>
</tr>
<tr>
<td><strong>44</strong></td>
<td><strong>More Screenshot Showcase</strong></td>
</tr>
</tbody>
</table>
Welcome From The Chief Editor

The last month has seen Mozilla capture headlines a LOT. First, they released Firefox 29.0 with its "new" user interface. The new interface was panned by some and welcomed with a loving embrace by others. The fervor over the new interface had barely begun to squelch when Mozilla grabbed headlines again as the last of the "major" browsers to include provisions for a new DRM scheme that has formally been incorporated into the HTML 5.1 "standards."

Hence, the reason for the trio of Firefox articles in this month’s magazine. Firefox has been a favorite of Linux users for ... well ... forever, it seems. When such a major Linux favorite grabs that many headlines, it just can’t be ignored. It can – and has – sent ripples throughout the Linux community.

It seems that most everyone has an opinion about the interface redesign, and there doesn’t seem to be much middle ground. Folks seem to either really like the new interface, while others seem to really hate it.

The opinions about Mozilla giving up the fight against restrictive DRM seem to be a lot more of a radical and “knee jerk” reaction. Many users cried foul, and felt as if Mozilla had sold them out. Granted, DRM and FOSS don’t seem to fit well together, especially philosophically. Others took a much more radical approach, suggesting the removal of Firefox – and presumably everything else Mozilla – from the repository, based on “ethics.”

THEN, as if the Firefox “storms” weren’t enough, it was recently revealed that Chromium will no longer be able to play flash content in the near future. No one I know will rush to the defense of flash, and certainly not me. Flash has been a nightmare from the beginning. It’s security vulnerabilities and troubles have been long and legendary. Most of us are biding our time, living with and adapting to its serious flaws, until flash is a blemish in the history of computing and it is supplanted with HTML5.

Yet recently, Jack Wallen, the lone Linux voice at TechRepublic, made this ridiculous statement in one of his recent columns (click the link to read the entire column, along with the reasons for the upcoming change/challenge for Chromium users).

"Honestly, Linux will never succeed without embracing entities like Google. With companies like Google behind it, Linux could take over the world!"

Seriously?! Linux is a success, with or without Google. It’s Google who hasn’t stood behind Linux. Let’s see ... Linux users wanted a Linux version of Picasa. What did we get? The Windows version wrapped in a WINE container, until Google ABANDONED Linux users with even that ill-contrived monstrosity. Linux users were “promised” an integrated helper app for Google Drive that would allow use of Google Drive as easily as Dropbox. We were told that such an app was “eminent.” Years later, there still is no official support under Linux for Google Drive, from Google. Back when SketchUp was under the Google “umbrella,” Linux users pleas for a Linux version were completely and totally ignored.

Google’s total disregard for Linux users is legendary, and the list can go on and on and on. Yet Linux is supposed to warmly embrace Google if it "wants to survive?" The last time I heard, a "hug" involved two people embracing one another. One person (Linux) hanging onto Google’s leg and not getting a response is called begging. Linux users no longer wish to beg Google for support. Nor will they "sell out" their principles. How fortunate that survival in today’s multifaceted markets doesn’t totally revolve around one tech giant who has transformed itself from its founding credo of “do no evil,” to the very embodiment of evil, at least in some users’ eyes.

Google wants to pilfer from the Linux community, basing their Android OS on the Linux kernel, yet they remain ever reluctant to give back to the community that breathes so much life into their immensely popular (and presumably, profitable) operating system.

Linux will survive, with or without Google. Linux users will support and embrace Google when (if) that embrace becomes a two-way street. Until then, it’s unreasonable to expect Linux users to embrace Google without getting anything in return.

Until next month, I bid you peace, happiness, serenity and prosperity.
Want to keep up on the latest that's going on with PCLinuxOS?

Follow PCLinuxOS on Twitter!

http://twitter.com/iluvpclinuxos

Want To Help?

Would you like to help with the PCLinuxOS Magazine? Opportunities abound. So get involved!

You can write articles, help edit articles, serve as a "technical advisor" to insure articles are correct, create artwork, or help with the magazine's layout.

Join us on our Google Group mailing list.

Posted by tbschommer, May 1, 2014, running KDE.
PCLinuxOS Family Member Spotlight: explorer

as told to Smileeb

How old are you?
I am 52 years old. I was born in Conneaut, Ohio September 13th 1961.

Married, single or what?
I am married, third time now!

Children, grandchildren?
I have 4 kids, Ashley, Donnie, Trent and Gabe and one grandchild, Hunter.

Retired or working and for how long and at what?
I work for Stoneridge North America in Portland, Indiana. I prep heavy gauge and multi-core wires to build wiring harnesses. I have been at Stoneridge for about 8 years now.

What is the area you live in like. Weather, Quietness, Scenery?
I live in Hartford City, it's a quiet little town. The land is pretty flat around here, lots of fields and farms. Currently it's winter here but we usually do not get very much snow. I remember being outside on Christmas with my brother and my grandfather and it was 60 degrees out! The weather changes here all the time.

Are you handy with your hands and have any hobbies?
I like working on cars and trying to fix up my house. I work on computers a lot and enjoy trying different desktop environments. I am an amateur when it comes to home remodeling, but it sure is a good feeling when things turn out nice.

What is your education level?
I am a high school graduate. I went to Kent State University for one semester and dropped out. I also went to Ivy Tech and took a course on Machine
What caused you to try Linux and join this forum?

I came across PCLinuxOS 2007 when it was under development, and I was very impressed! The lead developer was right in there with the community working and I instantly liked his style and humor. Many of the people on the forum are around my age, and in a short time I felt like I really knew the people I was interacting with.

The PCLinuxOS forum just seems like a family. Everyone supports each other, and not just where software is concerned. The people on the forum were there for me through some very rough times in my life, and their support helped more than anyone could ever imagine.

PCLinuxOS just works, too. It has never failed me. I have fun with the various editions, especially the Enlightenment edition.

If you would like to be featured in PCLinuxOS Family Member Spotlight, please send a private message to smileeb in the PCLinuxOS forum expressing your interest.

Donate To PCLinuxOS

Community Supported.
No Billionaires/Millionaires.
No Corporate Backing Or Funding.

Click here to make a one-time donation through Google Checkout.

Or, click one of the amounts down below to make a monthly, recurring donation.

---

Trades. I liked Ivy Tech because I could take what really interested me and I really enjoyed it.

Do you like to travel, go camping?

I used to go camping with my uncle and cousins. I still have fond memories of camping. I do not travel much, since my eyesight is not the best these days for driving. My wife Amanda does all of the distance driving. She can drive in big cities much better than I can.
Firefox 29: You Either Love It, Or You Hate It

by Paul Arnott (parnote)

On April 28, 2014, Texstar released Firefox 29.0 to the PCLinuxOS repository. On one side of the fence, you would have thought that someone just witnessed a horrible, bloody murder. On the other side of the same fence, users were singing the praises for the new Firefox 29.0. There appeared to be no fence-sitting. Users either liked it a lot, or hated it a lot.

Firefox 29.0 was released with a whole new user interface (shown below). The criticisms mostly focused on the changes in the appearance of Firefox, which represents a large departure from the time tested appearance users had become accustomed to.

Many who were critical of the new user interface likened its appearance to that of the Google Chrome browser. Others criticized that some of their favorite Firefox "add-ons" no longer worked. Yet others didn't care for the switch from squared to rounded tabs. In many ways, the old, tired appearance that had been "Firefox" for so long, was like home to many users, and they see no reason to "fix" something that isn't broken.

All of the criticisms are valid. But in the world of software, things evolve and move on, whether we like them (or agree with them) or not. People are resistant to change, especially when it appears to be change merely for the sake of change. In many ways, it's reminiscent of when KDE changed from 3.5.x to 4.x.

What's easily overlooked, at least initially while users scold the Firefox developers and accuse them of high treason, is that Firefox is as configurable as it has always been. With just the addition of ONE Firefox add-on, you can get as much of the "old" interface back that you want.

Don't like the tabs on top? No problem. Want to separate the back/forward buttons from the URL line? Easy sneezy. Want the add-on bar at the bottom of your Firefox window? Simple dimple. Do you prefer the squared tabs, instead of the rounded tabs? Esta muy facil!

Just download the Classic Theme Restorer v 1.1.8 add-on and install it in Firefox 29.0. With just this ONE add-on, you can then change all of those items, and then some more.

Firefox 29.0, as it appears after being started in safe mode, which is similar to the “out-of-box” experience.
There are four tabs of settings you can customize. I won’t go over all of them here, as I feel that most of them are fairly self-explanatory. Plus, if you change a setting and don’t like it, it’s easy enough to change it back.

Below is the way my Firefox 29.0 appears, after tweaking it with the Classic Theme Restorer add-on.

By default, the menu isn’t displayed at the top of the Firefox window. To make it appear, you will need to right-click your mouse on an empty spot of your toolbar, and place a checkmark in front of “Menu Bar.”

Another “feature” that mimics Google Chrome is the use of the “hamburger” button, in the upper right corner of the window. You can further customize the appearance of Firefox by selecting the “hamburger” button, then selecting “Customize” from the bottom left of the menu that appears.

Once in the customization mode, you can move pretty much everything and anything to a location you prefer. You can also add and remove items from the toolbar. Simply drag the items you don’t want from the toolbar and drop them into the area on the left, named “Additional Tools and Features.” Similarly, drag any item you see under “Additional Tools and Features” to where you want them to appear on the toolbar. It’s a simple as drag and drop. Click the green “Exit Customize” button (lower right) when you are done customizing.

Most of your favorite Firefox add-ons work with Firefox 29.0. There is, however, one very popular Firefox add-on that isn’t compatible with the newer Firefox — at least, it’s not available through normal add-on channels. That add-on is called Forecast Fox, and is probably one of the best weather forecast add-ons to have ever been devised (you can see it running in my “tweaked” Firefox screenshot, on the menu bar).

The latest version, 2.2.4, which works with the latest Firefox 29.0, isn’t available through the normal Firefox add-ons channels. It’s a mystery to me why Mozilla hasn’t made this available, but the developer has made an update available. You can, though, download it from [here](https://addons.mozilla.org/en-US/firefox/addon/forecast-fox-v2/).

**Summary**

If you love Firefox, I suspect you’ll keep loving it — and using it. If you don’t like the new appearance, it will most likely grow on you, just as KDE 4.x did and a number of other “advances” in software. If it doesn’t grow on you, I suspect you’ll be in the market for a browser replacement.
I did notice one additional benefit with the newest Firefox: it's much more stable than earlier versions. I'm not sure why, but every version of Firefox since 25.0 has crashed almost daily on the multiple computers I have running here. With Firefox 29.0, I've only experienced one crash of Firefox in nearly a month of heavy, continual use.

Perhaps of greater concern to Firefox users than the change in Firefox's appearance, is the fact that Mozilla has finally given in and included provisions for supporting DRM (digital rights management, or as some call it, digital restrictions management). This recent revelation has done more to set the Firefox community on fire than the mere change of appearance. An awful lot of Firefox users are feeling that Mozilla “sold them out” by embracing DRM content. If you haven't heard about this yet, I suspect you will. This Firefox firestorm has only just been sparked. When it will be introduced is still uncertain. Months of testing will have to be performed before it is fully implemented in a public release.
Firefox & DRM: Anything To Worry About?

by Paul Arnote (parnote)

In the middle of May, Mozilla announced to the world that they will embrace a new DRM (digital rights management, or digital restrictions management, as Richard Stallman has called it) scheme for the playback of protected (some might say restricted) content. That scheme, called EME (encrypted media extensions), will utilize a CDM (content decryption module) to stream protected content through the user’s web browser.

As you might imagine, the initial uproar among the web community was loud and quite negative. Our beloved open source browser would now include closed source DRM modules. Or, is it really as the nay sayers and negative Nellies initially think?

Let’s try to step back and look at this issue with a wider perspective. As early as January 2013, talk was circulating about the W3C consideration to include DRM specifications in the HTML 5.1 specifications. On September 30, 2013, Sir Tim Berners-Lee and the rest of the W3C committee signed off on such a DRM specification, called EME. This proposal was from Microsoft, Google and Netflix, and was put forth to try to standardize DRM.

Mozilla, the makers of Firefox, fought the proposal at every step along the way. Mozilla put up one helluva good fight. But at the end of the day, all of their fight was for naught. They were outmanned, outmaneuvered and outvoted.

Consider, if you will, the environment surrounding Mozilla’s decision. Opera, IE and Chrome all support the EME/CDM specifications. That left Firefox as the only major browser vendor not supporting the DRM specifications.

As popular as Firefox is, especially among Linux users, Firefox’s share of the browser “market” has been declining over the past five years. In that same time span, Google’s Chrome browser has come from virtually no market share to becoming the predominant browser in the browser market.

The LAST thing Mozilla developers want is for users to have to use another browser to view protected streaming content. But unless Firefox supported the EME/CDM DRM specifications, users would be forced into doing just that. The risk of losing those users altogether becomes significant, as those users may just opt to use that “other” browser as their predominant browser.

**DRM: A Double Edged Sword**

Indeed, DRM really is a double edged sword. On one hand, content providers want a way to protect copyrighted material from being pirated. You can hardly blame them. On the other hand, DRM, as it currently exists, is extremely burdensome on the end
user. The user must have the right “keys” (extensions, plugins, etc.) to unlock the content.

It’s also frequently not very easy to stream the same content on multiple devices. In many cases, if you “purchase” the keys to view protected content on one device, you often cannot view it on another device. Instead, you have to “buy” another key on the other device. That situation is a bit akin to buying a DVD, restricting the playback to just ONE DVD player, then having to buy another copy for every DVD player you want to play it back on. Generally speaking, the current DRM situation doesn’t allow for “fair use,” preventing playback of the purchased copy of the protected content on more than one device.

Mozilla’s preference was for watermarking content with something that uniquely identified the user. This would allow for the same content to be used between all the different devices a user might possess (smartphone, tablet, computer, desktop device, etc.), but provide a barrier to illegal file sharing. Should a user choose to share a file, the watermark would lead authorities back to the origin of the pirated copy.

Many have argued, rightfully so, that DRM is just a way for content providers to hang on to old business models, and avoid adapting to changing markets and market conditions. As it is in its current form, DRM heavily favors content providers and creates a nightmare for end users trying to jump through all the DRM hoops. In many ways, DRM encourages piracy of protected content, as users will try to circumvent DRM, rather than paying three times for streaming the same content on multiple devices, regardless of the existence of any laws (such as the Digital Millenium Copyright Act). Plus, there are those users who just love the challenge of trying to defeat any DRM, and they post their “successes” to share with everyone else.

So what does all of this mean?

Not much, if you stop and think about it. DRM already exists, in one fashion or another, through Silverlight (although not on the Linux platform) and Adobe Flash content. You already watch Flash content, and many Linux users are hell bent on trying to view Silverlight protected content under Linux.

According to Mozilla, you will always have the ability to say NO to installing the DRM modules, just as you can currently do with Flash or any other plugin module. No one is forcing Firefox users into
accepting DRM. That ability will, true to Mozilla's stated goals, remain with the end user to decide to accept – or not.

The good thing about the EME/CDM DRM scheme is that it spells the end to Silverlight and Flash – eventually. Those two atrocities have needed to go away a LONG time ago, and their departure cannot happen fast enough. Instead, users will have one “standardized” DRM scheme to deal with that should work across all platforms. You can read more about Mozilla’s decision to reluctantly enable DRM in Firefox here and here.

Users shouldn’t blame Mozilla. After all, they are simply wanting to maintain their current market share, and perhaps even increase it. If anything, users should place blame equally on content providers tenaciously holding onto their old business models, and on the W3C – Sir Tim Berners-Lee included – for capitulating to the whiny demands of those content providers.

Like it or not, DRM content is here to stay – at least for the time being. And it will remain that way until content providers embrace the digital age and adapt to the new business model that it brings with it. Currently, content providers want to embrace the digital age, but wrap it up in their old, outdated business model. Until that changes, DRM will be an ever present scourge upon content consumers.
Unhappy With Firefox 29?  
Here Are 21 Alternatives

by Paul Arnote (parnote)

The recent changes to Firefox 29 caused an uproar among faithful Firefox users. Many of those complaints were based on the cosmetic changes in Firefox. Beneath the surface, though, it remains the familiar Firefox that most of us have come to love and use. Sure, there are extensions and add-ons that no longer work with the updated Firefox, but over the years, that has happened with many Firefox updates. Firefox remains one of the most secure browsers, if not THE most secure browser around today.

If you just simply cannot tolerate the changes to Firefox, here is an alphabetical list of alternative browsers in the PCLinuxOS repository. Perhaps one of them will make a suitable replacement.

Chromium. This is the open source version of Google’s Chrome browser. The nice thing about this version is that it doesn’t contain the “phone-home-to-Google” code that Chrome is (in)famous for. The vast majority of extensions and add-ons for Chrome work just fine in Chromium. Also, Chromium is perceived as being more secure than Chrome, but not for the reasons you might expect. The numbers of security vulnerabilities over time prove that, indeed, Chromium is more secure.

Chrome, Google. This is Google’s freely distributed, but closed source, version of the Chromium browser. While it’s a fast and capable browser, be forewarned that it does include “phone-home-to-Google” code that may compromise the anonymity of your browsing. Chrome has captured the top honors as the most predominant browser currently in use.

Dillo. If you’re looking for a fast browser with a minimal footprint, Dillo may be just what you are looking for. Written entirely in C, it’s a graphical browser based on FLTK2 that utilizes a subset of HTML. You won’t get HTML5 features, but then you also cannot use/display pages with frames, Javascript or JVM.

Dooble. Available in versions for Linux, FreeBSD, Windows and OS X, Dooble was created to improve privacy. It uses Qt for its user interface, along with the Qt Webkit library.

dwb. dwb is a lightweight web browser based on the webkit web browser engine and the gtk toolkit. dwb is highly customizable and can be easily configured through a web interface. It intends to be mostly keyboard driven, inspired by firefox’s vimperator plugin. dwb is perfectly suited for tiling window managers, such as wmi.

ELinks. ELinks is an advanced and well-established feature-rich text mode web (HTTP, FTP, etc.) browser. ELinks can render both frames and tables, is highly customizable and can be extended via scripts. Besides its ability to render frames and tables, its features include the ability to display colors as specified in current HTML page, uses drop-down menu (like in Midnight Commander), downloading files in the background, and HTTP authentication. It is ran in a terminal session.

Jumanji. Jumanji is a highly customizable and functional web browser based on the libwebkit web content engine and the Gtk+ toolkit. The idea behind Jumanji is a web browser that provides a minimalistic and space saving interface as well as an easy usage that mainly focuses on keyboard interaction, like Vimperator does.

Konqueror. Konqueror uses the KHTML rendering engine, which was also selected by Apple to create WebKit. Today, WebKit forms the backbone for other
browsers, such as Safari and Google’s Chrome. Besides supporting HTML5, Javascript and CSS3, Konqueror also includes a built in ad blocker and popup blocker.

**Links.** Links is a text based WWW browser, at first look similar to Lynx, but somehow different. It renders tables and frames, displays colors as specified in current HTML page, uses drop-down menu (like in Midnight Commander), can download files in background, and can partially handle Javascript. It is run in a terminal session.

**Lynx.** Lynx is a text browser for the World Wide Web. Lynx 2.8.7 runs on Unix, MacOS, VMS, Windows 95/98/NT, DOS386+ (but not 3.1, 3.11), as well as OS/2 EMX. It is run in a terminal session.

**Maxthon.** Maxthon Cloud Browser delivers high performance and seamless browsing along with its core values of speed and a great out of the box experience. With speed and performance, Maxthon runs on an optimized WebKit core made faster by Maxthon's in-house Webkit R&D team. With the Maxthon Cloud Browser, you can automatically sync all of your tabs, bookmarks and contacts across all of your platforms, so you can start reading something on your PC, and continue reading it on your smartphone during your commute. Maxthon is available for Linux, Windows, Android, iOS, OS X, and Windows Phone platforms.

**Midori.** Midori is a lightweight but full featured web browser. Starting life as part of the Xfce desktop, Midori uses Gtk+2/3 and WebKit. It supports the display of pages using HTML5 and CSS3. Midori might be small (only a 4.6 MB download from Synaptic), but it is mighty. It features a small collection of built in extensions to help with the most common desires of web browsing users, such as blocking ads. Additionally, Midori features built in privacy tools that allow users to disable scripts, block third party cookies, strip referrer details, and clear history automatically after a set amount of time, or when Midori is closed. If you haven’t looked at Midori in a while, you might be surprised. It has grown up.

**Unhappy With Firefox 29? Here Are 21 Alternatives**

**NetSurf.** NetSurf is a lightweight browser with its own layout and rendering engine entirely written from scratch. It is small and capable of handling many of the web standards in use today.

**Opera.** Despite its relatively small market share, Opera has a very strong and loyal following. Opera is designed as a high speed browser, and most users find that tabs load faster, even on slower internet connections. Opera also checks risky sites and alerts you to possible threats, hopefully before anything is compromised. Its privacy settings allow you to surf the web without being tracked. Opera is also configurable with hundreds of downloadable extensions.

**QupZilla.** QupZilla is a new and very fast World Wide Web Browser which uses the Qt Framework and its QtWebKit rendering core. It is a lightweight browser...
with some advanced functions like integrated AdBlock, Search Engines Manager, Theming support, Speed Dial and SSL Certificate manager.

**Rekonq.** Rekonq is a lightweight KDE browser based on Webkit. Its code is based on Nokia QtDemoBrowser, just like Arora. Its implementation is set to embrace KDE technologies to put forth a full-featured KDE web browser. While Rekonq will never have tons of features like some other browsers, it can provide a good tabbed browsing experience. It will use the KDE download system to download files, and it can share bookmarks with Konqueror. Rekonq can also navigate in a proxied net, allow a user to browse anonymously, and allow users to inspect web pages.

**SeaMonkey.** SeaMonkey is an all-in-one Internet application suite. It includes a browser, mail/news client, IRC client, JavaScript debugger, and a tool to inspect the DOM for web pages. It is derived from the application formerly known as Mozilla Application Suite, and it uses the Firefox rendering engine to display web pages.

**SlimBoat.** Fast, secure and powerful internet web browser based on QtWebKit. SlimBoat is a free internet web browser that is fast, secure & loaded with powerful features. It is fast to start up and fast to open your favorite web sites. SlimBoat helps you surf the internet safely and securely by incorporating multiple layers of strong protection measures. SlimBoat also includes tons of powerful functions and flexible options so that you can reach your favorite destination on the Internet in the most convenient way while avoiding unnecessary distractions and annoyances.

**Surf.** Surf is a simple web browser based on WebKit/GTK+. It is able to display websites and follow links. It supports the XEmbed protocol which makes it possible to embed it in another application. Furthermore, you can point surf to another URI by setting its XProperties. Surf is a tableless browser, essentially meaning that it's like browsing with the browsers of long ago, where you could only view one web page at a time. While Surf is best suited for lightweight window managers, such as wmii, you should be able to run it under any desktop environment.

**Tor Browser Bundle.** The Tor software protects you by bouncing your communications around a distributed network of relays run by volunteers all around the world. It prevents somebody watching your Internet connection from learning what sites you visit. Tor also prevents the sites you visit from learning your physical location, and it lets you access sites which are blocked. Available
for Linux, OS X, and Windows, the Linux version will first connect to the Tor network, and then launch Firefox.

**Xombrero.** Xombrero is a minimalist tabbed web browser with sophisticated security features designed-in, rather than through an add-on after-the-fact. In particular, it provides both persistent and per-session controls for scripts and cookies, making it easy to thwart tracking and scripting attacks. In addition to providing a familiar mouse-based interface like other web browsers, it offers a set of vi-like keyboard commands for users who prefer to keep their hands on their keyboard. The default settings provide a secure environment. With simple keyboard commands, the user can “whitelist” specific sites, allowing cookies and scripts from those sites. It is distributed under the ISC license.

**Summary**

Well, there you go. If the recent changes to Firefox have you singing the blues, you have 21 “other” browsers to try out. Of course, by leaving Firefox, you’ll also be giving up on one of the most secure browsers around. Despite all the recent changes with Firefox, it remains one of the most configurable, most dependable, and most secure browsers around. Anyway, there’s nothing to lose (other than a little hard drive space) by trying out alternative browsers.

While Firefox remains my favorite browser, I also have Chromium and Chrome installed on all of my computers. On my computers running the Xfce desktop (which are most of them), I also have Midori installed. On one computer, I also have SlimBoat installed. On my computer that runs KDE, I also have access to Konqueror. While I may occasionally stray, I always come back home to Firefox. Variety IS the spice of life.
ms_meme's Nook: Sweetest Little OS

PCLinuxOS is the only one for me
I fled from that Windows as fast as I could flee
I never shed a tear as from it I did part
And if I return again just shoot me in the heart

It's the sweetest little OS made by Texstar
Always a working it is the best by far
You may tweet about Ubuntu or even Red Hat
But for PCLinuxOS I'll always go to bat

With PCLinuxOS you'll never have malware
Open up your browser you'll never have a scare
Come and join the Forum you're always welcome there
You will find members about from everywhere

It boots up so quickly it never slows me down
And if I need some help PCLOS geeks abound
I just go to a console and paste in their code
And that will bring me back again to my user mode

It's the sweetest little OS made by Texstar
Always a working it is the best by far
Everyone loves it that is no surprise
Download it right now that's what I advise
PCLinuxOS Puzzled Partitions

<table>
<thead>
<tr>
<th></th>
<th>1</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>9</td>
</tr>
<tr>
<td>4</td>
<td>7</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td>7</td>
<td>6</td>
<td>8</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>7</td>
</tr>
</tbody>
</table>

SUDOKU RULES: There is only one valid solution to each Sudoku puzzle. The only way the puzzle can be considered solved correctly is when all 81 boxes contain numbers and the other Sudoku rules have been followed.

When you start a game of Sudoku, some blocks will be prefilled for you. You cannot change these numbers in the course of the game.

Each column must contain all of the numbers 1 through 9 and no two numbers in the same column of a Sudoku puzzle can be the same. Each row must contain all of the numbers 1 through 9 and no two numbers in the same row of a Sudoku puzzle can be the same.

Each block must contain all of the numbers 1 through 9 and no two numbers in the same block of a Sudoku puzzle can be the same.

SCRAPPLIER RULES:
1. Follow the rules of Scrabble®. You can view them here. You have seven (7) letter tiles with which to make as long a word as you possibly can. Words are based on the English language. Non-English language words are NOT allowed.
2. Red letters are scored double points. Green letters are scored triple points.
3. Add up the score of all the letters that you used. Unused letters are not scored. For red or green letters, apply the multiplier when tallying up your score. Next, apply any additional scoring multipliers, such as double or triple word score.
4. An additional 50 points is added for using all seven (7) of your tiles in a set to make your word. You will not necessarily be able to use all seven (7) of the letters in your set to form a “legal” word.
5. In case you are having difficulty seeing the point value on the letter tiles, here is a list of how they are scored:
   0 points: 2 blank tiles
   1 point: E, A, I, O, N, R, T, L, S, U
   2 points: D, G
   3 points: B, C, M, P
   4 points: F, H, V, W, Y
   5 points: K
   8 points: J, X
   10 points: Q, Z
6. Optionally, a time limit of 60 minutes should apply to the game, averaging to 12 minutes per letter tile set.
7. Have fun! It's only a game!
PCLinuxOS Crossword Puzzle: June 2014

Browsers

1. Most predominant browser in use
2. Open-source version of Chrome
3. KDE based browser
4. Minimalistic and space saving, concentrating on keyboard commands
5. Browser with built-in email & IRC capability
6. Another well-known browser
7. Text based browser, run in terminal.
8. Originally a default browser in Xfce
9. Fast, secure and powerful browser based on QTWebKit.
10. New, fast browser which uses QT framework
11. Cloud browser, able to sync to all devices.
12. Fast browser with minimal footprint
13. Most secure browser - new version 29 just released
14. More secure by bouncing connections over several relays.
Handy Utilities To Organize Your Life, Part Three

by Meemaw

Address Books

We all have different ways of recording addresses. Most of the email programs in use have an address book in which we can save our friends' email addresses. Many of them have sections in which to save a friend's physical address as well. I use Gmail most and have addresses stored there.

However, what do you do if your internet is down? I use Thunderbird at work, and use its address book to keep track of business contacts. Thunderbird’s address book works even if I have no internet connection, but I couldn’t access my Gmail contacts if I wasn’t online. Fortunately, the PCLinuxOS repository has a few standalone programs to help me out.

Contacts is a basic address book with a small, simple window. When you open it, you see the window below. You can increase its size by clicking a corner with your mouse and dragging out the corner.

All you have to do is click on “New” and an Edit contact window will open, as shown at center top.

There you can add all your contact's information before clicking the “Close” button. The button shape in the upper right corner is to add a photo, if you wish. You see the main fields - name, address, phone and email - but you can add several other fields if you need them: MSN, Yahoo, AIM and ICQ nickname, birthday, homepage and a separate note space.

When you have your contacts added, you will have a list on the left side of the window. If you click on one of your contacts, the right side of the window will have a summary of your added information. You can also import contacts if they have been exported from another address book in vCard format (.vcf), but I don’t see an export function. However, Contacts is a nice, simple little address book.

Dexter is another very basic program. From alternativeveto.net - Dexter is a very simple, easy to use address book, designed with the home user in mind. This personal contact manager integrates with Postler, and can import and export contacts in vCard format. Opening Dexter for the first time, you see a window asking if you want to import a vCard address book file or create a new contact.

I imported some contacts from my Gmail, and can add as many more as I want simply by clicking on New Contact in the upper left corner. The new contact window looks like the one on the next page. You can add as many emails, phone numbers and addresses as you want by clicking the plus sign to the right of the section you need. If you make a mistake, you can go back to your contact and click on the next button, Edit Contact. If you no longer need a contact, you can delete it with the Delete Contact button.

You can export your contacts in vCard form from Dexter. Click on the rectangle in the upper right of your window, and you will be able to export your address book. The menu also has a section where you can choose how to sort your contacts.
Handy Utilities To Organize Your Life, Part Three

Abook is a program for those of you who want to do everything in your terminal. It is text-based, but still seems to do everything necessary. After installing from the repo, open a terminal, type `abook` and it will open with the following screen. I have already added a couple of contacts.

![Abook screenshot](image)

It's actually pretty straightforward. Keystrokes at the top of the window tell you what to do. If you want to add a contact, press `a`. You will see a new window with the impression of tabs at the top. The tabs say Contact, Address, Phone, Other and Custom. You can switch from one to another using your arrow keys. The first thing you will add is your contact's name, then press `Enter`. The way to enter more information is to press the number in front of the field you wish to add. The only other field in the Contact tab is `2 - email address`. Arrow over to the Address tab and press `1` to add the street address of your contact, then press `Enter` (top right).

![Abook screenshot](image)

Proceed through the tabs and fields in the same way, pressing the number of the field you want, adding the information and pressing `Enter`. When you are finished, press `q` for quit, and you will arrive back at the main screen. You can use your arrow keys, then press enter to go to a contact and look at their information. Pressing `?` will give you the help screens. Pressing `q` at the main screen will close the program.

```
Abook 0.6.qpre2 | help q:quit editor
```

Notice from the help files that you can sort, search or export your address book, and even print it. If you love your terminal programs, this will work well for you.

```
Abook 0.6.qpre2 | help
```

I also have an abbreviated address book in a spreadsheet, just for Christmas cards & labels, but that isn't everyone – just those to whom I send cards. It's nice to have a separate address book, just in case. I'm sure one of these will work just fine for you.

---

**Rubrica** seemed like it would be a great program. From Sourceforge: Rubrica is an addressbook manager for GNOME. It allows you to add personal data (name, surname, address, etc.), web links, irc and email addresses, telephone numbers, job information (company where contact works, company infos, contact's assignment, etc.) and notes. However, the source code hasn't been updated in about 18 months, and the version in the repos is from 2008, repackaged in 2010. I couldn't get it to run on my laptop. I could enter contacts and click Save As..., but if I closed the program, there was nothing saved to open the next time I started it.

Dexter is a nice little program.

---

PCLinuxOS Magazine
Blackberry Bacon Cobbler

This requires only six ingredients:
- 3/4 cup of flour
- 2 cups of white sugar
- 1/2 cup of butter
- 3-5 cups of blackberries
- 18-20 strips of bacon
- About a cup of brown sugar

Simple!

First off, we need some well done bacon to crumble into the topping.

Simple cook three or four strips of bacon until they are well done, and cool them on a plate with a paper towel. When cooled, crumble or run them through a food processor.

Mix the flour and sugar in a large mixing bowl. Soften the butter and fold it into the dry ingredients. Mix it well until it's lumpy, it should stick together if you squeeze it but crumble easily. If it seems too dry add a bit of water, but be careful, just add it a teaspoon at a time.

Finally, stir in the crumbled bacon and set aside.

On a foil lined baking sheet, lay out 7-8 strips of bacon side by side. Along one edge, fold every other strip of bacon back a bit, and lay another strip of bacon along this edge and fold the strips back over it.

The strips it is lying along should now alternate over-under-over-under. From the other side of the weave, fold all the under strips back, all the way to the perpendicular bacon strip. Lay another strip next to it, fold the strips back over, and then fold back all the new under strips. Repeat until you've got a weave!

Turn on your oven to 425F. Rub a good amount of brown sugar all over the top of the weave, and put it in the oven. Check it every ten minutes or so, until it's started to brown nicely.

Carefully flip the weave with a pair of tongs, and add more brown sugar. Put it back in the oven cook it longer, again checking every ten minutes or so. Candied bacon can get overdone pretty quickly!

Next time I make this, I'm going to pour off the grease after the flip. I think it would have been better if the bacon weave had come out a bit more crispy!

When it's finally done, place it on a plate with a paper towel to soak up the worst of the grease.

Line a small cake pan with tin foil and put the candied bacon weave crust in it. Trim any edges that stick out (and eat them!)

Pour the berries into the pan. It's fine if they stick out a bit over the rim, they will reduce down as they cook.

Pour the bacony topping crumble over the berries and gently pat it down.

Preheat the oven to 375F. Place the cobbler pan on a baking sheet to catch any drippings. Bake it for about fifteen minutes, then check it every five until the topping is golden brown and the berry juice starts to bubble up into it.
GIMP Tutorial: Fire

by Meemaw

When we were working on the July 2013 issue of the magazine, parnote asked me if I could create a fire effect for the cover. So, I went looking for tutorials, and found some. Two of the following are for creating flames across the bottom of a wallpaper. The third is for creating a very realistic looking explosion.

Creating Flames

This method will create flames that have a kind of “crackle” effect.

Create a new file with a black background. (File > New and clicking Advanced Options, and then Fill with foreground color). If for some reason you get something other than black, you can always choose black as your color and use your bucket fill tool.

Click on the color palette and change the foreground color to white. Select the paintbrush icon. Paint a white horizontal stripe just above the bottom of the canvas. It doesn’t need to be perfectly straight. Paint a second stripe 50 pixels above the first. This stripe doesn’t need to be perfectly straight either. (I can’t draw a straight line most of the time, anyway!)

Choose the smudge tool. (It looks like a hand with an outstretched index finger.) Click on the bottom stripe and draw your mouse up past the second stripe. This creates what looks like a black and white flame. Repeat this process along the stripes until the white stripes are no longer visible. It might take a while.

Creating the Crackle

Now we want to give it a sort of crackle effect. Click Layer > New Layer. Click OK without changing the default settings. Select Filter > Render > Clouds > Solid Noise. Set X to 13 and Y to 7. Click OK.

Set the layer’s mode to Overlay. You can do this from the Layers window on the right side of the screen. Mode is a drop down box near the top of the window.

Create another layer by clicking Layer > New Layer. Click on Filters > Render > Clouds > Plasma. Set Turbulence to 5 and then click OK (next page, top left).

Select Color > Color Balance. Set both the Shadows and Midtones so that Red equals 100, Green is 25 and Blue is -25. Set the Highlights so that Red is 100, Green is 0 and Blue is -100. This turns the black and white flames into red and yellow flames.
GIMP Tutorial: Fire

Select Colors > Desaturate, and then OK.

Set the this layer’s Mode to Overlay as well. You now have a fire with a crackle effect.

Right now, the fire looks really primitive. Click on Filters --> Blur --> Gaussian Blur. Set Vertical and Horizontal to 100. You should now see something similar to the image below.

Create a new transparent layer. Go to Filters > Render > Clouds > Plasma. Set the Turbulence=5 and click OK. Now go to Layers > Colors > Desaturate. Set this cloud layer’s options to Overlay, too.

Another Flame Method

Create a new file filled with black, and create a new transparent layer.

The fire will be made with 3 colors, red, yellow, and white. Using a red color, draw the basic shape of the fire. Do the same with yellow, making sure some red is still showing. Repeat with white. Your drawing should look similar to the screen below.

It looks better but still doesn’t look realistic. Create a new transparent layer and go to Filters > Render > Clouds > Solid Noise. Set the X-Value to 13 and the Y-Value to 7. Duplicate the layer with the clouds. Set both cloud layers’ Mode to Overlay.

It should now look like this:
If you want edit the fire a little more, you can just go to Filters > Distort > I Warp. Play around with it to get what you like. I didn’t do anything in I Warp.

An explosion effect.

Open a new file whatever size you want. Fill it with a gradient (black to white), making sure at least 1/4 of your page is white. The white will be the brightest part of your fire.

Create a new layer (transparent) and and click on Filters > Render > Clouds > Plasma, and set the Turbulence to 6. Find the plasma pattern that you like by repeatedly clicking New Seed. Set the layer mode to Grain Merge.

Desaturate this layer, then click Colors > Color Balance, and make sure the Preserve Luminosity box is checked. While you have that window open, also adjust the Shadows/Midtones/Highlights color levels until you get the desired look of your fire. The following settings look pretty good: Shadows: 88, -65, -56 / Midtones: 71, 35, -49 / Highlights: 91, 87, -5)

Merge ALL layers down, then select Blur > Selective Gaussian Blur. Set Blur Radius at: 25 and Max Delta at: 50. You’re done!
Available in the following desktops:

- KDE
- LXDE
- Xfce
- Openbox
- MATE
- Enlightenment e18

Posted by Aleph, May 16, 2014, running KDE.
Programming With Gtkdialog, Part Three

by Peter Kelly (critter)

So far, we have looked at widgets that show text or offer a choice to the user, but often we need to get input from a user.

The entry widget

This is the simplest way to get user input, but is quite flexible. The user is presented with a box into which they may type a single line of text.

You may provide some default text, hide the text as in a password prompt, restrict the length of the text, and set the focus to the input box so the user can immediately start to type, overwriting any default text. If the entered text is longer than the input box, then the text will scroll to keep the cursor position visible. The text may be supplied from or written to a file. You can supply icons, including Gtk stock icons, to appear to the left, right or both ends of the text. The icons may raise tooltips when hovered over, and the tool tip text may use markup tags to adjust font attributes, such as color or emphasis.

Naturally, the appearance of the widget itself can be adjusted. It may be flat or framed, adjusted for width and height, and may be visible, invisible, active or inactive. The text can be refreshed, automatically if required, or cleared by another widget. An entry box widget is responsive to signals. Not too shabby for a 'simple' widget!

Here it is in action.

#!/bin/sh

MY_DIALOG="'
<window title="Agent Authentication" width-request="300" resizable="false">
    <vbox>
        <frame Agent ID & Passphrase>
            <vbox>
                <hbox>
                    <vbox homogeneous="true">
                        <entry activates-default="true">
                            <default>'$USER'</default>
                        </entry>
                    </vbox>
                </hbox>
            </vbox>
        </frame>
    </vbox>
</window>

export MY_DIALOG

gtkdialog --program=MY_DIALOG

Agent Authentication

Agent ID & Passphrase

Capone-Al

????????

Enter your Passphrase

Submit Credentials
Programming With Gtkdialog, Part Three

In the preceding code, some of the lines are quite long, so I have split them over several lines. This is allowable, but splitting text may insert line breaks that output the text differently than intended. You must also make sure that the starting and ending tags are matched, as Gtkdialog is not very forgiving about mistakes here.

The first entry box has the 'activates-default' attribute set to 'true.' This gives it the focus on start up. The default text is taken from the system variable USER. The '$' tells the widget to show the contents of USER, not the word. This is where the system stores the name of the user logged into the operating system. This line could be omitted to present a blank user name field.

The next entry box is more interesting. I have removed the frame so that it appears flat on the dialog. Next, I have told it to use ASCII character 63 (the question mark '?') to mask the typed characters in the password. The primary icon sits on the left, and is taken from the system set of icons. This will vary depending upon what icon set your system uses. The tooltip for this icon starts with plain text, then uses markup to change the font to red, bold, italic text for emphasis on what is required. I put some default text in here, the word password, so that you can see the masking effect. Normally, this would be left blank for the user to complete.

The rest of the code is stuff that we have seen before and serves to decorate and format the dialog.

The Edit widget

This what to use when you need to work with multiline text. The text can be entered directly into the box from the keyboard, or loaded from an existing file. It may also be saved to a file of your choice. This widget can display both horizontal and vertical scroll bars to accommodate text. Also supported is insert/overwrite mode, text-wrapping and text justification.

The following little example demonstrates the basic usage of the widget.

#!/bin/sh

touch myfile

EDIT_DIALOG="'
<window title="PCLinuxOS Editor" resizable="true">
   <vbox>
      <hbox>
         <button image-position="0">
            <label>"Save file changes"</label>
            <input file stock="gtk-save"></input>
         </button>
      </hbox>
   </vbox>
</window>

We have already covered most of the stuff here in previous examples, but the two attributes specified in the edit markup need a little explanation. You may specify one of four values to wrap-mode: 0 disables text wrapping, 1 wraps text at the edge of the visible text area breaking words if necessary, 2 wraps text only at a word boundary and 3 is a stronger version of 2 which considers graphemes, such as ligatures which may be present in some languages but is safe to use in English text. Similarly 0.1 and 2 have special meaning to vscrollbar-policy: 0 always displays a scrollbar, 1 automatically displays a scrollbar when required and 2 inhibits the display of a scrollbar. Horizontal scrollbars are controlled with hscrollbar-policy. Clicking the 'Save file changes' button executes the save function to save the current contents of the edit window to the file named in the 'output file' tags.
Programming With Gtkdialog, Part Three

The Terminal widget

This next example reuses much of the code from the previous example enabling a useful little utility to be created quickly, without re-inventing the wheel. We have a terminal window and an edit window. If we type a command into the terminal window, it is executed as normal. However, if we redirect the commands output to the file 'results' using > (overwrite) or >> (append), then the edit window automatically recognises the file changes and updates its contents. We instantly have the results of the command in a window ready to be edited. Clicking the 'save file changes' button writes the edited file to the file 'results.new' to avoid overwriting the original 'results' file, to which you may wish to revert.

#!/bin/sh

touch results

EDIT_DIALOG='
<window window_position="2"
title="PCLinuxOS Editor"
resizable="true">

# Device  Mount point  Filesystem  Options
# Root file system
LABEL=mate  /  ext4  rw,errors=remount-ro
# Home directory
LABEL=home  /home  ext4  rw,errors=remount-ro
# Common data partition
LABEL=data  /home/pete/data  ext4  defaults.users
# Other distributions
LABEL=mint  /mnt/mint  ext4  defaults.users
# External drive partitions
LABEL=backup  /mnt/backup  ext4  noauto.users

</window>

export EDIT_DIALOG
gtkdialog --program=EDIT_DIALOG

Menus

Menus in gtkdialog are constructed by providing a menubar widget which contains one or more menu widgets. Each menu widget, in turn, holds menuitem widgets, menuitemseparator widgets and other, nested menuitem widgets.

Our menu system will be a fairly simple affair. It will be a menubar with two menus: 'File' and 'Help.' The 'File' menu will have menuitems for 'Save' file

...
separated from a final 'Quit' menuitem by a menuseparator widget. The 'Help' menu will have a single 'About' menuitem (where we will admit liability). Each menu will be assigned a shortcut key combination using the ALT key, and menuitems will have an accelerator key combination using the control key. The shortcut key will be represented by an underlined character for the menus, and text will show the accelerator key combination in the menuitems. All of the menuitems will display both text and icons.

This may not sound fairly complicated but thanks to gtkdialog, using this example as a template, quite complex menu systems may be constructed with a minimum of programming knowledge.

#!/bin/sh

touch myfile

ABOUT_EDIT=''
<window modal="true"
    image-name="system-help.png"
    resizable="true"
    window_position="1">
    <vbox>
        <pixmap height-request="80">
            <input file="/home/me/gtk/pcloslogo.png"></input>
        </pixmap>
        <text height-request="50" use-markup="true">
            <label><b><span size='"x-large"';
                color='"blue"'>Edit</span></b></label>
        </text>
    </vbox>
</window>

<menubar>
    <menubar label="_File" use-underline="true">
        <menuitem stock-id="gtk-save" accel-key="0x53"
            accel-mods="4">
            <action function="Save">edit1</action>
        </menuitem>
        <menumitem_separator></menumitem_separator>
        <menuitem stock-id="gtk-quit" accel-key="0x51"
            accel-mods="4">
            <action>exit:Quit</action>
        </menuitem>
    </menu>
</menubar>
<hbox>
    <edit wrap-mode="2" vscrollbar-policy="1">
        <output file="myfile"></output>
    </edit>
</hbox>

Programming With Gtdialog, Part Three

A text editor written for PCLinuxOS Magazine by Me"</label>
</text>

<text height-request="50" justify="2">
    <label>"me@my-email.mag"</label>
</text>
<button ok>
    <action>closewindow:ABOUT_EDIT</action>
</button>
</vbox>

<variable>ABOUT_EDIT</variable>
<action_signal="focus-out-event">
    presentwindow:ABOUT_EDIT</action>
</window>

EDIT_DIALOG=''
>window title="PCLinuxOS Editor"
    image-name="pclinuxos.png"
    resizable="true"
    window_position="1">
    <vbox>
        <menubar>
            <menubar label="_File" use-underline="true">
                <menuitem stock-id="gtk-save" accel-key="0x53"
                    accel-mods="4">
                    <action function="Save">edit1</action>
                </menuitem>
                <menumitem_separator></menumitem_separator>
                <menuitem stock-id="gtk-quit" accel-key="0x51"
                    accel-mods="4">
                    <action>exit:Quit</action>
                </menuitem>
            </menu>
        </menubar>
        <hbox>
            <edit wrap-mode="2" vscrollbar-policy="1">
                <output file="myfile"></output>
            </edit>
        </hbox>
    </vbox>

PCLinuxOS Magazine
Now we have some new stuff here. We have two scripts describing the windows that we shall show. One is named EDIT_DIALOG, which is the main window, and the other one is named ABOUT_EDIT, which we shall only display when the Help - About menuitem is clicked.

The main window is the editor we used previously, with the addition of a menubar and the 'save file changes' button removed, as it is longer required. The menu 'useunderline' tag sets up the shortcut key to use the character following the underscore in the 'label' tag. In the menuitem widgets, the accelerator key combination is set up using two tags: 'accel-key' is given the hexadecimal ascii value of the upper-case character that we want to use, the 'accel-mods' is given a value constructed from 1 for The shift key, 4 for the control key and 8 for the alt key. These values may be added so the you would use 9 (1 + 8) for shift + alt. This automatically provides the correct text hint in the menuitem.

The Save menuitem applies the save function to the edit widget named 'edit1.' The Quit menuitem simply exits the application, and the About menuitem launches the ABOUT_EDIT dialog window.

The ABOUT_EDIT window has the 'modal' tag set to true, which means that it must be closed before you can use the parent window. The signal 'focus-out-event' prevents the parent window getting focus. The rest of this window consists of a simple vbox containing various text and graphic elements with a single button dismiss the window.

Using the List and Progressbar widgets

These two widgets are completely independent, but I use them together in the next example.

The list widget takes a list of text items and displays them in a dialog box to allow the user to select one of them. You can specify how, or if, horizontal and vertical scroll bars appear and which item in the list should be highlighted on startup. In the example, I have chosen to show the first item (item 0) on startup, but have then selected a different file in the screenshot.

In this example, I am going to get the list remotely from one of the PCLinuxOS repositories. The list will be of all of the currently downloadable Live CDs of this
distribution. The code to do this is not, I'm afraid, beginner level stuff, but like all of the examples, you don't need to understand it to be able to use it.

When the user has chosen one of the ISO files, the example script will download it showing the percentage complete in a progressbar widget. If the download gets interrupted for any reason, then it can be resumed from where the connection was broken without having to start again from the beginning. There is also a simple option to include the md5sum checksum files in the list so that they may also be downloaded. Here's the script.

#!/bin/bash

# set the repository to use

# get the html source of the download page from the repo
wget -q -O /tmp/dl_list $REPO

cat /tmp/dl_list | sed -n '/pclinuos/p' | awk -F"" '{ print $6 }' | sed -n '/iso$' | /tmp/iso_list

# or use the line below to include the name of the md5sum checksum files
# cat /tmp/dl_list | sed -n '/pclinuxos/p' | awk -F"" '{ print $6 }' | sed -n '/iso$' | /tmp/iso_list

export LIST_DIALOG=''
export PROGRESS_DIALOG=''

<window window_position="1">
  <vbox>
    <text>
      <label>Please select a live CD to download</label>
    </text>
    <list selected-row="0" vscrollbar-policy="0">
      <width>400</width>
      <height>250</height>
      <variable>LIST1</variable>
      <input cat /tmp/iso_list>
    </list>
  </vbox>
  <button ok>
    <action function="command">echo $LIST1</action>
    /tmp/dl_iso</button>
</window>
We now need to strip away a lot of the html code and leave only the parts that we want. The first line that starts with the cat command will leave only the filenames that end in '.iso.' The other line two lines down, which is commented out here, will include the md5sum files in the list. Add and remove the hash marks as required. The refined list is then saved to the temporary file /tmp/iso_list. If you understand how it works – great. If not, just use it anyways.

The LIST_DIALOG code uses the usual assembly of widgets we have become used to, but includes the new list widget. The list of items to display is read from the code in the <input> tag pair, which here is the command ‘cat /tmp/iso_list,’ which simply sends the contents of the file to the list widget. The list widget has been given the name LIST1, and so the variable LIST1 will contain the currently selected list item.

Clicking the OK button saves the contents of the LIST1 variable to the temporary file /tmp/dl_iso, and then closes the LIST_DIALOG. The script next calls the gtkdialog application with the PROGRESS_DIALOG as its’ script to run.

Again, we have a simple dialog assembled from the usual widgets, with just the progressbar widget new to us. The progressbar widget needs input that continually changes from 0 to 100. For this input we again use the wget command. Now we use the rather clever -c option that tells wget to continue from wherever it was in downloading the file if this is another attempt to get a file that did not finish downloading. This is a very useful option when downloading large ISO files. We reuse our REPO variable as the source of the download, and the /tmp/dl_iso file as the name of the file to download. The rest of the code in this line serves to strip away all but the current percentage downloaded so that the progressbar slider position can be updated and the present situation displayed.

When the file has finished downloading we remove the three temporary files that we created.

If you decide to download the checksum file to accompany the large .iso file, and you really should, then this is how you use it. Both files must be in the current directory.

```bash
$ md5sum -c pclinuxos64-lxde-2014.04.md5sum
pclinuxos64-lxde--2014.04.iso: OK
```

If you get OK then the .iso file is safe to use, anything else and then something went wrong with the download.

```bash
$ md5sum -c pclinuxos64-lxde-2014.04.md5sum
pclinuxos64-lxde-2014.04.iso: FAILED
md5sum: WARNING: 1 computed checksum did NOT match
```
These little example programs are far from perfect. They were never meant to be perfect, but they do work. This is what gtkdialog widgets are for. They provide a way of building graphical applications quickly and with minimal programming knowledge. I wrote and tested the download application in under two hours, but I could spend another two days refining it. The application can be useful, but since I will probably only use it two or three times a year, it suffices. The Gtldialog widgets provide a means of constructing little utilities to perform the tasks that might otherwise require a much larger application that probably would not work in exactly the way that you would like.

If you do persevere and build an application that is useful, does all of the necessary error checking and includes internationalisation for users of other languages (actually quite simple to do under Linux) then consider sharing it. There are several such items already available in the repositories.
**Game Zone: Running With Rifles**

by daiashi

**About The Game**

RUNNING WITH RIFLES is a top-down tactical shooter with open-world RPG elements.

In RWR, you join the ranks of an army as a common soldier, just like the thousands around you. To your superiors, you're nothing but cannon fodder.

The open world approach lets you define your own path and story in the campaign. Push back the enemy with your comrades, or go deep behind enemy lines to sabotage their efforts and loot valuable items.

As you gain experience, you are promoted to a higher command level over soldiers and equipment. Call in artillery fire missions or paratrooper reinforcements when the situation gets tight! Use your squad to man armed boats, tanks and APC's, or become the expert lone wolf you always aspired to be. It's up to you!

**What is RUNNING WITH RIFLES?**

Pick up your rifle and join the Greenbelts, Graycollars or Brownpants in their mission to send the enemy home in a box! RWR is an open world, top-down, tactical shooter for single player and multiplayer online, that puts you right in the middle of chaos in towns, trenches and forests turned into ruthless battlefields, controlling just one soldier in an army of several hundreds.

In a war where men die like flies and endless streams of reinforcements run to fill the void, it takes tactics and marksmanship to capture territories effectively. The open world nature of the game enables you to use a multitude of approaches to help the front line move – it's up to you to shape your role. Experience the complete arc, starting as a private hardening into a high ranking officer with a squad under command, arming yourself with a variety of weapons and vehicles on your way to glory!

**Key features, so far**

1. 8x1 km² maps with total of 62 bases
2. Hundreds of simultaneous AI soldiers
3. Open world: it's up to you how you play, the war goes on without you
4. Not your usual "I'm the hero" shooter game: one bullet kills more often than not
5. Use cover, crouch and prone, move with others to increase your odds to stay alive
6. Emergent AI that tries hard: they too use cover and rooftops, attempt outflanking
7. Gain XP to get promotions to lead your own squad, unlock items & calls
8. A broad variety of faction specific weapons
9. Grenades, bazookas, remote detonable sticky C4, riot shields, medikits, vests, rare weapons
10. Mortar strikes, paratrooper reinforcements, vehicle drops
11. Jeeps, transport trucks, APC's, boats, tanks, patrol ships with AI driving
12. Deploy cover elements to strengthen your fellows' positions or use vehicles for mobile cover
13. Campaign and quick matches, with Map Capture or King of the Hill game modes
14. Locate & destroy the radio truck/tower behind enemy lines, or steal their cargo truck and deliver it home
15. Windows and Linux supported
16. 24/7 servers in Europe and USA supporting 30+ players

Much, much more to come.

**System requirements:**

Fully updated PCLinuxOS and Steam

**Hardware:**

* Minimum:
  * Processor: 1.6 GHz Dual Core
  * Memory: 2 GB RAM
  * Graphics: NVidia Geforce 6800, ATI x800, Intel HD3000 or equivalent with 256MB VRAM - please note that the game is not playable with ATI/AMD proprietary drivers!
  * Hard Drive: 400 MB available space

* Recommended:
  * Processor: 2.4 GHz Dual Core
  * Memory: 2 GB RAM
Getting It To Run

Install Steam (if you don't have it installed already), then start it. You will need to create a new account, if you do not already have one. Once you have Steam up and running, go to the store tab. Click on the Linux tab, if you wish, and search for Running With Rifles. Click on and download the demo. If you have updated your system, including graphics drivers, you should be good to go. If you ever wanted a top down view, this just might be it. This is a very fun game.

http://store.steampowered.com/app/270150/
Defending Your Rights

In The Digital World

It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...
Installing Plex On Your PCLinuxOS System

by YouCanToo

Getting started

Minimum Requirements — no transcoding

* Intel Core 2 Duo processor 1.6 GHz or better
* At least 1GB RAM for Windows/Mac OS X
* At least 512MB RAM for Linux
* Windows XP with SP3, Windows Vista SP2, Windows 7 SP1, Windows 8
* Mac OS X Snow Leopard 10.6.3 or later (64-bit)
* Ubuntu, Debian, Fedora, CentOS or SuSE Linux
* It even runs on PCLinuxOS

Recommended Configuration — transcoding HD Content:

* Intel Core 2 Duo processor 2.4 GHz or better
* If transcoding for multiple devices, a faster CPU may be required
* At least 2GB RAM
* Windows XP with SP3, Windows Vista SP2, Windows 7 SP1, Windows 8
* Mac OS X Snow Leopard 10.6.3 or later (64-bit)
* Ubuntu, Debian, Fedora, CentOS or SuSE Linux
* It even runs on PCLinuxOS

Make sure that your system is fully updated before proceeding.

Download the Plex Media Server from here:

32 bit RPM
http://archives.pclusers.com/plexmediaserver-0.9.8.17.282-c844f09.i386.rpm

64 bit RPM
http://archives.pclusers.com/plexmediaserver-0.9.8.18.290-11b7fdd.x86_64.rpm

WARNING: DO NOT USE THE NEWER PLEX RPM (plexmediaserver-0.9.9.7.429-f80a8d6.i386.rpm) FROM THE PLEX WEBSITE AS IT WILL CAUSE NOTHING BUT SEGMENTATION ERRORS!

Install using the following command as the root user.

```
rpm -Uvh plexmediaserver-0.9.8.17.282-c844f09.i386.rpm
```

You should see something like this

```
[root@localhost 28CF-DA49]# rpm -Uvh plexmediaserver-0.9.8.17.282-c844f09.i386.rpm
Preparing...
[100%]
vim/ppl: Using /var/tmp/rpm-tmp.8kXwXA: line 29: semodule: command not found
warning: %post(plexmediaserver-0.9.8.17.282-c844f09.i386) scriptlet failed, exit status 127
[root@localhost 28CF-DA49]#
```

You can safely ignore this error, as PCLinuxOS does not use SELinux.

Start the Plex Media Server using this command as root, in a console window.

```
service plexmediaserver start
```

```
[root@localhost /]# service plexmediaserver start
Starting PlexMediaServer: [ OK ]
[root@localhost /]#
```

You will also need to have a Plex account, so head over to https://plex.tv/ and sign up. While you are
Installing Plex On Your PCLinuxOS System

there, be sure to pick up an app for the device you wish to stream to. In my case, I chose the Roku player app. Follow the on screen display to install your app.

You will also need to add a plexmediaapplet bookmark.

I created a new bookmark with the name Plex It! and set the location to

```javascript
javascript:%20var%20s=document.createElement("script");s.type="text/javascript";s.src="/my.plexapp.com/queue/bookmarklet_payload?uid=20e14726a659ff3";var%20h=document.getElementsByTagName("head")[0];h.appendChild(s);void(0);
```

I placed this in my bookmarks toolbar.

You can also go to http://plex.tv/web/app#!/playlist/queue/help and drag the Plex It! button to your bookmarks bar.

To check to see if things were working, I opened my web browser, Firefox 29.0.1. Next, I went to YouTube, and picked something I wanted to watch. I then clicked on my Plex It! bookmark, and a query window opened to the left side of the screen. Since I was not signed into my account, it displayed a link to sign in.

Once I signed into my Plex account, I once again clicked on the Plex It! bookmark. This time, I got a "looking for queue" message, along with a countdown timer. You will see a green check mark when your video has been added to your queue.

At this point, I wanted to see if I was streaming the video to my Roku box. I went to the Plex channel on my Roku box, and sure enough, there was the video I queued. When I finished watching my YouTube video on my Roku box, I deleted it from the Roku query.

You now have Plex Media Server running on your PCLinuxOS machine. The possibilities are almost endless on what and where you can stream to.
Screenshot Showcase

Posted by parnote, May 2, 2014, running Xfce.
Print Your Poster With Ease

by Meemaw

Once a year, my company helps sponsor an Earth Day celebration to help educate local students about various aspects of agriculture, including conservation. In the course of preparation for the day, one of my jobs is to create and print a large poster to be displayed, thanking everyone who donated funds or materials to our project. The finished poster is usually 45” by 45” and is attached to a large board so everyone who passes it can read it easily.

Before I started using Linux, I used a Windows program called Print Artist to make the poster and print it out on 8.5” by 11” sheets of paper, and then taped them together into the poster. Now that I use Linux, I can create the poster using Scribus, but I have had trouble finding a Linux program that will print it. The pdf viewers don’t seem to print poster sizes yet, and Scribus doesn’t either, so I was stuck.... until I found PosteRazor.

PosteRazor is a handy program which converts the poster you want to print into a set of pages in pdf format, which can be printed and taped together into your finished product. From their website: The PosteRazor cuts a raster image into pieces which can afterwards be printed out and assembled to a poster. PosteRazor is in our repository.

After installation, you are guided through five steps to your finished product. For this article, I will use a png of Tux dressed as Indiana Jones. The program defaults to English and centimeters as your unit of measure. If you need to change either of these, click on Settings at the bottom left of the window.

1. Designate the file you are using. Your project in Scribus, or whatever program you use, should be saved as an image file. I saved mine as a png. The window to load your file is shown here.

2. Indicate the paper size you are using to print - plus the orientation & margins you need.

3. Decide how much and direction of overlap. When you tape your poster together, it will be easier to match up the edges of they overlap a bit.

4. Enter the number of pages wide the finished product should be (the length will adjust), and how you want it aligned on the pages (top left, centered, etc). I chose top left, but you could center it, and then you probably wouldn't have to trim anything off the sides. If you need your poster a certain size (like 48” x 36”), click Absolute Size rather than Size in pages. I originally picked 5.5 pages (because that would be 44”) but it didn't come out correctly, probably because of the overlap, so you need to designate an absolute size if you need it that way. You can also choose a percent, so if your picture is a certain size and you want to increase it 300%, you can do that. You will have a preview as well, so if it isn't the way you want it, you can change the settings before you save (next page, top left).

5. Save your poster with a meaningful name - it will save as a pdf.
When you open it in your favorite pdf viewer, you will have a multi-page document to print and tape together. Here you can see the pages in a pdf viewer (center, top).

For the big poster at our event, I printed it on about 20 pages, and taped it together. I’m so glad I found this program! It’s really easy to use.

Oh, yes..... the event was great!

Visit Us On IRC

- Launch your favorite IRC Chat Client software (xchat, pidgin, kopete, etc.)
- Go to freenode.net
- Type "/join #pclosmag" (without the quotes)
More Screenshot Showcase


Posted by nymira, May 1, 2014, running LXDE.

Posted by LKJ, May 2, 2014, running MATE.

Posted by Meemaw, May 2, 2014, running Xfce.