December, 2018

Table Of Contents
3
4
7
9
11
13
15
17
19
21
23
25
29
31
33
36
39
42
45

Welcome from the Assistant Editor
GIMP Tutorial: Exploring The Toolbox
GIMP Tutorial: Using Layers
GIMP Tutorial: Adding Text
GIMP Tutorial: Layer Mask
GIMP Tutorial: Quick Mask
GIMP Tutorial: Using The Clone Tool
GIMP Tutorial: Creating A Text
Reflection
GIMP Tutorial: Colorizing A Photo
GIMP Tutorial: Create A Shiny Button
GIMP Tutorial: Exploring The
Create Menu
GIMP Tutorial: Create Your Own
Alien World
GIMP Tutorial: Masks Explained
GIMP Tutorial: Tree Silhouette in
Sunset, Part 1
GIMP Tutorial: Fixing A Photo
GIMP Tutorial: Editing An Image
GIMP Tutorial: Fire
GIMP Tutorial: Frozen Text
GIMP Tutorial: An "Out-Of-The-Frame"
Effect

PCLinuxOS Magazine

47
53
57
59
61
64
68
71
73
76
78
80
82
84
86
89
91
93
95

Inkscape: Getting Started
Inkscape: Starting Your First Project
Inkscape Tutorial: Fun With Shapes
Inkscape Tutorial: A Torn Paper Effect
Inkscape Tutorial: ms_meme & The
Holiday Tree
Inkscape Tutorial: Tree Silhouette in
Sunset, Part 2
Inkscape Tutorial: Make A Chalkboard
Inkscape Tutorial: Decorative Patterns
Inkscape Tutorial: Create A Paisley
Pattern, Part 1
Inkscape Tutorial: Create A Paisley
Pattern, Part 2
Inkscape Tutorial: Create A Candle
Inkscape Tutorial: Reinventing The
Wheel
Inkscape Tutorial: Holiday Wallpaper
Inkscape Tutorial: Tracing A Logo
Inkscape Tutorial: Sunset With Stars
Inkscape Tutorial: Smiling
Jack-O-Lantern
Inkscape Tutorial: How To Create
Puzzle Pieces
Inkscape Tutorial: Taped Note
Inkscape Tutorial: Design Your Own
Paper

Page 2

Welcome From The Assistant Editor
I love computer graphics! I used drawing programs in Windows, but never used Photoshop or Corel Draw
much because they cost so much. Since I switched to PCLinuxOS in 2006, I have been playing with GIMP
and Inkscape, and have learned a bit more. I'm still far from an expert, but I have learned a few tricks. This
magazine started having a regular monthly article on GIMP or Inkscape in July, 2012. I have learned a lot
about both programs since then, and I hope you have, too.
GIMP is a wonderful program for editing photos, but it does many more things than just edit photos. We
have created buttons, fire, planets and decorative text in addition to editing and improving our photos. We
have also created custom borders with a quick mask and colorized our photos with the layer mask.
Inkscape is a wonderful drawing program in its own right. We've made decorative patterns and worked with
different shapes. We have also learned how to do a tracing and create a paisley design, along with
designing holiday wallpapers and Jack-O-Lanterns. I'm sure, however, that we have only scratched the
surface on our knowledge of either program.
Several months ago, both parnote and I had requests to
compile the graphics tutorials into a special edition. Several
people thought that they would enjoy some of the tutorials if
they were all together, especially the ones that spanned
more than one magazine issue.
So, here they are, and I hope you enjoy them. This special
edition includes all the graphics tutorials from July, 2012
through December, 2014. Our plans were to do an annual
compilation of the graphics tutorials, and we were planning
another graphics special edition for 2016, filled with the 2015
tutorials, but life intervened. Soon we'll have another
compilation with at least 2015 and 2016.

The PCLinuxOS name, logo and colors are the trademark of
Texstar.
The PCLinuxOS Magazine is a monthly online publication
containing PCLinuxOS-related materials. It is published
primarily for members of the PCLinuxOS community. The
magazine staff is comprised of volunteers from the
PCLinuxOS community.
Visit us online at http://www.pclosmag.com
This release was made possible by the following volunteers:

Chief Editor: Paul Arnote (parnote)
Assistant Editor: Meemaw
Artwork: Sproggy, Timeth, ms_meme, Meemaw
Magazine Layout: Paul Arnote, Meemaw, ms_meme
HTML Layout: YouCanToo
Staff:

ms_meme
Meemaw
Gary L. Ratliff, Sr.
Daniel Meiß-Wilhelm
daiashi
Smileeb

loudog
YouCanToo
Pete Kelly
Antonis Komis
Patrick Horneker

Contributors:
Khadis Thok

Until then, have fun and keep on creating your own graphics!
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GIMP Tutorial: Exploring The Toolbox
by Meemaw
I’ve been using GIMP since I started using Linux.
While I can do most of what I want to do fairly easily,
GIMP contains many options that I haven’t used
much. In these articles, I will try to explain a little
about GIMP and how to use it.
GIMP, of course, stands for Gnu Image Manipulation
Program. The website is http://www.gimp.org/. It can
be found in most any distro’s repository and
PCLinuxOS is no exception. It can also be installed
in Mac and Windows, so I use it at work in Win7, as
well as at home with PCLinuxOS.
When you open it, you are shown three windows as
shown below:

While many of our graphics programs are displayed
all in one window, Gimp has had them separate for
years. GIMP 2.8 has been released now. It has a
single window display, but has the option of leaving
the windows separate. I really like the separate
windows, because I can arrange the them the way I
want them. However, it hasn’t made it to our repos
yet, so be patient – GIMP 2.6 works very well.

Target

area. If you have a file manager open too,
you can drag the item you want to work on to this
area and it will open in Gimp.
Going across the rows in
order, the tools are as
follows:

Rectangle Select

The window on the left of the screen is your main
toolbox. The tools there are the ones you will use the
most. For each tool, there is a corresponding config
section, so the bottom of that window will change
depending on the tool chosen at the top. The area at
the top of the toolbox (where you see Wilber, the
Gimp critter’s eyes and nose) is the Drop

Continuous Region

- You
can
designate
a
rectangular
area
and
manipulate it.
Elliptical Select - Create
a circular or elliptical area
and manipulate it.
Freehand Select - Create
an irregular-shaped area
by clicking your mouse
along the outside of the
area. Very handy!
Select - This selects

connected areas.
Color Select - Selects areas of similar color.
Intelligent Scissors (Select from image) - Selects
along an edge ….

Foreground Select

- You can use this for cutting
items out of photographs... complicated tool.
Path Tool - You can use this to create a path, which
you can then edit
Color Picker - If you want to exactly duplicate a
color in a picture, choose this tool and click on the
color. You can use the selected color to edit your
drawing.
Zoom - You can see your work close-up with the
Zoom tool.
Measure Tool - Measures distances in your
drawing.
Move Tool - Click on this to move your object into
place.
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Align

- You can choose 2 or more objects or layers
and align them
Crop - You can crop an image. Click and drag for
your area, then press enter to crop.
Rotate - Clicking on this tool will let you rotate your
object.
Scale - To resize your drawing or object
Shear - To skew an object. (Example: You can
change a square to a diamond.)
Perspective - You can apply perspective to a 2
dimensional image to make it look more 3D.

Flip

- Used to flip your object horizontally or
vertically
Text Tool - To add text to your creation
Bucket Fill - To add one color to a large area
Gradient Fill - To create a gradient in your object
Pencil - Draws thin lines, like a pencil line, but not
smooth. Works better for very small objects where
the pixels have to be in exactly the right spot.
Paintbrush - This tool draws smoother lines than
the pencil, and this is probably the most used tool.

Eraser - Erases the color from your image. Actually,

it changes whatever you stroke to transparency, so it
can also be used as a paint tool.
Airbrush - Paints like an airbrush, using a spray or
fuzzy effect rather than a solid line.
Ink Tool - Draws lines more like a calligraphy pen.
Clone Tool - Use this to clone parts of an image.
Healing Tool - This will heal small blemishes in
photos.
Perspective Clone - Advanced tool for cloning
something into the image which may not look as it
looks now (like cloning a face so it looks like it’s a
picture on the wall).

Blur/Sharpen - Softens or sharpens colored edges
and blends colors together.
Smudge - Drawing with this through two colors will
cause the colors to blend, although maybe not the
way you want.
Dodge/Burn - Can make an area darker or lighter.
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The window on the right contains the Layers,
Channels, Paths and Undo tools, and we will use
that as well, but I will cover it separately, in an
upcoming article.
OK, let’s experiment. Your center window contains
all your menus (and all of your tools can be
accessed from here as well). Click on File > New.
You will see a window for a new image. Here you
should designate the size of your image, and in
Advanced Options, whether the background should
be white, black or transparent. I clicked on the
dropdown and selected 800 px x 600 px, then
opened the Advanced Options and selected white,
and clicked OK.

you are working on your creation. You can save your
finished product as any number of image types,
such as *.jpg or *.png.
Lets add some color to our drawing. From the
toolbox, you will see a color swatch (the black &
white rectangles underneath the tools). Click on the
swatch and the Edit Foreground or Edit Background
color window will open. From here you can choose
whatever color you want to use. The default
foreground color is black and the default background
color is white.

Select either the paintbrush or pencil, and draw a
circle. Play with it a little bit just to get the feel of the
tool. It doesn’t have to be a perfect circle.
Playing more with your
brush tool, make a face on
your circle. Since some of us
aren’t
artists
(myself
included!), your face will look
different from mine. Getting
the feel of the tool, you can
make several strokes. If you
make one you don’t like, you
can go to Edit > Undo, or press <CTRL> + <Z> to
remove the stroke. If you use the keystroke CTRL-Z,
you can hold down CTRL and press the Z as many
times as you wish to remove as many strokes as you
need.
Sooner or later you’ll have
to save your file. Just as
with other programs, go to
File > Save as... and name
your file, then designate a
location in which to save it
so you can find it again. The
default file format for Gimp
is .xcf, which is designed to
save all your layers while

You will have several tabs in your window (top left
corner). On the first tab, you will see the default color
square (probably in shades of red & black) with a
rainbow-colored vertical bar to the right of it. To the
right of that you will see six horizontal bars of color
with letters next to them. Those letters are for the
following words, which are color settings you can
adjust:

Hue: This is the color you want. You should probably
click it in the vertical bar first, then all the other
settings will display the color you are working with.

Saturation : This is how pale a color is (I think of it

as how much of the color used). The slider will make
it more or less intense.
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Value: I think of this as how light or dark a color is,

but Gimp’s glossary says it is how much light is
emitted by a color.

Red, Blue & Green : These

are the colors that will
be mixed for everything you do. Each individual
slider can be adjusted separately to produce just the
right color. To the right of each slider is a blank
containing a number. Each color can be described
with a series of numbers from 0 to 255 (0,0,0 is
black and 255,255,255 is white. All other colors are
in between.) If you have the numerical code for the
perfect color, you can adjust the numbers in these
blanks. If you are deciding on a color, each slider
can be adjusted individually.
In addition, all colors can also be described with a 6digit hexidecimal code. (000000 is black and ffffff is
white. One shade of purple is 430da9.) If you know
the code for your perfect color, you can enter it in the
space provided in this window. (Also called HTML
notation)

The Palette tab will have a grid of the colors
contained in the color palette being used by Gimp.
You can choose one of those, and go back to the
first tab and edit your color there.
I use the first tab and the color wheel the most. Click
on the vertical bar between yellow and orange.
Looking at the horizontal bars to the right, you can
adjust your color until it is an approximate skin tone,
whatever color you want to make the face. The color
will show in a bar underneath the color square or
wheel. You can keep adjusting until you get it just
right. There are also small swatches that will save up
a record of the last 12 colors you used. Click OK,
then choose the Bucket Fill tool and click inside your
face. Your drawing should now have a skin-tone
color in it. If you don’t like the color after all, press
your <CTRL> + <Z> to undo it, then go to your color
window and adjust your color again.

One of the tabs will have a printer on it and be the
CYMK, referring to the printer colors Cyan, Magenta,
Yellow & Black. This is not really supported in Gimp
so they don’t describe it much, but it is apparently to
adjust your colors according to the cartridge colors
of your printer. That would have been a great idea
with one of my older printers - it printed everything
several shades too dark.
One tab will have a paintbrush on it and it is the
Watercolor wheel. It gives you a color square and
you click the color you want. The more times you
click, the more intense the color will be.
One tab will have the “color wheel” on it (also called
the Triangle Selector). It is the multi-colored circle
around a multi-colored triangle. Click the color (Hue)
you want in the circle, then drag the white ring into
the interior of the triangle to adjust Saturation and
Value.
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A magazine just isn't a magazine
without articles to fill the pages.
NOTE: The Undo function keeps track of everything
you do so you can click undo over and over to
remove lots of things. HOWEVER, once you save
your drawing, all the undo history is gone, so make
sure it is the way you want it before you save it and
close down Gimp.
Play with this a little, and have some fun! Next
month we’ll learn more about the interface and then
add more to our drawing.

If you have article ideas, or if you
would like to contribute articles to the
PCLinuxOS Magazine,
send an email to:

pclinuxos.mag@gmail.com

We are interested in general articles
about Linux, and (of course), articles
specific to PCLinuxOS.

Page 6

GIMP Tutorial: Using Layers
by Meemaw
Last time we learned about the toolbox and the color
chooser in Gimp, and started a drawing. Mine is
shown below.

However, we never talked about the tools in the
right-hand window. If you haven’t closed that
window, the first thing you will see is the Layers
toolbox.
When I first started using
the Gimp, I didn’t use
layers, but as I’ve learned
more about Gimp, I have
found that layers are very
useful. You can use as
many layers as you want
to make your drawing, and
reorder the layers any way
you desire. Using different
techniques on the layers
can make your finished
product look different than
it would if it was all on one
layer. Also, when one layer
is finished the way you
want it, you can do whatever you want to another
layer without disturbing anything else. The tools
across the bottom of the window are, from left to
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right, New Layer, Raise Selected Layer, Lower
Selected Layer, Duplicate Layer, Anchor Layer and
Delete Layer.
When you started your drawing, it had only one layer
(called Background). In the layers window, click the
New Layer button (the button at bottom left that
looks like a piece of paper with the plus sign on one
corner). A window will appear asking you to name
your layer, designate how big you want it and
whether you want it white, black or transparent
(choose transparent because you want the face to
show through). If you don’t give it a new name, a
new entry, called New Layer, will appear in the list
above the Background. You’ll notice now that many
of the tools I just named are active.

Now, instead of choosing the bucket fill, we’re going
to do something a little different. Bucket fill often
leaves unfilled areas. Choose the Free Select tool
(looks like a lasso) and trace around one part of your
bow. Click inside the colored line you already made
and make segments until you have closed your
curve. Every place you click will leave a small circle.
But when your curve is closed, it will look like a
moving dotted line instead. Now choose your bucket
fill and fill your bow. Click on the color you have
already drawn and then click inside. It should fill
properly. Looking at the shot below, you can see the
difference. The top was bucket fill only - the bottom
is bucket fill after the free select. After this, I will
outline the top bow with the Rectangle Select tool
and delete that one because I don’t want it.

You may also notice that
your drawing appears in
the Background icon in the
Layers window. This is
done to help you stay
organized, so you can
choose the correct layer
when you want to work on
another one. If you didn’t
name your layer before
you created it, you can
right-click and choose
“Edit Layer Attributes” from
the menu, and rename it
with a more meaningful
name. Let’s name it “Bow”.
Choose a color you like and draw a bow on this
layer. If your “person” is a man, it can be a bow-tie,
and if it’s a girl, you could put it in her hair. It’s your
drawing, so do whatever you want. You can even put
it out to one side of the face, as we can move it
around later.

Since we have our bow on another layer, we can
rotate it or move it anywhere we want. Using the
Move tool (4-pointed arrow) and putting your cursor
on the bow, you can move the layer around as you
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wish. I put mine below my face. You can see the
layer boundary on the drawing.

arrows around them). When you click on it and then
on the bow, a window will pop up with the rotate
tools. You will see a circle with a plus sign inside.
That is the rotation axis, and you should click and
drag it to wherever you want as the center of
rotation. I dragged mine to the center of the bow,
then in the rotation window, clicked the arrow next to
the degrees to change the angle of the bows. As the
degrees get larger your bow will rotate clockwise,
and the larger negative degrees will rotate counterclockwise. Rotate it however you want it, then click
“Rotate” in the tool window (below). Before and after
views will show up, which is why my bow now looks
like it has four points on each end.

International Community
PCLinuxOS Sites

When you get it the way you want it, choose another
tool to keep the Rotate tool window from popping up
again. Make sure you save your drawing when you
have it as you want it.

Turkey

I should note that this particular rotation method is
different than the method you would use to rotate a
picture. It can be
used,
but
the
rotation commands
under
the
"Transform" menu
item are easier to
rotate
an
entire
image.
Next time, we’ll add
more
to
our
drawing.

Netherlands

Denmark
Czechoslovakia

Italy
Poland

Sometimes you want things rotated. I want the bow
in a different position, so I’m going to choose the
Rotate tool (looks like 2 sheets of paper with curved
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Brazil
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GIMP Tutorial: Adding Text
by Meemaw

text formatting tools (font, size, color, alignment, etc)
so you can make it look however you want.

So far we’ve learned a little about the layout of the
Gimp, and used some of the tools to draw a face
and a bow. Let’s experiment a little more.

You may wonder what is going on with the Bow layer
because we can see the edge of it on our drawing.
That is because that layer is selected at the
moment. When you choose or create another layer,
that line won’t show.
Let’s create another layer named “Text” (you can
rename it or leave it as “New Layer”). Make it
transparent as well, so we can see our drawing
through it. Click on the Text tool, and you will see
another window pop up. It is the text editor window
and, working together with the toolbox window, it
contains anything you might want to use to edit text
in your image. In the text editor box, you should type
the text you want. I typed, “I Love GIMP” in the box.
Notice that I spaced it the way I want it as well (with
each word on its own line). In the tool box are the
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I chose the font called Die Nasty, size 44, black,
centered. If you check the box “Use selected font” in
the text editor box, you’ll be able to see what it looks
like in the editor. This is good if you want to try
different fonts.

Notice in your layers window that your text is not on
the layer you created, but rather it is “Floating”
above it. Until you are finished editing your text, it
will remain as a Floating layer.

Let’s do something different to our text. Right-click
on the floating layer in your layer window and
choose Alpha to Selection . You will now see that
your letters of text are outlined with dotted lines.
Click on the gradient tool in the toolbox and pick one
of the gradients there. (I picked dark blue to light
blue.) Click on one side of your text and drag to the
other side. The gradient you picked should be inside
the text outlines now. If you click in the top left
corner and go to bottom right, your gradient will be
diagonal. If you don’t like it you can press <CTRL> +
<Z> to undo it and try something else. After I chose
the blue, I changed it to a tropical gradient.
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When you have it colored the way you want it, go to
Select > None in the menu. This will change your
floating text to an image file, which can be moved to
any place you want in your drawing.

All this time, you have been saving your creation as
a Gimp native .xcf file. This is good, because it
preserves the layers for you so you can make
changes to any of them. So what do you do if you
have your drawing finished and you want to post it
on the Internet as a .jpg or a .png file? With the new
version of Gimp, the File menu is a little different.
Save... means save
your drawing as an
.xcf file. Save As...
means save it as an
.xcf file (still) but with
a different file name. If
you want to save it as
a .png file (or any of
the other recognized
file formats), you will
have to Export your
drawing. It is easy,
though: go to File >
Export... and edit the
entries that are there
>>>>
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The folder location can be changed, but will probably
be the same folder that your .xcf file is in. The
program will assign the same name to this file as the
name of the .xcf file you’ve been editing, but that can
be changed as well. In the drop-down at the right
side of the window, you will see all the file formats
you can use. I use .png and .jpg most of the time,
but use what you want. You will probably get at least
one window with options. I generally use the defaults
that are there. You will now have your basic file to
edit however you want, and also an image file you
can insert into another document, use as wallpaper,
or print.

The PCLinuxOS Magazine
Created with Scribus

Does your computer run slow?

The new version of Gimp has
the single window display. You
simply Click on Windows >
Single Window Mode. When it
is checked, your windows are
fused together. When you
uncheck it, the sections are
separate. You should choose
whatever mode you are most
comfortable with.

Are you tired of all the "Blue Screens
of Death" computer crashes?
Are viruses,
adware, malware &
spyware slowing
you down?
Get your PC back
to good health
TODAY!
Get

Next time we’ll explore more
tools.

Download your copy today! FREE!
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GIMP Tutorial: Layer Mask
by Meemaw
One of the first tutorials I ever did was one from the
Linux Graphics Users Forum. One of the members
posted several neat ways to manipulate a photo and
I’m going to share this one with you. I used a photo
of flowers and did a Layer Mask. It creates an effect
like the one shown below:

Now click on the original layer, so that it's
highlighted, which means that it's the layer you're
working on. We’re going to make this layer black and
white. You can use the Desaturate tool, but it will
have better detail with the Channel mixer (Colors ->
Components -> Channel mixer).
Next, create a
copy
of
the
background layer
by
clicking
on
Copy Layer in the
layer tools.

You can name your new layer something else if you
want by right clicking the new layer and selecting
Edit Layer Attributes... and change the layer name
to mask or something else.
First, make the new layer invisible by clicking on the
eye next to the layers thumbnail and name. When
you click on it, the eye disappears.

Choose a photo and open the image up in the Gimp.
I chose this one (center top):
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To get a B&W image, click the Monochrome
checkbox. Now start moving the Red, Blue and
Green controls back and forth and you'll notice that
lower values make the image darker (or
underexposed) and higher values make the image
brighter (overexposed). The values to use have to
be found by experimenting. There probably is a
scientific explanation on how to do this, but play
around with different settings and then see what you
get. Every image is different so there isn't a setting
that will give good results on all images. On this
photo I had to be careful not to have Red or Green
too high since it would make parts of the flower
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overexposed (too white, loss of detail). After clicking
OK, I get this.

Now click the eye again on the mask layer (the
background copy we created), and also click on the
layer so it's highlighted. You should now see the
colored variant of the image again.
In the toolbar click Layer->Mask->Add Layer Mask
in the pop-up window click Black (full transparency)
and then click Add .

petals. I changed the size of my pencil to 5 until I got
the edges established. Use <Ctrl> + Z to undo it if
you go outside the 'lines'. I’ve learned to make short
strokes until I get the edges outlined so I won’t have
so much to redo if I stray outside the area I’m
changing. Zooming in on the image also helps. You
can use View... Zoom and change the zoom or hold
down <Ctrl> on the keyboard and scroll the mouse
wheel forward.

You should now see this
in your Layers,
Channels... window:
>>>

When you have it the way you want it, right-click the
mask layer and select Apply layer mask then rightclick the same layer again and select Merge down ,
then Export to a picture file.
You’re done!!!

...and the image will be
all black and white.

Finally, to really make the image 'pop' we need to
use the Unsharp mask (Filters -> Enchance ->
Unsharp mask) filter, that sharpens the image and
also adds some contrast. The settings I used here
are
Radius
4.2,
Amount
.51,
and
Threshold
5. The
screenshot
doesn’t
really show it, but the
detail in the flower
was better after the
Unsharp mask than
before.

Now, we will start painting
the color back. Make sure the mask layer is
highlighted in the Layers, Channels ... window.
Make sure the mask itself (the black box in
the layers toolbox) is highlighted. It will have
a white frame.

My thanks to conholster on the Linux Graphics
Users Forum for the two tuts I used.
http://linuxgraphicsusers.com/forum/?topic=505.0
http://linuxgraphicsusers.com/forum/index.php?topic
=565.0

Now select the Pencil tool.
Since the layer mask is black you must paint
with white to get the original color back. The
image at right has white as the Foreground

color

Using the pencil tool start painting the part of
the image you want in color. >>>
Change the size of the brush to have better
control: a bigger brush for the middle parts
and a smaller brush for finer ends of the
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GIMP Tutorial: Quick Mask
by Meemaw

Now, click the Quick Mask button again. The red
frame will disappear and the border you drew will
change to a dotted line. Go to Select > Invert. This
changes your selection to the frame around the
outside of the photo. Now, choose Edit > Fill with
BG color. Unless you have been using Gimp and
changed the background color to something else,
your background color should be white.

I came across a
cool tutorial the
other day, and it’s a
really easy way to
customize a photo
with a custom edge.

This takes advantage of the Quick Mask button at
the bottom left of your work area. You should open
the photo you want to use. I’m using the same rose
photo that I used
last time. After your
photo is open, use
the rectangle select
to draw a border
around your photo.

Export your drawing and save it as a picture file.
You’re finished!

Next, choose Filters > Blur > Gaussian Blur. A
configuration window will pop up. I set the blur
radius to 20, but set it however you want. The higher
thenumber,themorebluryouwillhave.ClickOK.

There are other filters you can use. I have included
three other photos below with the filters used to
create them. If you want to do something different
with a photo, one of these treatments may be just
what you need. Feel free to experiment with other
filters to see what you get. By the way, I put a two
pixel border on each to illustrate a frame (using a
different program!), but you don’t have to do that.

Now, click the Quick
Mask button at the
bottom left of your
workspace. A red
frame will appear on
the outside of the
rectangle you drew.
Noise - used Noise
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> Spread

(15 or 20)
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GIMP Tutorial: Quick Mask

Screenshot Showcase
Waves - used

Gaussian Blur

Distorts > Waves

Whirl - used Distorts

Spread

(45), then

Blur >

> Whirl & Pinch , then Noise >

Posted by RobNJ, running e18, on May 16, 2014.

Have fun!
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GIMP Tutorial: Using The Clone Tool
by Meemaw
Sometimes you take what you think is the perfect
photo, but then you’ll see that if just one little item
wasn’t there, the photo would be even better. But,
how do you remove an item from a photo?
Removing unwanted objects from your photo may
seem a little daunting, but the following method was
fairly easy for me. My vacation last summer was
riding 4-wheelers in Colorado. We went to one town
called St. Elmo. The old buildings were beautiful, but
one photo had a traffic sign I wanted to remove. I
thought my photo would look much better without it,
so I decided to edit it out of this photo rather than
cropping it out because I wanted the road in the
photo. We are going to do that using the Clone Tool.

Choose the Clone tool stamp from the Tools panel.
In the brushes area, choosing a bigger brush will
clone a bigger area. Hold down <CTRL> with the
Clone Tool selected, and click anywhere in your
image to sample that area. I clicked on the trees just
to the side of the sign I want to cover in order to
make the result blend in with the background. A plus
sign will appear in your area, meaning that you have
a “sample area” to use. Feel free to zoom in as
necessary on the area you are editing, in order to do
a better job.

match the area around one of the items you want to
remove, you can always choose another in the same
manner. In this photo I had to choose three different
samples: one for the background behind the sign,
one for the vegetation behind the top of the post,
and one for the part of the road behind the bottom of
the post. You can see now that the picture looks
better without the sign in it.

Start by opening the image you want to change. You
should always make a copy of your original photo
and edit the copy, or at least create a copy of your
background layer by right clicking on the background
in your Layers Panel and selecting “Duplicate”.

Now, paint carefully over the item you want to
delete. The sample area you grabbed with the
clone tool should cover up that item. When you
paint, your sample area indicator moves with your
cursor and the area you want to change should be
painted with the sample area. You should make
short strokes and proceed carefully to get the
desired effect (top right).
You can change brush size and hardness by rightclicking in your image. If the sample area doesn’t
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GIMP Tutorial: Using The Clone Tool
While this was a minor change, many photos can be
“cleaned up” in this manner. In the bottom photo
below, I removed the electric line above and
transformer to the left of the building.

Screenshot Showcase

What a great tool! With a little practice, you’ll find
yourself removing unwanted elements from your
images in no time, too.
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Posted by LKJ, running Openbox, on June 24, 2014.
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GIMP Tutorial: Creating A Text Reflection
by Meemaw
We see text reflections all the time. I think they are
pretty neat, and I always wondered how it was done.
This tutorial will show you a simple text reflection.
Open a new image (I made mine 400x300), select
the Text tool from the Tools Dialog, choose your font
and type in a word. If you want, you can rename the
Text layer to Main Text or it will end up being named
using the text you typed. In the layer dialog tick the
Lock Alpha Channel .
We want to put a
border around our text.
In creating smooth
outlines, we want to
use the text as a
guide.... to do this,
right-click on the Main
text layer and select
Alpha to Selection .
Then go to Select >
Grow to access the
Grow Selection dialog
or you can right-click on top of the Text and in the
menu click on Select > Grow. I added 2px for the
Grow Selection.

Click on Create New Layer, name it Border and fill
it with a darker color using the Bucket Fill Tool ,
then place it behind the Main Text layer to become a
border.
Now we want to create the reflection effect. First,
right-click on the Border Layer and in the menu click
on Duplicate Layer. Move the layer on top of the
Main text layer by clicking the up arrow in the Layers
Dialog box. Do the same for the for the Main text
layer and move it on top of the border Copy layer.

Right-click on the Reflection layer and in the menu
click on Add Layer Mask, selecting Black Full
Transparency, and then click Add . Your reflection
will disappear.

Now merge the two new duplicated layers by rightclicking on on the Main Text Copy layer and in the
menu click on Merge Down . Now rename the layer
Reflection.
Before we do anything else, de-select any selected
layer by going to Select > None . We want to be
working with only the reflection layer, and this makes
sure nothing else is selected.

Blend tool and select the FG to BG (RGB)
Gradient and apply it to the reflection from bottom to
Grab the

top. Make sure your foreground color is black and
the background color is white.

Using the Move tool, place the the new duplicated
text logo image below the original text logo. Choose
the Flip tool, make sure it’s on Vertical mode, then
drag upwards to finally flip it, or select Layer >
Transform > Flip Vertically. Make sure they are
lined up the way you want them.
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GIMP Tutorial: Creating A Text Reflection
Where you start and end your gradient determines
the visibility of your reflection. Starting at the bottom
of your reflection text and going to the middle of your
main text results in a bigger reflection (below, left).
Starting in the middle of the reflection text and going
to the top of your main text results in a much smaller
visible reflection (below, right).

Experiment with it until you get what you want
(remember <CTRL> + Z is the key combination for
Undo). When you get your reflection the length you
want it, you can always play with the transparency of
that layer to make the reflection lighter.

This can be as simple or fancy as you want. Make
sure your Main Text editing is finished before you do
the reflection.

It's easier than E=mc 2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...

Have fun!

DOWNLOAD

Mate Desktop
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Available in the following desktops:
KDE LXDE Xfce
Openbox Gnome
Enlightenment e17
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GIMP Tutorial: Colorizing A Photo
by Meemaw
I have several old photographs of my grandparents.
One of my favorites is a shot of my grandmother as
an infant. I have always wondered what that photo
would have looked like if color photography had
been available in 1893. I have scanned and saved
this photo to try to colorize it.

It’s also a good idea to give each layer an
appropriate name to make things less confusing
during this project, since there will be several layers.

Make a copy of this layer as well. Then you will need
to make sure that the image is not in Grayscale
mode. Go to Image > Mode > RGB and set the
mode to RGB.

Next, you should right click on the image and create
a layer mask (Layer > Mask > Add Layer Mask)

Now go to colors and select Colorize . Color Balance
or Hue-Saturation could be used as well, but we’ll
colorize this one.

Set the background as white.

The first thing I am going to do with it is to open a
copy of the photo in Gimp so I still have the original.
This way if I mess up, I won’t have to re-scan. In
addition, I am going to make a copy of that layer, so
I will still have the original I opened and can delete
any layer that’s messed up. You may try a lot of
options on this project, and having a copy of a layer
is one way to be able to undo something you did that
didn’t turn out as you wanted it. Remember, you can
always use the undo key combination <CTRL> + Z.
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For the Colorize dialog to actually come up, we need
to make sure our image is selected and not the layer
mask (below). The image is on the left and layer
mask is on the right and when either is chosen, it is
outlined in white. The image is chosen here (next
page, top).
With Color Balance or Colorize, we will now want to
try to get the image to be same color of the object
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GIMP Tutorial: Colorizing A Photo
Colors > Invert to invert the colors. Once the colors
are inverted, it will look like the original without any
color.

we want to color. I started with the skin. I made sure
I created a copy of the image and layer mask I could
use specifically for the skin.

Next I used paint brush, selected the white color and
painted. You can use the selection tool, outline the
object you are colorizing, then fill it with white, but
using the paintbrush is easier. As we did on the
other layer mask, you can outline with a smaller
brush, then fill in with a larger one.

Once you adjust the opacity on the layers, you are
done! Export your photo. As a finishing touch, I
opened the finished photo and took out the white
spots (blemishes on the original photo) using the
Clone tool, like we did the road sign a couple of
months ago.

When you choose Colorize, your photo will change
to a bluish/turquoise. Adjust the hue until you find
the color you like. Below are the the screens that I
adjusted to do the blanket in light blue.

Once you have that layer the way you want it, create
a new copy and repeat the process for another
portion of the photo. For my next layer I did the
dress.
Keep on repeating the process for every object that
is a different color. It can be quite tedious but it’s fun.
I ended up doing the skin, hair and dress and
decided against doing the blanket. ---->
Don't worry too much about getting the colors exact.
Changing the colors later is quite easy. If you decide
you want to go back and change a color, just select
the layer and go back to colorize (make sure the
layer mask is NOT selected).

After you have the color you want, you will now need
to select the layer mask by clicking on it. Now go to
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Looking for an old article?
Can't find what you want? Try the

PCLinuxOS Magazine's
searchable index!

After you do all the layers, you can go back and
adjust the opacity on the layers to make it look a bit
more natural and not over saturated.
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GIMP Tutorial: Create a Shiny Button
by Meemaw
We’ve all seen those shiny buttons that people
make, so now we’re going to make one.
Start a new project, 640 x 400 with a white
background. If your project has some other color
background, you can always change it by choosing
white on your color palette, and using the bucket fill
tool.

With the new layer selected, bucket fill your
rectangle with black. Notice the rectangle is the only
thing that gets filled. Save your project as Button.xcf
Now add another transparent layer. On this one,
choose Select > Feather. You want to choose your
feather setting to be the same as the height of your
rectangle, so if your rectangle is 90 pixels tall, make
your feather setting 90 pixels as well. Mine will be
100 pixels. Notice that this outline is a little different.

(When you hover your mouse over the button, it will
say, “Replace the selection with this channel.”) Now
the dotted lines that surround the selection are
around the original rectangle. However, we want to
delete everything outside that rectangle. Make sure
you go back to your Layers tab and the colored layer
is selected, then click on Select > Invert. This will
choose everything except your rectangle. NOW,
press your Delete key, and the outer color will
disappear.

Choose the rectangle select tool and draw a
rectangle. In your tool options below, check
Rounded Corners. A slide will appear, allowing you
to set the amount you want rounded. I set mine
around 25.
We want to save this item, because we will use it
again. Go to the Select menu and choose Save to
Channel . We haven’t really talked about Channels
yet, but are used to designate the colors in an
image, and also any selection masks that may be
used. Our drawing has no color yet, but we have
selected and saved a rectangle, so it is saved there.

Next, we want to add a layer. Make sure
Transparency is selected in your add layer dialog.
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Now, bucket fill your drawing with a color you like. I
used a teal blue (00c0f5). If you make it darker your
button will be darker. Notice your fill now is blurry
around the edges. That’s the feathering. However,
look at your drawing, and you will notice that the
feathering extends beyond the edges of your original
rectangle. Let’s get rid of that.

Make sure your color layer is selected, then go to
the Channels tab and select the rectangle you
saved. Click the red button at the bottom of the tab.

Go back and click Select > Invert again, since we
are working on the button itself.
Now we want to make our button shiny. First we
want to choose the ellipse select tool. Start your
mouse to the left and above our button, and end up
to the right about centered. Hold down the <CTRL>
and <Shift> keys while you draw it. This will select
the intersection of the two figures (see the dotted
line?)
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GIMP Tutorial: Create A Shiny Button
Next, choose Select > Shrink to shrink the selection
you just drew. When the settings box appears,
choose to shrink by 3 pixels. Notice that the dotted
line is now inside the button.

This will be the shiny part. Click on your color
chooser to make the foreground white, then click on
the Blend , or Gradient, tool. Choose the gradient
FG (Foreground) to Transparent. Create another
transparent layer, choose your Gradient tool, hold
down the <CTRL> key to make your gradient
straight, and draw a line from above your button to
about halfway between your selection and the
bottom of the button. (You can probably play with the
gradient and get it the way you like it.) Clicking on
Select > None removes all your selection lines so
you can see what it looks like so far. If you like
what you’ve done since you saved last, save your
work.

to a rectangle select. Enlarging the box and clicking
in it will allow you to type your text. When you have
the text typed and formatted correctly, change to the
Move tool to position your text box.

We want to move our shiny layer OVER our text as
well, so click on the shiny layer (here Layer #2) and
then the up arrow at the bottom of the layers tab to
raise the shiny layer to the top. I’ve already moved
mine.

You should have saved everything while you were
working on it. While I was working on mine, I
decided I wanted the text larger and in a different
font. Simply click on the text layer, click on the Text
tool, highlight your text and change the font and
size. You may have to reposition it so it’s centered
again, but that’s easily done by clicking on the Move
tool.
I also made a smaller button that I can use for the
menu button on my panel.

Now, let’s put some text on our button. Choose the
text tool, formatting your font, size and color in the
text tool options on the bottom left. I think the tool’s
appearance has changed since we did text earlier.
Your text box will appear wherever you click similar
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Have fun!
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GIMP Tutorial: Exploring The Create Menu
by Meemaw
I’ve been using Gimp for quite a while, and haD
never noticed a section in the File menu. It says
‘Create ’ and in it are several already-configured
items that you can make in just a few minutes.

Let’s play a little. After opening Gimp, click on
Create > Logos. You will see many options.

Now, let’s do a button. Click on
Button .

File > Create >

There aren’t as many choices. Let’s do a simple
beveled button. The only way to increase the size of
your button is to change the font size. The ones
below are 63 pixels wide and 24 pixels tall with the
font size 15.

File >
This window contains all the configuration items you
need. You can change the text, font and size, along
with the gradient you want to use for the text (Deep
Sea or Caribbean Blues) and outline (Brushed
Aluminum) plus the color for the background (Dark
Blue). You can experiment with many of the settings,
including using patterns for the text or outline, or
even overlaying the whole thing with a pattern. Make
as many as you want and save the ones you really
like.

Let’s do a Glossy logo. Choose Glossy from the list
and you will see this window (center, top):
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I changed the upper left to purple and the lower right
to dark blue (my colors of preference). After I made
one, I changed the text color to white. Then I made a
third and clicked the “Pressed” check box. This one
looks like a button after I have clicked on it.

Page 23

GIMP Tutorial: Exploring The Create Menu

As always, experiment with colors and settings to
get just what you want.
Another section in the create menu is
Pattern .

Create >

As you can see, there are 3 colors to set. The
‘Smooth’ checkbox puts a blur into your camouflage
and the ‘Flatten’ checkbox merges all the layers
together.
The Create menu has many different items you can
try. Another couple of patterns are below:

Two other items are at the top of this menu. The first,
Create from Clipboard , places clipboard contents
directly into Gimp so you can work on it. The second
is Create from Screenshot. Choosing it gives you
the following window:

Swirly Tile

I chose Camouflage
3D Truchet

You can also design items for web pages, including
arrows, bullets, buttons, headings and Hrules
(horizontal rule, which can be used as a border or
divider) in two different patterns:

Image size is how many pixels on each side, so with
400, it will be a 400 x 400 square. Granularity is how
much detail to camo has. In the image below, the left
side’s sample has granularity of 2, and the right
side’s is 15.
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You can configure your screenshot method (window,
screen or region) and any delay you want, click
Snap, then the screenshot is imported into Gimp for
you to manipulate.
We’ve had some fun with the Create menu. Its
ready-made configurations are nice if you need to
design something quickly, like a button or a pattern.

Linux Docs
Linux Man Pages
Arrows for the two patterns are shown below on the
tabs in Gimp. The design on the left is called Alien
Glow, and the one on the right is called Beveled
Pattern.
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GIMP Tutorial: Create Your Own Alien World
by Meemaw

See all the dots inside the sky? I don’t want that.
Sometimes the selection doesn’t include all the area
you would like it to. A way to remedy that is to set
the threshold up a bit and click again. (Threshold is
in the Select by Color tool options at bottom left.)
Keep doing that until your sky is outlined and all the
other dots, if there are any, are outside it.

I was sent a cool tutorial the other day. It’s got
several useful manipulation methods in it and I’m
going to share it. When you are finished, you’ll have
something similar to this:

I’m first going to add an alpha channel to each layer
so we can make part of each transparent. Right-click
on each layer and choose “Add Alpha Channel ”.
Now I will put the mountain layer on top and “turn
off” the water layer by clicking the eye to the left of it
in the layers tab.
I just want to use the mountains, so I’m going to
choose the select by color tool and click on the sky.
This a three part process: editing the land, creating
the starry sky and then the planets.
The first thing I did was find a couple of
photographs: one of mountains and one of the
seashore. Opening Gimp, you need to click File >
Open as Layers.... and navigate to the folder
where you saved your photographs. Choose them
by clicking the first and then pressing the <CTRL>
key while you click on the other. (Remember,
multiple select uses <CTRL> or <Shift> depending
on how many you are selecting.) I moved one layer
so you could see them both (center, top), but you
don’t have to do that.
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Now choose your eraser, using a hard brush, and
erase the sky. Be careful next to any similar colored
mountain you want to use. In mine, the mountain in
the background is too hazy for me, so if I erase part
of it, I’m not going to worry, because I’m going to
clone another mountain into that spot.
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GIMP Tutorial: Create Your Own Alien World
Click Select > None to remove your selection. That
turns off all the moving dotted lines.

your layers around on the page to get the effect you
want as well. I moved the water layer down to show
more mountains.

With the clone tool, we’ll use the same technique we
used for taking the road sign out of a photo, except
this time we will pick a piece of the existing mountain
(using a soft brush), hold <CTRL> , and brush across
it. Then go to the place you want a mountain and
paint there. If it doesn’t turn out the way you want it
the first time you can always undo part of it (<CTRL>
+ Z) and try again. Save your work if you are
satisfied (Remember, saving as a Gimp xcf file
deletes your undo history, so only save it when you
are happy with what you have done.)

If you are happy with your work up to now, right-click
on the top layer and choose Merge Down, then save
your work.

Now we can make the water layer visible again by
clicking the eye icon on that layer. Move it to the top,
too. What I want to do is stack these layers so it
looks like there is a cove or lake with hills around it,
so we’re going to erase the sky and part of the
water.
To be able to see what we are doing in relation to
the bottom, mountain layer, set the Opacity on this
layer to about 50%. Using a hard brush, start
erasing the top layer until you like the way it looks.
When you get part of your water erased and want to
see what you are doing, you can set the opacity
back up and finish your erasing. You can also move
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Let’s do the sky now. First, make the mountain/water
layer invisible for now. Then, in the Layers dialog,
click on Create New Layer. Choose Fill with
Foreground Color (since we haven’t changed
anything, your foreground color should be black). On
this layer, click Filters > Noise > HSV Noise . In the
configuration box that pops up, move the Value
slider all the way to the right, then click OK (top,
right).
We want a little variety, so click on Filters > Light &
Shadow > Sparkle. Leave the settings as they are
and click OK (center, right).
However, this is a little too sparkly for my taste, so
Create a New Layer (black). In the new layer,
choose Filters > Render > Clouds > Difference
Clouds. Then, in the Layer dialog, change the mode
of this layer from Normal to Burn (bottom, right).
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Now your stars look more varied. Merge these three
layers.

An alien world wouldn’t be complete without some
nearby planets!

We want to add a little color to the stars, so create a
new black layer. Click Filters > Render > Clouds >
Plasma. Then change your layer mode to Dodge.

Create a new layer, but make it square, and a little
more than half the height of your project on each
side. My drawing is about 750 pixels, so I’m going to
make this new layer a 400 pixel square. Pick a red
color and bucket fill it.

You should study your layer a bit before you
proceed. The top is going to be visible, but not the
bottom. You can flip your layer using the Flip tool if
you wish. Make sure it is set on Vertical before you
click on your layer to flip it. Right click and Anchor
layer if needed. Now you can “turn on” your land
layer and bring it to the front.

Now choose the paintbrush. Change it to another
brush style, like acrylic (I chose acrylic02). Choose a
brown color, increase the size of your brush to 150
or 200 and paint inside your layer. Don’t cover all the
red, though.

Now we are going to make it into a sphere. Click on
Filters > Map > Map Object. We’ll change some of
these settings:
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Main Window: Uncheck Show wireframe and check
Show preview live.
General Tab: Choose Map to Sphere and check
Transparent Background.
Light Tab: Change from Point Light to Directional
Light. This removes that small light reflection as our
light source will be farther away.
Materials Tab: Change Ambient to 0.20 and
Specular to 0.00. This darkens our sphere a bit.
Orientation Tab: Change the Position Slider for Z to
0.90000. This makes our sphere larger.
Click OK.

Using the Move tool, you can move it anywhere you
want it, and move the layer down under the land
layer so it looks farther away.
Before we finish with this layer, we want to add
some light to one side of it to give our picture the
feeling of a light source. With your planet layer
selected, right-click in the layer tab and choose
Alpha to Selection . This chooses only the planet.
Select the Blend tool, then choose as your gradient
FG to Transparent with the foreground white and the
transparent on the left. Also, choose a radial
gradient, because we want the white around the
edge of the planet, and change the offset to 85.
Starting from just below and to the right of the center
of your planet, hold and drag your mouse pointer up
and left to just outside the planet (next page, top
left).
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Filters > Render >Clouds > Plasma. Now, click on
Filters, but go to Recently Used, and choose Map
Object. then Alpha to Selection again, and choose
your blend tool and add your light.
Let’s make it a little
more alien. Choose
your land layer, click
on
Colors
>

Brightness
Contrast, and

Cool,

huh?

Click
to
unselect everything.

Select > None

&

set the
color down and the
contrast up to change
the colors a bit. When
you are satisfied with
your work, save. If you
are sure you are
finished you can merge
all your layers by choosing Image > Flatten Image .

As a final feature in our
project, let’s put one
supernova in our picture.
Click Filters > Light &

Shadow > Supernova.

The crosshairs show where
it will be on your picture,
and you can make it as
bright and as big or small
as you want by changing
the color, radius and
number of spokes. I left the
defaults.
If you don’t want to mess with the photographs, you
can just make the sky and the planets, which is fun,
too. Experiment with different settings & colors and
see what you get!

Now I’m going to
make another planet a
little smaller than the
first. I made my new
layer 300 x 300, filled it with an orange, then using a
brown, clicked over it with a different brush (I used
one called Galaxy). Since you have already made a
sphere, all you need to do is choose Filters >
Repeat Map Object. All the settings are already
there, so just click OK. Alpha to Selection, as before,
then choose your blend tool and add your light.
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Let’s
make
one
more
planet,
smaller than
either of the
other
two
(150 x 150 in
a new layer).
Instead
of
painting
it,
Click
on
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GIMP Tutorial: Masks Explained
by Meemaw
We’ve used masks in several of our projects.
Sometimes it’s hard to understand exactly what a
mask does, so I’m going to try to explain it in this
article.
A mask is a layer you can add to your project to
affect certain parts of it. However, instead of being
another layer, the mask is attached to a layer and
affects the pixels on that layer. It’s used to block or
show the pixels on the layer it is part of, so your
project is changed in some way.
Basically, a white mask makes your layer show, but
allows you to “cover” part of it to show what’s
underneath, and a black mask makes your layer
transparent, so you see the next layer down, while
allowing you to “uncover” any part you want visible.
When we did the layer mask on the flower photo, we
created two layers, made the bottom layer
grayscale, and configured the mask on the color
layer to be black, which blocked out the color.
Painting a black layer mask with white makes those
pixels transparent, so we could see the color in that
layer.
It
just
blocks out the
layer it’s attached
to, so we could
still
see
the
grayscale
layer
on the rest of the
photo.
This
resulted in our
flower showing as
color and the rest
of the photo as
grayscale.
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On
the
infant
photograph, we also
made the layer mask
black.
Painting
with
white makes the mask
transparent and the
color in that layer shows
through. That’s also why
we had to make several
layers, each with its own
color. Each layer mask
brings out the color we
configured on that layer
in the areas we painted,
while leaving the rest
grayscale.
If you have a color and a
greyscale layer, you can
put a white layer mask
on the color layer and paint with black to make the
greyscale show through. On the example below, I
did just that.

rose. Notice the layer section on the right. The layer
mask now shows the areas painted with white and
gray on it besides the black part of the mask.

With the right photo and a little imagination, you can
make a very dramatic image!
Let’s
try
something else.
I loaded this
photo into Gimp:

One thing we haven’t tried is using a shade of gray.
If you paint on a layer mask with 50% gray, then that
portion of your layer will be 50% transparent. In the
example below, I chose a 65% gray and painted the
leaves above and to the left of the rose. You can see
that there is color there, but it is not as bright as the
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In Gimp, I did the following:

Linux Training
Courses & Classes

Duplicate Layer, then using the bottom layer, click
Color > Desaturate. Add a Layer Mask to the color
layer.
With the layer mask chosen, Blend with a BG to FG
gradient (BG is background white on the left of the
button, FG is foreground black on the right).
Starting with the top of the
photo, click and drag to
about two thirds of the way
to the bottom of the photo.
------>
Now we see that the top of
the photo is still in color, but
the gradient in the layer
mask slowly changes the
color to grayscale as you
get lower in the photo. You
can see what is unmasked
so the color shows through
and what is not. You can
make either the color or the
grayscale as big or small as
you
want
simply
by
changing
where
the
gradient starts and ends.
The farther down you start
makes more color and less grayscale in the photo. If
you want color at the bottom, simply start at the
bottom of the photo and drag upwards.

Experiment with your photo to get the effect you
want. To prevent overwriting – and possibly losing
the only copy of your photo – it’s best to always work
on a copy of your original image.

Visit Us On IRC
• Launch your favorite IRC Chat Client software
(xchat, pidgin, kopete, etc.)
• Go to freenode.net
• Type "/join #pclosmag"
(without the quotes)
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by Meemaw

GIMP Tutorial:
Tree Silhouette in Sunset, Part 1

This month we will make a silhouette of a tree using
Gimp, then next month we will put a sunset behind it
using Inkscape. I was sent this tutorial and it looked
really fun. You can use one of your own photos or
download one from a free site, making sure it is legal
to use it. I downloaded five from Google Images,
and then looked at them together to see which one I
wanted to use.

When you find the photo you want to use, open it in
Gimp. I think I want to use the one at bottom right.

There are several methods that will remove the
background but let’s use the Clone tool. Clone
everything you don’t want the same color as the sky
so you only see the tree. Notice that I have some
sunlight in the center of mine. I will want to clone
that as well.
Crop the photo down to only the tree. Yes, my Gimp
workspace has a grey background.

Now that I’m finished cloning you can see what I
have left. I know it looks a little red, but we’ll fix that
soon.
Now we will start adjusting the color, so click Colors
> Curves. You will get a graph with a diagonal line in
it. While watching your photo, adjust the color curve
(the diagonal line) so the color is disappearing. You
will have to grab it with your mouse and move the
line up and to the left.
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Now, click on Colors > Brightness-Contrast.
Change the Brightness and Contrast up by moving
the sliders to the right. Increasing the brightness
make the background lighter and increasing the
contrast will make the tree darker. Keep an eye on
your tree, though, because just sliding everything
clear to the right may cause you to lose the detail in
your tree. Mess with it a bit and discover the settings
that look best to you. Every photo is different too, so
my settings probably won’t work for your photo.

Users Don't
Sometimes we can sharpen our image just a bit.
Click on Filters > Enhance > Sharpen and see if it
helps, because sometimes it doesn’t. It didn’t make
any difference on mine.
Save your tree, and then export it as a picture file. I
usually use .png or .jpg.
We finish this project with Inkscape on page 64.

Click on Image
Greyscale.

> Mode and change it from RGB to

Defending Your Rights

Notice that part of my tree is grey and not black.
Now we will go back to Colors > BrightnessContrast and adjust again. This time we will adjust
the brightness down, and the contrast up. Make the
brightness -100, and the contrast 110. There’s your
silhouette (center, top).
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Phone
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Facebook
Tweet
Instagram
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Email
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While Driving.
In The Digital World

Put Down Your
Phone & Arrive Alive.
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GIMP Tutorial: Fixing a Photo
by Meemaw
Not all the photos we have are in perfect condition,
especially older photos of parents or grandparents.
My cousin and I have shared many photos of family
members, and many of those photos are not in the
greatest shape. Many are torn or cracked. If you can
scan and save these photos to your computer, Gimp
can help you do a good job of fixing them.
I have this photo that is cracked and too dark in
places;

wish and allow it to be saved with the .xcf file
extension. This way you will still have your original
photo just in case something happens to your work.
Fixing the cracks will be done with the Clone
tool, which looks like a date stamper to me.
Click on the Clone tool, choose a place in your photo
you want to fix and, holding down the <CTRL> key,
click on a spot nearby that is the same color and
texture you want to use to fix the crack. If necessary,
zoom into your drawing to see your work more
clearly. Also, depending on what you need to clone,
adjust the size of your brush. I’m working on the
background, which has darker lines every so often,
so I made my brush 5.5 px wide. The circle with the
+ inside is the indication that my clone area has
been selected.

While I am at it, I’ve decided to try to reconstruct the
bottom right corner of the photo, which has torn off.
For the background, I have chosen to copy an area
of the existing background and place it into the
missing corner. I used the crop tool and outlined an
area, clicking <CTRL> + C (Copy) and then <CTRL>
+ V (Paste), and then moving each pasted piece into
position down the right side of the photo.

The tear on the corner also cut off part of her arm,
so, using the clone tool again, I
put the
same colors as her blouse into the photo, changing
my clone selection where it needed to be lighter or
darker. I can always go back and put in more detail,
but I’m happy with it at the moment. Any time you
are happy with the work you have done up to that
point, you should save your work. Remember, if you
clone in a color and it looks wrong, you can always
use <CTRL> + Z (Undo)

very slowly

I would like to fix the cracks and even out the color.
Find a photo you would like to fix and we’ll get to it.
Opening it in Gimp, the first thing you should do is
choose File > Save a copy. Name it whatever you
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You will want to use small strokes and go slowly.
Also, you will want to change your clone sample as
many times as necessary to match the area you are
fixing. I have to change several times because the
background is a light color with darker lines, and
different areas of the photo are different shades of
those colors.
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the contrast up to about 22, but your photo may
need different settings. When you get what you think
you want, click OK.

I like this one, so I saved it. Feel free to keep
adjusting your photo until it looks right to you, then
save it.
The next thing I’m going to do is rotate my photo. It
looks like it was placed in the scanner crooked. Click
on the Rotation tool, then click in the center
of the photo. You will get a Rotate window,
and a grid will appear over your photo. Using
the arrow keys will help you rotate your photo until
it’s correct (mine only needed a few degrees). When
you are finished, click OK. You can always open it
again if you decide that you need to change it.

Once you get everything cloned to your satisfaction
and save your photo, you can lighten the color a little
by choosing Color > Brightness - Contrast. The
Color menu has several color tools, but we can start
here.

You can slide the sliders in the center, or click on the
up & down arrows at the right. I choose the arrows
because the sliders are not as easy for me to control
and I always go too far. The good thing about the
arrows is that you can go up or down one number at
a time, and stop when you think you have it right. I
ended up setting the brightness up to around 72 and
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This doesn’t look right yet. One trick you can use is
to Undo your editing using <CTRL> + Z and then
Redo it using <CTRL> + Y. Toggling back & forth will
give you an opportunity to see the original in
comparison to your work, and decide what you need
to do next. I don’t think it’s quite sharp enough, so
I’m going to set the contrast up a bit.

Last, I’m going to crop the ragged edges out of it.
Using the Rectangle Select tool, draw a rectangle
around the photo and the choose Image > Crop to
Selection . When you have it rotated and cropped to
your liking, save your work. You can always keep the
.xcf file to work on it further, but you can also Export
your photo to an image file (png, jpg or whatever you
want). Remember, if you click “Save”, your photo is
saved as a Gimp .xcf file. If you want to save it as
anything else, you should click “Export…”, then
choose the format you want (next page, top left).
One other item is the color of the photo. This photo
has a sepia tone to it. Some of the tone may be
intentional by the original photographer and some
may simply be yellowing because of age. You may
wish to reduce the sepia tone using Colors > HueSaturation . This will change it to more of a black &
white photo. Here is the photo with the saturation
adjusted by -50 (next page, bottom left).
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Linux Docs
Linux Man Pages

Screenshot Showcase

As always, it is your creation, so you can change it
as much or as little as you want. When it looks good
to you, and you think it’s finished, then you should
save it and/or export it.
We’ve seen that just a few tools in Gimp’s toolbox
will help us “restore” a photo, or at least repair one.
I’m sure that your photo album will look wonderful
very soon.
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Posted by Stephen!, running KDE, on July 16, 2014.
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GIMP Tutorial: Editing an Image
by Meemaw
We’ve made bunches of pretty things with GIMP!
We’ve also done a little bit of photo editing, but I
know there are more tips to editing digital photos
than the ones I’ve covered already. When a digital
photo is opened for the first time, even expert
photographers will do something to improve the
shot. From Chapter 10 of the GIMP Manual,

“Most
commonly the things that you want to do to clean up
an imperfect photo are of four types: improving the
composition; improving the colors; improving the
sharpness; and removing artifacts or other
undesirable elements of the image.”
Let’s look at some things we can do to improve our
photographs. I will follow the four topics listed in the
GIMP Manual’s Intro to Chapter 10 above. I have a
folder of photos from a recent trip to edit. I am going
to copy all of them into a sub-folder called Originals
before I start, just in case I really mess one up! Also,
remember, anything you do to a photo can be
undone just by pressing <CTRL> + Z or clicking on
Edit > Undo. Make sure you have your photo the
way you want it before you save.

Improving Composition
No matter how hard you try, sometimes you just
haven’t held your camera absolutely level. If you are
scanning a photo for saving, you haven’t placed it in
the scanner straight. Rotating your image will
remedy that error. GIMP’s rotate tool looks like this:
When you click on it, then click inside your
photo, you will find your photo covered with
a grid, and the rotate window will appear.
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If you need to
rotate clockwise,
you should click
the up arrow next
to the angle, and
if you are going
counterclockwise,
the down arrow
should be clicked.
You can do it by
hand with your
mouse, of course,
but this is much
more precise. A
tip is to rotate a
bit, then click OK
to see how you did. Clicking in the center of your
photo will replace the grid squarely and you can see
if you have it rotated enough (or too much!) I rotated
this photo -2.00 degrees,
then
another
-1.5
degrees. I wanted the
signpost to be straight,
and I wasn’t happy with
it the first time. I clicked
the photo a third time,
and the signpost was
straight, so I canceled
out of that window. To
keep from accidentally
starting the rotate tool
again, I chose some
other tool.

Choose the Rectangle Select tool and draw a
rectangle around your desired area. Click on
Image > Crop to Selection and everything
outside the rectangle will be eliminated. Another
cropping tool is the actual Crop tool. Your cursor will
change to a cross and you will be able to
draw a rectangle around the area you want to
keep, then press Enter or click on your
selection.

On either tool, you are able to adjust the sides of
you rectangle before you actually crop your photo,
just in case your rectangle isn’t quite where you
want it.
(This photo is of the entrance to the Miniature
Railroad Museum at Balboa Park in San Diego, CA.)

Notice that the edges of the photo now have some
transparent sections. That’s because Gimp rotated
the photo, but there wasn’t anything to place in
those corners. One option is to crop the photo.
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Improving Colors
Exposure Problems
Heaven knows I’m not a perfect photographer! Most
of us aren’t, so we take loads of photos and then
weed out the bad ones, leaving us with the ones that
are most promising. Sometimes a photo will be really
good, except that it’s just a bit dark. We’ll want to do
a little color correction on that. The easiest tool to
use is the Brightness-Contrast tool. You can slide
the sliders or use the up and down arrows, which will
be easier if you only have to adjust a little bit.
I have a few photos that are just a bit dark, so I will
open one in GIMP and choose Colors >
Brightness-Contrast. A window will open that
shows sliders for brightness and contrast. You will
also see a checkbox that says “Preview.” Make sure
it is checked. As you slide the sliders or use the up &
down arrows next to the values, your photo will
reflect the change.

If you are tempted to use only the brightness setting,
I should warn you that some of your photos will look
washed out or way too light if you don’t adjust the
contrast as well. See the difference at center top:
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(This is a photo of part of the bay in San Diego, CA.)
The Levels tool is another tool that can help you
adjust your highlights and shadows. I opened this
picture. It turned out really dark when I took it, and
after I used the Brightness-Contrast tool on it, I got
this result:

I said it was really dark! Then I chose Colors >
Levels. When the window appears, there are three
arrows below the histogram, one at each end and
one in the center. Adjusting the arrows below the
histogram, I was able to lighten the photo up
considerably (top, right).
Please be aware that large adjustments here will not
only lighten the photo, but add noise. However, a
slightly noisy photo where you can actually see
Uncle Jimmy and Aunt Sally is better than a dark
photo where you cannot (center, right).

This is a photo of one of the rooms in Whaley House
at Old Town, in San Diego, CA.

Adjusting Sharpness
I don’t know about you, but I can’t always hold
absolutely still while taking a photo, and it come out
a bit blurry. Many of those aren’t repairable, but
sometimes a blurry photo can be helped with a
couple of tools. One is Filters > Enhance >
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Unsharp Mask, and it might be able to reduce some
of the blur.

We have already learned how to remove unwanted
items in a photo using the Clone tool, which will help
fix the photo above, too. The Healing tool should
work as well. There is also the Resynthesizer plugin
available for Gimp, but it isn’t included in the default
Gimp installation. You can install it from the repo
through Synaptic.

Another method is to choose a brush (paintbrush
tool) with soft edges, and size it a tiny bit larger than
the red you want to remove, then paint a dark color
into the red. If it doesn’t look right, use <CTRL> + Z
to undo it, and try again.

Many photos have the dreaded red eye effect. To
remove it, use Filters > Enhance > Red Eye
Remover. You need to outline the area you want to
change with the lasso or ellipse select tool first.
Before

After

Something else that might help is Filters > Enhance
> Despeckle. With both tools, you need to play with
the settings until you get the result you want. Be
very careful here, adjusting only a bit at a time, as
over-sharpening looks glaring and artificial.

Wow! We’ve covered a lot of tips. I am sure that your
photos will be even more beautiful now!

If it seems too sharp, then you might try Filters >
Blur. Sometimes a photo will look better if it is
softened a bit.

Removing Unwanted Objects
I have taken a photo in the rain before. Then, when I
look at it, the rain detracts from the photo quality, of
course. Using Filters > Enhance > Despeckle may
be able to remedy that. Here, I took the photo
through a dirty windshield… despeckle didn’t take
everything out, but it looks better (right).

Does your computer run slow?
Are you tired of all the "Blue Screens
of Death" computer crashes?
Are viruses, adware, malware &
spyware slowing you down?
Get your PC back to good health
TODAY!
Get

Download your copy today! FREE!
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GIMP Tutorial: Fire
by Meemaw
When we were working on the July 2013 issue of the
magazine, parnote asked me if I could create a fire
effect for the cover. So, I went looking for tutorials,
and found some. Two of the following are for
creating flames across the bottom of a wallpaper.
The third is for creating a very realistic looking
explosion.

Choose the smudge tool. (It looks like a hand with
an outstretched index finger.) Click on the bottom
stripe and draw your mouse up past the second
stripe. This creates what looks like a black and white
flame. Repeat this process along the stripes until the
white stripes are no longer visible. It might take a
while.

Creating Flames
This method will create flames that have a kind of
“crackle” effect.
Create a new file with a black background. (File >
New and clicking Advanced Options, and then Fill
with foreground color). If for some reason you get
something other than black, you can always choose
black as your color and use your bucket fill tool.

Creating the Crackle
Now we want to give it a sort of crackle effect. Click
Layer > New Layer. Click OK without changing the
default settings. Select Filter > Render > Clouds >
Solid Noise. Set X to 13 and Y to 7. Click OK.

Click on the color palette and change the foreground
color to white. Select the paintbrush icon. Paint a
white horizontal stripe just above the bottom of the
canvas. It doesn't need to be perfectly straight. Paint
a second stripe 50 pixels above the first. This stripe
doesn't need to be perfectly straight either. (I can’t
draw a straight line most of the time, anyway!)

Set the layer's mode to
Overlay. You can do this
from the Layers window
on the right side of the
screen. Mode is a drop
down box near the top of
the window.
Select Color > Color Balance. Set both the
Shadows and Midtones so that Red equals 100,
Green is 25 and Blue is -25. Set the Highlights so
that Red is 100, Green is 0 and Blue is -100. This
turns the black and white flames into red and yellow
flames.
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Create another layer by
clicking Layer > New
Layer. Click on Filters >

Render > Clouds >
Plasma. Set Turbulence
to 5 and then click OK
(next page, top left).
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fire. Do the same with yellow, making sure some red
is still showing. Repeat with white. Your drawing
should look similar to the screen below.

the Y-Value to 7. Duplicate the layer with the clouds.
Set both cloud layers’ Mode to Overlay.
It should now look like this:

Select Colors

> Desaturate, and then OK.

Set the this layer's Mode to Overlay as well. You
now have a fire with a crackle effect.
Right now, the fire looks really primitive. Click on
Filters-->Blur-->Gaussian Blur. Set Vertical and
Horizontal to 100. You should now see something
similar to the image below.

Create a new transparent layer. Go to Filters >
Render > Clouds > Plasma. Set the Turbulence=5
and click OK. Now go to Layers > Colors >
Desaturate. Set this cloud layer’s options to
Overlay, too.

Another Flame Method
Create a new file filled with black, and create a new
transparent layer.
The fire will be made with 3 colors, red, yellow, and
white. Using a red color, draw the basic shape of the
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It looks better but still doesn't look realistic. Create a
new transparent layer and go to Filters > Render >
Clouds > Solid Noise. Set the X-Value to 13 and
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If you want edit the fire a little more, you can just go
to Filters > Distort > IWarp . Play around with it to
get what you like. I didn’t do anything in IWarp.

An explosion effect.
Open a new file whatever size you want. Fill it with a
gradient (black to white), making sure at least 1/4 of
your page is white. The white will be the brightest
part of your fire.

Create a new layer (transparent) and and click on
Filters > Render > Clouds > Plasma, and set the
Turbulence to 6. Find the plasma pattern that you
like by repeatedly clicking New Seed . Set the layer
mode to Grain Merge .

Desaturate this layer, then click Colors > Color
Balance, and make sure the Preserve Luminosity
box is checked. While you have that window open,
also adjust the Shadows/Midtones/Highlights color
levels until you get the desired look of your fire. The
following settings look pretty good: Shadows: 88,
-65, -56 / Midtones: 71, 35, -49 / Highlights: 91, 87,
-5)
Merge ALL layers down, then select Blur >
Selective Gaussian Blur. Set Blur Radius at: 25
and Max Delta at: 50. You’re done!

Reach Us On The Web
PCLinuxOS Magazine Mailing List:

http://groups.google.com/group/pclinuxos-magazine
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PCLinuxOS Magazine Forums:

http://www.pclinuxos.com/forum/index.php?board=34.0
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GIMP Tutorial: Frozen Text
by Meemaw

The background is selected now, so go to Select >
Invert to select the text. Using the bucket fill again,
fill this text with white.

This tutorial was sent to me a year or so ago, and I
thought it was fun. We have done text in GIMP
before but this one is a different effect and uses a
combination of some skills you already have.

“Turn off” text layer by clicking on the little eye to the
left of it in the Layers window. Create a new
transparent layer on top. Using the bucket fill tool,
check Fill Whole Selection in the tool settings and
fill the text with white.

Opening GIMP, create a new 1600 x 1200 canvas
with a black background. Click on the text tool,
change the foreground color to white, change the
text size to 400 px, and type your text. I wrote
PCLinuxOS the first time on a bigger canvas, as you
see above, but I wrote Linux this time. Choose the
Move tool, and move your text to the center of the
canvas.
Now, right click the text layer, and choose Alpha to
Selection to select the text only. Choose Select >
Feather. In the window that appears, change the
number to 10% of your font size, in this case, 40
points.
What we are trying to do is make the text look like
ice with the inside clear and the outside frosty. It will
be rounded text rather than having sharp corners
(center, top).
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Duplicate this layer, then turn off the original. Select
the text layer, and choose Alpha to Selection . Then
go to Select > Feather again. If the feather box is
still set to 40 px, click OK.
Select the top layer (mine says “Layer copy”) and
press Delete. Go to Select > None to deselect
everything.

Now use the Select by Color tool. Click in the
background. Notice that the selection lines are
farther out from the letters now.

If you haven’t saved your file, you should do it now.
We have the text now, so let’s put some ice crystals
into it. Create a new transparent layer, check that
your foreground color is still white and then select
Filters > Render > Nature > Flame. In the window

Page 42

GIMP Tutorial: Frozen Text
that opens, slide the brightness clear to the right.
Click the Edit button at the top, then choose Bent
from the dropdown in the edit window. Click on the
randomize button several times to find a pattern you
like. then click OK. (This filter takes a few seconds.)
Now click on Filters > Edge-Detect > Sobel , then
click OK. You’ll notice your nice white pattern has
changed to black so go to Colors > Invert.

Gradient tool. In the tool settings, make sure the FG
to BG gradient is set, and that your background is
set again to white. Change the foreground to a nice
blue. The color I used was 485bbc, but you should
use whatever looks good to you. (As you saw, the
one at the beginning of the article used a darker
blue.) Click and drag your mouse straight down from
the approximate center of the letter to the bottom.
While your shape is selected, change the foreground
color to black, and change to the Airbrush tool. Set
the opacity of the tool to around 50%, and use a little
bigger brush, even bigger than the one you see in
the photo below. Put some shading at the bottom of
your snow shape (above, right side).

We don’t want all of that but we are going to clone
part of it to make our text look frozen. Find a spot
you want to use, then click on the clone tool. Make it
the same size as your text with a soft brush.
<CTRL> + click on the pattern that you want to
clone. Turn off that layer and choose the Layer copy.
Using smooth strokes, paint your pattern into your
letters. It seems to look best if you start in the middle
of the letter and stroke up and down without making
many short strokes. Make sure you have saved your
work (center, top).
Let’s add some snow! Add a new, transparent layer
on the top. Using the Lasso tool, draw an irregular
shape on the top of a letter, then bucket fill the
shape with white (center, left side).
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This illustrates the path of the gradient tool. When
you get finished, the text looks like it is sitting on a
surface of ice or snow. I added a border to clarify
the edges of the drawing, but that’s up to you.

Repeat your snow shapes on each letter. We are to
this point now (right, top). Make sure to save your
work.
While it looks cool this way, it needs a different
background. Click on the black background, most
likely the bottom layer. In the toolbox, choose the
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We need snowflakes as well. Add a new layer at the
top filled with black. Go to Filters > Noise > HSV
Noise. In the window that appears, slide the Value
slider clear to the right, and click OK. Now, choose
Filters > Light and Shadow > Sparkle. In that
window, change the Spike Points slider to 10. Then,
in your Layers window, change the Mode from
Normal to Screen . Wow!

Like Us On Facebook!

The PCLinuxOS Magazine
PCLinuxOS Fan Club

Screenshot Showcase

Save your work and export your creation.

Want to keep up on the latest that's
going on with PCLinuxOS?
Follow PCLinuxOS on Twitter!

Posted by Ika, running Xfce, on September 24, 2014.

http://twitter.com/iluvpclinuxos
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GIMP Tutorial: An "Out-Of-The-Frame" Effect
by Meemaw
I saw this tutorial a while ago and thought it was
interesting. Your finished product gives the effect of
your subject emerging from a photo.

image of a picture frame. I downloaded a framed
painting image from Wikimedia Commons and cut
the photo out, leaving the frame. You can also make
a picture frame using the method from my earlier
tutorial in Inkscape. Now you are ready.
Open your photo in GIMP. You can resize it to
approximately the size you want your finished image
to be. Using the lasso tool, outline the object you
want to bring out of your photo. In mine, it is the red
truck in the foreground. I grabbed part of the
shadow, too.

You want to start with a photo of something that is
moving toward you. Since I went to a parade
recently, I have several photos of trucks and cars
taken from the front. For this you will also need an
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resizing if necessary. This might be a good time to
save your project.
Still on that layer, click on the
click on your picture.
The perspective tool
will cover it with
gridlines.

Perspective tool, then

While that is selected, click <CTRL> + C (Copy), but
before you paste it, create a new, transparent layer
and paste it there (<CTRL> +
V). Also, create a new layer
filled with a light grey (or
whatever background color you
think might look good) and send
that layer to the bottom.

I am going to grab the left side of my photo and
move it in, making that side of the photo look like it is
farther away. You might have to move it around a bit
to make it look like you want it, but until you click
Transform in the window that pops up, you will be
able to manipulate it. If you click Transform, and
discover you don’t like it, you can always undo it
(<CTRL> + Z). Don’t let it fool you either. As you
move your photo, you will see the image in its
original position behind the one you are moving.
When you click Transform , it will disappear (next
page, top left).

Select
your
layer
which
contains the original photo, and
open the photo frame graphic.
Copy and paste the photo
frame onto your original photo,

Check your project carefully as you may have to
move your out of bounds layer a bit to cover the
original photo of the same thing. I had to move the
truck a bit to cover the other image in the original. It
might even be necessary to clone background colors
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over something that you can’t cover. If your lasso
tool was off at all, you might just use the eraser tool
(in one spot in mine, I erased a bit of background I
had selected by mistake to make the front end of the
truck look smoother).

You might need to crop your photo if you moved the
one level around very much. Save your work, merge
your levels down and export your project to your
preferred graphics format (center, top).
This one (center) was fun, too, but gives a little
different effect. I went to Monument Valley in 2012
and took the original photo. I just moved the rocks
and the ground outside the frame.
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Created with
Scribus

I have also seen this wallpaper (right), which is also
very
interesting.
I
downloaded
it
from
deviantart.com. I’m sure it was made in much the
same manner. Deviantart has several similar
designs.
Let your imagination go, and I’m sure you can make
something wonderful!
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by Meemaw
While we have enjoyed creating many
wonderful things with GIMP, you
should know that GIMP is not the only
graphics program to use. GIMP is
primarily for editing photos. Inkscape
is a great program for creating images
from scratch.
While that sounds daunting, it really
isn’t too hard. With a little practice,
you can make some really nice
images. I have done much more with
Inkscape than I ever could with a
pencil and paper. I’m far from being
an artist, but with the Inkscape
program to help, things come out
much better.
Let’s take a look at the basic window
and see what’s there.
When you open Inkscape for the first time, you get
the window as shown above. You already have a
new document in your work area, and rulers across
the top and down the left side. You can change your
preferences to show or hide any number of tools as
you want.
Across the top we see the Menu Bar with the items
File, Edit View, Layer, Object, Path, Text, Filters,
Extensions and Help. Many of the items can be
accessed elsewhere, and we’ll see that soon.
Under the menu bar is the Commands Bar, which
has many of the most used tools. The first eleven
default tools here are
New, Open, Save,
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Print, Import, Export, Undo, Redo, Copy, Cut &
Paste.
The rest of the tools are used together with the tools
at the left side of the window, or to help you navigate
your project, and need a little explanation.
The next three look like magnifying glasses with
boxes inside. These are zoom tools: from left to
right, they are ‘Zoom to fit Selection in Window’,
Zoom to fit Drawing in Window’ and ‘Zoom to fit
Page in Window’. They are an easy way to zoom in
and out conveniently between the whole page and
any selection you are working on. These are also
accessible from the menu bar under View > Zoom .

The next three look like two
overlapping sheets of paper with one
blank, one with a closed lock and one
with an open lock. These are
‘Duplicate the selected Object’,
‘Create a Clone of the Selected
Object that is Linked to the Original’
and ‘Cut the selected Clone’s Links to
their originals’. These are used to
duplicate or clone something you are
making, in case you need more than
one of the same thing (like stars or
flowers). If you duplicate your object,
you can make different changes to it
than are made on the original. If you
clone your object, the changes you
make to the original also are made on
the clone. This is handy if you need
two objects exactly alike except for
color, for example. If you have cloned
the original, you can make all the
changes, then use the third button to
cut the connection between the two,
then change the color on one of them. These items
are also available from the menu bar under Edit >
Duplicate or Edit > Clone.
The next two look like a circle and rectangle with
black dots around them. The one on the left is
‘Group Selected Objects’ and the one on the right is
‘Ungroup Selected Objects’. In some of your
creations, you will want to group certain objects
together to make your finished project. These
buttons are very handy to group them, and also to
ungroup them again if you find you need to undo
something. These are available from the menu bar
under Object > Group and Object > Ungroup .
The last seven tools
are probably the most
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used on this bar. From left to right, they are Fill &
Stroke, Text Configuration, Layers, Edit XML Tree,
Align & Distribute, Inkscape Settings and Edit
Document Properties. Each of these tools, when
clicked, brings up a separate window, so we’ll look at
them.

object (size, color, location on the page, etc.) The
more complex your object gets, the larger this file
becomes. Even though I’ve never done it, the
drawing can be altered by simply altering the file. I
tried it, though, by duplicating an entry in an XML file
which represented a circle I had drawn. I ended up
with 2 identical circles. If you understand it well
enough, you could probably edit a whole drawing
this way. It is also accessible from Edit > XML Editor.

Fill & Stroke

- This is the tool you use to
put color inside most objects and borders
on the outside. If I draw a rectangle, Stroke
is the border and Fill is the inside color. I can change
the inside color by clicking the Fill tab and choosing
color, gradient or pattern. I can change the border by
clicking the Stroke tab and choosing color, gradient
or pattern. In the example below, I have drawn a
rectangle, filled it with a blue color, and made the
stroke black, then clicked Stroke Style and changed
the stroke size to 5 pixels. You can do loads of
variations just using the Fill & Stroke dialog. You can
open it from the menu bar under Object > Fill and
Stroke.

Layers

- Just as in many other programs
(like LibreOffice Draw, Scribus and GIMP),
the Layers tool is very useful in creating
your project. You can create your artwork on one
layer, your background on one layer, and your text
on another. This keeps things organized and also
can help you keep from moving things that shouldn’t
be moved. If you are sure of your background, you
can put it in the bottom layer and lock the layer, and
you won’t ever move your background until you
unlock it again. This leaves you free to work with
your other objects . The Layers tool is also available
from the menu bar under Layer. The buttons are the
same as we saw in Gimp: clicking the eye hides the
layer, and clicking the lock closed locks the layer so
nothing on that layer can be changed.

Text Configuration

- Any time you put text
onto a project, you will use this tool,
because it is where you change the font
settings for the text you have. This works in
cooperation with the Text tool on the left side of the
window. You choose the text tool at left and then,
after you’ve typed the text you want, open this tool
(center, top) to configure the text you have written,
or even alter your text. The menu bar has a Text
section which contains this tool.
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Edit XML Tree

- Each Inkscape drawing
you make has a text description which is
saved in the drawing’s file format of .svg.
Each object you add has a descriptive name and is
listed in this text file. Clicking on the descriptive
name gives you a whole list of parameters for that

Align & Distribute

- If you have an object
that you want to center on the page, this is
the tool you grab. It’s also in the menu bar
under Object. Clicking on
your object, you can click any
of the align buttons and
center it. Choosing two
objects, you can center them,
line them up by their borders
or, in the case of the
distribute section, spread
them evenly across the page.

Inkscape
Preferences

- This
is a quick and
handy button to access your
preferences window. You can
also find it under the File
menu.
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Now let’s look at the left side of the
window. Your tools are here, and
everything you want to make can be
done with these tools. In addition,
the third toolbar will change
depending on what tool you are
using. The tools are as follows;

pointer inside the circle, while the arc was made by
pulling with it outside. Be prepared for the ellipse to
flicker a bit while you are working. The nodes tool is
very useful for all your objects.

Selection Tool

- This is the arrow
we all know so well. It selects an
object with a single click. You will
see arrows at the corners of the
object’s frame, pointing outward,
which you can use to resize your
object. If you click once more, your
arrows will change direction and you
can rotate your object. These arrows
are called ‘handles’, and allow you to
edit your object in a certain way.

Preferences Window

Document Properties

- Each document
you create is different. This tool allows you
the opportunity to edit the properties of that
document, setting orientation, margins, page size
and even whether you have gridlines or guides
enabled. It is also located in the File menu.
Just in case you
haven’t
noticed,
every time you hover
your mouse over a
tool, you get a tooltip
with the description
of the tool and also
the
keyboard
shortcut for that tool.
So if you hover over
Fill & Stroke, the
shortcut is <Shift> +
<CTRL> + F. Now
you have three ways
to get that tool. Use
whichever is easiest for you. Oh, by the way, the
Undo command, which is under Edit > Undo is
<CTRL> + Z here, just like in several other programs
we have used.
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Tweak Tool

- The Tweak tool allows you to change
your object - blur, move, enlarge, and several other
changes. Hovering your mouse over the tools will tell
you what each does. Truthfully, I haven’t used it
much yet, but the tool below is the blur tool.

Nodes Tool

- When you have an object selected
and click on the Nodes tool, your handles will
change to small squares and circles, and you will be
able to manipulate your object even more. One of
the first things you can do is move the circles at top
right and it will make rounded corners on your
rectangle. When you grab the small circle on an
ellipse, you will get either a pie-shaped object (with a
piece cut out!) or an arc (where your stroke doesn’t
go all the way around). The left-hand object was the
result of pulling the node handle with the mouse

Zoom Tool

- Hey, here’s another way to zoom into
and out of your drawing! Choosing this tool turns
your mouse cursor to a magnifying glass with a plus
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sign in it. Left-clicking in your object zooms in: rightclicking in your object zooms back out. You can also
use your scroll wheel - but hold the <CTRL> key
while you use it.

Rectangle Tool

- Any rectangle you draw will be
done with the rectangle tool. You can place your
mouse pointer on the page, click and drag to make
your rectangle. If you hold down the <CTRL> key,
your rectangle will snap to one of several preset
dimension ratios. In the toolbar above the page, you
will see boxes you can fill to set the dimensions and
location you desire.

3D Box Tool

- This is a tool that will allow you to
draw 3 dimensional solids. The box is drawn in
perspective, and to manipulate it, you must also
move the axes that appear. You will need to
experiment with this a bit.

Ellipse Tool - This tool draws ellipses and circles. If

Star Tool

- If your desired object has three or more
sides, use this tool. With the accompanying toolbar
at the top, you can choose whether it will be a
polygon or a star, and configure the number of
corners you want in your object. If it is a star, you
can set the spoke ratio as well (the smaller the
number, the more ‘pointy’ your star is and as the
number approaches 1, your star approaches the
appearance of a circle). Both examples below have
8 corners, and the star has a spoke ratio of .5. As
long as your tool is selected you can change the
appearance of your polygon or star, adding more
corners or changing the spoke ratio.

Pencil Tool

- The pencil allows you to draw
freehand lines on your page. While this is good
sometimes, the tool also shows any shake your
mouse might have, so if you want an absolutely
straight line, you need the pen tool.

Pen Tool

- The pen tool is for Bezier curves and
straight lines. A bezier curve is drawn with control
points which allow you to edit your curve. Below are
three lines: the top was drawn with the pencil, the
second was drawn with the pen and the curve is a
bezier being drawn. The tools shown above your
page will allow you to draw what you want. You can
actually draw a spiral using this tool and the node
tool, but the spiral tool is easier and faster.

Spiral Tool

- The Spiral Tool does just what it says:
it draws spirals. The toolbar has three settings:
Turns, Divergence, and Inner Radius. Turns
designates how many times your line curls around.
Divergence is how much farther apart the outer lines
are than the inner, and Inner Radius is the radius of
the open area inside the spiral. The spiral on the left
is 9 turns, divergence of 2 and inner radius of .5. The
spiral on the right is 5 turns, divergence of 4 and
inner radius of .25. Again, if your tool is still chosen
you can change the spiral you just drew to your
wishes.

Calligraphy Tool - This is another pen-type tool, but

here you can draw calligraphy-type lines with it. The
tool settings above your page will change the
appearance of your line. You have 6 pre-configured
tools, plus a ‘No Preset’. The tool can make some
interesting variations in lines drawn.

you hold down the <CTRL> key as you drag your
mouse, you will draw a perfect circle.
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Text Tool - This is the tool which allows you to enter

objects that you want the exact same color. Choose
the one you want to change, then choose the
dropper tool and click in the one with the correct
color, and your selected object will be filled with that
color.

your text. Choose it, then click on your page and you
will get a cursor. Type your text, then click the text
button at the top to change the font and size. Your
text is also displayed there and you can change it,
just in case of a typo or any other correction you
might wish to make.

Connector Tool

Spray Tool - Spray is an interesting tool. It has three

settings: ‘Spray copies of the selected object’, ‘Spray
clones of the selected object’, or ‘Spray objects in a
single path’. Remember, if you make a copy, each of
the objects can be edited independently, and if you
make a clone all edits on the original affect all the
clones until you unlink them. If you spray objects in a
single path, you get an extension of the object you
used, all enclosed within the same stroke. One
example of this is using an ellipse to make a cloud.
In the example, the ellipse on the left is the original,
and the cloud on the right was what I got when I
copied the ellipse, then sprayed in a single path.

Bucket Fill Tool

- I think all bucket fill tools are the
same! Choose a color, click in the area you want to
fill, and there it is.

Gradient Tool

- The Gradient tool works together
with Fill & Stroke to make gradients. Choosing a
gradient in Fill & Stroke results in a simple gradient
of the last color you chose: that color to transparent.
However, clicking on the gradient tool allows you to
see which direction your gradient is going, change it
if desired, and allows you to edit your gradient for a
different effect. You can add Stops, as they are
called, and change the color at every stop while in
Edit Gradient. You can then arrange your stops to
get your desired effect.

- With the Connector tool, you can
draw lines between objects. As you arrange the
objects, the lines stay between them instead of just
staying in one place. This is useful for flowcharts or
any other instance where you need a line between
two objects. The settings allow you to ignore or route
your connector around an object if you don’t want to
include it in your connected group. The lines below
were drawn to connect three of the ellipses, while
routing around the center one. Connectors are
strokes, so you can go into Fill & Stroke and edit the
design of your connector (wider line, dotted line,
etc.)

Eraser Tool

- This tool looks like most other eraser
tools: like a little pink eraser. Choose the object you
want to erase, then choose the erase tool. The
toolbar at the top will display a fill and stroke color
and you will see it while you are erasing, which is
kind of unnerving, but it will be fine. As soon as you
lift your finger off the mouse, whatever you erased
will be gone. If you don’t choose an object, then all
objects under your mouse pointer will be erased
(center, top).
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Dropper Tool

- The Dropper tool is an easy way to
choose a color for fill on an object. Say you have two

These tools are fun to play with! You might choose a
few and get a feel for how they work. This is also a
good time to look at the bottom of the window. It
looks pretty and all, with the color palette there, but
actually, the bottom of this window has a wealth of
information.
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This display actually tells you about your selection.
On the left side it says Fill and Stroke, and they both
have colors. You can use this to change the fill and
stroke in your object if you wish. Clicking on a color
will change the fill to that color, and Shift-click will
change the stroke. These are the colors of my circle
selected below. Just to the right of the Stroke color is
the number 5. I used the same settings to draw the
ellipse below that I did to draw the rectangle earlier,
and my stroke size was 5 pixels. (I have obviously
changed the Fill since then.) There is a right-click
menu there with a few standard sizes, so you can
set your stroke size there, or even remove it if you
wish. Next to that is a box that says 100. That is
Opacity, which can be set here and also in the Fill &
Stroke tool window. Next to that, there is the ‘eye’
you can click to make your layer invisible and the
lock you can click to lock your layer so it can’t be
changed. In the center, it says, “Ellipse in layer
Layer 1”. It looks like they have repeated the word
layer, but I think of it as “Ellipse in the layer Named
Layer 1”, so if you name your layer something else,
the line will make perfect sense. You will also see
some helpful text just to the right. Since we selected
the ellipse with our selection tool, it is telling us that
if we click again, we can toggle to tool to the rotation
handles. To the right of that we get an X and Y
location. This tells you where your mouse pointer is
at any given time. Last on the end, the percentage
shown tells you how much you have zoomed into
your drawing.

I know it seems like a ton of information, but we can
make sense out of it soon. Notice that Inkscape is
designed to provide several ways of doing any task,
so if you want to use a certain method (menu bars)
and your friend does things differently (keyboard
shortcuts), you can both enjoy Inkscape.
Next time we’ll start a project.
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by Meemaw
We have gotten familiar with the Inkscape window
and some of the tools. Let’s make something!
If you already have Inkscape open, you have a new
page. Click on the Document Properties button
(the last one on the right in the Command Bar). In
the window, change the page orientation to Portrait,
then change width to 900 px and height to 1200 px
to make it a custom size. If it is not checked, check
Show Page Border at the bottom of the window. I
have also checked Show Border Shadow, but you
don’t have to check that one. The border helps me
see the edges of my page. I think that’s default
anyway. Remember, after you get accustomed to
things you can set them up as you desire.

Notice that the rulers are across the top and up the
left side. Also notice that the left side ruler counts up
from the bottom of the page. Page location
measurements in Inkscape start from the bottom left.
Now we have plenty of room to work.
OK, let’s draw. Choose the ellipse, then click and
drag your mouse. Click on a color in the pallette
down at the bottom of the window, and your ellipse
should now be filled with that color. Holding <Shift>
and clicking a color will make the Stroke (Border)
that color, and probably 1 or 2 pixels wide. You can
right click
the number
and make
the Stroke 2
if it is
another size.
I chose a
blue for fill.

Now we are going to make this ellipse bigger. Click
on Path > Outset or <CTRL> + ) . Your ellipse will
enlarge by 2 pixels, which is the program default.
You can do the same command or Key combination
as many times as you want to enlarge the ellipse
until it is outside the blue ellipse. Mine looks like this:

Close that window and you should see this:
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We’re going to make a simple picture
in a frame. Click on Edit > Duplicate
or use the keys <CTRL> + D . You
won’t see it right away because it is
the same as the ellipse you have.
Click on the Fill & Stroke button in
the Command bar at top, and your
Fill & Stroke Window will appear.
Change the fill on this new ellipse to
none by clicking the button with the X
(at the top of the fill & stroke window
above the color wheel, or in the
palette at the bottom), and change
the stroke to 6 (top, right).

Now do the same thing again (duplicate and
enlarge), only this time make our stroke width 15
(next page, top).
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using the slider at the bottom, then click on

Blurs > Fancy Blur.

Filters >

Now click on the outer stroke. change it to a similar
brown color, the opacity to 100, and make sure the
stroke size is still 15. Go back to Filters and this
time choose Bevels > Dark Glass . Your image
should now look similar to the following:

project and choose Edit > Duplicate (or <CTRL> +
D ). Click on the duplicate and move it over by your
photo. Change the Fill to None, and the Stroke size
to 2. If one of the items is smaller, size each until
both objects are close to the same. My photo is
taller, which is OK, but I need it to be at least as
wide as the ellipse. Holding the <CTRL> as I size
will preserve the aspect ratio of the photo.

Before we go any farther, let’s make sure everything
is lined up correctly. Position your mouse out from
the drawing, then click and drag a rectangle around
it. This will select everything inside the box you draw.
Then click on the Align & Distribute button in the
command bar. Click on both Center Vertically and
Center Horizontally to make sure everything is
centered.

I have opened a copy of the photo I colorized earlier.
I want to put it inside the frame. Since it is saved as
a png, you will need to Import it (File > Import).
When you have chosen your photo to import, you
will be asked if you want to Embed or Link the photo.
Embedding adds the file to your project, and will
make your file bigger. Linking will link the file to your
project without increasing the size, but if you save
your project to another location, you will have to
save any linked files there too. I usually embed
anything I import so it is all there together.

Click on the Fill & Stroke tool at top. When the
window pops up, choose the inner stroke. Change
the color to a brown color and the opacity to 100
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Before we proceed, click on the ellipse and duplicate
it, then set it aside for later use. We’re going to use
the Clip tool. Click on the ellipse FIRST, then hold
down <Shift> and click on the photo. That selects
the photo without de-selecting the ellipse. Go to
Object > Clip > Set. When you do that, your two
items should be cropped to the inside of the ellipse.

This photo is rectangular and I want it to be oval, so
we’re going to make it oval. You can place your
photo off to the side of the main project so we can
edit it. Click on the ellipse in the center of your
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I’m going to place the ellipse I just set aside over the
photo for a border. You can select them both, like we
just did, then center them both ways.
You can Group these so you won’t have to align
them again. I selected my ellipse, made sure the
opacity was 100% and changed the blur to 1 before I
grouped. It just softened the border.

You can move the photo into your frame, but I like
the blue color and I’m going to resize my photo just
a bit so a little of the blue is visible around the photo.
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To preserve the aspect ratio of the photo, I will hold
down <CTRL> . Before we do anything else, click on
your photo or ellipse with the color in it and duplicate
it once more. Slide it to the side of your project. After
that, you should select everything by drawing a box
around it all, or by clicking on the selection buttons
at the left end of the second tool bar. The one that
looks like a stack of papers and says “Select all
objects in all visible and unlocked layers” is the one
you want. Hold down <Shift> and deselect the
ellipse we just created and stored to the side of our
drawing. Then use your Align & Distribute tool to
center everything else one more time. If you are
satisfied with your work so far, you can also group
everything so you don’t have to align it any more.
You should also be saving your work (bottom, left).
OK, let’s do one more thing with that extra ellipse.
Most picture frames have glass on the front to
protect the photo. Let’s give the impression of a
glass front. Make the fill on that ellipse a Linear
Gradient, and the Stroke size a 1, just so you can
see your edge. Using your Fill & Stroke window,
click on linear gradient in the fill tab, and make it
white. Your ellipse will immediately change so it’s
white on one side and transparent on the other side.
We’re going to change that. Click on Edit... in that
window, and you will see another window pop up.
Also, go to your left side toolbar and click on the
Gradient button (towards the bottom). You should
now see a line crossing your ellipse that has a small
square on one end and a small circle on the other.
These are called Stops . We are going to add a few
more. In the newest window, click on the Add Stop
button five times. Each time you click, you should
see another small square appear on the line. Five
clicks, five squares. They will not be evenly spaced
across the line, so you should click & drag them, one
at a time, until they are closer to evenly spaced. It
doesn’t have to be perfect, though, since light and
shadow makes things look uneven at times.

In your Edit box, there is a drop-down with the stops
numbered. One at a time, choose every other stop,
and slide the color slider below the color wheel
towards transparent. It will look similar to this:

If there is too much white when you finish you can
always go back to your Fill & Stroke window and
set the opacity down to 45% or so. Experiment with
your gradient until you get it the way you want it.
When you are satisfied with that you can group
everything together and save.
As one last thing, let’s choose Filters > Shadows &
Glows > Drop Shadow. We will get another
configuration window. It asks for Blur Radius,
Opacity, and Horizontal and Vertical Offset. I think
the default is 4 px, 30% opacity and 3 px for each
offset. I left the defaults. The buttons at bottom are
Apply and Close. When you click Apply, the drop
shadow will be added where you configured it. If you
don’t think the shadow is pronounced enough, click
Apply again. (I think I clicked twice.) The worst that
can happen is that you get too much and have to
undo it (<CTRL> + Z). Do it the way you like it. It is,
after all, YOUR creation (next page).
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Screenshot Showcase

After you save it, you can export a bitmap from the
file menu and save it as a png, jpg, or other image
file.
It’s really amazing what you can do with several
copies of the same ellipse and a photo. I’m sure with
a little experimentation, you can make any number
of wonderful items.

Posted by Taco.22, running Openbox, on October 15, 2014.
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Inkscape Tutorial: Fun With Shapes
by Meemaw

one at right is the result of grabbing the inner handle
and moving it across the star until it crosses the
other sides.

Messing around with some of the tools in Inkscape
can be fun! I started with a simple 12 point star
(below, left) and made so many other designs.

Where am I going with this?
Here are more examples of moving handles/nodes:
All of these started out with the Spoke Ratio 0.5,
Rounded 0.0, Randomized 0.0 (left end), then I
changed the settings for different effects. The
second from the left is Spoke Ratio 0.5, Rounded
0.0 Randomized 0.25.The third one is Spoke Ratio
0.5, Rounded 0.25, Randomized 0.0. You can put
negative readings on Rounded or Randomize and it
will result in other effects. The fourth one has
Rounded setting of -0.75.
Another thing you can do is grab one of the handles
you see when you select your shape and click on
the Nodes tool.
You can see in the
example that there is
a “handle” or “Node”
on one of the outer
points and another on
one of the inner
points. Grabbing the
outer handle and
moving it can change
the direction of your
spokes (center). The
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Using just a few of the shapes I showed here, I
made a wallpaper. On this one I started with a sixpoint star and then
moved the nodes until I
had this:

Believe it or not, both of these were made with the
same 12 point star, just by moving the inner node
(top right):

Duplicating and rotating
can give you the
starburst (next page,
top).
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While I was duplicating,
I also changed the
colors to pink, blue &
grey. I also used the
rotate
handles
to
change the starburst so
it wasn’t exactly round,
but more elliptical. (The
side arrows will skew
the object, while the
corner arrows will rotate the object around the plus
sign, which is in the center, but can be moved.)
Then, I put a dark blue
background
behind
everything so I could
see the lighter colors.
Actually, I put the dark
blue background on it’s
own layer, so I wouldn’t
move the background
while
selecting
something else.
After that, I duplicated the starburst at least twice
and made them all huge, then moved them so the
center of the starburst was in the bottom left corner.
On those duplicates I set the blur up (like 4 or 5) and
the opacity down (like 50%) so they are not as
visible. I added a circle in the center of the top
starburst to make it more the same color instead of
having a dark center. To do that, I changed the blur
and opacity of the circle until it was similar to the
starburst, then grouped them.
On that starburst, I made sure the blur was less (like
1) and used Filter > Bevels > Stained Glass to
make it shiny. Then I added one more of the basic
stars on top, then put another dark blue rectangle at
opacity 60% on top so everything looks a little
darker. You should save each time you are happy
with your work, and if you are closing your drawing.
When you get it just right, save it again, then use the
File > Export Bitmap. Since part of your drawing is
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outside the page border, you want to export the
page instead of the drawing (choose the appropriate
button from the top of the export window).
You can experiment all you want. Some projects are
just for fun and even though you use very few items
or even commands, you can still come up with
something you like. If you design something you
think you will use a lot, duplicate it and set it to the
side of your page. Also, you can do something
interesting with any shape. One of the first Inkscape
projects I did was to transcribe Sproggy’s Glass
Panel Tutorial from the video he made. In it, he used
mostly rectangles to get his effect.
Have fun!

Linux Training
Courses & Classes

A magazine just isn't a magazine
without articles to fill the pages.
If you have article ideas, or if you
would like to contribute articles to the
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send an email to:
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Inkscape Tutorial: A Torn Paper Effect
by Meemaw

photo (hold the Shift key to choose the photo), click
on Object > Clip > Set. Any corners outside the line
should now be gone.

If you are like me, you want all your projects to look
crisp and perfect, even around the edges. However,
sometimes you may want a “weathered” effect on
something you are creating. I scrapbook a bit - gotta
chronicle the growth of my grandchildren, and make
sure past memories are recorded for the future.
Sometimes your design calls for a more antique
effect. This tutorial is to give the effect of torn paper
on the edge of a printed photo.
Scan and save your photo. Open Inkscape and
import your photo. As it has been repeated many
times,
so you don’t lose your
original, but once it is imported into Inkscape, you
are working on a copy, so your original will remain
unchanged.

always work on a copy

Before you do anything, create a rectangle the same
size as your photo. Remember, when your photo is
chosen, the dimensions are in the bar above your
project. Just create a rectangle and change the
dimensions to the same height and width as your
photo. Make the Fill Black and Stroke none. Put it to
the side to use later.
Using the pencil tool, draw a box around your photo,
cutting across the corners or sides where you want
the edges to look torn. Draw a second one, and
overlap the line on the first box, so they are kind of
wavy back & forth. On my photo, the top right and
bottom left corners are going to be frayed the most.
Notice my lines cross in a few places (center, top).
The next step will be done to both lines. We want to
make our curves more jagged, so it will look like a
rougher tear. Choose both lines, then click
Extensions > Modify Path > Add Nodes. You will
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be asked whether you want to add by segment
length or segment number. Choose segment length
and change that to 5 px. Click Apply, then Close .
Then, with the same line chosen, click on
Extensions > Modify Path > Jitter Nodes. You will
be asked about displacement. I put 2 px in each
space and left the rest alone. Click Apply, then
Close. In the example below I have only done one
of them so you can see the difference.
We are going to use one of
these lines to “cut off” part of
our photo. Choose one of the
lines and duplicate it, setting
the duplicate aside. (We’ll do
enough duplicates here that
you can probably use the
keystroke <CTRL> + D faster
than you can click on Edit > Duplicate .) Choose the
same line that you just duplicated, and then the

Using the same line you just used, change the fill to
black and the stroke to none. Set the blur on it to
0.5, and send it down behind the original. Duplicate
it, and on the duplicate, change the fill to something
similar to your photo’s border, and change the stroke
to none. Align those two with the lighter one on top,
and slide them under your photo with the lines
matched up. That is going to give a little shadow to
the torn border of the
photo. These three objects
can be grouped so you
don’t have to line them up
over and over.
Just as a reminder, the
Selection toolbar, just
above your project, is
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activated when your Selection tool, or cursor is
chosen. It has the Levels buttons, so you can stack
things in a certain order. From left to right, you can
Lower to Bottom, Lower One Level, Raise One
Level, or Raise to Top. We’ll use these many times
while we’re working on this project.

Many photos have two layers of paper, and when
they tear, the layers tear in different spots. Using the
second line you created will give this effect.
Duplicate your photo, and the line, and slide the line
off to the side. Using this line and photo duplicate,
click Object > Clip > Set again to cut off the corners
in different spots. Slide it back over the photo you
did earlier. Then, click on the line duplicate you just
made, set the fill to something just a bit lighter than
the photo border, and the stroke to none. Duplicate it
again, and on the duplicate, set the fill to black,
stroke to none, and set the blur to 0.5. Line these
two up with the black underneath and group them,
then send them to the bottom. Then slide them
behind the photo where you want them. You can
group these as well.

Now you need to position these photos directly over
each other. I should be fairly easy with some of the
corners cut off, but you probably need to zoom in on
your edges and use your arrow keys to move a pixel
at a time.

Position the black rectangle you created earlier over
the photo and make sure everything is lined up.
Using your cursor only, click and drag around the
edges of your project to select everything, then click
on Object > Clip > Set again. Your photo should
now have straight sides again except for the torn
parts and the torn parts should look like they have a
little shadow around the edges..
Some of this may
have been a bit
difficult, and I
hope your photo
came out the way
you wanted it. As
with
anything,
practice helps.
This torn paper
effect can be
used other places
too. Your only
limit
is
your
imagination!
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Inkscape: ms_meme & the Holiday Tree
by Meemaw

you click on the red lines between the nodes, you
can curve the lines a bit. You should move and curve
until you get the nodes arranged the way you want
your tree to look. I have clicked on the upper line just
inside each node, and dragged out to make the
curves.

A couple of years ago, ms_meme and I entered a
holiday wallpaper contest on the Linux Graphics
Users Forum. We both used Inkscape to design our
wallpapers, and ms_meme won first prize!

your stroke color is) when it’s finished. Then click on
the Nodes tool (at the left side under the cursor
arrow). Now your selected tree should be red again,
with a node at each corner.
Click on your cursor tool every so often and see
what your curve looks like, then go back and move
your line and nodes until you have what you want.
This would also be a good time to save your work in
svg format. You can name it “Tree” or whatever.

When I asked her how she did that beautiful
wallpaper, she said that she had gotten the idea
from a Christmas card she’d seen, and opened up
Inkscape to see what she could do.
The first thing you should do is the tree. Opening
Inkscape, choose your “paper” size (for a wallpaper,
I choose 1600 x 1200). Selecting the Bezier tool,
make a zig-zag set of lines, clicking every time you
want your line to change direction (center, top).
When you get something you like, right-click to end
the drawing process. Your line should be green
when you have clicked to change direction, and red
until you click the next time, and black (or whatever
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We’re going to mess with these a bit. If you click on
the node (the little square on the end), you can
lengthen and shorten the lines and move them up
and down, space them out, whatever you want. If
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When you are satisfied and your file is saved, select
the tree you just created, and duplicate it (Edit >
Duplicate or <CTRL> + D ). When you duplicate an
object, the new one is created in the exact same
spot as the one you have. If you notice anything, you
might notice that the colors of your object are
deeper. The duplicate is selected, so grab it with
your mouse and move it around a bit until you like
how it looks. You can enlarge it a bit by grabbing the
arrow on one of the corners or sides and pulling out.
You can reverse it. You can even go back to the
nodes tool and move it a little more.

When you are satisfied, use your cursor to select
both objects. From outside them, click and drag a
large rectangular area. The rectangle should
disappear, and both of your curves should be
selected. Click on Object > Group or click the
Grouping tool in the toolbar above. You can also
press <CTRL> + G . If you are satisfied, save your
work.

changed, but you will still have the svg file in case
you want to try something different.
You can move your tree to the side of your page
while we do the decorations. Let’s do the colored
balls first. Click on your Circle tool, hold down the
<CTRL> button, and click & drag a circle.
Remember, we held down the <CTRL> key to make
our circle perfectly round. If you like ovals, then
make them oval. Choose your fill color and, if you
want to, choose a hairline gray stroke. They will be
small enough that the stroke won’t be visible.
Duplicate the circle. On the duplicate, change your
fill to white, and send it to the bottom. On your
colored circle, change your fill to a round gradient.

We need to edit this a bit. In your Fill & Stroke
window, click on Edit. You will get a new window
where you can change your gradient around. Click
on one of the gradients in the drop-down, and slide
the indicators in the lower slider to the other end.
Choose the other gradient and slide those to the
other end as well, then close the window. In the left
side tool bar, click on the gradient tool. You will see
the gradient lines on your circle. Click on the one in
the center and drag it up and to the left to change
the highlight on your circle.

Select both circles and center them both ways. Next,
draw a small rectangle at the top of the circles. It
should have a grey fill and a dark grey or black
stroke. This is the addition at the top where the
hanger is attached. It needs to be behind the circles,
and centered at the top. When you get them placed
and are happy with your work, group them to make
one decoration. You can duplicate it as well. In fact
you should make a couple of duplicates and
ungroup them long enough to change the fill color,
unless you want them all the same color. Don’t
forget to regroup them.

We can also make stars to help our tree shine. I
have put a dark blue background on my page so I
can see the stars. A blue rectangle the same size as
your page will work. Make a couple of stars, one of
them a six-point star and one of them an 8-point
star, both with a spoke ratio of .1, filled with white
and no stroke. Click on Filters > Shadows and
Glows > Glow to make your star more “shimmery”.
I applied that filter twice on many of the stars.

The good thing about saving in the svg format is that
it is all saved as data, so you can still go back and
change things (even a font if you have text) after you
have saved a drawing. Anything can be changed in
the svg file. When you are finished, you should
export your work in a different file type. I usually
export to a png file, but there are many file
extensions you can use. The exported file can’t be

PCLinuxOS Magazine

Page 62

Inkscape: ms_meme & the Holiday Tree
You can manipulate your stars with the handles,
rotating and stretching them out so they aren’t all
exactly alike. You can also go back and create stars
with more points if you wish. Make lots of duplicates,
and arrange them on your tree as you desire. You
can even make a larger star to go on top.

the handles as below to make your highlight a little
less circular. You can make it as big or small as you
want.

As you can see, my tree is designed basically the
same as ms_meme’s but turned out differently (her
decorations are all smaller, for one thing).
Remember though, that it is your creation, not
someone else’s, so it is up to you to decide how it
looks. I’m sure your design will be wonderful!

Looking for an old article?
Can't find what you want? Try the

PCLinuxOS Magazine's
searchable index!

Save your work, then export your picture. The good
thing about Inkscape is that you can always go back
and change it if you decide you want it a little
different.

As a bit of accent, select your blue background, and
change the color to a radial gradient. The default is
blue in the center extending to transparent on the
outside, but it might look better if you edited your
gradient so the blue is outside and the transparent is
in the center. It doesn’t even have to be totally
transparent. Click on your gradient tool and change
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It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...
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Inkscape: Tree Silhouette in Sunset, Part 2
by Meemaw
In the first part of this article on page 31, we made
our tree into a silhouette. We started this project in
GIMP, but now we are going to use Inkscape to
finish it.

You want to make sure that “Grays” is checked,
along with the “Remove Background” checkbox. You
can set the number of scans, which will show up as
layers in different shades of gray, from 5 to 15. I
used 12. Click OK. Inkscape is going to trace over
the original drawing we loaded. Depending on your
computer hardware, this might take a bit. Just as
duplicating an object puts the duplicate on top of the
original, Trace bitmap does the same. Click away
from your object, and then select it again. Look at
the status bar at the bottom. If it says “Group of xx
objects” (xx is however many scans you selected),
move that to the side. You’ll see your tree still there
where it was. Click on that one and delete it. Choose
your group you moved a minute ago, and click
Object > Ungroup or just click on the Ungroup
button in the upper toolbar. Now move your scans
apart so you can see them all.

Let’s add the ground under the tree. Using the
Bezier Curve and Straight Lines (Pen) tool, draw
the ground however you want it to look. Make sure
you click many times and make it the general shape
of that you want. With this tool, you should draw a
closed curve, even if you have to follow the edges of
the page, because you are going to want to fill it with
black to match your tree. Don’t worry if it doesn’t
look the way you want it right away - we can remedy
that as well. I made my stroke red, so you can see it.

Load your tree into Inkscape. You will always get a
window asking if you want to Link or embed the
image. With this project it doesn’t matter. We are
going to do a bitmap trace of the tree. We can use
the original image file if we wish, but I also want to
experiment. A bitmap trace will enable us to
manipulate our drawing easier and do more things
with it while keeping the file size smaller. Click on
Path > Trace Bitmap. The window that opens will
have several items from which to choose.
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Place your tree on your drawing where you think it
should be located. If you are happy with your work,
save your project as a .svg file.

Using your cursor and drawing a box around them to
select them all, change the fill on all of them to
black. You might see some that ended up with more
detail. Pick the one that looks the best to you. I saw
a couple that seemed to have more detail, so I
chose one of them. You can move the rest off to the
side or delete them. If you just move them off to the
side, you can try this tutorial later with another tree.
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Now we will smooth out our curve. You can click
Path > Simplify, or use the keystroke for Simplify
<CTRL> + L, which is much easier. Use this
keystroke until your land curve looks relatively
smooth.

of everything else. Edit your rectangle’s dimensions
so that it is the same size as your page, the using
the Levels icons above your workspace, send that

rectangle to the bottom of your drawing. You might
want to fill it with something besides black so you
can see what you’re doing. We’re going to change it
soon anyway.

diamonds on it. this will allow us to edit this gradient
until it looks the way we want. The first thing you
want to do is reverse the gradient that’s there and
add some color. Click on the square in the center
and change it to a yellow or gold that reminds you of
a sunset. The click on one of the circles at the edge
and choose a dark blue or gray. Also, since sunset is
usually down on the horizon, you want to move your
gradient down lower and lengthen the gradient
handles to widen the gradient. You can see what I
have now:

Then click on the Node Editing Tool and finish
editing the land. You can pull the nodes or the
curves in between until you have it as you want. You
can go back and forth between the node tool and the
selection tool to see what needs work. Make sure
you also square off the corners at the sides and
bottom. Add a fill (and I changed my stroke to black
as well). When you are satisfied, save your work.

If you don’t have the Fill and Stroke window open
yet, you need it open to set the colors and edit the
sunset gradient. Remember the icon in the top row
of tools that looks like part of a square with a
paintbrush across it. Clicking on it will open
the window. If your screen is large enough,
you can move your project to the left and put the Fill
and Stroke window on the right and see everything
you need.
Now we have our tree and ground silhouettes mostly
finished. Let’s work on our sunset. The first thing you
want to do is create a rectangle the same size as
your page. Using the Rectangle / Square Tool ,
draw a rectangle. It will be filled with whatever color
you used for fill last, and will cover your tree and
ground, because all new objects are created on top
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With the Fill tab selected, click on the Radial
Gradient button. (It’s the square at the top that has
the round highlight in the center.) When you click on
it, your fill will change to a round area in the center
of your drawing. In the left side toolbar, pick the
Gradient tool near the bottom. Now you will see an
L-shaped line in your drawing with circles and

While you might think this looks pretty good as it is,
we need to add a little more color. Most sunsets
have several colors. Double-click on one of the blue
gradient lines, and a small diamond should appear
in each of the lines. Every time you double-click,
another diamond will appear. Each added diamond
allows us to add another gradient color. Be careful,
though, to double-click over the line in the sky,
because double-clicking over your tree or land will
create a gradient on one of them. You can create as
many as you wish, but I have done only three for
now. You can also click on a diamond and move it
up or down the gradient line to space them closer
together or farther apart.
If your center gradient is a brighter yellow or orange,
you want to add a darker colors as you get farther
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away from the sunset. Click on the diamond that is
closest to the sunset and add a darker yellow or
orange.

While I have been adding gradients, I have also
moved my gradient around and extended the bottom
gradient out so the sunset looks more elliptical than
circular. You can also put a gradient right up close to
the square in the center and put in a brighter yellow,
in case you want your sun to still be up a bit. When
you are satisfied, save your work.
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Remember, you can make it as bright or dark as you
like - it’s your project. So far, mine looks like this:

However, I decided that if the sun hadn’t completely
set yet, the sky would be a lot brighter. So I removed
one of the diamonds and spread the colors out a bit.
By the way, the way to remove one of the diamonds
is to click on the gradient icon in the Fill & Stroke
window, click on Edit Gradient, find the one you
want to remove in the drop-down list, and choose
Delete Stop. Now my project looks like this:

We could stop here, but we could also do a couple
more things to make our picture look more realistic.
The first thing is to put a little gradient on the ground
to make a little highlight. Select your ground and
choose Linear Gradient from the icons. The
program will default and show a side-to-side
gradient. We are going to edit that. Click on the
gradient tool at left, then move your gradient handles
so the lighter color is at the top of your ground and
the darker color is at the bottom of your picture.
Move the handles until you get what you want. Mine
looks like this:

If the sun is going down the tree will cast a shadow,
so the last thing I’m going to do is add a shadow.
Start by selecting your tree and making a duplicate
of it (<CTRL> + D or Edit > Duplicate ). Remember,
the program puts the duplicate directly on top of the
original. Grab it and move it off to the side. To make
the shadow, you need to do a vertical flip on the
photo, then stretch it and/or rotate it so it looks the
way you think a shadow might look at that time of
day. With the sun so low in the sky, your shadow will
be rather long, and in the opposite direction from the
sunset.
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When you get it stretched as you like, place it at the
bottom of your original tree, making sure they line
up. You may have to zoom in on the tree truck and
work on the stretch and rotate a bit.

Before I do anything else, I’m going to blur the
shadow a bit, choosing a blur of 2 or 3 from the
Stroke & Fill window.

As you see, the shadow extends far out of the
picture. I want to get rid of all the excess tree.
Choosing the Square & Rectangle tool we drew the
background box with, draw a rectangle over the part
of the tree you want to keep. Changing to the
Selection arrow, select the tree, then holding the
shift key down, select the rectangle you just drew.
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Now, click on Object > Clip > Set and you should
have only that part of the shadow that’s in your
drawing, and the rest should be invisible. Now my
drawing looks like this:

Summary
Wow! We’ve learned quite a few things this time! We
have a great tree with the sunset behind it, and
we’ve learned a little bit about bitmap trace and
vector drawings. If you made your drawing with the
sun farther down, and darker sky at the top, you can
also go back in and create a few stars, like we did a
couple of months ago for a holiday tree, and scatter
them in the darkest part of your sky. When you are
satisfied with your work and have saved it, you
should also export the drawing to png or jpg.
One great thing about a vector file (svg) is that you
can go in and change almost anything in the drawing
even after you have saved it. That way you can have
different versions of the same design, as long as you
don’t delete your svg file. Want your gradient
brighter or your sunset in a different spot? Change it.
Want the land different or the tree smaller? You can
change it. Even after you’ve exported a bitmap of
your finished drawing, you can go back and change
the svg file again to try something different.
Remember, it’s your project, and it’s finished when
you decide it’s finished.

Support PCLinuxOS! Get Your Official

PCLinuxOS

Merchandise Today!

Page 67

Inkscape Tutorial: Make a Chalkboard
by Meemaw
In an earlier article, we made an oval picture frame
with ellipses and applied a filter to make it look a
little more like a wood frame. This time we’re going
to make a rectangular wood frame with a chalkboard
inside. I used a wood and a chalkboard graphic, and
a font called Eraser, but there are also several fonts
that look like chalk that you could use.

Opening Inkscape, you will already have a blank
sheet. It doesn’t need to be very big, so go to File >

Document
Properties

and
change the size to
640
x
480
(landscape).
While
you are there, make
sure that on the Snap
tab, Snap to Object
and Snap to Grid are
checked.
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Also, go into your Inkscape Preferences. In the list at
the side, towards the bottom of the list, choose
Steps, and make sure the setting for “Rotation
snaps every ___ degrees” says 15.
OK, so let’s get started on the frame. Draw two
rectangles on your page, one of them 640 x 40 and
the other 40 x 480. The long one will go at the top of
the page and the long one down the left side. Make
sure the Stroke is set to none on both of these.
Making them each a different Fill color will help you
to see what you are doing. We’re going to end up
with wood-grain anyway.

Now choose the top rectangle and do the same,
making a mitered corner there.
Choose your left side rectangle and duplicate it.
Move the duplicate to the right side and flip it. Your
corner is already done there but not on that end of
the top rectangle, so do that one. Then duplicate the
top rectangle and flip and move it to the bottom. Do
any corners that aren’t done yet. When we are
finished both ends of all rectangles should have the
mitered corners. Try to make sure they match up: if
you have a white space in between the objects,
there will be a white space between the corner
pieces of your frame.

You want to select each of these rectangles and
click Path > Object to Path . We’re going to move a
node on each.
Starting in the top left corner, choose the left side
rectangle with your Nodes tool. Grab the node on
the top right corner and pull it down until it is even
with the bottom of the top rectangle. Shown below,
I have pulled it
partway down
on the left and
finished on the
right.

We’re going to add the wood texture now. Choose
your top and bottom rectangles (above, the blue
ones) and group them. Do the same with the left and
right ones (green above). Import the wood texture
graphic into your drawing, and make a duplicate of
it. Rotate the duplicate 90 degrees. Now it should
look like this (next page, top left):
Position the horizontal wood texture behind your
frame and deselect it by clicking somewhere else in
the window. Select the top and bottom grouped
rectangles, hold down the <Shift> key and select
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will get a nice shadow on two sides of your frame
that will give the illusion of depth.

the wood texture. Now click on Object > Clip > Set.
Your wood texture should now be visible in your top
and bottom. Do the same thing for the left and right
group. Remember to select the frame before the
texture.

Using the other two sides of your frame, but on the
outside of the frame, do the same thing again.

Now we have a nice wooden frame for our
chalkboard.

OK, before we put anything in our frame, let’s give it
a little depth. Using your Bezier tool, draw a line
inside the frame from the top left corner to the top
right corner, then from there to the bottom right
corner, right along the edge of the frame. Make the
stroke 3 px wide and try to make sure it is centered,
covering both the frame and the white inside. You
can always set your transparency down to about
50% so you can see, then set it back up to 100%
(center, top).
Also, make sure that the ends of your lines stop a
little short of the frame edge. Make sure your opacity
is set back to 100%, then change your blur to 1. You
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Let’s add the chalkboard. Draw a rectangle the same
size as your drawing (640 x 480). Make the fill any
color you want with no stroke. Slip it behind the
frame. Now, import the chalkboard graphic. It’s large
so you will have to resize it. Make sure it’s still big
enough that whatever you put into the frame looks
the way you want it to look. There is a seam in the
graphic you might want to leave out of your project
(top, right).
Just as before, click on the rectangle, then on the
chalkboard, then click Object > Clip > Set (right).

We’re almost finished but let’s do one more thing for
depth. Using your Bezier tool again, draw another
line on the inside of the frame on the other two sides
(left & bottom). Make that line white, stroke size 1.
Zoom in to get it just on the edge of your frame, but
not all the way to either corner. In your Fill & Stroke
window, change the color to a radial gradient. Click
on the Gradient tool and drag the corner handle to a
spot outside and to the bottom left corner of the
frame. In your toolbar, you will see the gradient.
Click the edit button on the right and add a stop
(next page, top left).
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Reach Us On The Web
PCLinuxOS Magazine Mailing List:

http://groups.google.com/group/pclinuxos-magazine

You then want to edit your gradient so it shows a
little white on the two edges but not all along both
sides of the frame. My gradient looks like this in the
toolbar:

PCLinuxOS Magazine Web Site:
http://pclosmag.com/

Here’s another version with the font Chalkboard:

Does your computer run slow?

But yours could look however you want.

Are you tired of all the "Blue Screens
of Death" computer crashes?
Are viruses,
adware, malware &
spyware slowing
you down?

The last thing is to write on our chalkboard. A tutorial
I read says you can design your own filter to make
text look like chalk, but I opted to use the Eraser
font.
Click on the text tool at left and then click where you
want to write. Type whatever you want, then
highlight the word(s) you typed. Click on the text
toolbox in the top toolbar, and a window will pop up.
This is the Text Formatting window. Change your
font, size, alignment and spacing here. When you
get it the way you want it, you can Apply and Close
that window.
Now, if you select the text with your cursor, you can
rotate the text if you like, or leave it straight. You can
also make it a bit bigger, too. Save your work when
you are satisfied, and export your project (center,
top).

This one was fun! With different graphics, you can
make a white board and use a blue marker, or make
just the frame for your favorite photo. The
possibilities are endless!

Get your PC back
to good health
TODAY!
Get
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Inkscape Tutorial: Decorative Patterns
by Meemaw
Sometimes when you are creating a project in
Inkscape, you have a need for some little repeating
pattern to use. You can create those yourself.
Next month we will start a project that will use some
of these patterns. Let’s make them now. In this
project we will be moving nodes to make the shapes
we want from the ones we can draw. Starting a new
drawing in Inkscape, use the toolbox at left to draw
some basic shapes: square, triangle and circle. Also,
draw an 8-pointed star and a pentagon. We’ll edit
these and develop some more designs.

We can make many other shapes and designs with
just these five basics.Let’s start with the circle. Just
by duplicating, resizing and filling with different
colors we can make several different “beads”.
Choose the circle and make the stroke about 10 and
change it to another color. Then fill it with a different
color. They can be similar colors or contrasting
colors, and whatever colors you want.
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The triangle can be manipulated the same way,
increasing the stroke and filling with something
different. Remember, the beauty of saving this as an
Inkscape svg file is that you can go back next year
and change all of these… changing color, size,
combination and how they are grouped.
One of my combinations has been to
duplicate the triangle, change the stroke
to none and the fill to red, and place a
white circle inside.
You can reshape these as well, by manipulating the
nodes. We used the nodes to reshape our object on
the holiday tree a while back. One thing I did using
an 8-pointed star was to pull out some of the nodes
and create a cross. The first thing you do after
selecting your star is to click Path > Object to Path ,
then select the Nodes tool. Pull 3 nodes out of the
center to about the same distance, then pull the
fourth node out even with the two next to it. Those
three nodes we will select together and lengthen for
the bottom of the cross. Select one node, then,
holding down the shift key, select each of the others.
(You can also use your mouse to draw a rectangle
around only those three nodes and they will be
selected as well.) Placing your mouse pointer (with
the nodes tool activated, it will be a long arrowhead)
on the center node, pull down. All three nodes
should move down together.

Leave it as it is, fill it with color or black, or whatever
you want. If you haven’t saved any of this yet, you
probably
should.
I
just
named
mine
BasicShapes.svg.
One of the good things about nodes is that they can
be manipulated in many ways. Besides grabbing the
handle and pulling it somewhere else, the lines
themselves can be stretched or rounded. Let’s use
the pentagon to make something like a leaf.
Duplicate your pentagon and
move it over to an open spot.
Click on Path > Object to Path ,
then click on the Nodes tool,
and select the top three nodes
but using your mouse to “draw”
a rectangle around them.
In the Nodes toolbar just above your page, two of
the tools look like this:
When you hover your mouse, one tooltip should say
“Make selected nodes smooth” and the other should
say “Make selected nodes Auto-Smooth”. Clicking
on the auto-smooth tool will change your pentagon
so the top three lines are now curved.
I don’t know about you,
but
my
hand
is
occasionally shaky, so
this is a really handy
tool to have when you
are trying to smooth out
a curve you have made.
Select
the
nodes
around it and click the
Auto-Smooth tool.
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Clicking outside your object will deselect all the
nodes, and we can then pull it a little differently.
Some leaves are longer and have more of a point
where they connect to the stem, so select the
bottom two nodes, and click the Add Node tool.

grab closer to one of the ends, it will look a bit
different. Play with them until you get what you want.
Remember that as long as the file is an svg, you can
always change it, and if you move something and
don’t like it, you can always undo it with <CTRL> +
Z.
Yes, I realize I could have started with a hexagon
instead of a pentagon and wouldn’t have had to add
a node, but the more tools we know about, the
better, right?

Grab the center node and pull down until your leaf
looks right to you.

Clicking back on the selection tool, you can resize
and change the width or length. You can also stay
with the Nodes tool and pull nodes (or the line
segments in between) until it looks the way you want
it to look. If you want it to look
more like an actual leaf, lines can
be drawn inside to represent the
veins. Those can be curved as
well.

Another combination is something that may look
familiar, appearing on the cover of the February
2014 PCLinuxOS Magazine. Using three circles, I
combined them with a triangle that I altered with the
settings Spoke Ratio 0.300 and Rounded -0.360. I
then made the stroke red and size 3 and arranged
them this way:

The white lines in the third figure resulted from
duplicating the combination figure, changing the
stroke to 1 and changing the color to white. All
objects were then grouped.
Play with these shapes yourself. I’m sure you can
come up with other useful patterns. Next month we’ll
put them to work.

It's easier than E=mc 2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...

Experiment with your lines: curves
will be different depending on
where you grab the line. If you
grab it in the center, the curve will
be fairly symmetrical from the
center to the outside, but if you
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by Meemaw

Inkscape Tutorial:
Create a Paisley Pattern, Part One

I grew up in the 1960’s, and sometimes we wore
some pretty wild stuff. One of my high school
friends, very talented artistically, painted her yellow
car with hundreds of paisley patterns on our last
school day before graduation. Go to Google, search
for paisley, and you can find tons of patterns!

This sort of pattern seems to be making a
comeback. I’ve found it on everything from clothing
to tablecloths and from tablet and phone covers to
tattoos. As you can see, this is basically a curved
teardrop pattern with a lot of extra patterns inside it
to make it fancier. How can we make one of these?
We can use Inkscape.
Last month we made several
small patterns to use in a
project, and we will use some
of them now to make our
paisley. We will start drawing
the teardrop using the Bezier
tool. Then we will “pretty it up”
with the small patterns we
made last month. Let’s make
one similar to this one:
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(Wow! I don’t want to have to
place all those little circles by
hand!) Don’t worry, we’ll use a
different method. Let’s draw
our teardrop first. Open a
page in Inkscape and choose
your Bezier tool. Using that
tool, make a kind of teardrop
shape, clicking with your
mouse at least 10 or 12 times.
That will give us nodes to use
to manipulate our shape. Set
the stroke black or gray, and
the fill white.
When we were making our
basic shapes, we used the
Auto-Smooth tool to round off
our leaf. This time we want to
smooth out this teardrop, so
select all of your nodes by
drawing a frame around them
with the Node tool, BUT,
before you hit Auto-Smooth,
press Shift and de-select the
node on the very end. We
want it to have a point on it.
Now click Auto-Smooth. Each
of your line sections will
become rounded and the
curve will be much smoother.
You may still feel like
adjusting a few of the nodes
separately. Go ahead! It’s
your project. I adjusted some
of them in the example below.
Now, instead of trying to draw
another one of these, we are

going to duplicate this
one and adjust the size.
Click on your object and
duplicate it. Remember
that the duplicate is
placed directly on top of
the original, and it is
now selected. Click on
Path > Outset to
increase the size of your
object, or press <CTRL>
+ ) . Each time you press
it, your new curve will
grow
a
bit.
My
preferences are set to 2
px, and we want it 20 px
bigger all the way around, so we should do this ten
times. You can use the menu, but the keyboard
shortcut is much quicker!
Now, choose the original
object and duplicate it
again. This time use the
Path > Inset menu item
or <CTRL> + (. This one
will shrink inside of the
original so you will have
three separate curves.
Now we want to place
some decorations on
our object. Remember
those
decorative
patterns we made last
month? Import them into
your new project. It’s
easier to import the svg file so changes can be
made to them if necessary. After you import it, you
should click on Ungroup so you can move each of
them around freely.
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The following options are available, and I will explain
each:
Single; Repeated; Single, stretched or Repeated,
stretched - This choice determines how the objects
are arranged around your path. Single means that
only a single copy is used, while repeated means
that (obviously) the pattern is repeated all around
the path. Stretched means that the pattern is
stretched around whatever curve you use.
Snake or Ribbon - Snake means that the copies are
arranged in a flat manner, while ribbon means that
they have a bit of perspective to them. Depending
on your project, you may need the ribbon setting
instead, but we’re using Snake here.

Now we are going to decorate our curves. Notice
that I have duplicated and resized one of the circular
shapes and it is on my page above my paisley
curve. Click on the circular shape and, holding the
<Shift> key, click on the outer curve. Now click on

Extensions > Generate from Path > Pattern along
Path . The following window will appear:

Each pattern is different, so you would have to play
with the settings to get what you want. If making the
setting positive doesn’t seem to work, try a negative
setting.
Pattern is vertical - I haven’t used this except to
experiment, but I found that it orients all of the
objects at a 90 degree angle. I had my diamond
shape oriented “longways”, but when I checked the
box, the extension oriented the diamonds with the
short edges touching. In the example below, the
outer line results if Vertical isn’t checked, and the
inside line results if it is checked.

Space between copies - You can set your group of
objects to be spaced out, or touching at the edges.
This will require a number setting. A setting of zero
lets them touch, while a setting of 3 pixels will space
them out 3 pixels.
Normal Offset - This will set your group of objects
directly on your curve, but setting the offset with a
positive or negative number can set them inside or
outside your curve.
Tangential Offset - This setting has the effect of
moving your objects sideways on your curve, which
can be helpful if you see a corner where your
objects seem to have a result you don’t like. For
example, my diamond might show up as on the left,
but shifting it a bit would give the result on the right.

Duplicate pattern before deformation - Duplicates
the original pattern you are using before you close
the window. If it isn’t checked, the single pattern
above the project will be deleted. It might be OK to
leave it unchecked, but it’s always nice to have a
copy of the pattern until you are completely finished
with your project.
Live Preview - Lets you see your choices as you
alter them. If you change one of the number
settings, you move to another settings box before
you see the change.
In the example (next page, top left), the pink &
purple circles and the outside purple circle
combination were added to the outermost curve, the
blue & purple ellipses were added to the next curve
inside, then the diamonds were added to the
innermost curve.
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Connect

All your
PCLinuxOS
connections in one
convenient location!

Screenshot Showcase

The settings are as follows:
All are Repeated, stretched ... Snake, then for the
Space Between Copies, Normal Offset and
Tangential Offset settings;
1st; 0, 6, 0 (6 for offset put it inside the curve
I used)
2nd; 1,-8,0 (-8 for offset put it outside the
curve)
3rd; 0, 0, 0 then tangential of 2.5 (to fix the
corner)
4th: 0, 0, 0
All have Duplicate pattern before deformation
checked. Make sure you have saved your work.
This is a good start! I’m sure your selected patterns
and colors are very different from mine, although I
made a couple of different colored patterns. Next
month we will finish this design.
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Posted by cypher, running Mate, on November 12, 2014.
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by Meemaw

Inkscape Tutorial:
Create a Paisley Pattern, Part Two
used the purple and pink I’ve been using, and the
pink stroke was size four.

Last month, we started a paisley pattern using our
decorative patterns created the month before. I did a
different colored paisley as well.

Many times, a paisley design will have some sort of
flower motif in the center. I am going to make a
flower using the star tool. With the following settings:

12 corners,
Let’s take the original on the left and add a bit more
to it. Click on the innermost curve. You will find that
all you can select is the objects along that curve, so
since you have them selected, press your right or
left arrow key five or six times (remember how many
times you pressed). This will move the objects over
enough that you can choose the curve itself. Choose
the curve and duplicate it as we’re going to make
another. Click <CTRL> + ( nine or ten times to make
the duplicate smaller. Now, click on your objects that
you just moved and press the opposite arrow key to
move them back into place.
Now choose the duplicate curve you just made. This
one we’re going to fill rather than putting a pattern
on it. Choose a color that looks good with the rest of
your project and fill your curve. If you want, you can
choose another color and make it the stroke color. I
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spoke ratio .25, rounded .45 duplicating twice and setting fill and stroke different
on each, plus a circle for the center,

I made this flower lighter because the object I’m
going to place it on is darker. I then placed it in the
object we made at the start of this article. My paisley
now looks like this:

If you don’t like that particular pattern, feel free to
design one of your own, or search for something you
like among the millions of free clipart objects on the
web.
I like this, but I want to put in some accent strokes.
Once again, using my Bezier tool, I drew a curve but
this time it looks more long and pointed. Again
choosing Path > Object to path, I used the node tool
and auto-smooth to make it the way I wanted it. This
one is only accent strokes, so it’s going to be
smaller. I duplicated
it three times, then
changed the fill and
stroke for each.

I made this object. You will
have to rotate two of the
flowers so the petals will all
show instead of being stacked
right on top of each other.

These
can
be
flipped and rotated
whichever way you
want them to be
placed into your
pattern. I’m finished
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with mine, but you can certainly do whatever you
want to yours, adding smaller flowers or some other
accent shape. Your choices are up to you. You might
also group it all, selecting your whole pattern by
drawing a rectangle around everything with your
mouse, and clicking on the Group tool. You can also
export it in an image format, such as .jpg or .png.
Mine now looks like this:
Wow! We learned several tools this time! I’m sure
your paisley pattern is wonderful! It might be fun to
show everyone else what you’ve made. I’m going to
put mine up as a wallpaper, and post it in the
desktop screenshot section of the forum. I’d like to
see yours as well. You don’t have to leave it your
wallpaper if you don’t want to… just long enough to
take a screenie. Here’s mine, but I posted it, too.
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Screenshot Showcase

Visit Us On IRC
• Launch your favorite IRC Chat Client software
(xchat, pidgin, kopete, etc.)
• Go to freenode.net
• Type "/join #pclosmag"
(without the quotes)
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Posted by OnlyHuman, running e17, on December 18, 2014.
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Inkscape Tutorial: Create A Candle
by Meemaw
Some of us like to make wallpapers for the holidays.
I saw a tutorial about creating a candle, and I
thought it would be a great project to do before the
holiday season starts, so we might use it in one of
our wallpapers. Opening Inkscape, use whatever
size page you want. The default is A4, Portrait
oriented, so I’ll probably open Document Properties
from the File menu, and change it to Letter,
Landscape oriented. The choice is up to you.
To draw the basic candle, you can use the pen tool,
or you can create a rectangle and an ellipse and
choose Path > Union to combine them. If you do
that you will have to create extra nodes across the
top and pull them out to make the part of the candle
that is melted down. It’s just a decision between
making the separate items, merging them and
pulling nodes … or drawing the whole thing by hand
with the pen tool.

Using the Pen tool, draw
an
irregular
elliptical
shape. This will be the top
of the candle. Fill the
shape with a radial
gradient, lighter in the
center. When the candle is
lit, the center is the
brightest, so make it very
close to white.

Let’s highlight the top so it
looks more like the wax has
melted down and fallen
over. At the top-front, draw
an
elongated
irregular
ellipse shape, just below the
edge. Blur it, then apply a
white to transparent radial
gradient. Do several around
the edges.

Difference.

Set it to a semi-transparent white and

Blur it.

Now we want to show the inside of the candle as
brighter because it is lit, so we’ll add a highlight on
the inside of the lip. Draw a shape that looks as if it
curves around the back of the candle. Slide it under
the inside ellipse that we drew first, then blur the
inner highlight.

Apply a radial gradient going from a bit lighter than
your candle to transparent. Extend the gradient
handles beyond the bounds of the object. So far,
mine looks like this (next page, top left):
Let’s fill it with color. Open your fill and stroke
window, and fill your object with your desired color.
Mine will be an orange shade. Set the stroke to
None. I’m going to add a linear gradient in the
center to look like a highlight.
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Let’s add a highlight to help define the shape of the
lip. We will add one highlight going all the way
around. Draw a ring, and then draw an inner ring on
top of it. Select both rings and choose Path >

I’m sure you can see other edits I have made in my
progress…. changing the color of the center to a
little darker one, and shortening the amount that the
wax has dripped. Most of that is personal
preference, so you draw yours however you wish.

Page 78

Inkscape Tutorial: Create A Candle
Now we can work on the
flame. Every lit candle
has a pool of wax at the
bottom of the wick, so
let’s do that first. Draw
an ellipse in the topcenter, color it yelloworange, and give it some
blur. Draw the wick. You
can start with a black
rectangle, but flare the
edges a bit to make it
look uneven. Change
the fill to a black to
yellow gradient, top to
bottom.
The flame will take a bit of work. Start
off drawing a sort of ellipse with a dent
in the bottom (looks kind of like a
fingernail to me). Make the fill a solid,
fleshy color (left). Draw a little different
shape on top of it, leaving the bottom
of the first shape visible. Fill the top
shape with white and blur it (center). Draw a flat
arrowhead-like shape at the bottom of the flame. Fill
it with yellow and blur it. Draw a circle at the bottom
of the flame and blur it. Apply a peach to transparent
gradient, running top to bottom (right). Select all
parts and group them.

Place it on top of your wick. Now, mine looks like
this:

I did a couple of things to mine after this. I am going
to put a dark background behind my candle.
However, many of the gradients I have been using
have been transparent in places. I’m sure there is a
professional way to keep the background from
showing through, but the easiest way I have found is
to duplicate the candle base, change the fill to solid
white or something close, and send it to the bottom
of the drawing. I also added tiny a bit of shade on
the front of my candle to simulate a shadow from the
wax that is dripping over the front.
Now we will add a background. Draw a rectangle on
your page and send it to the bottom of the drawing.
Mine will be a dark blue to transparent linear
gradient, top to bottom. I made it mostly dark blue
with the transparent showing only toward the
bottom. Then I added a shadow at the bottom of the
candle. Since it’s your drawing, you can do as much
or as little of this as you desire. Mine now looks like
this (top, right):
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You can always dress up your candle by designing a
base or platter to put it on, or putting some sort of
floral design around the bottom. I remember
ms_meme making a candle like this and drawing
poinsettia leaves around the bottom for a Christmas
wallpaper.
It’s your project – do what you want, and personalize
your creation!

Visit Us On IRC
• Launch your favorite IRC Chat Client software
(xchat, pidgin, kopete, etc.)
• Go to freenode.net
• Type "/join #pclosmag"
(without the quotes)
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Inkscape Tutorial: Reinventing The Wheel
by Khadis

snap
snap from and to center of objects

2. Ensure that the
option is active (can be
accessed under View menu). Please also activate
"
" option as
illustrated below:

An alternative of graphic design software, Inkscape
is quite powerful, like CorelDraw, including the ability
to make a vector based graphics illustration. Several
years ago, when I studied graphic design, I made a
wheel illustration using CorelDraw as one of my
'basic' exercises. Now, I will make the same wheel
using Inkscape.

circle. If you have activated the "snap from and to
center of objects," it will show you a red-cross sign
saying "Handle to center." Now, put your "+" sign on
a place where it says "Handle to center." The "+"
sign is your trapezoid's axis that is moved to the
circle's axis. If the axis of your trapezoid is not
moved to the circle's axis, when the trapezoid is
rotated, it will rotate to itself. While if the axis is
moved to the circle's axis, when the trapezoid is
rotated, it will rotate to the circle.

1.

Open up Inkscape. Create a circle with the
tool. The size absolutely depends on your
taste, while the fill color is white and the stroke color
is black, with any thickness you desire.

ellipse

3.
After that, create a rectangle (fill color: black,
stroke color: black or no stroke is also OK). Convert
it into a
. This rectangle will be transformed into
a trapezoid. Select this rectangle and choose Path Object to Path menu (Shift + Ctrl + C). You can use
the "
" tool (F2) to modify this
rectangle into a trapezoid by dragging in the handles
in the top right and top left corner.

path

edit path by node

4. Place this trapezoid above the circle. For a clear
view, take a look at the picture at top right:
5. After that, activate the Transform panel (Shift +
Ctrl + M). Double click the trapezoid until its handles
turn into rotation handles. Pick the midpoint of the
trapezoid (with "+" sign). Drag it to the center of your
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rotate

6.
Now, choose
menu in your Transform
panel and type 15 in Angle box. Duplicate the
trapezoid by pressing Ctrl + D and followed
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by pressing "Apply" in your Transform panel. Do it
several times until your new trapezoids round the
circle.

7. The next step is creating the inner circle. You can
do this by pressing Ctrl + D on the previous circle to
duplicate and then resize it. We can resize it by
dragging in the top right handle and pressing Shift +
Ctrl to make it keep on its proportional shape.
8. Color this second circle with black-to-white
gradient by opening up Fill and Stroke panel (Shift
+ Ctrl + F), and then choose Fill - Linear Gradient
followed by choosing Edit. In your Gradient Editor,
you can choose the gradient color by pressing Add
Stop button and slide the slider on each color box: R
(Red), G (Green), B (Blue), and A (Alpha / Opacity)
as shown at center top.
9. Press F2 on your keyboard to activate Edit path
by nodes function. With this tool, you can change
the direction of your gradient.
------>
10. Do the same steps as described in step 7 to step
9 to create 2 other circles so that the final result will
be like this (top right):
11. The final step is creating smaller circles as
decoration. So, create a small circle (the size is up to
you). Color it with white and no stroke, and put it
close to the stroke of the second (big) circle.
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12. Repeat step #5 and #6. Duplicate and rotate the
small circle. Give 30 as new value in your Angle box
in Transform panel, tab Rotation .
13. The final result will be similar to the picture at
right (the gradient may vary depending on the color
and direction you choose).
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Inkscape Tutorial: Holiday Wallpaper
by Meemaw
It’s early yet, but most of us like to celebrate some
sort of winter holiday. If you like to put up
decorations and send cards, you might have fun with
this project, and we’re doing it early enough that you
can practice. I send Christmas cards every year. I
saw something with a snowman/snowball theme, so
I thought I would try it for my cards. It would also
make a nice holiday wallpaper. We can make a
snowman or decorative balls. These look like they
were made from wire.

You can also make them different colors! I have
found that you need to use a lighter color to start,
because the glowing metal filter will darken the color
somewhat. You will probably have to experiment
with the colors to get what you want. With this one I
used a pink, but the glowing metal filter made it a bit
darker.

When you have it the way you want it, select all lines
and the circle by drawing a box around them with
your cursor, and then Group them. Change the color
to a light grey.

I used the colored ones for the decorative balls, and
the silver ones for the snowman, duplicating,
resizing and rotating the first circle and then stacking
them.

With your group selected, click on Filters > Bevels
> Glowing Metal . Your group will turn a shiny silver
color.

Open Inkscape, and start by making a circle. Using
your bezier tool, draw many lines across your circle
to make it look like it is made of wire. Using Path >
Object to Path on each line, select your Nodes tool
and put a little curve in each of your lines (center,
top).
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For the ball hangers, I drew a square with a linear
gradient fill, grey and white, to give it some highlight.
I kept a very thin dark grey stroke to define the
shape a bit. Choosing Path > Object to Path , I
added two nodes to one side of the square, and then
moved things around until it was narrower at the top
with a scalloped edge at the bottom, like many of
those hangers have. Then, I made a circle (no fill
and 5 px stroke with a grey to white gradient) and
covered a little over half of it with a rectangle. I then
chose Object > Clip > Set to only use part of the
circle. Rotating them into position, I combined the
two shapes for a ball hanger, grouped them and
placed them on the edges of the wire balls (next
page, top left).
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The hat is done the same way as the wire circles. I
drew three rectangles, different sizes, to represent
the top brim and band of the hat. The top and brim
were done with the wire-look, and the band was
filled with a solid color. When I had them done, I
grouped them and then used the glowing metal filter.
When you get them all finished and arranged as you
want them, group and export your selection. If you
want something moved, just ungroup them and
make your change, then regroup them. There will be
two versions of my snowman because I moved one
of his arms.
If you want, you can
create colored stars,
make them shiny with
the glowing metal filter
and place them on the
wire balls, as shown at
the beginning of this
article.

The snowman requires a bit more work. Most of it is
creating the desired shapes (coal pieces for eyes,
mouth, and buttons, a triangle for the nose, lines for
arms, and irregular rectangles for the scarf). I used
black hexagons for the eyes, mouth and buttons,
pulling the nodes on the eyes and mouth so they
look like irregular pieces of coal. The nose was an
orange triangle with the nodes pulled on it to make it
irregular. The scarf is three red rectangles that I
made irregular and merged with Path > Union . The
nose, buttons, arms and scarf were also made
metallic with the Glowing Metal filter that we used
on the wire circles. The eyes, mouth and mittens are
black with a white blur to highlight them a bit.
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Here is my snowman, but yours will probably look
different:

After that, you can use Inkscape to create a holiday
wallpaper or greeting cards from either of your
creations.
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Inkscape Tutorial: Tracing A Logo
by Khadis
On some occasions, I often help people to create or
to re-create a logo they have. Mostly, they come with
a bitmap logo (a scanned draft of logo) or come with
low-resolution bitmap image. They often need a new
logo that can be used or manipulated for later use.
In brief, they need a vector format of a logo, which
can be easily made using Inkscape.

For now, I changed the stroke width into 2 px and
red as the color. We can always turn its color back
into its original one, of course.

Step Three:

Keep drawing the line by clicking on
each corner until you get as pictured below (in the
end, click on the starting point to close the
curve/path):

The tutorial below will show you how to trace
random simple logo I picked from my logo collection.

Step One: To trace a logo, we need the Bezier Tool
(Shift + F6) . Then, after this tool is in your hand,

now draw a continuous line starting from point “A” to
point “B”.

have a pair of symmetric wings, so I do not need to
trace the remaining wing part, but later I can copy
and flip it instead. In the picture below, I traced the
middle part of my logo using 3 px-stroked blue curve
so you can spot the difference.

Step Four: Using “Edit path by nodes” tool (F2) ,
you can manipulate the path into desired shape (e.g.
bend the straight line into a curved one).

Step Five: Using this tool, pull the middle part of the

Step Two: If your default line is hard to see, you can
zoom the screen to get better view. You can also
raise the stroke width and change the stroke color.
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line. You will also get two handles which can be lifted
up and down to bend the line. If you find the nodes
you have are not enough, you can always add the
nodes by double clicking your mouse on the path
(top, right).

Step Six: After

all parts have been bent, you can
continue to another part. For the logo I traced here, I

Page 84

Inkscape Tutorial: Tracing A Logo
Step Seven : Using “Edit path by nodes” tool (F2) ,

you can bend the line following the original path
(logo). The final touch will be like this:

Visit Us On IRC
Step Eight: Do the same steps for other parts. Now,

let’s insert text, as in the original logo. Using the
Text tool (F8) , type the text. I use Times New
Roman 32 pt. Your font size may be different from
mine because of the size of the overall picture.

Step Eleven :

Finally, it’s time to put a pentagon
shape as the background. Please group all the
objects first. After that, create a black-stroked
pentagon (no fill color) using Stars and Polygon
Tool (*) . Adjust the size as you need and set the
rounded into 0.100.

Next, let’s create a path as we will put
the text on a path. For the path, I use an ellipse. To
ensure that the text will flow on the path correctly, I
drew an ellipse right under the original text to
measure the required size. Look at the 4 px-stroked
green ellipse at center top:

Step Twelve: You can then adjust the shape of this
pentagon by converting it into path (Path – Object
to path menu or press Shift + Ctrl + C) and reshape it using “Edit path by nodes” tool (F2).

Step Ten : After

Step Thirteen : Now, align the grouped objects with
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• Go to freenode.net
• Type "/join #pclosmag"
(without the quotes)

Step Nine:

you get the right size of your path
(your ellipse), now put the text on it. Select your text
and your ellipse, then go to the Text > Put on path
menu. Your text will be placed on the ellipse. You
might need to make some minor adjustments so that
the text position fits your needs. After your text is
positioned to your satisfaction, you can remove the
ellipse.

• Launch your favorite IRC Chat Client software
(xchat, pidgin, kopete, etc.)

the pentagon. Make them centered horizontally and
vertically (right, top).
That’s all. Now, you can trace any logo you want
only by using Bezier curves.
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Inkscape Tutorial: Sunset With Stars
by Meemaw

With your irregular shape chosen, hold down
<SHIFT> and select your black rectangle. Go to
Object > Clip > Set to form your ground silhouette.

We did a sunset project earlier, but the stars in this
one use a different process, so we’ll do it anyway.
This month’s magazine cover was made using this
same method.

At this point, I imported the silhouette clipart, resized
it and placed it into the picture. Now would be a
good time to save your work.

Using the Pencil tool, draw an uneven shape across
the black rectangle and around the bottom of your
page, connecting back to itself. This will make the
land.

For this project I downloaded a free clipart image
(the elephants) and will export that into the project
pretty soon.
With Inkscape open, start a new drawing. I used US
Letter size in portrait orientation (990 px tall and 765
px wide). Create a rectangle the same size as your
page, with no stroke and blue fill (just so it’s visible,
because later we will change it). Create another
rectangle the same width as your page and about
1/3 the height, filled with black.
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Now, we will work on the sky. Since the sun is
setting, we’ll need to illustrate this with a gradient.
Click on your blue rectangle, make sure you have
your Properties window open, and change the fill
from solid color to linear gradient. In the properties
window, click on Edit, then click on the Add Stop
button twice so you can make four colors. From top
to bottom it will be dark blue (so dark it’s almost
black), a lighter blue, yellow and orange. When you
get your colors set, close the gradient editor and
click on the Gradient tool at the left side of the
program window. You can choose whatever colors

Page 86

Inkscape Tutorial: Sunset With Stars
look good to you, but the colors I used in the image
below are as follows;
dark blue 1a1a2cff, blue 425495ff, yellow c2a908ff
and orange c33b06ff

You will want the dark blue at the top, so grab the
handle at the left and move it to the center of your
picture towards the top. Then grab the handle on the
other end and move it towards the bottom of the
picture. Mine is below. You can move the handles
wherever they look good to you. When you get it the
way you want it, save your work.

It’s time to do the stars. Rather than duplicate them
a hundred times and then have to move and resize
them all, we’re going to use a different command.
First, though, we have to make one star. Using the
Star/Pentagon tool at the left of your screen, create
a star you want to use. I did a six-pointed star with a
small circle in the center. I did it by creating the star,
six-pointed with the spoke ratio around .08, then the
circle, and made sure the fill was white on both (and
no stroke). Then I selected them both and, using the
Align and Distribute tool, centered them both ways,
then grouped them.

Now we are going to make a bunch of stars. With
your star still selected, click on Edit > Clone >
Create Tiled Clones. A window with many tabs will
appear.

When yours is created, change
the blur to 5, and reduce the
size of the star, placing it near
the top left corner of your
picture. Save your work.

Each of these tabs will affect your group now,
depending on the settings. I will give you the settings
I used, but I will try to explain a bit along the way.
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In the first tab, Symmetry, we want to designate
how we want them to be spread. The default is P1:
Simple translation, and I’m going to use that. Other
choices are possible. Then below, we need to
indicate how big our group of clones will be. We can
use columns and rows of clones or we can use a
width and height measurement. I will use a width of
700 and a height of 250. Notice at the bottom of the
window we see three buttons: Remove, Unclump
and Create . With those three buttons we will be able
to change our settings and see the results very
easily. If we click Create now, with no other settings,
this is what we will get:

Well, that’s better. It looks more like a random
scattering of stars. If you don’t like the one that
appears, you can always click Remove and then
click Create again, and the Randomize setting will
make it look different. However, all the stars are the
same size and brightness, so we will have to do
something about that, so go to the Scale tab, and
set both Randomize settings to 50%.

Let’s do one more thing. Click the Blur and Opacity
tab, and set Fadeout - Randomize to 100%.

At this point all our stars are exactly alike and are
lined up like soldiers in formation, and not like real
stars at all. Click Remove . Next, we will change
some numbers in the Shift tab. I am going to
change Shift X - Per column to 60%, then Shift Y Per row to 60%, then make both Randomize
settings 100%. Clicking Create again, I get this:
When you get it the way you want it, close the
Create Tiled Clones window. As a last thought, if
you think your stars are still too bright for a sunset,
you could click back in the Fill & Stroke window and
set the opacity down to your liking. Save your work,
then export your page.
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Inkscape Tutorial: Smiling Jack-O-Lantern
by Khadis
Halloween will quickly arrive to knock at our door.
Most people in my country don’t celebrate it,
actually. But I am interested in participating in
cheering up this moment, at least, by helping some
Inkscape newbies to create a simple Halloween
mascot: Jack-O-Lantern.

Step One:

Open up your Inkscape and create an
ellipse. I used 8.5 cm x 7.5 cm in size. You may use
your own size, of course. Give it fill color R: 240, G:
138, B: 2, A: 255, and no outline.

Step Three: Convert it into “path” by accessing
menu Path – Object to Path (Shift+Ctrl+C) . Later,
don’t forget to make the left side into a curve using
Curve tool (F2) . Duplicate this triangle using Ctrl +
D , flip it horizontally, and put it in the right side.

Step Four:

Make another triangle and make it
smaller. We will use it as the “nose” of the pumpkin.
You can duplicate one of the previous triangles and
rotate it.

Step Five: Now, create the mouth using Bezier tool
(Shift + F6) , and modify it using Curve tool (F2) .

You can click on any part of “the mouth” to add more
nodes. Those nodes then should be modified as the
teeth. See the picture below:

Step Seven : Give it the same color as the eyes and
nose.

Step Two: Now, create a triangle using Stars and
Polygons tool (regular polygon with 3 corners). Give
it fill color R: 80, G: 45, and B: 22 without an outline.
Resize it to meet your needs.

Step Six: Keep using the Curve Tool (F2) to get the
perfect shape. You may need to resize. Make the
curve smoother or symmetric.
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Step Eight: Now, create the stem. You can always
rely on the Bezier tool for this part. Create the stem
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using any shape, add more nodes, and bend it. Give
it color R: 0, G: 97, B: 0, A: 255, and no
stroke/outline.

Step Ten : For the final “touch,” put some text under
the Jack-O-Lantern. I used “Grunt Reaper” font. You
may want to find your own “scary” font.

Step Nine:

Now, we need to create the shadow to
give lighting effect. You can duplicate the great
orange ellipse and by using Curve tool (F2) , and
then you can modify the ellipse. Don’t forget to
convert it into path before using Curve tool (F2) ,
and change the color into R: 169, G: 91, B: 11, and
A: 120 or 200. You can set the Alpha value (A) lower
or higher to get nicer effect. And you can also locate
the shadow under the eyes and mouth by pressing
Page Down button on your keyboard.
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Inkscape Tutorial: How To Create Puzzle Pieces
by Khadis
Do you like playing with puzzles? I do. What about
making a puzzle and then challenging your friends to
solve it? It might be fun and entertaining. So, in this
tutorial, I would like to show you how to make simple
puzzle pieces.
1. Open up your Inkscape and create a rectangle of
any size and any color. Convert it into a path from
Path > Object to path (Shift + Ctrl + C).
2. Create a circle (or an ellipse). You can make it
any size and any color, but I recommend you to
create a circle that is smaller than your rectangle.
Duplicate the circle three times using Ctrl + D until
you finally get four circles. In the illustration, I have a
green rectangle and yellow circles without stroke.

4. Do a “union” operation by selecting the circle, hold
down your Shift button, then click on the rectangle.
Press Ctrl + + or access the union function from the
Path > Union menu.
5. Now, put the second circle on the right part of the
rectangle. Place the circle so that its bigger part is
inside of the rectangle.

3. Put one circle on the left part of the rectangle. You
may place it randomly. This means you do not need
to put the circle perfectly vertically “justified” to the
rectangle. But please note, that if you want to make
this puzzle playable, you may want to consider to
“justify” the circle into “center on vertical axis”. The
same height of rectangle with the same puzzle's
“hole” position will fit each other.
6. Do a “difference” operation by selecting the circle
hold down your Shift button, then click on the
rectangle. Press Ctrl + - or access this function from
the Path > Difference menu. Now, your rectangle
should look like this (right, top):
7. Repeat steps four through six, by putting the third
and fourth circles on the top and bottom part of the
rectangle. The final result may look like either of
these (center and bottom right):
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8. Of course, you can explore the way you place the
circles to produce cooler pieces of puzzle.

12. Or you can do this simple trick: select the first
puzzle, and then remove the right hole's nodes and
return the curved side into a flat side.

9. To give a “final touch”, you can convert the puzzle
into curve and modify it into smoother shape. You
can use Edit path by nodes tool (F2 ) and use the
available modifying tools or modify your nodes
manually.

14. Now, it's your turn, to create your own your very
own puzzle creation.

10. As I mentioned in step three, to make these
pieces of puzzle playable, you should create the
same “distance” of circles placement and flat
rectangle. But, if your imagination flies further and
you want to create a curved puzzle, as in the step
nine above, then you should totally modify the other
pieces of your puzzle.
11. Duplicate your curved puzzle piece, then place
the new piece close to the first one. Hold the Ctrl
button while moving your object so that it can move
straight. By using Edit path by nodes tool (F2 ),
adjust the size or even the position of your first
puzzle's hole and puffed part.

13. Put them “stuck to” each other, then do the
“difference” operation. Your second puzzle will be
removed. Duplicate (Ctrl + D ) the first puzzle again,
and stick the second one to it. Give them different
colors (top, right).
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Inkscape Tutorial: Taped Note
by Meemaw
This one is pretty easy. It resembles a note taped to
a surface with clear tape.

Properties window, click on the colored line behind
the word Background, and the small window will
appear (bottom, left):

Create a new rectangle for the note itself. I made
mine yellow, but you can make it any color you want.
You can arrange your tape pieces now, or wait until
you are finished.

I changed mine to a medium grey. It will be easier to
see what I’m doing.
Next, draw a rectangle, white fill and no stroke. In
the Path menu, click Object to Path while your
rectangle is selected. Change to the Paths tool
(second from the top at left). On each end of your
rectangle add five nodes by double-clicking on the
end line five different times. Grab alternating nodes
and move them inward to create a “cut tape” effect
at each end. Don’t worry, it doesn’t have to be
perfect, and you can add more if you wish.

Open Inkscape and set your document properties. I
used a letter sized page, in landscape orientation. It
seems to be easier if you change your background
from white to something a bit darker so you can see
what you’re doing. In Document Properties , one of
the choices is background color. From the Document
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When you get your “tape” the way you want it, go to
Properties and set the opacity down to 30 or 35, or
whatever looks good to you. Resize it (depending on
how big you made it when you started), then
duplicate it and separate the two.

Not all pieces of paper are wrinkle free, so let’s put
in a shadow that makes it look like the paper is
curling a bit at one side. Using your Bezier tool with
the width set about 10, draw a line similar to the one
shown below.
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Zoom in on your corner and move the line up to the
corner of the paper.

Send the line underneath the paper, and set the
Blur at 5.

From here, you can personalize your project. You
can change the background back to white and save
just the note and tape or do something different. I
angled my note and tape pieces a bit, and then put
one of our favorite wallpapers behind it. Remember
to make sure your tape pieces have been moved
above all other items so they show as being over
both the paper and the writing. Save your work and
export your project.

The bigger the shadow you want/need, the longer
and less angled you should make your lines.
Now we want to do our note. Click on the Text tool
at left, click on the yellow “paper” where you want
your note and type. Now click on the Text
Formatting tool at the top of your window and
format the text. I used a font called !Paul Maul, but
you should use whatever you like (center, top). Save
your work.
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Inkscape Tutorial: Design Your Own Paper
by Khadis
At the very beginning stage of learning graphic
design, I learned to design a piece of writing paper
from a “how-to” book for kids. It was fun, although
the book was really intended for elementary
students or kids of that age. And now, I will show you
about what I learned. Then you can practice it both
for yourself and your kids (if any) or the kids around
you.

• Click on that new node(s), and choose 'green' as
the color. You can move the new node(s) to create a
better, smoother gradient.

• If you wish, you may group or unify those circles
with the rectangle using Path > Union . Don’t forget
to remove the stroke if you still have it.

• Create another rectangle and fill it with ‘white’ color.
I used width = 16.5 cm and height = 24 cm. Place it
in the middle of previous rectangle using Align and

Distribute.

• Open up your Inkscape and create a rectangle
width= 21 cm height= 29.7 cm (A4 size) or any size
that you like.
• Use the Gradient Tool and drag it from the top to
the bottom of your rectangle. Click on the top handle
(the box shape) and click on the yellow color on your
color pallet. Add one or two more nodes by doubleclicking the gradient line to create a yellow-to-green
gradient.

• Create some lines and arrange them like in the
picture below. You may color them too. I used 1.50
px as the line width.
• Create some circles, fill them with ‘white’ color,
without stroke, and place them on top of the white
rectangle. See the picture below. In the picture, I still
have black strokes. It’s only to describe that I
created the circles. Of course, later, they can be
easily removed.

• Finally, you can put text or images to decorate your
design. I used some PNG images that were taken
randomly from Google (next page, top left).
• This design can be used as a photo frame too. You
can also set the gradient as much as you like. If you
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plan to teach basic Inkscape to your child or children
around you, this simple tutorial will fit your needs.
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