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Welcome From The Assistant Editor
Welcome to the second installment of the magazine’s
Graphics Special Edition! This has been compiled from the
GIMP and Inkscape articles published from January, 2015
to December, 2017. Remember, since each one has
already been published in the magazine, we’ve only
released this in PDF and not in ebook or HTML versions.
This special edition contains not only my articles, but also
those created by our friend Khadis, who submitted many
great articles before life intruded and he had to attend to
more important parts of his life. Many thanks go to Khadis
for all his contributions!

The PCLinuxOS name, logo and colors are the trademark of
Texstar.
The PCLinuxOS Magazine is a monthly online publication
containing PCLinuxOS-related materials. It is published
primarily for members of the PCLinuxOS community. The
magazine staff is comprised of volunteers from the
PCLinuxOS community.
Visit us online at http://www.pclosmag.com
This release was made possible by the following volunteers:

Many things have happened in the years since the first
special edition was released! Life has intruded on most of
us, whether it be life or work changes, COVID, really bad
weather or the loss of someone we love. These days we
can’t even get together very much because we’re busy
social distancing. I hope your particular situation is a happy
one, or will be soon. In spite of all that has happened,
we’ve found time to experiment with GIMP and Inkscape,
creating loads of projects and having fun (at least I hope
you have!). We’ve done calendars, wallpaper, many
different text effects and even learned a bit more about
editing our photos.
We plan to do another special edition, with the articles from January, 2018 to December, 2020 soon. In
the meantime, enjoy this edition and the monthly issues of the magazine.

Chief Editor: Paul Arnote (parnote)

Assistant Editor: Meemaw
Artwork: ms_meme, Meemaw
Magazine Layout: Paul Arnote, Meemaw, ms_meme
HTML Layout: YouCanToo
Staff:

ms_meme
Meemaw
Gary L. Ratliff, Sr.
Daniel Meiß-Wilhelm
daiashi

Cg_Boy
YouCanToo
Pete Kelly
Smileeb
Alessandro Ebersol

Contributors:
Khadis

Meemaw, Assistant Editor
The PCLinuxOS Magazine is released under the Creative
Commons Attribution-NonCommercial-Share-Alike 3.0
Unported license. Some rights are reserved.
Copyright © 2020.
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GIMP Tutorial: Quick Neon Text Using G'MIC
by Meemaw
In this tutorial, we can create a simple neon text with
G’MIC. G’MIC is a program you can use online or as
an add-on to Gimp. You can install it from Synaptic.

Right-click on the text and choose Layers > Layer
to image size. Go to the Layers tab. Right click on
the text layer and choose Alpha to Selection .
Click on Filters > G`MIC. A window will open that
shows a list of filters.

Quick, huh? You can change the background if you
wish, and should merge the layers before exporting..
Open GIMP and create a new project. You can make
it whatever size you want. Mine is 600 x 400 px. The
background should be black. Choose your Text tool
and write your desired text. You can use whatever
font you want, but the neon effect looks really good
using some sort of rounded font (the tutorial I found
used Arista but I used Art Brush and Tango BT).
Highlight the text and change the color to white and
the size to 200 pt or so, depending on the font.
Change tools back to the moving tool and move your
text to the center of your drawing.

The filter we will use is Contours > Gradient RGB .
From the sliders that appear, set the smoothness to
10 and max threshold to 100, then click OK. Click
Select > None.

Duplicate this layer and, choosing the lower text
layer, click on Filters > Blur > Gaussian Blur.
Increase the Blur Radius to about 60. Then choose
Hue/Saturation , and change the Saturation to 100
and Lightness to 70.
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GIMP Tutorial: Create A Swirl Effect
by Meemaw

the swirl won't be perfectly uniform, unless you draw
much better than I do!

We’ve done backgrounds before, but we will use
GIMP this time to create a swirled background. This
was a fun tutorial to do, as well.

Now, click on Filters > Distorts > Whirl and Pinch .
Move the Whirl angle slider all the way to the right
(the number will be 720), the Pinch amount slider
about three-quarters to the left (around -0.5) and
leave the radius at 1.00.

Open a new image (File > New) in the size you
want. I used 1600 x 1200, but you can use bigger if
you need it.
Decide on a color and then choose two shades of
that color so we can put in a bit of a gradient. My
favorite wallpaper color is blue so I used two
different shades of blue.
Click on the Blend tool in the Toolbox and verify that
the Gradient is set to FG to BG and the Shape set
to Linear. With the Blend tool, draw a line from the
top to bottom, bottom to top, or from corner to
corner. I drew mine from top left to bottom right, and
as you can see, the top left corner is darker.

Click on Filters > Blur > Gaussian Blur and set
both values to 40, then click OK. You should have an
image that looks sort of like this:
Let’s adjust. Click Filters > Distorts > Waves . Make
sure that the Smear radio button is selected. Play
around with the amplitude, phase, and wavelength
sliders until you're happy with the result (as you can

Change the foreground to white, then draw a swirl in
the middle of your image using the brush tool. The
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GIMP Tutorial: Create A Swirl Effect
see on the previous page, I set the amplitude to 70,
phase to 145, and wavelength to 45).
Before we finish, we want to make the ripple effect
stand out a bit more. Go to Filters > Artistic >
Softglow and adjust the sliders to your liking. I set
the Glow radius to 1.00 (all the way to the left),
Brightness to 0.25, and Sharpness to 1.00 (all the
way to the right).

We are finished, unless you want to go back and
adjust something else. You can always go back into
any of the Filters items and change settings. If you
decide the color is wrong, instead of starting over,
click on Colors > Hue-Saturation and adjust the
Hue slider.

You can always play around with the other filters and
see what different effects you can come up with.
One option is Filters > Render > Clouds >
Difference-Clouds. I changed the color of my
original to a shade of green (in Colors > HueSaturation ), then did the Difference-Clouds filter
with the X and Y sizes set to 1. ------->

All your
PCLinuxOS
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convenient location!

Want to keep up on the latest that's
going on with PCLinuxOS?
Follow PCLinuxOS on Twitter!
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GIMP Tutorial: Create a Lightning Bolt
by Meemaw

Now click on Colors
back to the middle.

> Invert to bring the lightness

I always wondered if a realistic looking bolt of
lightning could be created in any of the programs we
use. I found a tutorial that does it in GIMP, and so I
will share it with you. It’s not too long and pretty fun.

transparent layer which will help us isolate the main
lightning bolt. Use the Paintbrush tool with a large
soft black brush on the mask to erase the rest of the
unwanted areas.

Open GIMP and start a new document. I used 800 x
600. Click on the blend tool and create a grayscale
gradient (FG to BG), linear shape, running left to
right.

Click on Colors > Levels , then grab the center
triangle in Input Levels and drag it far to the right.
You can see in the tool window the two triangles at
the far right under the histogram. You should now
have a fuzzy-looking lightning bolt.

To finish, I put a black background behind my
lightning, merged the layers and exported the
picture.

Right-click on the layer and choose Add Layer
Mask. You have several options, but select
Grayscale copy of layer and click Add . This adds a

You can experiment with the difference clouds
(clicking on New Seed) to get lightning that looks

Click on Filters > Render > Clouds > Difference
Clouds. Turn the Detail all the way up to 15. It looks
cloudy, but notice that there is now lighter gray on
the left and the black is mostly in the center of the
page.
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GIMP Tutorial: Create a Lightning Bolt
different, and can also experiment with your gradient
(maybe drawing from upper left to lower right) to get
different effects. In the image below, I used a smaller
brush, and drew my gradient from upper left to lower
right.

Linux Docs
Linux Man Pages

Screenshot Showcase

A magazine just isn't a magazine
without articles to fill the pages.
If you have article ideas, or if you
would like to contribute articles to the
PCLinuxOS Magazine,
send an email to:

pclinuxos.mag@gmail.com

We are interested in general articles
about Linux, and (of course), articles
specific to PCLinuxOS.
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GIMP Tutorial: More Photo Editing Tricks
by Meemaw
I have a couple of wallpapers that I like very much,
probably since I have been to the location pictured.
Several years ago, I downloaded a wallpaper of
“The Mittens” in Monument Valley in southeast Utah,
USA. Then, I went there during a trip to Utah several
years ago, and took one of my own. As you can see,
the wallpaper I downloaded, on the left, is much
more colorful than the photo I took, which is on the
right. Bear in mind, the original photo on the left may
have been a little more dull as well, until the
photographer enhanced it.

So, how am I to brighten up the one on the right?
Let’s use GIMP. Choose a photo you want to edit,
and open a copy of it in Gimp. Navigate to Colors
and select Levels . You'll see a histogram, which tells
you how the pixels are distributed. If most of the
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black in the histogram is to the left, then your image
is probably dark and underexposed. If they're to the
right, then the picture may be too bright. A perfect
shot will show most of the action in the middle. Mine
had some in the center but lots in the right. Grabbing
the arrow on the right and moving it left cleared up
my photo a little (bottom, left).
Now let’s navigate to Filters > Enhance > Sharpen .
The more you sharpen the image, the more detail
you can see, but be careful! I went too far with the
sharpen and almost had white detail spots on top of
everything and white outlines around objects.
Reducing the setting solved that problem.

Colors > Brightness and Contrast can also help to
brighten up your image. Just make tiny changes.

I went back to Color Balance and then Levels and
played around a bit more. I am happier with it, but I
think I can do better. You can see the before and
after photos on the next page.
I also used Colors > Color Balance . I had way too
much brown in the image, and that location really
isn’t dull brown, but many shades of orange. Be
careful with this one as well, or you can drastically
change the color of everything. Obviously I put too
much red into this one because the clouds now have
some purple in them that wasn’t there before.
Fortunately, all that is needed is to reduce the red
setting in the color balance window. The arrow keys
are very useful, as they allow you to make very small
adjustments to get the color you want (right, top).

It is much more colorful than the drab brown photo
was. Make sure you keep the original of your photo
and only work on a copy. Since every photo is
different, there are no absolute settings that will work
on everything. The best way is to experiment with
the setting until it looks right to you. Don’t forget you
can undo each change (<CTRL> + Z) if you don’t
like it. With a little more practice, I’m sure I can get it
right quicker … and you can, too!
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GIMP Tutorial: More Photo Editing Tricks
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GIMP Tutorial: Graffiti Text
by Meemaw
I saw a neat tutorial not long ago that featured
another text effect to make graffiti. You will need two
things: some sort of image to put your graffiti on (I’m
going to use a brick wall or wood siding), and some
sort of font that looks like it could have been made
by a spray paint can. I have a font called A.C.M.E.
Secret Agent, and another called Style Wars, and
you may see either of them. While I hate to see
graffiti on walls, train cars or other property, painting
graffiti in GIMP is allowable, and very fun!

Open the background you want to use in GIMP. Click
on the Text tool and choose your desired font, then
type your graffiti.

While your grown text is still selected, choose a
couple of colors for it - one light and one darker.
Click on the Blend tool, choosing Normal Mode ,
gradient FG to BG , and Shape to Linear. Draw a
line from top to bottom to create the gradient. Click
on Select > None .

Go back to your original (black) text layer, and do
the same steps again. You will right-click and choose
Alpha to Selection in your Layers dialog again,
then duplicate the layer and send that layer down a
layer. This time, however, when you choose Select
> Grow, change your setting to about one fourth of
the original setting. I used 15 the first time, so I
changed the second setting to 4. Choose two more
colors, and create the gradient just as you did
before. Click Select > None , then merge this layer
down onto the other color layer.

So, now we have our graffiti, but it just looks like a
text box created in front of an image of a brick wall.
Let’s fix that. Choose your original (black) text, then
right-click the layer again and choose Alpha to
Selection . Change your gradient colors to gray and
a darker gray, and draw your gradient line so the
lighter gray is on the top. Now, go to Filters > Map >
Bump Map. You will see a dropdown with your
layers in it. Click on the dropdown and choose your
brick wall layer. Change the Depth setting to 10 ,
then click OK. You should notice that the paint now
looks as if it is painted on the brick.

Since this is supposed to be black paint, we need to
darken it back, so click on Colors > Brightness and
Contrast. Set the Brightness down to about -115
and the Contrast up to about 40, but you can play
with these until you like them.
Now, choose your color layer and repeat the process
without changing the gradient colors (Alpha to
Selection , Filters > Map > Bump Map, choose
brick wall layer, check to make sure Depth is 10,
then OK.)

With your layer still chosen, right-click the text layer
(in the Layers dialog) and select Alpha to Selection .
Duplicate the text layer and send it under the original
text layer. Click on Select > Grow. In the window
that appears, you will see the number 1, but you
want the layer you are growing to be larger. I used
15, but use whatever looks good to you.
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GIMP Tutorial: Graffiti Text
We can merge the text layers down, but it isn’t
necessary.
As a finishing touch (because graffiti writers aren’t
satisfied with just text - they always seem to paint a
little more). Create another transparent layer, then,
using your choice of brush, do some “wall painting”.
Use different brushes to sprinkle in some paint
splatters and other effects to make it look more
realistic. Using the same steps as before, finish with
your Bump Map to make it look like this “paint” is
also on the brick. Export your finished product.
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GIMP Tutorial: Using Levels To Correct Photo Colors
by Meemaw
How many of us have older photos of family? We
want to put them in a family album, but the photo
has darkened or changed over the years, and the
color looks off. We may even have some more
recent photos that are off because of the light in the
location they were taken. Let’s try to fix them with
levels in GIMP. I am using a photo of a local 4-H
club. The photo that was taken shows a bit too much
yellow.

except the line at the bottom. It will most likely be at
one of the ends. Using the arrow there, click on it
and drag it toward the graph where the gap ends
and the curve starts, and stop there. You should
already see an improvement in your photo,
depending on the color balance of the photo you are
using. Choose the green, and do the same thing,
then the blue. As with all photo work, this is a
process that you have to “fine-tune” according to
your own photo and histogram. Truthfully, I didn’t see
much change with the red or the green, but when I
chose the blue, my photo was changed as shown:

I tried red, but there was not much change.
However, I then tried green:

(still not much yet), and then blue:

Open a copy (always work on a COPY of your
image, rather than your original) of your photo in
GIMP, then click Colors > Levels and the Levels
window will open. Some of your photos can be
edited using the settings that are already there,
which is using all colors at once. You can try it, but
you may have better results if you choose one color
at a time from the dropdown.
Choose the red first, and you will see the histogram
(that graph in the center of the window) change to
show the red levels. Look for a gap in the curve,
usually on the right side, where there is no curve
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These colors look much more realistic. Here’s
another older photo:
While it isn’t perfect, it’s a bit more clear than it was,
and will now only need to be lightened a bit (if
desired) and possibly repaired a little, with the dark
spots towards the bottom left of the photo removed.
Most photos may not need this degree of editing, but
you might find that some of your photos will benefit
from using the levels editor. You can always try
some of the other color editing features in GIMP.
This photo might have been edited simply by using
Desaturate, leaving a plain black & white photo, but I
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GIMP Tutorial: Using Levels To Correct Photo Colors
wanted to preserve the “old photo” flavor (since it
was likely taken in 1945).
It is fun to experiment with these old photos to keep
them for coming generations! As always, each photo
is different, and you will need to experiment using
small changes, but adding Color Levels to your
group of editing tricks should help you with those
hard-to-edit older photos.
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GIMP Tutorial: Convert A Photo To A Sketch
By Meemaw

To highlight the details, go to
Equalize.

Colors > Auto >

I found a tutorial that will allow you to change a
photo to a sketch. While you wouldn’t do this very
often, it might be fun for a child to color a picture that
means something to him.

'Equalized ’. Now double-click the layer you just
created (the copy) and rename it 'Adjusted '.
We need to bring out the details of our sketch. This
means we will darken the blacks and lighten the
whites, so we are going to use the Levels tool that
we used in November. Go to Colors > Levels and
adjust the Input Level sliders until you're happy with
the results. This is one of those times you need to
use your own judgement about how it looks,
because every photo will need something different.
The finished product should look sort of like this:

Pick out a photo and open it in GIMP. Make it a
simple photo, rather than one with loads of detail. I
am using a photo of a parade I attended last year.

We want a black & white sketch, so we need to get
rid of the colors that are left in the photo and convert
them to grey. Click on Colors > Desaturate and hit
OK.

Navigate to Filters > Edge-Detect > Sobel . Make
sure all the checkboxes are selected and hit OK. It
looks dreadful, but we have a few more steps.

Another method is to click on Colors > Curves and
adjust the curve until it looks the way you want.

We are going to create a duplicate layer (Layer >
Duplicate Layer, or press Shift+CTRL+D ). Let’s
also name each layer so we don’t get confused.
Double-click the original layer (the one that doesn’t
say Copy in the Layers panel) and rename it
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We’re also going to use a
layer mask on this. Make a
duplicate of the Equalized
layer by selecting it and
clicking Layer > Duplicate
Layer. Move this layer to the
top (with the layer chosen,
click the up arrow in the
Layers dialog), double-click,
and rename it 'Masked '.
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GIMP Tutorial: Convert A Photo To A Sketch
We will invert the colors on this new layer. Click on
the newly created layer (which should be on top),
and select Colors > Invert.

Now, create a new, white layer (Layer > New Layer
or click on the New Layer button in the Layers
dialog), and place it underneath the Masked Layer.
Your sketch should now look similar to the one
below.

It is starting to look a bit like a sketch! However, it
looks a little grey when we want it to be brighter.
We're going to apply the adjusted layer as a mask.
Highlight the Adjusted layer and select Edit > Copy.
Now highlight the Masked Layer, right-click, and
select Add Layer Mask. In the dialog box that pops
up, check the Selection radio button, then press
Add . Now, select the Masked Layer you just created
and click Edit > Paste . Right-click the 'Floating
Selection' layer that appears in the Layer box and
click Anchor Layer. It looks kinda weird again, but
we’ll fix it.

PCLinuxOS Magazine

While the shadows under each truck didn’t come out
exactly the way I hoped, the trucks themselves look
good. I’m sure your project will look great!

It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...
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GIMP Tutorial: Pop-Up Text
by Meemaw
I found a fun tutorial the other day that shows how to
make your text look like it is pushed up out of the
background.

Create a new page. It can be any size you want, but
mine is 640 x 400. You can use the Pattern choice
on your Bucket Fill or just open some sort of pattern.
The one I did above was the pattern Paper. The rest
of this tutorial will use a wood background. Add your
text as usual, setting the characteristics to your
liking.

Now we will copy the background texture onto the
text. With the text layer chosen, right click it in the
layers dialog and choose Alpha to selection . This
will outline your text. Now click on the background
layer, then click Edit > Copy. Then, click the text
layer, and choose Edit > Paste .

There is a floating layer above your text layer.
Choose that layer and click the anchor in the layers
dialog to anchor it to the text layer.
Create a new, transparent layer, then click back on
your text layer. Right click the text layer and choose
Alpha to selection . You will be able to see your text
again by the moving dotted lines. Click on the new
layer again, then go to Select > Grow. A box will
appear asking how much you want it to grow. You
can set it from 5 to 8 px, depending on the size of
your text, then click OK. Now choose your bucket fill
tool and change it to FG black, then click inside the
letters (right, top).

This layer should be behind the text, so in the
Layers dialog, choose the text layer and move it to
the top.

Now choose Select > All to select the whole layer,
then go to Filters > Blur > Gaussian Blur and
change the vertical and horizontal settings to 20 px,
then click OK (right).

PCLinuxOS Magazine
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GIMP Tutorial: Pop Up Text
Now we are going to add another effect to help our
text along. Right-click on the text layer on top and
choose Alpha to Selection . Then go to Filters >
Decor > Add Bevel . Change the setting to 5 px and
uncheck the two boxes in the Bevel window. Click
OK. You should see a tiny bit of a bevel on the
edges of the letters. Change to the Move tool and
move text layer up and left a tiny bit, then anchor it.
Now it looks as if it is popping out of the background.
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GIMP Tutorial: Make A Folded Map
By Meemaw

I have signed on to the Gimp Chat forum. It is a fun
place where everyone shows their Gimp creations
and help each other learn new things. A user named
alc59 posted a tutorial for this project. I took a
screenshot of a Google map of Kansas City and
used it for this tutorial. I was surprised how easy it
turned out to be. This is the map I used to start:

Let’s start by giving ourselves more room in the
image. Choose Image > Canvas Size . I want a 50
pixel border around my map, so I added 100 pixels
to each measurement, clicked on Center, then
clicked Resize .

Using your rectangle select tool, select the first
section of your map, then click on the Shear tool,
then click back in the selection.
Give the Y magnitude a setting of -50, then click
Shear. Anchor the layer, then select the third section
and do the same thing.

Choose Layer > Layer to Image Size , so when we
start changing things the changes will show up
correctly. Now let’s put some guides in where we
want our map folds. From the left ruler, click and
drag three guides over your map to divide it into
fourths.

Selecting the second section, apply the value 50
(positive this time). While you have the section
selected, choose Color > Hue and Saturation and
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GIMP Tutorial: Make A Folded Map
Choose Layer > Layer to Image size for this layer
as well. For the shadow, we want to choose Blur >
Gaussian Blur and set it about 35. Now it has a
shadow.

change the Lightness to about -20 or so, whatever
looks good to you, enough to make it look like it’s a
bit shadowed. Anchor the layer.
Do the same steps with the fourth section.

You can move your guides back now as we no
longer need them. Now we will use the perspective
tool to make our map look more realistic.

Choose Layer > Layer to Image size . Duplicate this
layer and move it under the main map layer. Right
click on the layer copy and choose Alpha to
selection, then bucket fill it with black. You might
have to set your Threshold up quite a bit on your
bucket fill tool, but it will work. Also, create a new,
transparent layer and put it under both of your other
layers.
We will put a shadow under this map. Choosing the
black layer, click on your Scale tool and shorten that
layer down so it’s only about ¼ the height of the map
layer.

Choose the perspective tool and move the top of
your map down and inward so it looks more like it's
lying on a surface.
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Now, choose the bottom, transparent layer and use
the Gradient tool, choosing a Linear BG to FG
gradient. On mine, I changed the foreground color to
blue, but you could make it any color you wish. This
time I’ll use a beige. Start in the upper left with your
gradient so it looks like the light is coming from
there. That’s why we made the sections facing away
from the light a little darker. The result is below.

I had fun with this one! You don’t have to use a map,
either. You can use any picture you desire, or even
make the folds different - horizontal, maybe, or only
two folds. Your only limit is your imagination.
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By Meemaw
I found another fun text effect to show you. This
effect makes your text look like it has been cut or
burned into the background.

However, we need another drop shadow with
different settings. Choose Filters > Reshow Drop
Shadow (because the Filters menu saves our work
as well), then change the settings to X = 0, Y = 0,
and Blur Radius = 30. This puts a bit more shadow
where the first one was, plus adds some to the other
side of each letter.

Load in whatever image you want to use. I am using
a couple of different wood images. Place your text
on the image. Move the text layer to where you want
it, then choose Layer > Layer to Image Size . Also,
choose the image you imported and choose Layer >
Layer to Image Size again. This will make sure the
changes we make will work correctly. We are going
to use the Displacement tool to roughen up the
edges of our text, so it looks like it follows the
contour of the wood. To use that filter, both layers
have to be the same size.
With the text layer chosen, click on Filters > Map >
Displace. In the window that appears, choose the
wooden background in both boxes, and leave the
other settings at default, then press OK. Now it
should look like it has picked up the texture of the
background.
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Now you can click
selection lines.

Select > None

to remove the

Select the text layer, right-click it and choose Alpha
to Selection to outline your roughened-up text. At
this point you can delete the text layer, and we’ll
work with just the selection. Now we want a drop
shadow, but sort of inside the text so it looks cut in
rather than popped out, like we did in March. To do
that, we will first invert the selection, then choose
Filters > Light & Shadow > Drop Shadow. Leave
most of the default settings, but change the Opacity
to 100%. Now you can see a shadow inside the text
that is starting to make it look engraved.
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Save your work, if you haven’t already, then crop
your image and export it as your desired image file.
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It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...
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Posted by dpascal, on October 29, 2019, running Mate.
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GIMP Tutorial: Fancy Text
by Meemaw

When you have your nodes edited, add a
transparent layer above your text. With the path tool
still selected, click on the new layer. Below your path
tool (on the bottom left of your window, probably) are
the settings for the path tool. Click on Stroke path ,
and in the window that appears, change the line
width to 8 px, then click Stroke .

ellipse with twist around into a curly shape. You can
do that to each of the paths that you created simply
by grabbing the ellipse (don’t change tools) and
moving it to the new spot, then choosing Filters >
Repeat Whirl & Pinch , which is now at the top of
the menu.

I thought we’d make some fancy text for the
magazine’s 10th birthday. Open your GIMP and
create a new project at least 800 x 600 px. Using the
text tool, enter your text and edit it to your liking (font
and size). Now click on Layer > Text to path , which
will outline your text with a path. However, we can’t
see the path yet. Go to the paths tab, choose the
path and make it visible by clicking the eye next to it.
Click on the path tool in the toolbox and click on the
text (within the outline somewhere). You now will see
nodes on your path, and you can move nodes or
part of the path to alter your text.
You have your text on a new layer now, so you can
go back to the paths tab and “turn off” the visibility of
the path. Save your work.
Making sure your new layer is selected, click on your
ellipse select tool, and draw a small ellipse over one
of the places you edited in your text. Click on Filters
> Distorts > Whirl & Pinch , and set the Whirl to
about 300. You can see that the path inside your
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When you are finished changing your text, choose
Filters > Alpha to Logo > Glossy. From the window
that appears, choose the two gradients you want to
use, then apply. You might have to experiment to get
the look that you want, but remember, you can go to
Edit > Undo, then start over on your gradients as
many times as it takes to get what you want.
To finish, one option is to click on the layer
Background 1 and put a gradient on it with the Blend
tool. I used a background to foreground gradient.
Now choose Filters > Artistic > Clothify or Filters
> Artistic > Apply Canvas. Color it in a manner that
will blend with your text. One way to do that is to
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choose Colors > Colorize . The Hue slider will
change the color however you want, then move the
Lightness and Saturation sliders until it looks good to
you.
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GIMP Tutorial: Create Abstract Glass Art
by Meemaw

When you’re finished, the image should look similar
to this:
I found this one on http://mygimptutorial.com/ and it
looks really neat. It creates shapes that appear to be
cut glass with light reflecting on and through them.
This one takes a little practice as colors tend to
blend more than you want them to. You can use
different gradients and get different effects, but let’s
do the basic steps that resulted in the image above.
Create a new image, size 1024×768, making sure
the background is white.
Select the Blend tool and set Mode to Difference
and the Shape to Radial . The original tutorial used
Land1 as the gradient, so we will do that (center,
top).
You will want to create eight gradients: one from
each corner to the opposite corner. You can see I
have already done 3 of those (center):
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You also want one from each corner to the center.
This one is my first (right, top):

You might also notice that the color in your last
corner is much brighter, so let’s adjust the brightness
there. In this one, my bottom left corner is too bright.
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Click on the Fuzzy Select tool, set the threshold to
45, and also enable Feather edges and set them to
5. Holding down the Shift key, click once in the
corner:

Again, click on Select > None . This might be a good
time to save your work, if you haven’t already.
To make this look a bit more “glassy”, let’s add some
blur to soften some of the edges. Click on Filters >
Blur > Gaussian Blur and set the blur radius to 2.
Now it should look similar to this:

Keep holding Shift and click on all the light areas in
that corner until your selection looks similar to this:

Just in case you also have a corner that is too dark,
you can use the Fuzzy Select tool again. Set the
threshold to 30 this time. Just like before, hold the
Shift key and click until you have a selection like you
had before. It might be a little more difficult. If it
wants to select more than you need (like parts of the
center), set your threshold down a little bit and try
again.
This time set Brightness to at least 70 and
Contrast to 45. My upper left corner was very dark,
so I experimented a bit and ended up setting the
Brightness to 80 and the Contrast to 30, and mine
turned out like this:

Now duplicate the layer. (In your layers dialog, click
on the Duplicate Layer button.)
Making sure you have the top layer selected, go to
Colors > Desaturate.

Click on Colors > Brightness-Contrast. Set the
Brightness to at least -60 and Contrast to at least 20.
You might have to experiment to get your corners
closer to even. I ended up setting mine to Brightness
-75 and Contrast 30 (center, top).
When it looks closer to the other corners, then click
on Select > None to go back to the entire drawing.
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The layer will be gray, so now select Colors >
Colorize. Set the Hue to 100, and the Saturation to
60. This will give your image a nice green color, kind
of like old glass.

One last thing you can do is to lower the opacity of
the green layer to around 75 (in the Layers dialog),
so your background layer will shine through and
make it look like it’s reflecting colors through it.

This is one you can experiment with, substituting
other gradients (some don’t work as well as others!),
other colors in the colorize step and other gradient
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shapes. I tried one with the Radial Rainbow gradient
and did the first four gradient paths (clear across the
rectangle), then reversed the gradient and did one
path from the center of the rectangle to below the
image. Surprisingly, I didn’t have to lighten or darken
anything. Then I duplicated and desaturated the
layer, but then when I colorized, my hue was set to
360 and Saturation down to 40 or 50. I then set the
opacity of the layer to 90. Here is my result. Weird,
huh? Definitely not as “glassy”.

Screenshot Showcase

Posted by luikki, on February 1, 2020, running KDE.
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GIMP Tutorial: Make A Simple Animation
By Meemaw
Suppose you’re giving a speech and have
something you want to emphasize. You could make
a simple animation to help you out. I’m going to use
a graphic to help emphasize my point, so I’ll open it
in GIMP.

Now to create our text.
My text will say “WOW!
GIMP animation is easy!
Have Fun!”, but it will be
split into four text frames,
one for each layer. I’m
sure you can think of
some text you’d like to
use. Choosing the first
layer, create your text
frame and enter your
text.
Just
as
you
normally do, format the
font and size of your text.
When it appears as you
wish, choose the Move tool and position it. You can
see that the text layer is “floating” at the moment

What you didn’t see is me adding this clipart to a
larger page with a white background. I needed room
on the right for the words I’m going to add.
An animation is simply a multi-layered graphic,
saved as a .gif file, and configured to make each
layer visible for a certain length of time as decided
by you, the artist. It can have as few as two layers,
or as many layers as you want to make your design.
On this animation, let’s do four layers.
We’ll start by duplicating this layer three times, so
the pointing finger will be constant throughout the
animation. In the Layers dialog, click on the
Duplicate layer button three times. The only place
you’ll be able to see the copies so far will be in the
Layers dialog (top, center).
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To position your successive text frames, you can set
the layer transparency on the finished ones to a
lower value, so you can see the layer below it. You
can also move the text frame you’re working on to
the top so you can compare it to the top text, then
move it back down when you have it positioned.

in the title you want. This might be a good time to
save your work, if you haven’t already.

While you are changing the layer names, you can
also put in the frame delay. Simply type an
expression similar to the following after your layer
name: (1000ms) . You can see I have that above in
my layer names. With this in each “layer comment”,
the animation will change frames every second. If
you want it longer, just increase the time in ms. You
can make it change every two seconds by using
(2000ms) rather than (1000ms). At the last minute, I
added another frame to mine. It has a GIMP logo,
and I made its delay 3000ms.
To check if it looks good to you, click on Filters >
Animation > Playback. You will see a new window
with your creation, and can press the play button to
see how it looks.

Something I have learned while doing this animation
is that your text has to be in order from last to first
(my “Have Fun!!” is at the top of the layer stack and
my “REMEMBER!!” is at the bottom for it to play
correctly). If you have trouble knowing which layer
has which text, you can always rename each layer
by double-clicking it in the Layers dialog and typing
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You now need to save your animation as a GIF. You
can go in and optimize your file first, if you want to.
There are two ways listed in GIMP: Optimize
(Difference) or Optimize (for GIF) . Difference
works by using the background on the bottom layer
for all frames, and removing the rest, leaving the text
boxes and other additions intact. Optimize for GIF
works much the same way but includes a size
reduction. However, if your gif isn’t very big in the
first place (mine is only 800 x 400 px) file size won’t
be too serious. The biggest mine turned out was
66.4KB, and that was with no optimization. The
optimized ones were around 36KB. If you start a
bigger canvas, it will probably make a big difference.
There is also a choice for no optimization.

you only want it to play once, you can uncheck that.
“Frames disposal where unspecified” choices are
combine or repeat or I don’t care. If you had
optimized your file, that should be covered already.
You can change your frame delay if you set it above
and click the box that says “Use delay entered

above for all frames”. However, we already set ours,
so we won’t check that either, or the frame disposal
box at the bottom. You can do a lot from this window
if you need to change something at the last minute
before you export. My animation turned out well! You
can view it here.

Screenshot Showcase

Now you can choose File > Export, and name your
animation using the file format gif. When you do that,
you will get a new window asking if it should save
the image as an animation. This is exactly what we
need. In the window, you have some checkboxes to
specify what you want.

The box “As animation” HAS to be checked, of
course. The frame delay was set in your Layers
Dialog, but if you hadn’t done it there, you can do it
here. Loop forever means play over and over, so if
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By Meemaw

GIMP Tutorial:
Six Awesome GIMP Add-Ons

I have been visiting a site called Gimp Chat over the
last year, and have discovered some VERY talented
Gimp users. There’s a family there as well (kind of
like our forum family). Someone will post a photo or
some artwork, and invite everyone else to try some
editing. The results are amazing! Many of them are
experts at writing scripts and plugins for Gimp.
These scripts take the steps for a certain effect and
roll them together so all you have to do is change
some settings and get your desired result. I thought I
might take this opportunity to share a few of them
with you. Ed. NOTE : Many links have been updated.

member named Rod, who experimented with the
steps needed for the effect, and dinasset wrote the
script. It takes your photo or drawing and converts it
to a “Roman-style” mosaic. Here is a tulip I
photographed on vacation, with the filter done on it.

Reflect on Ponds

(Pack 8)

Dinasset created this one as well, used to simulate a
pond where the original photograph had none. This
is a photo from a vacation in Colorado, and I added
the pond to a grassy valley area. The filter adds the
ripples and the reflection.

NOTE: These are small files that you place into your

/home/<UserName>/.gimp-2.8 folder, either in the
scripts or plug-ins folder. Since they only run when
you activate them, and are only in your /home folder,
they shouldn’t cause any system problems. One
member named GnuTux created the website called
GIMPScripts and that is where nearly all these
scripts are posted. In addition to Gimp Chat, many of
the members have joined another forum called Gimp
Learn. The same activity happens there, but with a
slightly different set of members. GIMP Chat was
closed for a while recently (server issues, I believe),
so GIMP Learn was REALLY active for a while.
Some of the most fun I’ve had is with effects that
have changed a photo of mine into some sort of
abstract image, or use the text I have typed and
make it truly fancy with very little effort.

Mosaic Lyle Style

(Pack 10)

A member of GIMP Chat known as dinasset created
this filter, saying, “This filter has been inspired by
Lyle’s experiments on Mosaic creation, posted on
Gimp Chat”. One of the Gimp Chat threads was by a
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Bling Text Logo

(Pack 1)

GnuTux created this one, saying, “Bling Text Script
V2.0 allows you to create animated “Bling” (sparkle)
text with an added drop shadow & background.” The
bling won’t show up in the pdf or ebook versions, but
viewing it in the html version of this article will show
that the purple part of the text also has sparkles.
This particular one of mine has no shadow.

Chewed Text
Member Rod created this one. Depending on the
patterns you choose, your text will look slightly
uneven or “chewed” around the edges.

Jamack Sketch

(Pack 2)

This filter takes a photograph and creates one or
three sketches from it. If you choose three, each has
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different characteristics: one is an almost colorless
sketch, one emphasizes the darker areas, and one
is colored closer to the original. This one is the
nearly colorless copy of a photo of our wonderful
editor and his beautiful wife.

Lots of really fun add-ons can be found on Gimp
Chat! Take the time to register and visit often!

Crazy Tone Map

(Pack 2)

Dinasset created a wonderful add-on that is very
useful for enhancing photographs! You load your
photograph into GIMP, and then apply this add-on. It
has several settings so you might have to
experiment to get the effect you want. So far I have
found excellent results from this one! You can
choose a low impact or high impact from your script,
and choose different nuances to bring out the color
you want. Here I just wanted to accent the
vegetation a bit more. (center, top)
The original is the top photo, and you should be able
to see that the green vegetation is brighter in the
second.
The forum is great because everyone helps by
testing and using the add-ons and posting their
result and comments. This always results in better
versions of the add-ons. There is also one called
Add Gimp Decor that will add a “Created using
GIMP” text detail to your creation. I put one in the
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bottom right corner. Decor would be a valuable tool
to add your own personalization. Oh, I also used an
add-on called “Render Snow”. (top, right) Add GIMP
Decor is Pack 1 and Diego - Render Snow is Pack 3.

(Oh, by the way, this post on Gimp Chat contains
directions to add new splash screens to your Gimp,
if you want to. Some of the members have even
shared some.)

These sites are very valuable Gimp resources for
me;
http://gimpchat.com/
http://gimpscripts.net
http://www.gimplearn.net
Several of the members have posted sites where
their artwork/creations are displayed. Feel free to
see the awesome artwork!

GnuTux
Griatch
Trandoductin

http://gimpscripts.net
http://griatch-art.deviantart.com/
http://www.gimplearn.net
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GIMP Tutorial: Using The Cloning Tool
To Edit Photos, Again
by Meemaw
In the December, 2012 issue of the PCLinuxOS
Magazine, I did an article about photo editing which
centered on removing unwanted items from your
photo. This uses the Clone tool, which is different
from the Clone menu in Inkscape. Inkscape’s Clone
tool is used to make exact duplicates of an object,
while the Clone tool in GIMP allows you to cover up
an imperfection in a photo with something that will
blend with the surrounding features.
In my original article I used the Clone tool to remove
a traffic sign from a photo, replacing it with the
appearance of the surrounding vegetation. In this
article we will explore ways to make this a bit easier.
One of the forums I used to frequent was the Linux
Graphics Users Forum, which I’m sad to say has
disappeared. However, one of the members posted
this list of suggestions for cloning:

A few things that I have found helpful when cloning
are : -• Select the area to clone over to avoid having to go
so carefully near the edges.
What this means is that you can select an area you
want to clone (or one you don’t want to clone). I
have a photo of my mother that was damaged years
ago. I repaired it in an earlier GIMP article as well,
but let’s do something different. This time I used the
Scissors Select tool to draw around her so I can
clone in a different background (center, top).

• You should make sure you have the selection
pretty close to what you want to keep.
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I zoomed in to make sure things like lips and
eyebrows were selected smoothly, then when I’m
satisfied, I press Enter, and the selection is shown
(top, right).

background, I’m going to choose Select > Invert.
This will choose the background and allow me to
use the clone tool without worrying that I’m going to
cover her image with a color I don’t want.

• When backgrounds blend into the edges around a
person. Selecting them, enlarging the selection by
one or two pixels and then cloning around the edges
helps clean the edges.

Also, in the clone tool properties, you can choose an
area of the photo to use for your clone (we already
knew that), but you can also choose a pattern to
clone in. If you have some patterns you think would
make a good background, try one and see. You
might have to try a few before you find one you think
will work best. Notice you can swipe quite a bit with
your mouse and the selected area will be the only
part affected (next page).

Before I started on anything else, I did Select >
Grow and grew the selection around her by 1 pixel.
Since I want to keep her and clone in a different
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While I was doing that, I also cloned over the places
in the photo that looked cracked.

This is a tip you probably already know, but possibly
haven’t thought about. It’s really easy to switch back
& forth between one change and the previous one to
see which looks better.

Then I cropped the photo and saved it as a GIMP
.xcf file.

• Stopping and starting frequently avoids having to
undo too much at once, but sometimes it pays to
start in the same position for each addition to keep
the same reference point while extending the
coverage.
When you are finished with the background you
want, choose Select > None to get back to the
whole picture.

• Magnify up to the pixel size for final tuning-up in
important areas, such as around a face.
I did some fine tuning around her cheek and her lips,
then found this big lump on the sleeve of her blouse
(center, top). For this, you need to zoom in close and
make your brush small, like 10 pixels, and stroke
very carefully.

• Use 'Ctrl + Z' to quickly undo the last change(s)
and use 'Ctrl + Y' to put them back. Alternating these
commands lets you quickly evaluate which is the
better of two views.
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Sometimes I get into what I’m doing and draw
several changes without stopping or even releasing
the button on my mouse (it’s easy to “color” with
your mouse for several strokes), but if you are doing
something more delicate, it will be better to use short
strokes and release the mouse button, then look at
what you have. If you’ve gone too far, then you won’t
lose as much progress when you undo something
you don’t like.
While I was at it, I cloned in the bottom right corner
and completed the corner of the photo that had been
torn, and fixed her blouse, using other areas of her
blouse to match. Remember, if you are using the
photo to choose the clone “material”, you position
your mouse over what you want to use, then hold
down the <CTRL> key and click.
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• Run the blur tool over the cloned area, especially if
it is sky/clouds, to remove unnecessary detail.
I also felt that the edges of her face and hair seemed
way too sharp, as if they had been cut out with
scissors. (and of course, they had.) To remedy this, I
used the Blur tool (looks like a water drop) along the
edges (very lightly) to smooth out the places that
were cut out in the first step.
After that, I exported it to a photo format.

I’ll have to try it again. Just like with any project in
GIMP, if you don’t like your first attempt, you can
always start over (as long as you are working on a
copy of your original and not overwriting the
original.) I didn’t like the original background but
saved a copy of the one I fixed, and I’m still
considering the background on this one.
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GIMP Tutorial: Add Rain To A Photo
by Meemaw
GIMP does all sorts of special effects! You can take an ordinary photo and add or
subtract almost anything using GIMP. This month we’re going to make it rain in an
otherwise clear photo.

the Angle to eighty, but you can experiment with these settings to produce the
result that you think looks best. Higher Length values will make it look like harder
rain and different Angle settings will make it look like the rain is coming from the
other direction or driven harder by the wind. Click OK when you're happy with the
effect.

Choose the photo you would like to use. Create a new layer filled with black. This
is the layer we’ll use to make the rain. Go to Filters > Noise > RGB Noise and
uncheck Independent RGB so that the three color sliders are linked. Click on
any one of the sliders and drag it to the right so that the values of all the colors
show a reading of about 0.70. The Alpha slider should be clear to the left. When
you've selected your setting, click OK. The layer will now look kind of like it’s
snowing, but we have more to do.

With the rain layer still selected, click on the Mode dropdown menu in the Layers
palette (at the top) and change the Mode to Screen .

If you desire, you can use different settings for this step. Generally moving the
sliders further to the right will make the rain appear heavier.
Ensuring that the speckled layer is selected, go to Filters > Blur > Motion Blur
to open the Motion Blur dialog. Ensure that the Blur Type is set to Linear. Then
you can adjust the Length and Angle parameters. I set the Length to forty and
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I know the rain is hard to see so far, but the next step will help considerably. Go
to Colors > Levels and check that the Linear Histogram button is set (red circle
at right) and that the Channel dropdown is set to Value (red oval at left).
In the Input Levels section you will see that there is a black peak in the
histogram and three triangular drag handles beneath. First, drag the white handle
across to the left until it is aligned with the right hand edge of the black peak.
Now, drag the black handle to the right and check the effect on the image as
you're doing this (make sure that the Preview checkbox is activated). You can
move these handles back & forth until you get what you want. I actually had to
move the white handle back to the right a lot to get the effect I wanted.

When you're happy with the effect, you can drag the white handle on the Output
Levels slider a little to the left. This reduces the intensity of the fake rain and
softens the effect. Click OK when you're happy with your result.
It may look the way you want it, but if not, there are a couple more things you can
try. You might also go to Filters > Blur > Gaussian Blur and experiment with the
Horizontal and Vertical values, and see if that makes any difference. It didn’t
seem to on mine.
One last thing you can do is select the Eraser Tool from the Toolbox and select a
large soft brush in the Tool Options, and reduce the Opacity to 30%-40%. Using
the large brush, stroke a few areas of the rain layer make it look more varied and
natural (right).
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Also, if you feel like you have messed up thoroughly and just want to start over,
you can always just delete that layer in the Layers dialog. You will be left with
your original picture, free to have another try. If you like it, be sure to Export it
with a new file name so you still have your original photo.
This is the process to use if you want a lot of control over your creation. However,
if you want rain quickly, you can use the GIMP filter Render Rain written by our
friend dinasset over at GIMP Scripts. It is a one-step script that does the rain
quickly (next page). NOTE : the render rain script is in Pack 3 at GIMP Scripts.
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GIMP Tutorial: Exploring G'MIC
by Meemaw

Generally, starting out with one of these filters, I just
use the default settings, then start “tweaking” to see
if I can get a better outcome. Most of the time
(depending on the photo), the defaults are right for
the result I’m looking for, because I’m sure that in
developing the filter, the author has spent many
hours figuring out the settings that give the best
result. So, using the photo of the windmill, and using
the filter Details > Tone Enhance , we get this result:

GIMP has many wonderful filters you can use to
enhance, fix or wildly change your photos, and more
are being developed all the time. If you click on
Filters, you will see one that says G’MIC at the
bottom of the menu.
The letters stand for GREYC’s Magic for Image
Computing , and you can get G’MIC as a plug-in for
GIMP or Krita, a command-line interface that works
with ImageMagick or a stand-alone online program.
It is available for Linux (and Windows), and is in the
PCLinuxOS repository.

carefully chosen and used, can enhance your
photos. There are also many that will give you some
really different outcomes. I’m going to be using
G’MIC on the two following photos, both of which
were taken in Colorado a couple of weeks ago.

From their website:

G'MIC is a full-featured open-source framework for
image processing, distributed under the CeCILL
license. It provides several different user interfaces
to convert / manipulate / filter / visualize generic
image datasets, ranging from 1d scalar signals to
3d+t sequences of multi-spectral volumetric images,
thus including 2d color images.
After opening a photo in GIMP, click on Filters >
G’MIC. You’ll see the following window (top, center):
Let’s see a few of the effects that you can do with
G’MIC. I am not an expert, but many of the effects,
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It seems to sharpen it up a bit.
If we use the Light & Shadow > Equalize Shadow
instead, it seems to make it a bit more dull with less
color (next page, top left):

As you saw from the G’MIC window above, there are
MANY categories with many filters in each, so I will
describe them by the section and filter name so you
can find them if you want to play.

Both of these could be useful, depending on what
your photograph looks like. If it’s really bright and
you want to tone it down a bit, the Equalize Shadow
may work very well.
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Glow

Mine came out like this:

Testing section,
Psychedelic Glasswork,

For something completely different, you can use
Black & White > Threshold Etch . It made this
photo look like a wood carving:

gives a glow effect to the photo. If yours is
dark, this may bring out highlights.

For a really different look, I also tried the filter called
Artistic > Pen Drawing . It gives a totally different
effect.

under Photocomix >
you can get some
interesting effects. Go to the layers dialog and
duplicate your layer first, then perform the filter on
the top layer. Before you click OK, go into the
settings for that filter and uncheck Activate Mirrors.
When you are finished, change the layer mode to
Overlay. You’ll find that your layer mode will make a
difference as well.
In the

Using the photo of the Aspen trees, I tried more
G’MIC filters. One called Light & Shadow > Light
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Not all of the filters in G’MIC just accent a photo:
some of them give you something wild. I used this
tiger photo, and did a filter called Artistic >
Rodilius. You can see the result below the original.

DOWNLOAD

Mate Desktop

Screenshot Showcase

This article has barely scratched the surface of all
the filters you can find in G’MIC. I hope in your
experimentation, you find some more awesome
effects!
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Posted by ms_meme, on June 5, 2020, running KDE.
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GIMP Tutorial: Exploring G'MIC, Part 2
by Meemaw

After applying the filter, we get this result:

I hope you had fun exploring G’MIC a couple of
months ago. We are going to do a few more this
month, to illustrate how versatile G’MIC really is. If
you haven’t tried it, I urge you to do so at least once.
There are literally dozens of effects located there.
Let’s get started!
The first thing I want to do is give you a bit of a
warning. NOTE - the bigger your photo is, the longer
G’MIC will take. Some of the G’MIC commands take
more time to accomplish as there are several
commands in the filter. I’m telling you this because a
complicated filter will slow down an older/slow
computer, and you should be prepared for it.
Our first filter is called Artistic > Dream Smoothing .
I took this photo of a grave I saw on one of my 4wheeler rides this summer (believe it or not, there
are a few graves in the national forest, along one of
the riding trails):

Another filter, Artistic > Brushify looks a lot like the
first filter above, only not so bright:

In an article from November, 2014, Khadis showed
us how to create puzzle pieces in Inkscape. In GIMP,
we can use the G’MIC filter Arrays & Tiles > Puzzle
to create one from a favorite photo. Using the
following scene, I applied the filter.

Artistic > Graphic Novel

kind of sharpens up
everything and makes it brighter than the original
(next page, top left):
I could print this out and actually make a jigsaw
puzzle with it:
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Another effect is Black & White > Pencil Portrait
which is kind of like making a pencil drawing. You
can choose the color, but sepia is the default.
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Rendering > Neon Lightning

is a bit different, but
still fun. You can change your color settings here
and have it green, orange or red if you want:

Warning : this one takes a few minutes.

a white square. These would be useful if you need
some sort of crazy background, or even wanted to
create a zany wallpaper.

Rendering > Circle Art is kind of fun (this one takes
a minute or so). Changing some of the settings can
alter the nice symmetrical appearance I have going
here.

I’m sure there are well over one hundred filters in
G’MIC! Some of our friends over at GIMP Scripts
have added more as well. Your creativity is only
limited by how willing you are to experiment. Just as
a reminder, your results may vary greatly from mine.
The more you alter the settings in each filter, the
more different your photo will look. I stayed with the
defaults most of the time. I’m sure you can make
something truly amazing.

Donate NOW
This next one is something you might use to edit
your photo. Details > Sharpen (texture) seems to
help sharpen it, and it might be useful if you have a
photo that’s just a bit fuzzy (center, top).
Then, if you want to have a bit of fun, we can open
the Rendering section and play! Start with a new
project with a white background. I started with
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Inkscape Tutorial: Creating A Personal Calendar
by Khadis
Hurray! The new year is here and there must be a lot
of wishes, right? How was your party to welcome
this new and “fresh” year? I do hope that the party
was awesome and cheerful.
In this edition, I would like to show you a little trick to
improve your creativity in using Inkscape. As we
know, Inkscape has some superiorities compared to
the similar graphic design software. The extensions
module is one of the superiorities that its competitors
don’t (always) have. One of the modules collection
I’d like to use is “Calendar,” which will help us to
create an instant personal calendar. Now, let’s go!

3. Import an image (Ctrl + I ) to be used as a
background. I picked a random image collection in
my computer. Of course, you can find better
image(s) over the Internet. Set the image as large as
(or bigger than) your rectangle. Put it in front of the
rectangle, select all (Ctrl + A), and then go to Object
– Mask – Set. The image should now be inside of
the purple rectangle. You can set the opacity lower
than 100% to get better color (Ctrl + Shift + F ).

4. Go to Extension – Render – Calendar menu.
The Calendar window will appear in your screen. It
has some parameters that you can adjust, such as
the year number, number of month in each page
(e.g. 12 months per page for 1 page calendar, 6
months per page for 2 pages calendar, etc.), the
starting weekday and weekend, the months and
days name in your local language, etc. You can
activate Live Preview to get the preview before you
apply your settings.
5. I set the parameters as follow (Indonesian style,
especially the starting week day and the name of the
days):

1. Start your Inkscape engine and then create a
landscape document with your own preferred size
(File – Document Properties or Ctrl + Shift + D ).
Mine is A4 landscape.
2. Create a rectangle with the same size as the
document size (29.7 cm x 21 cm). Color it with
purple (or any color you like).
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6. Click Apply and Close . Resize to fit the page
and make it center on horizontal axis (Ctrl + Shift
+ A).
7. If you want to change the font type or edit a
single object inside of the calendar, e.g. to edit the
year number’s font, just double click your calendar,
then double click the year number, then change the
font type/color/size. Each double click will
“temporarily” ungroup your calendar into single
editable object.

Note: In this part, you can set the color by seeing in
the color bar. There, you will see the name of the
color and the pattern (e.g. green = #008000, red =
#FF0000, etc.).

8. Create another rectangle as a background of
each month. I chose white color with 66% of opacity.
Duplicate it (Ctrl + D ) and resize it (see the picture
at top right) and give different color. In this case, I
chose green.

9. Make these two rectangles’ corners rounded by
using Edit paths by nodes tool (F2). After that you
may group them first, or just select them, then move
them lower (behind the calendar item) using Page
Down button on your keyboard. You may need to hit
the button twice or three times. Or you can select
the calendar item then hit Home button so it will
directly on top of all the objects.
10. Duplicate these rectangles and put them behind
the other months (right).
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11. You can then put photos, create decorations (by
combining circles, rectangles, stars, hexagons, etc.),
or place texts (next page).
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by Meemaw

Inkscape Tutorial:
Creating A Feathered Background

to the clipboard using Edit > Copy (or <CTRL> + C).
With the Path Effects dialog open, choose Pattern
on Path from the dropdown, then press the Add
button

Many of the wallpapers and Impress backgrounds I
have seen seem to have a kind of “whispy” or
feathered background. Solid colors are nice, and so
are gradients, but this tutorial I found gives us
another option. We will use Spiro and Clones in
Inkscape, along with a few other skills we have
learned along the way. In this one, I went into
Document Properties and unchecked the page
frame and shadow checkboxes at the bottom so I
have lots of room to work without seeing the page
outline in the background.
First, click on the pen tool. In the tool config at the
top of your window (shown below), click on the
Spiro tool, then draw a curved path with 5 points.

In the Path Effects dialog, click the clipboard icon to
paste the triangle we copied there. The triangle is
the pattern (“brush”) we are putting on our path (the
spiro). Your spiro should now look something like
this.

Click on Path > Path Effects to open that window.
You will see that the Spiro spline is already present
in that window as it is a default in Inkscape now.

All segments should be curves. As soon as you
finish the curve, it will change to a spiro curve.

Now, we will unset the fill and the stroke of the
tapered curve that we are going to use. Right click
on the “None” label next to fill in the bottom left
corner, and choose “Unset Fill” from the menu that
appears. Right click on the black box next to stroke
in the bottom right corner, and choose “Unset
Stroke” from the menu that appears (next page, top
left).
Next, we will add a triangle “brush” to our spiro curve
using the Path Effect Pattern on Path . Using the
pen tool, draw a triangle. While it is selected, copy it
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Next, we need to clone our path, move the clone
away from the original, change the color to
something other than black, and duplicate it several
times. Select the path with the select tool, then make
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The curve selected is the clone, and I’m going to
separate them more. Change the color of the clone
either with the palette at the bottom or the Fill /
Stroke dialog. Only the clone should change color. If
both objects change, you are probably changing
the color of the original and you should grab the
other curve and work on it instead. Shown below,
the clone is the only one that changed color.

ONE clone of it, using Edit > Clone > Create Clone
or ALT + D . Separate your clone from the original
curve so you have room to work.

With the 30 clones still selected, open the Fill /
Stroke Dialog , and lower the opacity of the clones.
The tutorial used 30%, so I did too.
Duplicate the colored clone 30 or so times using
Edit > Duplicate or CTRL + D . Now, we are going to
use the tweak tool to jitter the position of our 30
clones, as well as jitter some the saturation and
lightness values of the clones.
Using the select tool, click and drag around the
clones to select all 30. If you aren’t sure, look in the
status bar at the bottom of your window, which
should say something like “30 Objects selected….”
Click on the tweak tool in the toolbox, then look at
the configurations across the top of your page. The
Tweak tool has three modes for moving objects but
you want Move Objects in Random Directions .
Now click and drag the tweak tool over the clones
and watch them move. If they don’t look like they are
moving much, you may need to play with the Width
and Force values of the tweak tool. I used 25 for
Width and 20 for Force. The selection outline of the
objects will disappear when using the tweak tool, so
you won’t see all the dotted lines around everything.
Your end result should look something like this (top,
right):
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With all clones still selected, go back to the Tweak
tool, and this time set the mode to Jitter Colors .
Make sure the only 2 values checked/toggled are
Saturation and Lightness. On my desktop the
channels show as toggle buttons in the toolbar,
since my screen is wider. In a smaller window they
will be hidden in a dropdown. Click and drag over
the clones and watch their colors change slightly. If
they change too much, consider tweaking the Force
value.
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If we want to, we can play with the original that all
our clones are based on, as well as our triangle
“Brush”.
Select the black original, and change to the node
tool. The familiar node editing handles should
appear. Move the nodes of your spiro to make a
better curve. Notice that your creation will update
with the changes to the black original path. Play
around with it until you get something that you want.

You can also change the “Brush” we used to create
the curve design. Click on the Show Pattern
Source button in the Path Effects dialog, and
somewhere on the Inkscape canvas, your triangle
should appear (you may need to zoom out to see
where it appears. if it is far from your drawing, select
all 3 nodes and move it closer.)

Now, you can finish this one of two ways. You can
draw a rectangle over the area, and use a clipping
path to create a rectangular background, or you can
go back to Document Properties, make your page
visible by checking the page border checkbox, place
your finished texture over it and export the PAGE as
a bitmap.

Can you see my triangle? Now, using the node tool,
edit the triangle shape, adding and moving nodes.
Your changes should update as you go on the black
original path, and also the blue clones. Cool, huh?

After I finished the background, I then used it to
create a background for a LibreOffice Impress
presentation.

Let’s do a bit more. Group your clones together, then
duplicate the group 2 or 3 times, rotate each one a
bit, and change the opacity of each group. When I
got close to what I wanted, I found that I wanted it a
bit more blue with less white, so I duplicated the
whole grouping once more.
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The great thing about this project is that you can
always go back and change the curve, or the brush
(or both) and the color and have another feathered
background to use for whatever you want.
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By: Khadis

Inkscape Tutorial:
Creating A Water Drop Illustration

Creating a water (or blood) drop or splash in
Inkscape is radically easy and simple. If you are
going to create it, you just need one tool to do it.
Let’s go!

• Still using Tweak tool, click and drag several times
on the edge (including “undoing” if you get bad
result) so the result will be like this (yours may be
better):

• Open up your Inkscape and create an oval of any
size and any color using Circle tool (F5) .
• Grab your Tweak tool (Shift + F2 ) and activate
Push parts of paths in any direction option. Here
are some of other parameters that you can set:

• Do tweaking again for other parts. You might need
to do a circular movement or drag calmly and gently.

• Click and hold any side/part of your oval, then
drag it out. On my example, I dragged out the upper
part. Your first result on the edge might be like this:
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• Here are some of my creations. Not so good, but I
am sure that you’ll be inspired to create the better
and realistic one:
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• To get different effect, you can always change the
width of tweak area and the force value. You can
also switch from Push parts of paths in any
direction to Shrink (inset) parts of paths option.
• For the next touch, you can duplicate (Ctrl + D )
the object, give it a different color (I chose the darker
color), add a stroke, send it to back, and move it
some millimeters to create a shadow effect.

• I used the Impact font, while you can choose your
favorite font. Resize it to fit your main object.
• Then, I rotated the text, duplicated it and picked a
darker color for the duplicated one, and also moved
the duplicate to higher position. It will give a shadow
effect too.
• If you think that the text isn’t good yet, you can
modify it by giving it a “shattered” effect. Here is
how:
• Type your text. Then, by using the Bezier tool
(Shift + F6 ) create some objects (example: triangle
or any random shape), and put them above the text,
similar to the picture below:

• Then, do Difference (Ctrl + - ) operation by
clicking on the Bezier object, then hold your Shift
button, click on your text, and press Ctrl + - .
• You can also put text above the objects like this:

• Apply the text to your water drop object.

Support PCLinuxOS! Get Your Official

PCLinuxOS

Merchandise Today!
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Inkscape Tutorial: More Tools
by Meemaw
I had already thought that we needed to cover more
of the tools in this wonderful program, but suddenly,
here is an update which has even more tools! The
toolbar on the left has one more item now, and some
of the tools we already have contain more features.
Now we have even more to explore.
The newest version of Inkscape is version 0.91 and
is available in Synaptic. Some of the tools have
been enhanced with extra features. Let’s explore.

Improved Import
Many of us import images to work with in Inkscape.
The old Import window asked only whether we
wanted to Link or Embed the imported image. Now
the window is bigger and asks more questions:

the resolution in the object you are importing, or the
default resolution from your preferences (under
Bitmaps). Also, you can choose how something is
imported by changing the Rendering Mode to
optimize quality or speed. So far, I have kept the
defaults shown above.

Ruler Tool
The new left side toolbar has an
additional item: the ruler. Here you
can see a comparison of the toolbar
before (left) and after (right) the
update. Measuring is easy. Place
your cursor on one end of the item
you are measuring and drag to the
other end, holding down the mouse
button until you are finished reading
the measurement. I experimented a
bit, and holding the left button down
plus doing a right-click will keep the
measurement display there temporarily. You will get
a drop-down and can left-click once to close it, and
your measurement will stay until you left-click away

from it. This is handy if you need to measure
diagonally, since the top and left rulers don’t do that.
It will also give you an angle measurement. Notice at
the top of the drawing you can change the size of
the displayed text and also the unit of measure.
When I was thinking about what to cover in this
article (since Inkscape has so much), I was already
going to cover the Tweak tool. It hasn’t had any
additions this time, but it already has several
features that make it fun to use.
When you click on the Tweak tool, the upper bar
looks like this (below), and each item does
something different.

We used the Tweak tool a couple of months ago to
do our feathered background. However, the bar
above has more than just the two modes we used.
Some are self-explanatory, but going from left to
right, the modes are as follows (items in parentheses
occur if you hold down the <Shift> key):

Move objects in any direction

- if you move the
area under the tool to the right, your objects will all
move that direction

Move objects towards (or away from) the cursor We are still asked whether we want to Link or
Embed the image, but now we are also asked about
the DPI (resolution) and Rendering Mode. It will use
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if you place your cursor over the selected objects,
they will all move towards (or away from) your
cursor.

Page 51

Inkscape Tutorial: More Tools
Move objects in random directions - we used this
one in our feathered background to move the
duplicates around a bit

Shrink (or enlarge) objects

- you can make many
duplicates, then select some and resize them
smaller (or larger)

Rotate objects clockwise (counter-clockwise)

You can rotate things as little or as much as you
wish.

Duplicate objects (or delete objects) - This is an
alternative for the Duplicate command <CTRL> + D .

Holding the Shift key down will delete some of the
selected objects. Caution! If your Force setting is
higher, you can create bunches of duplicates pretty
fast. I left my Force setting higher while I was using
this tool, and ended up with 358 duplicates in about
two seconds!

Push parts of paths in any direction

- Generally,
when I am moving parts of paths, I am concentrating
on a certain path, but depending on your creation,
you might be able to do several at once.

Shrink or inset (grow or outset) parts of paths
Attract parts of paths toward (or away from)
cursor
Roughen parts of paths
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Paint the tool’s color upon selected objects
Jitter the colors of selected objects

- Jittering
colors changes them just a bit, so if you have
several objects that are the same color, you can use
this jitter tool and end up with several shades of the
same color. If your Force setting is up, it’s possible
that several blue objects could end up a bit closer to
purple.

Blur objects more (less)
Looking at the Tweak tool bar, the first two settings
are Width and Force . They are fairly selfexplanatory, with Width being how big an area you
want to affect, and Force being how much of an
effect you want to make. As an example, if you want
to use the third tool (move objects in random
directions), your Width should be big enough to
cover the majority of the objects you want to move.
Your Force needs to be set depending on how much
you want to move your objects, using a small setting
for minimal movement and a larger setting for more
movement. Also, remember that the Tweak tool will
only affect objects that have first been selected with
the Select tool.
As you move your cursor over your object(s), the
tweak tool will carry out the desired operation, but
you will have to practice with this tool a bit to get
your desired result. Remember, you can always
undo it if you don’t like the result.

Align & Distribute Plus?
Another new feature is in the Align and Distribute
tool. We have always used the first two tools, Align
and Distribute, but I don’t remember the Rearrange
tool. With it, you can do a few more things to make
your work easier. Actually, the rearrange tool has
items that the old Align and Distribute tool window
had elsewhere. You can see the difference between
them shown below with the newer one on the right:

Gradients
The gradient tool works the same way, but here is
where a new feature has been added. When you
create an object, and click on the gradient button in
the properties window, you now get an open window
which will list the gradients you have used in your
drawing (plus how many times it has been used).
This is nice because you can choose a particular
gradient you have already created and won’t have to
create it again (right, top).
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As you can see, there are three additions to the
window and they are grouped under the section
“Rearrange”.
From left to right, the buttons are:

Exchange positions of selected objects stacking order: This will exchange the positions of

your objects while retaining the order in which they
are “stacked”. Whatever object is at the bottom will
remain there.

Nicely arrange selected connector network: This
will “auto-arrange” the items you have connected. I
started with the array on the left with connectors
running from bottom left to bottom right (Orange,
blue, gray, red, blue, purple, blue, purple, gray).
When I selected the group and push this button,
they changed to the arrangement on the right. This
is not to say you will like the way that Inkscape
arranges them, but it will be different. Remember,
Undo is still <CTRL> + Z.

Unclump objects: try to equalize edge-to-edge
distances: This will try to move your objects apart a
bit, but possibly still overlapping.

With the ability to exchange and rearrange things,
your design should be easier to manage.

Edit Menu Addition
There is another new tool from the edit menu, and it
will be really useful if you need to change something
in multiple objects. Let’s do color first. Select an item
of the color you want to change, then choose Edit >
Select Same > Fill Color. Each item of the same
color as the one you chose will be selected. Now
you can change the color of all of them at once. (I
changed all the green squares to purple.) The menu
item Select Same also has four other options: Fill
and Stroke, Stroke Color, Stroke Style and Object
Type. This should make your work easier.

Exchange positions of selected objects clockwise rotate: If you choose more than two
Exchange positions of selected objects selection order: This is a neat tool you can use
while arranging things the way you want them in
your drawing. A few months ago, I was doing an
image with text and realized that two of the text
boxes had been placed wrong. With this tool, I could
have selected them both and clicked this button,
which
would
have
interchanged
the two text
boxes without
any effort on
my part. As you
see here, I
exchanged the
gray
and
orange boxes.
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objects and click this
button, the objects will
be
moved
in
a
clockwise direction. In
the series below, I
chose all eight objects,
and you can see how
the
colors
move
around.

Randomize centers in
both directions: This
will move your objects
so the centers are at
random distances. The
result may not be what
you want, but you can
undo it and try again, or
not use it at all (right,
top).

While we didn’t actually complete a project, I hope
you have a better understanding of the new tools
present in Inkscape and how they will make your
artwork easier to do. I always look forward to seeing
any of your projects, and I hope you have enjoyed
creating them.
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by Khadis
As we know, it's now getting easier to create a
design in Inkscape. Moreover, Inkscape is now
equipped with a symbol library, which will make our
designing process much easier and faster. This time,
I want to show you how to use items in the symbol
library to create a city map.
As usual, please open up your Inkscape and set the
paper size as you want. I use landscape A4 and use
cm (centimeter) as the unit. Please look at
Document Properties (Shift + Ctrl + D ) to ensure
that the paper size meets your need.
Using the Rectangle Tools (F4), draw a rectangle of
your preferred size and fill it with 60% gray color.
Before we continue, it will be better if you have
already had a concept of your city map.
Assuming that that you already have the concept,
you are totally ready to continue drawing the map.

Drawing a city map is quite easy. We only need
several modified rectangles (which I gave a light
green color) and some circles with different sizes as
the ground, buildings, lake, etc. I also put some
shapes and built-in symbols taken from symbol
library.
I started by drawing a rectangle and modified it a bit
using Path – Object to Path (Shift+Ctrl+C) menu.
You can duplicate (Ctrl+D ) the rectangle as much as
you want and modify them using Edit Path by
Nodes (F2) tool. You might want to modify some of
the rectangles into trapezoid or other “irregular”
shapes, and it's OK to do so.
Next, zoom to one of rectangles and create a small
circle above it. Convert it into path by using Path –
Object to Path (Shift+Ctrl+C) and grab your Edit
Path by Nodes (F2) tool. Add one or two more
nodes, then click and drag them to create tree-like
shape. Give it a dark green color, and duplicate it
(Ctrl+D ). Put the new (duplicated) shape randomly
and you may change some of them to a different
color, too. Do the same step to create the “lake”
shape.

Draw circles, convert to path, and make
small adjustments
For the other rectangles (or other land shapes), you
can do the same steps.
Assuming that you have filled all the town parts with
“pool,” “lake,” and “trees,” let's access the symbol
library by pressing the (Shift+Ctrl+Y) button. There,
you will see some categories. Just point your mouse
to the United States National Park Service Map
Symbols category on the available drop-down
menu.
Search the symbol(s) that you want to put into the
map by clicking and dragging the symbol out of the
box. Put somewhere on the map and adjust the size
and the color (next page, top right).
You might want to put the symbol inside of a shape.
So, create a shape, insert the symbol, and adjust the
alignment using various options in Align and
Distribute (Shift+Ctrl+A) box.

Concept
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Set the movement distance according to your need,
whether it's horizontally or vertically. Example:
Horizontal: 1.500 cm, vertical: 0.000 cm. It will move
the object 1.500 cm horizontally from its original
location. You can set the value into -1.500 cm to
move the object in the reverse direction. Positive
horizontal value will move the object to right
horizontally, and the negative value will move the
object to the left. And so does the vertical value. The
positive value will move the object up, and the
negative value will move the object down.

nodes and also change the curve model (smooth,
symmetric, corner, etc.)
Fill the river with cyan as the fill color and light
orange as the stroke or any other color combination
that you think will be better.
What about the road that crossing the river? It's
easy: just place a rectangle above the river with the
same width and color as the road. Look at the
picture below. At the first, I put a rectangle with the
same width but in a different color. Then I changed
the color so that it has the same color as the road.

Symbol Library
Now, let's finish the road part. Zoom to the road part,
then draw a white rectangle (no border) as the road
separator. The size might be small enough, depends
on the map size you want to create.

Transform panel
After you decide the movement direction and its
distance, click on the new rectangle of road
separator. Press Ctrl+D to duplicate it, and click
Apply on the Transform panel. Repeat the steps
until you reach the end of the road.

Road separator lines
Put this new rectangle accordingly. Open Transform
(Shift+Ctrl+M ) panel, then open the Move tab.
There,
you
can
see
the
movement
direction—horizontal and vertical—and also the unit.
I prefer to use centimeter.
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Before (above) and after (below) change

You can also put a river. I used the Draw Freehand
Lines (F6) tool to create the river. Just click and
drag this tool, click on the last point to start new line
until you reach the first starting point to make this
new object as a closed-curve that can be filled with
color and stroke.
By using Edit Path by Nodes (F2 ) tool, you can
modify the river shape. You can add or delete the
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You can add text if you think that it's necessary.
Because it's impossible for me to show all the steps
to create the whole map, I will assume that you have
already understood how to make the objects to be
put on other town parts. Just remember, I only use
rectangles, circles, triangles, and Bezier lines. The
rest (including the layout), later, will be totally
depend on your imagination.
Here is the example of my small work:
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Inkscape Tutorial:
Creating A Photo Popping Or Photo Cutout

By Khadis

Photo popping or cutout is usually done in photo
editing software such as the Gimp (like what
Meemaw did in the PCLinuxOS Magazine, Volume
94, November 2014 edition, entitled GIMP Tutorial:
An "Out-Of-The-Frame" Effect). However, it can also
be done through Inkscape. Let’s try to do it!

and it is still okay. The color will not matter since we
will flood it with the pattern, so you can choose any
color for now.

Fill and Stroke panel by pressing
Shift + Ctrl + F on your keyboard. On this panel,
open the Fill tab and choose Pattern . Your rectangle
• Access your

will be now filled by the new pattern (the photo you
imported to the document).

• Open up your Inkscape and import an image using
command or through File – Import menu. I
myself used a random picture from Google Image (I
took Synyster Gate’s photo).

Ctrl + I

• To be able to see the popping / cutout result, you
can first make a big rectangle behind the photo (as
the background) and color it. Look at the illustration
below:
• Now, let’s convert this patterned rectangle into a
path by pressing Shift + Ctrl + C or through Path –
Object to Path menu. After that, you can use the
Edit path by nodes tool (F2) to modify this object. If
it is possible, use the Zoom tool (Z) to get a better
view.

• Now let’s return to the photo and convert it into a
pattern using the Alt + I command or through Object
– Pattern – Objects to Pattern menu. Once you
have done that, please create a rectangle with the
size equal to the photo size. You can make the
rectangle a little bit bigger or smaller than the photo,
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• Now grab the top right corner handle (node) and
move it lower. Then grab the bottom right corner
handle (node) and
move it higher. It
should now look like
a perspective photo,
as in the picture
here:
• Now, still using

Edit path by nodes
tool (F2 ), put some

new nodes. For this

sample, I put some new nodes in these places (look
at the yellow nodes):
• Now, let’s “trace”
the
picture
by
moving the nodes
one by one. Use the
Synyster’s body as
the “path”. You can
add or reduce the
number
of
the
nodes by simply
double click on the
picture to add more
nodes or click in a
node and press Delete to reduce the node.
• Before we really move the nodes one by one, let’s
make a Bezier curve (Shift + F6 ) first to “extend” the
picture so it will be easier to be edited. Draw a
Bezier curve like this (look at the white Bezier. The
shape might be different from mine):
• Do a Union by
selecting the Bezier,
then press the Shift
button, click on the
photo, then press
Ctrl + +.
• Now, let’s go back
to the photo. Move
the nodes one by
one, by following the
Synyster’s body and
his guitar shape. Still, you can add or delete more
nodes if you need to do so. Use the Zoom tool (Z) to
zoom any parts you need to see in detail. The final
result might be like this (the better your imagination,
the better the result will be):
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photo. Always use the
need a better view.

Zoom

tool (Z) whenever you

• Zoom out the photo, and here is my result:

• After you are satisfied with your result, send the
yellow perspective rectangle to the back of the photo
by pressing the Page Down button on your
keyboard. Once the yellow rectangle settled behind
the photo, return its opacity to 100%. The final result
could look like this:

• For the final touch, let’s create a frame for the
photo. Grab your Rectangle tool (F4) and draw a
rectangle above the photo. The size can be bigger
than the photo, and the color is up to you. I chose
yellow.
• Call the Fill and Stroke panel (Shift + Ctrl + F ) to
appear. On the Fill tab, reduce the color opacity so
the rectangle is now semi-transparent. Convert it into
path by pressing Shift + Ctrl + C or through Path –
Object to Path menu.
• Activate your Edit path by nodes tool (F2 ). Adjust
the shape of your semi-transparent rectangle to form
a perspective shape that following the shape of the
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by Meemaw

Also remember that when you export your wallpaper,
you will choose Export Page , and the part of the
circle not on the page will be omitted.

Many of the wallpapers we see have circles that look
like they are different sizes, but all look similar. We
have now worked with clones enough to know that
the Tiled Clones tool can do that pretty easily. I saw
this tutorial not long ago, and thought it looked pretty
fun, so let’s play a bit.

Inkscape and edit your Document
Properties. My page will be 1200 X 900, but yours
can be whatever you want. Start with a rectangle the
same size as your page, and make it whatever color
you want. My preferred color is blue, and I’m going
to make it a bit dark to start. When you have your
color in, change the stroke to none, and the fill to a
linear gradient, with your original color on the top of
the page, and a lighter shade of that color on the
bottom (center, top).
Open

Choose the circle tool and draw a circle with fill the
same color as the bottom of the gradient (or at least
a color that blends well with it) and no stroke. Make
the circle about two-thirds as wide as your page. My
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Next, let’s add a layer to our drawing. I want to be
able to put more objects in without moving or
changing anything I have already drawn. That’s the
great thing about layers. Generally we add a layer
above the one we have been working on, so when
you choose the Add Layer tool, the pop-up that
appears has that as the default. Click Add .

page is 1200 pixels wide, so I made my circle 800
pixels. Remember, after you get your circle drawn,
you can adjust the size in the boxes along the top of
your workspace. Put it about halfway off the top of
the page, and center it horizontally using the Align
and Distribute tool. Finally, change the Blur to
about 25% and the Opacity to about 50% (but you
are free to
play
with
these
numbers
and
choose
what looks
good
to
you - we
are
just
looking for
a highlight
at the top
of
our
page).

As an extra safety precaution, you can go back to
Layer 1 and lock it by clicking the little lock on that
line.
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If for some reason you added the new layer below
the original, you can move your rectangle and circle
to the bottom by selecting them both and then
choosing Layer > Move Selection to Layer Below
or pressing <Shift> + <Page Down> .

When you get all the settings in, click the Create
button at bottom right. This is another place you can
experiment: if you don’t like the array that appears,
you can click Remove and click Create again until
you see something that’s more pleasing to you.

Now let’s add more on the top layer. Make sure that
layer is selected, then draw a circle that is about 40
or 50 pixels wide. Make the fill one color, and a 3pixel stroke using a lighter shade of the fill color. All
of mine will be different shades of the blue I started
using on the background. Change the opacity on
your circle to 50%.

Let’s multiply this circle by creating clones of it.
Select it, then click Edit > Clone > Create Tiled
Clones. The window that appears has several tabs
and can be quite daunting. The best way to figure
out what it does is to play with the settings and see
what happens. For this tutorial, I got some help and
will give you the settings I used.
When we did the stars in our sunset project, we put
in rows and columns of clones. This time we will
designate an area that we want to cover. On my
1200 x 900 pixel drawing, I used a 400 px width and
200 px height. Then the following tabs were set as
shown below:
Shift - 50% in Randomize x and y,
Scale - 25% in Randomize x and y,
Blur and Opacity - Both 15% in Randomize. The
Shift tab is shown at center top.
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Wow, I’ve decided that I need to change the fill color
of my objects! Remember, if you change the original,
all the clones will be changed. OK, which one of
those is my original? None are selected! This is
cool…. choose one of the clones, then press
<Shift> + <D>, and your selection will change to the
original item. Now you can edit the fill. If you haven’t
saved your file yet, this is a great time to do so.
This is the basic tutorial, but I’m going to do more.
First I will select all my clones , then duplicate the
whole bunch of them (<CTRL> + <D> ). Then I’m
going to move them into another part of my drawing.
I also want to flip mine and change their opacity so
they don’t look identical to the others. I also
increased the size of both groups. Increase the
original first, because the change to the original
circle will affect them all since they are all clones.
Then if you want your duplicates bigger or smaller
again, select the second group and change them
(top right).
The next thing I am going to do is put a couple of
swirls through the picture. I will use the pencil tool
and make the stroke one of the lighter colors we are

using. I also changed the Opacity to 75% and the
Blur to 3%. After I get a line I like, I will duplicate it
and flip it so I have two lines. Since I only duplicated
the first line to get the second line, I can change the
Opacity and Blur to something different on the first
without altering the second.

Another thing that you can do is place a rectangle or
triangle on your wallpaper. My triangle will be in the
bottom left of the page, and will be the darkest of the
colors. I also positioned a line along one side of the
triangle, and made it much lighter with a radial
gradient as an accent (next page, top left).
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You can do much more or much less than I have
done. It’s your project, so make it the way you want
it.

It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...
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Posted by mutse, on April 3, 2019, running Mate.
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by Khadis
Here in Indonesia, Lebaran Day, which is celebrated
with “ketupat” — cooked rice that is wrapped with
coconut leaves—is only several days ahead. On this
day, people usually send greeting cards—and of
course, with a “ketupat” image or icon. In the image
below you can see ketupat before it’s cooked.

To create a rounded rectangle, just draw an ordinary
rectangle, then modify it by dragging down the circle
handle (top right corner of your active rectangle)
using the Edit path by nodes (F2) tool.

Duplicate the rectangle using the Ctrl + D command.
After that, move this new rectangle through the
Transform (Shift + Ctrl + M ) panel. Set the
parameters as shown below, then click Apply:

Select all three rectangles and group them (Ctrl +
G ). Then, duplicate and move them using the
following parameter:

Repeat the previous step so you will get the
following formation:

There are various techniques that we can apply to
create the image or icon as realistic as possible. But
now, I would like to use a simple technique to create
a flat “ketupat” icon. Let's go!
Open up your Inkscape and create a 5 cm x 5 cm
rounded rectangle. Give it a dark green color (R: 0,
G: 128, B: 0, A: 255) from the Fill and Stroke (Shift
+ Ctrl + F) panel. Outline is optional.
The setting above will move the duplicated rectangle
5 cm to the right and additional 0.25 cm for space.

Change the color to get the following color
combination. Don't forget to un-group the rectangles
(Ctrl + U ) first:

Set the second rectangle with brighter green (R: 0,
G: 255, B: 0, A: 255). Duplicate (again) the rectangle
using Ctrl + D and return the color into darker green
(R: 0, G: 128, B: 0, A: 255).
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Select all the rectangles and group them (Ctrl + G ),
then rotate them -45 degree (rotating 45 degree will
produce the same result as well).

linuxfordummies.org
There Are No Stupid Questions

Con n ect

All your
PCLinuxOS
connections in one
convenient location!

Screenshot Showcase

Now, create the “head” and “tails” using the
Calligraphic tool (Ctrl + F6). Try to draw the “head”
and the “tails” using a different parameter for each.

Final result:

Posted by OnlyHuman, on December 3, 2019, running enlightenment.
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by Meemaw
We have already done a wallpaper
using tiled clones. Now, let’s just use
lines, shapes and gradients. This
project is actually pretty easy.
Open Inkscape and edit your
document properties to reflect your
desired wallpaper size. My desktop
monitor is 1024x768, so I chose that
size. You can make it any size you
wish.
Draw a rectangle the same size as
your document. I am partial to blue
backgrounds so I used a dark blue, but you can use
any color you wish as well. We will probably change
it later, anyway.
Now for the gradients. Let’s use the bezier tool first.
Draw any figure, making sure you close the curve so
it will fill. In your Fill & Stroke window, make the Fill
white, and the Stroke a 3 px white line.

Go back to Fill and choose a radial gradient, then to
Stroke and choose radial gradient there as well.
Clicking your Gradient tool, you should see two
gradient handles, one for the fill and one for the
stroke. Grab the one for the fill first and move it
where the figure you made looks like a highlight,
then move the stroke handle so it emphasizes just a
part of your stroke. You can also set the Opacity
down on your color. I set mine down to about 60%.

One thing that perplexed me was that the gradient
handles seemed to jump together so when you
wanted to move one, both of them moved. The way
to remedy that is to hold down your Shift key while
moving one of them. It will move away from the other
one and then you can manipulate them one at a
time.
To keep from having so much of your artwork “off the
page”, you can also duplicate your background and
then, holding the Shift key, choose your object. Click
on Path > Intersection and the only part of your
gradient you will see is that part on the page. You
will still be able to move and resize it.
We can also use the Ellipse tool to do this. The
procedure is the same. Simply draw an ellipse,
change it to white, and configure the gradients the
same way. You can use a linear gradient as well,
depending on how you want your drawing to look
(next page, top left).
You can put in as many of these figures as you want,
arranging them any way that looks pleasing to you.
You can also use your bezier tool to put in more
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varied objects with different curves…. whatever
looks good to you. After all, it IS your creation. I put
a little purple in one of my gradients for a bit of
variety (center, top).
Did you decide you wanted a different color
background? Choose the background, change the
color, and export it again (center). Easy!

The PCLinuxOS Magazine
Created with Scribus
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duplicate this shape (Ctrl + D ), then flip it
horizontally. Adjust the position to get the following
image.

By Khadis
We can find a lot of clip art about foods and
beverages out there on the internet. Do you ever
imagine creating your very own clip art? If you do,
let's create a piece of clip art using Inkscape. The
clip art image we are going to create is a glass filled
with orange juice.

Step One:

Open up your Inkscape and create a
rectangle with your own preferred size. I used 3.5
cm x 7.5 cm. If necessary, use Zoom (Z) tool to get
a better view. I used a 20% gray color fill and used
50% gray color for the stroke. I also set the stroke
width to 4.5 px.

Step Three:

Click the new node, then click the
upper handle and drag it to the right to bend the left
side of your rectangle. You can repeat this step until
you get your most perfect shape. You can also move
the other handles to make more adjustments.

Step Two: Convert the rectangle into a path using
the Path – Object to Path menu or by using the
Shift + Ctrl + C shortcut. Modify the rectangle using
the Edit paths by nodes (F2 ) tool. Add a node on
the left side of the rectangle. Look at the picture at
center top:
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Step Five: Press Ctrl + + to combine the shapes so
your new shape will be like this:

Step Six:
Step Four: After

you get the shape you want, you
can do the same steps above to be applied to the
right side of the (ex-) rectangle. Or, you can

Now, to create the juice inside of the
glass, you just need to copy the glass shape,
remove the stroke, and resize it. Fill it with a linear
gradient, from yellow to orange. First, you need to
choose the Gradient (Ctrl + F1) tool, then drag it
from top to bottom. Click the first node (top) and
choose a yellow color.
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Step Eight:

Draw a free curve by clicking the tool
until you get the shape like this:

Look at the illustration below.

Step 11:
Click the second node (bottom) and choose an
orange color. Look at the following color parameter
through Fill and Stroke (Shift + Ctrl + F ) panel.

You can also create another circle or
duplicate and resize the current circle, then give it a
20% gray color. Place the second circle like this:

Step Nine:

Now, fill this shape using a gradient
color. So, access the Gradient (Ctrl + F1) tool
again. Click the first node (top) and choose a white
color. Click the second node (bottom) and choose a
yellow color. You can always change the nodes (top
or bottom) to get a better gradient.
You can draw another shape using the
+ F6) tool so that it will look like this:

Bezier (Shift
Step Twelve:

Create an ellipse and put at the
bottom of all the objects. You can use any
proportional size. For the color, I used 30% gray
color and no outline/stroke.

Step Seven :

Is the color combination satisfying for
you? Now, let's create “accessories” on the glass.
Grab your Bezier (Shift + F6 ) tool. Choose Spiropath mode and Ellipse on the Shape drop down
menu.

Step Ten : Now, create a circle and put it under the
all shapes above. Give it a 50% gray as the color.
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Step Thirteen : Duplicate (Ctrl + D ) the ellipse and
fill it with 60% gray color. Then, move it a little bit
lower and move it a bit to right to create a shadow
effect. After that, press the Page Down button on
your keyboard to send the shadow ellipse to the
back of all objects.

Other possible results:

International Community
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Netherlands

Turkey
Step Fourteen : At last, you can create a “connector”

between the circle and the ellipse as shown in the
illustration below. The “connector” can be made of a
small rectangle with a 30% gray color without stroke.
On the picture below, I modified the rectangle a bit
and gave it a red color so that you can spot my
“connector”.

Denmark
Czechoslovakia

Italy
Poland

Brazil
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Inkscape Tutorial: Creating A Bubble
By Khadis
Well, I have just got inspired to create a bubble
illustration on Inkscape after seeing many bubblestyle wallpapers. So, I tried to create my own
bubble. Let’s go!

Create a new ellipse and put it above the previous
blurry circle. Give it the same color as the stroke
color of the previous circle, but set the stroke to
none. Adjust the size to match your preferred size.

Duplicate the blurry circle by pressing Ctrl + D .
Remove the blur effect (set the blur effect back to 0).
Make sure that this new circle is above all of the
other objects. Click this circle and press Home
button on your keyboard if you are unsure.
Now, press Ctrl + A to select all objects and then, go
to menu Objects > Clip > Set. Finally, add a small
white ellipse like in the following picture. You can
rotate this white ellipse to make it look nicer. Blur the
small ellipse, and you are finished.

Open up your Inkscape and draw a circle of any
size. Give it no fill and a stroke with a color you like. I
chose green as the stroke color.

Now, set the color to transparent. Use Edit paths by
nodes tool (F2) to change the direction and the
distance of the transparency.
Set the stroke width as wide as you like. Just ensure
that it is thick. Then, make it blur using the blur effect
in Fill and Stroke Panel (Shift + Ctrl + F ).
You can also change the bubble color, as well as the
stroke and the gradient of the ellipse. As this bubbleshape is not only representing a bubble itself, but
also a water/rain drop, later, you can test the
“realistic level” of your creation by putting it in front of
a textured background (see next page, left).
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Inkscape Tutorial: Six Helpful Inkscape Tricks
by Meemaw
Inkscape has a great deal to offer any artist. One
can find tutorial after tutorial on the internet to help
learn to use it, and I have tried to share some really
excellent tutorials to help you make some really
great creations. Many of the features of Inkscape
can be plainly seen, but some of them aren’t so
evident. Let’s look at six items that might help a bit.
Sometimes you need to manipulate nodes in an
object you have drawn in order to make it into what
you really need. (Not all objects are regular objects!)
Draw the object you want, and click on Path >
Object to Path to get the nodes you need. Select at
least 2 nodes. In the Nodes toolbar directly above
your workspace, click on the Show Transformation
Handles button (see button above red arrow below).
You will get handles around your nodes and can
resize or rotate them just as you would a regular
object. You may have to experiment a bit, but you
will have more choices in your object manipulations.

While making star shapes, pay attention to the
nodes. Moving the outer node towards or away from
center will let you change the size of your star or the
angle sizes, but if you move it left to right, all it will
do is rotate your star. The inner node, however, will
let you change the angles differently and even make
a new type of figure. In the top illustration, I changed
from the right figure to the left simply by moving the
outer node toward the center of the star. In the
bottom illustration, I changed the star by moving the
inner node. The left star was made by moving the
inner node to the left just a little. The right object was
made by moving the inner node clear across to the
opposite side of the star

I know we always use the Fill & Stroke window
when we are creating. As there is always more than
one way to do anything, coloring an object is just as
easy with the color palette at the bottom of your
Inkscape window. Draw your object, then Click on
your desired color for the fill, and <CTRL> + Click
for the stroke. There are many colors so the palette
has its own scroll bar (bottom).
If you have another object
and you want the two the
same, use the color
dropper (left side toolbar
near the bottom). Click on
the object you want to
color, choose the dropper,
then click on the object
color you are trying to
match.
Rulers can be used to give you guide lines. Make
sure your rulers are enabled, then click and drag vertical and horizontal lines will move to the desired
position on your page. You can now align objects
using the guide lines. If you enable your snapping
toolbar (in View > Show/Hide , you can show the

Snap

Controls

bar), items can
snap
to
the
intersection
or
along the guide
lines, or even to
each
other.
Experiment!
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Sometimes when I am making a tapered line,
Inkscape acts a little squirrelly, and it doesn’t turn out
exactly the way I want it. Another way to do it is to
make a diamond shape, then choose the top and
bottom nodes. Click on Make selected nodes
symmetric (to round the diamond shape) in your
nodes bar (See blue object below.) Copy it to the
clipboard (<CTRL> + C), then use it as model for
your Freehand or Bezier lines (Shape from
Clipboard ).

• The layer that object is on (and even if the layer is
locked or made invisible)
• The type of object selected (Rectangle)
• X and Y coordinates of your mouse (147.48
x 72.23)
• The zoom percent of your project (68%)
One of the things that is really great is where it
shows the type of object selected. If you have more
than one object selected, the status bar will tell you
how many objects. I use this when I do the word
search puzzle solution every month. I put the puzzle
on one layer, and the lines showing the answers on
a higher layer. I make sure I have them all when I
can select everything on that layer and it will tell me
the correct number of objects (if I have 30 words, the
status bar will report 30 lines).
I hope I’ve provided a few tips to help you use
Inkscape. I’m sure there are tons more!

I think I have covered the status bar before, but it
bears repeating. Pay attention to the information in
the status bar, as it can tell you what’s happening in
your drawing. You can see loads of information in
the bar below (left to right):
• The fill and stroke color of the
item selected (red fill and
black stroke)
• The stroke size (3)
• The opacity of the figure (0
meaning no opacity)
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Available in the following desktops:
KDE Mate Xfce
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by Khadis

• Create an A4 sized document and draw a
rectangle the same size as the document.

When designing a brochure, leaflet or flyer, we might
be more inclined to use Scribus instead of Inkscape.
But, some people also rely on Inkscape, as it has
richer capabilities and more flexible tools, especially
the ability to draw lots of items right in the
application.

• Give it a 7.5% gray as the fill color and no stroke.

In this article, I'd like to imitate a simple brochure
made by my friend using proprietary software for a
seminar in his workplace. But here, besides redesigning it using Inkscape, I will also change the
content. OK, let's go!

• Create a circle with diameter 5 cm. Give it 7.5%
gray as the fill color and 20% or 30% gray as the
stroke color.
• Duplicate (Ctrl + D ) the circle and re-size it to 4
cm. Duplicate again and re-size again, so that the
diameter is now 3 cm. Repeat duplicating the circle
until you have a circle with diameter 1 cm.
• Open up Align and Distribute (Shift + Ctrl + A)
panel, select all circles, then on the Relative to
option, choose Last selection . Click on Center on
vertical axis and Center on horizontal axis.

stroke. For the height, it is up to you. Put the new
rectangle down a bit from the top side of the gray
one.

• Group these circles (Ctrl + G ), then duplicate the
group several times (Ctrl + D ), and spread them
above the main rectangle (top, right).
• Create a rectangle with the same width as the
document and give it orange as the fill color without
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• Duplicate (Ctrl + D ) the orange rectangle and fill it
with yellow. Then, duplicate this new yellow
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The result might be like this:

rectangle and fill it with 40% gray. Open up Fill and
Stroke (Shift + Ctrl + F) panel, then reduce the
Alpha (A) value of this gray rectangle into 150. The
orange and grey rectangles will be spaced out
further down the page.
• Now, create a new yellow rectangle (about 8 x 9
cm) and reduce the Alpha (A) value to 150. Later,
you can play with this Alpha value to make a proper
color combination.

Here is the temporary look. Yours might be better :)

• Put this new shape in the top left corner of the
main A4-sized rectangle by opening up Align and
Distribute (Shift + Ctrl + A) panel. There, set the
Relative to option to Last selected .
• Click this new shape, hold your Shift button, then
click the main rectangle. Choose Align left edges
and Align top edges .

• Convert this new yellow rectangle into path
through Path – Object to Path (Shift + Ctrl + C)
menu. Use your Edit Paths by Nodes (F2 ) tool to
raise the bottom right corner node of this rectangle.

• Create an ellipse (about 7.5 x 3 cm) and fill it with
orange color. Then, duplicate and give it different
color. I chose gray (again).
• Put these ellipses above the long yellow rectangle
like this:

• Create new orange rectangle (about 6 x 26 cm).
Again, reduce the Alpha (A) value through Fill and
Stroke panel. Convert into path, and modify it using
Edit by nodes (F2) tool.
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• Later, you can duplicate the ellipse and make it
different colors for the next part.

• Now, let's add some text and picture/logo. For the
texts, I use some fonts: Belwe Bd BT, Helvetica
Neue LT Std, and Arial. Meanwhile, for the Gimp
logo, Inkscape logo, and Scribus logo, I took
randomly from Google Images.

The final result:

Want To Help?
Would you like to help with the PCLinuxOS
Magazine? Opportunities abound. So get
involved!

Want to keep up on the latest that's
going on with PCLinuxOS?
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Inkscape Tutorial: Another Fun Text Effect
By Meemaw
I was talking to ms_meme the other day about ways
to manipulate text in Inkscape, and one of the
extensions we discussed was the Envelope
extension. Envelope is an extension that will “mold”
text to a rectangular shape. Let’s do one!
Start with the bezier tool and draw a rectangle. You
have to make it a rectangle for the extension to
work. If you want a triangle, you can draw a 4-sided
figure that looks kind of like a triangle with one point
cut off, as shown below.

Some of these extensions are picky about how you
draw them. Envelope requires the figure to be drawn
in this order: top left, top right, bottom right, bottom
left, and close. Change your rectangle to a path by
clicking Path > Object to path .

Once you change it to a path, you can always go in
and move the nodes around to get the shape you
want. It has to be four-sided, but the four sides can
be any way you want. If you want a banner shape
(or any other four-sided shape), just move the nodes
until you are satisfied with the result. The text will
align with the rectangle along the first and fourth
lines, with the top of the word being against the first
line and the left side of the first letter being against
the fourth line. When you move your nodes, keep
this in mind.
Now for the text. Type and configure it, changing the
font, size, etc., however you want. With your text
selected, click on Path > Object to path . At this
point, your text is a group of paths, with each letter
being its own path. Ungroup your text, which will
then look like this:

then click on Path
into one path.

> Combine and combine the text

Envelope works with only two paths. If you don’t
perform the above step, you will get an error
message that says you have to have only two paths.
Choose the word, (hold down <Shift>) and choose
the shape, and then go to Extensions > Modify
Path > Envelope (top, right).
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After your text is changed, you can use or delete the
shape, whatever you need to do for your drawing.

It’s a fun process! With a little experimentation, you
can get all sorts of effects.
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ms_meme got this (which looks kind of like a tree):

linuxfordummies.org
There Are No Stupid Questions
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This one’s fun! I hope you have fun with it as well.
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Inkscape Tutorial: Creating A Jigsaw Puzzle
Using The Lasercut Extension

by Khadis

A couple of months ago I wrote a tutorial about
making jigsaw puzzle pieces manually. I realized that
it took a long time to create it, although it still good to
sharpen your designing skill. But, thanks to the
Inkscape community, working in Inkscape is now
getting easier each day — including creating puzzle
pieces instantly.
In this issue, I will show you how to create a jigsaw
puzzle instantly using the Lasercut extension. OK,
let’s go!
To get started, download the Lasercut extension
(Lasercut-jigsaw.inx)
from
https://github.com/Neon22/inkscape-jigsaw. If you
cannot download it directly, just copy the script into
your favorite text editor, then save it in the <.inx>
format with name “Lasercut-jigsaw.inx”.
Also, download the python script (Lasercutjigsaw.py) from the same address above. Simply
copy the script into your favorite text editor and save
it with a <.py> format.
Put

those

2

files

in
the
folder and start
your Inkscape. If it doesn’t work, put those files in
~/.config/inkscape/extensions/ folder. You’ll find
this new extension under the Extensions – Render
– Lasercut Jigsaw menu. If it still doesn’t work, try
to run Inkscape using root mode.

usr/share/inkscape/extensions/

Click Apply and your puzzle pieces will appear in
the center of your working canvas. By default, they
are fairly hard to see because the stroke is very thin.
So, open up the Fill and Stroke (Shift + Ctrl + F )
panel and increase the stroke width from the Stroke
Style tab.

Go to the Extensions – Render – Lasercut Jigsaw
menu entry. A Lasercut window will appear in your
screen. Set the width and height the same as your
image dimension. Also, set the number of pieces
across and down (see the illustration below). You
can experiment with the number of pieces to gain a
better result.

After that, put the puzzle above the image (click the
puzzle and press the PageUp button to ensure).
Then, select all (puzzle and the image) and center
them through the Align and Distribute (Shift + Ctrl
+ A) panel.

Now, import an image to your Inkscape. I used a
random free image from http://www.123rf.com/.
Look at its dimension. Mine is 562.5 x 435 px (center
top).
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Done. You can later cut the puzzle into pieces by
following the pattern. Good luck.
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Inkscape Tutorial: More Text Tricks
by Meemaw
It seems you can make practically any text design
you want, and this tutorial taught me a lot I didn’t
know! I add text to many of my projects, and I
always used the Text window to edit my text
(correcting a misspelled word, changing the font and
size, etc.), but I hadn’t really paid attention to the
toolbar that is directly above my work area. I found
out that you can use text window (the “T” at the top
of the window), but the toolbar just below it has more
options … many things can be done just using this
toolbar (at top).
Going from left to right, we start with the normal
settings: Font, Font Size, Font Style (Normal, Bold,
Italic or a combination) and Alignment buttons. We
even have two buttons for superscript and subscript,
if needed. From there, however, we have six settings
that can really make your text look different. Let’s
concentrate on this half of the toolbar (at bottom).
The first one is line spacing . This is useful if you
have more than one line of text. Inkscape’s default is
1.25. Depending on how you set it, you can put
letters right on top of each other (with a negative
setting) or space them far enough apart that
something can be put between them. One use for
this could be the award certificates that some
schools give to children. If you have a two-line
statement, you can space it out enough to leave
room for someone to write in the child’s name. If you
design your own certificates, this may work better for
your spacing than using the Enter key several times
in a row (center).
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The second is letter spacing . This setting
determines how close or far apart your individual
letters are. A negative setting “smooshes” letters
closer together, and a positive setting stretches the
words out, as shown below. The center image is a
zero setting, or “normal”. This works well if you want
to make a banner fitting a precise length (top right).
The third of the settings is word spacing . You can
stretch your sentence out as much as you want by
increasing the space between each word. This might
help on your banner design, or a newsletter headline
or ad you want to emphasize (center, right).

The fourth one is kerning . This adjusts the letter
spacing only between the letters you've selected
(putting the cursor between the letters you want to
space out). As you see on the next page, I
separated the “e” from the rest of the word “Time”.
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You can also highlight each letter and change the
color. I did the colors and rotated all of these. The
rotation setting is zero because no letters are
highlighted.

You can change the kerning on each letter
individually to get a different look. If you play with it a
bit and decide you don’t like it, you can use the
Undo function (<CTRL> + Z) which will undo them
one at a time, or choose Text > Remove Manual
Kerns to remove them all.

Shift is next. Shift moves letters up or down. Place
the cursor to the right of the letter you want to move,
then change the setting. A positive setting moves it
up and a negative setting moves it down.

Another way to edit your text is to use the path effect
editor. Change your text to a path (Path > Object to
Path ), then click Path > Path Effects. Add the effect
you want (Bend, for example). In the Path Effects
window, choose the edit on canvas tool (the node
tool symbol) and you will get a line in your text to
manipulate, just like moving nodes. On this one, I
grabbed the center of the line and pulled it up.

The last two buttons are text direction buttons.
Most of the time you will want your text to run
horizontally, but occasionally you might want vertical
text. Choose your text tool and type it in as usual. If
you forget, just highlight it and click the button and
your text will change.
Another path effect is the envelope, which we
covered in the December issue.
Have fun adding some more zip and pizzazz to your
text in your next Inkscape project.

Rotation

is the last number setting in the toolbar.
You can rotate the letters one at a time by placing
your cursor to the left of the letter you want to rotate,
then changing the setting to a positive or negative
setting in degrees.
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Inkscape Tutorial:
Five Cool Inkscape Extensions You Must Try
by Khadis
Inkscape has dozens of extensions that can help us
create various designs, illustrations, etc. In the
previous issues of this magazine, you have seen
many creations that used many techniques involving
different extensions. Now, I will show you some cool
extensions that you can use in your next designs.

Foldable box

Are you often curious about how to create a box
design for a product package? Using the Foldable
box extension, you can design a product package
template easily. Once you access it from
Extensions – Render – Foldable box menu, a
setting window will appear (left). There, you can set
the box size by setting up the box width, height, and
depth. Later, if you need to modify each part of this
package design, you only need to ungroup (Ctrl +
Shift + G) and the box will turn into editable pieces
(bottom, left).

It is very easy and it takes no time to setup a readyto-use QR code. In the setting window, you only
need to put “something” in the Text field. In the
default setting, the Text field is filled by the Inkscape
homepage address. You can fill it with the
information you want. Then, in the Size field, you
can choose any size of QR code that matches your
needs. You can also choose the character encoding
you want.

L-system

QR code creator

QR codes are now everywhere, and QR code
creators are also can be found easily on the Internet.
But, do we really need a separate QR code creator
to put a certain “identity” in our products designed in
Inkscape? No. We only need an integrated QR code
creator right inside Inkscape, and it is already there,
under Extensions – Render – Barcode – QR Code
menu.
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Do you wonder about how to create instant dry
bushes for your illustration? Creating bushes from
lines and curves can take forever until it's done.
Don't worry, you can rely on L-system extension that
can be accessed from Extensions – Render menu.
With a single click, you will get a perfect bushes
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illustration. Since we need to understand how the
extension is working, for the complete help, we can
access the Help menu in the setting window of the
extension.

The similar extension that might help is Random tree
extension that can also be accessed from
Extensions – Render menu.

Cover template

Designing the cover of a book is much more easily
done in Scribus, although Inkscape can do the same
thing, depending on our creativity. If you want to
design a book cover using Inkscape rather than
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Extensions –
Render – Layout – Perfect-Bound Cover
Template for a help. You only need to decide the
another software, you can access

size of the cover (width and height), and start
designing it. The guidelines showing the margin
limits will be prepared by Inkscape.

Lorem ipsum
Lorem ipsum seems to be just useless text.
However, it is a very popular template of a
paragraph that we can find almost everywhere:
brochure templates, tabloid templates, etc.
Sometimes, when we are designing publication
material, we also need to show it to the client first.
And instead of using a final design with the whole
text, we can use lorem ipsum paragraph.

The good news is that lorem ipsum is available in
Inkscape and can be accessed from Extensions –
Text – Lorem ipsum .

Available in the following desktops:
KDE Mate Xfce
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Inkscape Tutorial:
Easy Patterns Using The Stamping Tool

by Meemaw

We have created loads of really fun things over the
past several years. Sometimes the creation design is
something that repeats or something that copies a
certain shape. We can duplicate or multiple duplicate
to get what we want, but maybe that’s too slow. I
found this tutorial not too long ago, and it discusses
the stamping tool. Let’s experiment!

We can expand on this. Remember that when you
select your object, and click a second time, the
rotate arrows appear, along with a little plus sign on
the center of your object. Depending on where the
plus sign appears, since it serves as the center of
rotation, you can make all sorts of different designs
just by changing the center of rotation.
If we leave it in the center, we get the following:

Create a rectangle with a border. To use the
stamping tool, click on the rectangle like you are
moving it, start dragging your rectangle, then press
and hold down the spacebar. As you are moving
your object, you will see it multiplying before your
eyes. Cool, right?

Using the selection tool, move the plus sign to one
end (I actually moved it past the line end, as you can
see), then grab the other end to rotate it. I used the
corner arrow closest to the curly end.

However, using the rectangle, move the plus sign to
the end, then grab the other end to rotate it:

You can do this,
naturally,
with
any
object
rectangle,
square, triangle, star….

You will have to keep your motion smooth and at a
constant speed to make your copies even all the
way around the rotation. It takes a bit of practice.

Let’s try that with a simple curved line. Using the
draw tool, draw a line (top, right).
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This expands the items we can make and makes our
job easier. I made this simple flower (next page, top
right) by drawing one petal, then using the stamping
tool to duplicate the petals, after which I created the
center by itself.
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Screenshot Showcase
This was a 2 minute creation. I also went back and
chose individual flowers to move to make it more
even. You could always edit individual flowers so
each of them is not identical. With a little practice,
I’m sure you can do something spectacular!

Looking for an old article?
Can't find what you want? Try the

PCLinuxOS Magazine's
searchable index!
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Posted by parnote, on October 12, 2019, running Xfce.
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Inkscape Tutorial: How To Create Melted Text
By Khadis

There are various nice text effects we can create
manually in Inkscape. You can create scattered
effect, bubble effect, 3D effect, etc. In this article, I
want to show you a simple technique to create a
melted text effect. It might be suitable to be put in a
food package :)

* Do the division operation. Click the letter, hold
your Shift button, then click the ellipse. Go to Path
– Division . Click outside your choices, then select
the bottom part of the letter to see the division.
Give it brown as the fill color.
* Modify the new modified ellipse using Tweaking
tool (Shift + F2 ) by clicking and dragging the
bottom part of the ellipse several times in different
spots.

Donate To PCLinuxOS
Community Supported.
No Billionaires/Millionaires.
No Corporate Backing Or Funding.

Here we go!
* Create a text. I choose to type “Cokelat”, that
means “chocolate” with yellow as the fill color. For
this text, I simply use Arial Black 180 pt.

* Duplicate the text (Ctrl + D ) and convert it into
path from Path – Object to Path menu (Shift +
Ctrl + C). Un-group this duplicated text (Ctrl +
Shift + G ). This action will break the text into
single letters.
* Create an ellipse above each
letter, started from letter “C”.
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Your final result might be similar to this:

* For the tweaking setting, I use Width = 7, Force =
20, and Fidelity = 28. The selected mode is “Push
parts of paths in any direction”. Your setting could
be different, depending on the font size.

Click here to make a one-time donation
through Google Checkout.
Or, click one of the amounts down below
to make a monthly, recurring donation.

* Do the same steps for other letters.
* You can add a 3D effect to the text by grouping all
objects, then duplicate the group and color it with
black. Then, send it to back by pressing Page
Down button. Place it little bit higher or lower than
the main “Cokelat” text (depends on your
preference). And also move it little bit to right or
left.
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Inkscape Tutorial: Create Transparent Text
by Meemaw

down <SHIFT> and select the top level text, then
choose Path > Difference . You should now have a
blurred text edge with your third color showing.

I saw another fun text effect that I want to do for you.
In Inkscape, import an image file that you would like
some text in. I’m using a photo from a trip I took to
Utah several years ago. This is Butler Wash, with
Native American rock art. I want to put the text
“Butler Wash” at the top.

Select the top text, and change it to white, then
make a gradient (linear, from above the top of the
text to about the center of the text so the white is
barely visible at the top. Now you should have
transparent text with a bevel, highlight and shadow
sitting on top of your image.

Move the blurred text to the bottom of text stack (but
above the image). Choose the top text and change
the color to white, then do Path > Outset once or
twice. Move it below the text it is above (1 level),
select both and do Path > Difference on them. It will
look like a white outline with your last color showing.
With the white text outline selected, change the
opacity to 30%, and move it down to just above the
black blurred text.
Load your photo, then create your text. Change to
the selection tool, and make the text the size you
want. Now, make 4 copies of it using Edit >
Duplicate or <CTRL> + D . It helps to make them
different colors so you can tell them apart.
Change the top copy to black, change the blur to
0.5, then do Path > Outset two or three times,
depending on how big everything is and whether you
used bold text or regular. Move your black text to the
right just so the next copy is visible, then lower it one
level. Now you should have a different color text
above the black text. With that text selected, hold
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Inkscape Tutorial: Creating An Interactive Object
by Khadis
It’s not a new thing that the interactivity function will
make designing more fun, but it is available in
Inkscape. There are so many things that we can do
there, BUT, it will need some JavaScript tricks.

Create text fields labeled “Secret #1”, “Secret #2”,
and “Secret #3” and put them above the 3 previous
white rectangles. The temporary look might be like
this:

For “page 3” (saved as “interactive-3.svg”), I created
this:

In this article, I will show you the basic and simple
steps about how to make an interactive object. My
example is not very cool stuff, but at least, it will
inspire you to make more creative contents. And, it
might be useful to create contents for your
blog/website, or to create a unique presentation.
Let’s check it out!
As usual, start your Inkscape. Then create a
rectangle at any size and color you’d like. I used 15
x 8 cm rectangle and colored it with red.
Insert the text “Tell me a secret!” with any font you
like. I used white Arial Black 36pt. Put the text
horizontally center to the red main rectangle. Then,
create 3 new white rectangles and arrange them as
shown in the illustration below:

And for “page 4” (saved as “interactive-4.svg”), I
created this:
Now, group the “Secret #1” text with the rectangle
below it. Do the same step with “Secret #2” and
“Secret #3”. Later, let's call this set as “page 1.”
Save your work as “interactive-1.svg.”
Create other sets of pages. For “page 2” (saved as
“interactive-2.svg”), I created this:

Now, go back to the interactive-1.svg page. Select
the “Secret #1” group, right click, and choose Object
Properties. Find the Interactivity option, and in the
onclick
column,
type
this
code:
window.location='interactive-2.svg'. (see next page,
top left)
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linuxfordummies.org
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Screenshot Showcase
Select “Secret #2” group, right click again, and
choose Object Properties . Fill with this code:
window.location='interactive-3.svg' in the onclick
column under Interactivity option.
Do the same action for “Secret #3” group by filling
code: window.location='interactive-4.svg' in the
column onclick.
To make every “secret” group (or now, it becomes a
button) in every page is clickable, make sure to put
the code in every button on every page.
Now, let's test our creation.
Close all Inkscape windows. Then, right click
interactive-1.svg, and open with your browser
(Firefox or Chrome).
There, you can try to click “Secret #1”, Secret #2”,
and so on. Once you click the button, it should jump
you to “Secret #1” page, “Secret #2” page, and so
on.
Later, you can add a Back or
you back to the main page.

Home button to jump

The PCLinuxOS Magazine

Posted by seaplane_tux, on February 14, 2019, running Mate.

Created with Scribus
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Inkscape Tutorial: A Painted Text Effect
by Meemaw
I found a tutorial which shows how to create an
image that looks like it was painted on some sort of
material.

Now create your text, and change it to a path.
Depending on your version of Inkscape, this involves
choosing Path > Object to path , then Ungrouping
the text, then choosing Path > Union . I made my
text grey, so I could see it against the black label
(below, left).

Select and align the greyscale with the color texture
so it looks like the textures match. If the label layer
isn’t dark enough, just duplicate it.

Place your text over the label, choose both and do
Path > Difference. Now it looks like the text has
been cut out.

We used to see burlap bags of materials with the
labels painted on them. We should do something like
that.
You will need two bitmaps of the same texture (one
normal color and one greyscale) to use for the bag. I
am using a burlap pattern I got from
www.textures.com, but you can get them here.
We will make the label. Open Inkscape and draw a
rectangle or some shape you think would make a
great label. Make sure you change it to a path using
Path > Object to Path. I made a 400 x 400 px square
with rounded corners, then curved the sides inward
(center, top).
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Now we will make the painted layer. With the
greyscale texture, position the label behind it and
choose Object > Mask > Set (top, right).

Save your work and export your creation.
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Inkscape Tutorial: Create A 3D Landscape
by Khadis

press Page Down once, twice, or many times until it
moves behind the first shape. Press Page Up to
return it to upper position.

Creating a 3D photo using image editing software
isn’t something new. How about if we create it using
Inkscape? It is totally easy, and can be done in
minutes. Let’s start!

7. Before doing the same step to the third shape,
let’s make the second soil image darker than the
first.
8. Select the second soil image, go to Filters - Color
- Lightness-Contrast. Set the lightness lower than
the original value (make the image darker). Check
the Live Preview to see the changes, then click
Apply once you are satisfied with the darkness
level.

1. Create the following shapes. You can use the
rectangle tool (F4), or manually draw them using the
Bezier tool (Shift + F6 ).

4. Select the grass and the shape, then go to Object
- Clip - Set. The grass image should now fill the
shape.
9. Put this second soil image under the third shape,
then go to Object - Clip - Set.

2. Arrange those object like this:

10. Now, import some rock and tree images in PNG
format. You can easily find them in Google Images
using a search keyword like “rock png”, “tree png”,
or something like that.
5. Import a soil texture image in PNG format. Again, I
took randomly from Google Images. Before you put
the image behind the second shape, it is better for
you to duplicate the image (Ctrl + D ) so we do not
need to re-import the image to fill the third shape.

3. Import a grass image. I took a random image from
Google Images. Put the image behind the first
shape. If the image isn’t behind the first shape yet,
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6. Put the first soil image behind the second shape
like in the step #3. Select them, then go to Object Clip - Set.

11. Arrange those rock and tree images. Mine is like
this (next page, top left):
12. Later, you can add a lake, pond, or river, or even
buildings. I added a pond by creating it manually,
using the Bezier tool (Shift + F6 ). (center left)
13. Then place a water image using Object - Clip Set action. Again, I took the sea water image from
Google Images.
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14. The final result might be like this:
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Inkscape Tutorial: Five Handy Inkscape Tricks
By Meemaw
I view loads of tutorials to choose some I think you
will find useful. In my reading, I have also found
several tricks that could make things easier. Let’s
look at a few.

Tools: Use <CTRL> + the mouse wheel to zoom in

and out easily. The toolbar also gives you three
choices (below): Zoom to fit Selection in window,
Zoom to fit Drawing in window and Zoom to fit Page
in window. No, the drawing and the page aren’t
always the same thing. The page is whatever is
contained on your designated page size. Your
drawing includes your page and anything that
happens to lie outside your page boundary.

Also, when you are ready to export your image, the
Export window gives you 4 choices: page, selected
item, drawing and custom. By the way, “selected
item” means you can export individual parts of your
drawing. If I created an image of bleachers with a
crowd of Tuxes on them (April 2011 cover), I could
export only that part of my creation if I wanted to use
it again somewhere else (July 2014 cover). I just
need to make sure it’s all selected. “Custom” means
that you define an area to export, whether it be a
part of your page, or an area in your drawing that’s
possibly not all on the page. When you choose
Custom, the export window will try to guess the area
you want. In the following illustration, it guessed part
of the page and part of the window because of what
I had selected. Locations x0 and y0 will define the
lower left corner of your export area, and x1 and y1
will define the upper right corner of your export area:
the exported image will then be the rectangle
defined by these four numbers.

The gray rectangles are the page boundary. Notice
that exporting the drawing brought in a few of the
items from the side of the page.

Status Bar:
Need some storage while you organize your
project? Use the area outside the page boundary.

Many of my “from scratch” drawings contain pieces
of items I have put together to make one object. If I
am putting a hat on Tux, I usually make the hat
separately. The birthday Tux on the cover of the
August issue had an ice cream cone and a sign with
balloons - both made separately, or imported, then
combined with the Tux I used. I store stuff outside
the page boundaries and get them as I need them.
This is the reason I choose “Page” when I export a
creation. Exporting the drawing would include all
those little items.
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In the above image, “Page” would be only where the
group of Tuxes is inside the page border that you
can see. “Drawing” would be the page and
everything to the side of the page boundary. See the
two exports at top right to see the difference:

Keep an eye on the status bar, as it
contains much information. You can see what your
Fill & Stroke settings are at the moment, including
the size of your stroke. You can see how many
objects you have selected and what type of objects
they are. When I am doing the word find puzzle’s
solution, I open the puzzle in Inkscape and add a
layer named “Answers”. I know I’m finished marking
the answers when I have one more object than
words to find (since the puzzle counts as one
object). Notice below that I have one ball cap
selected, but the status bar shows that I have five
objects selected, since I created the cap using five
different objects. The X and Y in the lower right tells
me where my cursor is, and the percent is how big a
zoom I have on this object/drawing. On the left side
you see the fill & stroke colors (but since I have five
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object is changed when you choose the filter and
you have no choice. However, on the filter windows
with settings, the live preview is a good choice.

objects, it can’t show each, so it says Unset), tells
me which layer I am on, and lets me hide or make
the layer visible and lock or unlock the layer from the
status bar.

Nodes:

If you select multiple nodes using the area
select tool, you can hold down <ALT> while
dragging one and the others will move proportionally.
Also, select many nodes and click one, and you can
rotate or resize those within the selection. To do this,
make sure you have the “Show transformation
handles for selected nodes” tool button active (third
from the right in the nodes toolbar)

I’m sure you have some handy tips that you use in
Inkscape! If you have something that I haven’t
mentioned, please PM me in the forum and tell
about me it, so I can share, OR, share it in the Tips
& Tricks section of the forum. For me, Inkscape is
great fun and frustrating at the same time. I hope
yours is more of the fun, and less of the frustrating.

Defending Your Rights
In the illustration (center), the chosen nodes are
blue, and also outlined by the smaller dotted line
rectangle. You can see that I have lengthened the
arrow and the nodes have moved as well.
Clicking on one of the nodes changes the arrows to
the rotate handles, and you can rotate your nodes
as well (center, bottom).

Filters:

We all use some filters to achieve special
effects in our projects. Many of these filters have
previews. Make use of the previews to save some
time. It’s much easier to look at the preview and
make adjustments than it is to apply your filter, close
your filters window, and then have to go back in to
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adjust. In the example at top right, I can change the
settings on the drop shadow and see the results
immediately and not have to close the settings
window each time I change something. Bear in mind
that not all filters have settings you can alter. Your
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Inkscape Tutorial: Sliced Text
by Meemaw
I saw a cool tutorial a couple of months ago, and I
wanted to share it with you. This will make a line of
text look like it has been cut apart.

To make make our effect, we’ll have to duplicate
some of it, so let’s first draw a triangle over your text
using the path tool. I changed the color of the
triangle to make it easier to see.

Now, you can combine all these separate pieces
together by pressing CTRL + A to select all (or draw
a box around them all with your cursor), then choose
Path > Combine. After you do that, you can click on
the color bar to change the text to your desired color.

Create the text you desire. Then, single click the
canvas with the text tool to create a normal text
object (not a flowed text object). Don’t change tools
yet.

With the text tool still selected, place the cursor in
between two of the letters in the text. Then hold
down the ALT key and then press an arrow key on
the keyboard. This will manually adjust the spacing
between the letters (Kerning). Repeat this process
for all the letters in your text. Wherever you place
your cursor will cause all letters to the right of the
cursor to be changed, so you will have to do each
letter from left to right, depending on how you want it
to look.
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Next, select both the triangle and the text, and
duplicate them (Right click > Duplicate or Edit >
Duplicate). Make sure that you do not deselect
them after the duplication. With one copy of the text /
triangle combination still selected, choose Path >
Intersection , to create the first piece to cut out.
Click in the color bar and change the colour of the
triangle to something that will stand out (I chose
green).

Finally, select the leftover red triangle and the other
text path and choose Path > Difference . This will
remove the triangle from the text. Repeat these
steps on the black text as many times as you want.
You should end up with something like this…
Then, move the green sections out a bit to create
the “shattered” or “sliced” look. Save your work, if
you haven’t done it already.

We could stop here if we wanted. However,
something else we can do is apply a “grunge” look to
the text. We can use a splatter pattern and layer it
over the text. You can create a splatter pattern and
use the Path Effects menu to put the pattern onto a
path. We did this in another tutorial, but we can do it
here, too. Create some sort of splatter object and
edit it so it looks the way you want (I did a rough
circle that looks like a drop of paint). Now, using the
pencil tool (or bezier tool)
draw a path. Mine was
kind of squiggly. Choose
your splatter object and
copy it to the clipboard
(<CTRL> + C). Click on
your path and go to Path
> Path Effects (near the
bottom of the menu).
Click on the plus sign to
add the effect Pattern
Along Path .
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You will want to set your parameters before anything
else. You should probably change your Pattern
copies to Repeated so there will be more than one
of your pattern on your path. I also set my Spacing
to 1.00 so the path wouldn’t be one continuous
pattern. Then click the clipboard towards the top to
indicate the pattern is on the clipboard and is the
one that should be used. I got one similar to this:

The PCLinuxOS
Magazine
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Created with
Scribus

Mate Desktop

Screenshot Showcase
Place the pattern over your text.

Finally, select both the grunge and your text path,
and choose Path > Difference to finish. The text will
now look even more broken.

Have fun with this one! You can do as much or as
little as you want. Depending on your triangle
locations, it can look more or less “sliced”.
Remember, both of these items need to be paths for
the effect to work correctly.
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Posted by Snubbi, on April 7, 2020, running Mate.
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by Khadis

Inkscape Tutorial: Using Envelope
Deformation To Manipulate Text
Using the Edit path tool (F2 ), modify the ellipse into
a leaf shape. Look at the illustration below (note: you
are free to make your own shape):

In this tutorial, I would like to show you how to apply
the envelope effect on a text to create a new
“shape”. I am inspired by a poster in Flickr.
Let’s go!

Type a text. I choose to type the same as the
example above. So first, I typed “COMMERCIAL”.
Use any fonts you like. Then, resize the text so that
it almost covering the ellipse. Set the text so that the
left and right edge stick to the leaf shape.
Now, convert the text into path by accessing
Object to path menu. Then, open up Path
effects (Shift + Ctrl + 7 ) panel.

Add path effect,
Deformation . Click Add .
Click

Create an ellipse using the Circle tool (F5). Choose
any size and stroke color you like. No need to give it
fill color. Convert it to a path by going to Path Object to path menu or press Shift + Ctrl + C.

and choose

Path - Path

Now, the upper part of the text is surrounded by
green line. Drag the line so it sticks to the leaf
shape. Do the same step for the lower part (choose
the Bottom bend path first).

Envelope

Uncheck the Enable left & right paths option. Click
on Top bend path icon to edit the upper side
of the text (right, top).
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Now, you can remove the leaf shape while the
enveloped text will remain there.
Later, create another leaf shape and another text, for
example “RESIDENTIAL”. Do the same steps as
above until you have the “leaves” you want.

For the flower, you only need to follow the steps like
you did on the leaves. Prepare another eight
elliptical shapes containing words ORGANIC,
HOME-MADE,
BENEFICIALLY,
NATURAL,
RECYCLING, GREENER, ENVIRONMENTALLY,
and CONVENIENT for the petals. You can color the
text with a solid color or gradient color. Later, you
can delete the ellipse shapes.

Create a circle and make the petal shapes go
around the circle. How?
First, select the first petal shape and rotate it 90
degrees. Put it above the circle.

For the stalk, you can make an ordinary curve using
Bezier tool (Shift + F6). Then, type a text “THE
POSSIBILITIES ARE ENDLESS”. Rotate it 90o. Put
this text into the curve by selecting both the curve
and the text, then select Text - Put on path. Hide the
path by removing its stroke.

Before the ellipses are removed

Double click the petal shape. You will see + sign in
the middle of the petal shape. Move it to the center
of the circle. You can also activate Snap an item’s
rotation center option first. Ensure that your Snap
Control Bar is active (go to View - Show/Hide Snap Control Bar menu).
Open up Transform (Shift + Ctrl + M ) panel and
open the Rotate tab. Set the rotation angle to 45o,
click Apply.
Click the second petal shape, move its center point
(the + sign) to the center of the circle, and rotate it
45o twice.
Do the same step to other petals. For the third petal
and later, rotate them 45o several time so that you
achieve the right position.

After the ellipses are removed
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Group all petal shapes and put them above the
stalk. Make proper adjustment such as rotate them a
bit.
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The final result can be like this (or even much
better):

Screenshot Showcase

Posted by tuxlink, on June 4, 2019, running KDE.
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Inkscape Tutorial: Create Tiled Clones, Part One
by Meemaw
The Clone tool in Inkscape is useful for creating
many copies of a single object. It is convenient to
clone an object rather than to simply copy one. If
you make several copies of an object, then they are
all stacked up in one group and must be moved.
Also, clones are unique in that if you change the
beginning object, the change also happens to the
clones. This may make for easier work. The section
Create Tiled Clones is very useful for creating many
clones arranged a particular way. It is a menu option
that has multiple configurations. The configuration
window has tabs for several different types of
changes. Let’s try a few.
Create a simple object, like a circle, square or star. I
got a little silly with my star.

tabs for a moment. We’ll do a few basic things, but
honestly, there is so much you can do with the
Clones window, it will take more than one article.

Symmetry: This tab lets you choose what to do with

the figure you have drawn. The dropdown has 17
choices that alter the clones with a regular pattern.
P1: Simple translation makes the pattern that you
see above. Some of the other choices can give you
a different effect. PMM: reflection + reflection gives
you a different pattern, each “star” being a reflection
of the one to the left of it, and the pattern continued
down and across.

If you choose P1: Simple translation, 4 rows and 4
columns, and click Create , you will see an array like
the one below:

This one is P4M:

Select your object, then choose Edit > Clone >
Create Tiled Clones. The configuration window will
open, and you can see the tabs at the top. There are
only six tabs, but there are loads of changeable
options which can create many effects. The one
thing common to all tabs is that the bottom never
changes. Everything below the line “Apply to tiled
clones” remains throughout your tab choices (center,
top).
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90o reflection + 45o rotation

If you tried this with a square, you probably noticed
that your clones were sitting up against each other in
a sort of checkerboard pattern. In fact, you can
make a checkerboard pattern in just this manner.
What if we don’t want everything jammed together?
Some of our tabs could remedy this. Let’s look at the
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As you can see, there are many choices just using
the first tab. You can also click on the Remove
button at the bottom to delete your clones and go
back to the beginning star. Let’s experiment more.

If we add 25% to the settings in the Randomize
column, we will get this:

but decreasing the height and increasing the width in
each column. That probably is hard to visualize, so
look how we end up:

Shift: These settings will let you move things so they
aren’t just crammed up against each other, or even
on top of each other, as in the last example. You can
shift, or move, each successive row and column by a
certain percent, or randomize each. Click on this tab,
and change the settings as you see them below,
then click Create .

Randomize varies the results of the other settings so
things aren’t symmetrical.
Any of these settings can be changed to any
percent. Experimentation is the key in this project!
So let’s experiment more. Change randomize back
to zero, but leave the shift settings as they are.

Scale: This setting will let us change the sizes of our
clones. Put in the following settings:

We probably want to reset those settings. However,
we’ll keep experimenting. For the next setting, I
pressed Reset in the lower left of the window, then
went back and set the Shift tab back to the 25% we
started with, so that our result will be more easily
seen.

Rotation : This setting does exactly what you think:

rotates your clones. Set each to 30% as shown
below. See the results below that.
This will be similar to your result:

This will have the effect of increasing the height and
decreasing the width of each clone in the first row,
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Notice that some are blurrier than others and some
are more opaque. You can do these separately as
well.

Let’s stop here so you can experiment on your own.
Stay tuned for the next article. I’ll show you some
uses for this tool that you may have already seen.

Color: This setting changes the hue, saturation and

lightness of the original, so if you need some colors
to be different, you can do that as well. Make sure
you click on the color chip in the settings window
and choose the correct color.

Obviously, each clone is at a different angle. You
should be able to tell on these that each result as we
move to the right and down is a progressive product
of the item to the left and/or above it. What I mean
by that is that one the first row, the second star has
resulted from a 30o rotation of the first, then the third
is the second one rotated 30o, so when you get to
the fourth, the rotation is much more evident: in fact,
it is a 90o rotation of the first.

Linux Training
Courses & Classes

Donate To PCLinuxOS
Community Supported.
No Billionaires/Millionaires.
No Corporate Backing Or Funding.

Blur & Opacity: This setting makes the opacity and

Click here to make a one-time donation
through Google Checkout.

blur of your clones different (just what you thought).
In this one, I changed my star to a 6-pointed star,
with black fill. I also changed the rows and columns
to 8 rather than 4. I used a 25% randomize in each
setting. You can see what the result is below.

Or, click one of the amounts down below
to make a monthly, recurring donation.

It might be difficult to see, but the stars aren’t all the
same color intensity. Some are lighter than others.
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Inkscape Tutorial: Create Tiled Clones, Part Two
by Meemaw
In part one, I introduced you to the Create Tiled
Clones window and a few simple things you can do
with it. Now I will show you a few things you may
have already seen with this tool. Many of the
settings I report can be changed to suit yourself.
Also, if you have clones and decide that you want to
clone the same object again, you can use any of
them. However, if you decide to delete some and
delete a clone that you have used to clone more, all
if its clones will be deleted as well. To find the
original, all you need to do is choose one (in the
status bar, it will say “Clone of Image (size of
image)”, then press <CTRL> + C and you will see a
line extend from your choice to the original.

First, I made some little confetti pieces… diamonds
and squares, one of each in three different colors.
Using each one alone, I opened the Tiled Clones
window and changed the settings as shown below.
All settings were entered in the Randomized
columns.
Shift 85% - Scale 25% - Rotation 50% - Blur 30% Opacity 40%
In part 1 of this article, I gave you rows and columns
for the limits of the clones (bottom of the window) but
on this, I used 7” x 5” width & height.
This also worked for the stars on the cover of the
October 2014 issue. However, the settings were
different.

OK, more examples:

All Randomized … Shift 85% - Scale 25% - Rotation
50% - Blur & Opacity 0%
I selected all and moved the clones over the
shamrock background and added Tux and his hat
(parnote always adds the panels with the article
titles).

100th issue of the PCLinuxOS Magazine,
May 2015, our cover featured one of Georgetoon’s
In the

awesome cartoon characters with a cake and
confetti in the air. The confetti was made using the
Create Tiled Clones tool.

The St. Patrick’s Day, March 2015, magazine cover
featured a mess of shamrocks. I started with a
shamrock background (below, right), but I wanted
more shamrocks, so I used a different, single
shamrock and cloned it.

Also, the checkerboard mentioned in part 1? Do it
this way (next page):

Inklscape Tutorial: Create Tiled Clones, Part Two
Draw four squares, filling two with black and two with
white, and all with a .25 black stroke. Depending on
how you have your preferences, you can “snap”
them together, or use align and distribute so that
their edges are touching. Select all four squares and
click Group . They should look as shown below.

DONATE
TODAY

Help PCLinuxOS Thrive & Survive

Screenshot Showcase
Now, open the tiled clones window. The first thing
you should probably do (if you’ve been
experimenting) is reset all settings to zero by clicking
the Reset button at bottom left. Now change the
settings at the bottom of the window so you are
making 4 rows and 4 columns. Leaving all other
settings at zero, click the Create button. And, there
you go….

Posted by ximru, on June 11, 2020, running Xfce.
In the next tutorial, we will experiment with clones
that may not necessarily result in rows and columns.
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Inkscape Tutorial: Create Tiled Clones, Part Three
by Meemaw
We’ve spent some time doing tiled clones for stars,
shamrocks and confetti, and I hope you have
experimented with your own projects to see what
you can do. Each of those made use of the row and
column concept. However, many of our designs are
circular. Can we do that with tiled clones?
I actually went back to Inkscape’s tutorials list and
searched. In their Tips and Tricks section, Inkscape
Tutorials, Tips & Tricks, I found some instructions:

It's easy to see how to use the Create Tiled Clones
dialog for rectangular grids and patterns. But what if
you need radial placement, where objects share a
common center of rotation? It's possible too!
This is where we use the Rotation tab. Let’s create
the start of a clock face. Open Inkscape and draw a
line.

I want a line on each hour, so I want 6 lines (since
we’re rotating the line around the center of the
starting line, we’ll only need half as many), so set
the rows to 1 and the columns to 6. Click on the
Shift tab and set the Per row/Shift Y and Per
column/Shift X both to -100%. Now click on the
Rotation tab and set the column rotation to 30o.
Click on Create .
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I want my clock face a bit fancier, so I’ll zoom in on
the original line (which should already be selected).
Click on the Paths tool just under the selection tool
at left, then double click on the line at the center and
halfway between each end. I just moved the lines
between the nodes a bit so my line looks a tiny bit
curved. The great thing about doing this with your
line and then cloning it (or doing it after it’s cloned,
like now) is that each clone will turn out exactly like
the original. If you aren’t happy, make changes to
the original, and the changes will be made to the
clones as well… I’d rather do it once than 6 times
(top, right).
After messing with it a bit more, and adding the
numbers and circles for decoration, my clock face,
while not real fancy (or even to your liking), looks like
this (right):

There are some presets in the program, so you
could try the P3, P31M, P3M1, P4, P4M, P6, or P6M
symmetries and see how they work out.
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That was a relatively simple design. You can do
more if you vary your row and columns, varying your
rotation along with them. These settings (with the
shift left at -100 like before), you’ll get the result
shown below.

Let’s try another. With the following settings, I
obtained the figure below, which looks more like a
flower than a starburst:

P1 Simple Translation with 3 Rows and 10 Columns
Shift
X 25% Row -100% Column
Y -100% Row 25% Column
No Randomize
Scale 0% all
Rotation Angle 20% Row and 40% Column

To get a really full flower, we should duplicate it
more.
This is just a sample of things that can be done with
the Create Tiled Clones tool. Honestly, you should
just experiment to get your desired result.
Remember, the Remove button is at the bottom of
the window, just like the Create button is. If you
Create something that isn’t what you want, just click
Remove.

Linux Training
Courses & Classes
The groups of 3 are the rows, 3 degrees apart, and
the groups are the columns, spaced 30 degrees
apart.
What if you don’t want to use only lines? This time I
made a teardrop shape, and when I was satisfied
with the design, I clicked on it twice to turn on the
rotation arrows, then grabbed the cross in the center
and moved it away. The cross is the center of
rotation for the one object, and if I move it away from
the center of the object, and use the exact settings
we used before, then the clones will be arranged as
shown below. Notice that the cross in the center was
the one I moved from the original teardrop.

Does your computer run slow?

Duplicating a couple of times, and resizing the
duplicates larger and smaller, and even rotating one
of them, we end up with this:

Are you tired of all the "Blue Screens
of Death" computer crashes?
Are viruses,
adware, malware &
spyware slowing
you down?
Get your PC back
to good health
TODAY!
Get
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Inkscsape Tutorial: Easily Create A Neon Effect
by Meemaw
We’ve done many text effects in Inkscape and GIMP,
but this is a really quick and easy way to create the
effect on almost any path you draw. I experimented
with a font called Scriptina, and came up with the
following effect in just a few minutes. I’m sure you
can do the same. The good thing is that if you draw
any spirals or curves to accompany your text, you
can use this method to match them.

line. Then I’ll click on the node tool, and move the
nodes around until I like my curve, then click on the
selection tool. Change the color of your line to the
color you want.

You want to duplicate this line twice. Hold down the
CTRL key, and press D twice. You won’t see much
but your line seeming to darken, but all duplicates
are stacked on top of one another. Grab and move
the two duplicates.
Open Inkscape and set your document as you
desire. I always start with an 8.5 x 11 page, oriented
landscape, but you do whatever you like. One of my
good friends designed a template that he opened
every time, then renamed to the project. His was
1600 px by 1200 px, I believe, also oriented
landscape. Anyway, now you have a new page,
ready to create!

Also,click on the buttons that make your curve round
on the corners and at the ends. Go down to Blur,
and change it to 3. In your main window click on
“Lower selection to bottom”. We want this curve to
be behind the other two.

Choosing the center line, change the stroke to
about 8, and make sure the round corner and end
buttons are clicked. This curve will be between the
other two, so leave it where it is.

Design the item you want to change to neon. It may
be text like above, or a stroke of some kind. Let’s
start with a stroke. I’ll use my “pencil” and draw a

Let’s change things now. Open your Fill & Stroke
window, and click the Stroke Style tab. Select your
top curve, and change the stroke to about 18.
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Now for the bottom curve. This one will be on top, so
select it and click on “Raise selection to top”.
Change the stroke to 2 or 3, whatever looks good to
you (I used 3), and change the color to white. Give it
a blur of 1, and make sure the rounded curve and
corner buttons are clicked. I changed mine to a very
light purple so you could see it in the following
image, but then changed it to white for the next step.
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Now we want to stack them up for our neon. Using
your mouse, draw a rectangle around all three
curves to select them all.
This is fun! I did the text first, and you will have to set
the stroke differently because your text has fill as
well. Setting your stroke to 18 will make a mess
(since the stroke is basically an outline, and it will
overlap the letters a lot), so make your stroke about
4 or so. If you use text, you can also try making the
fill and stroke different colors, which may enhance
the neon effect.

Open your Align and Distribute window. With all 3
curves selected, click on Align vertically and Align
horizontally. This will put them right on top of each
other, something like the following:

Now I can export this as a .png so the background
will be transparent, then add it to my text (center,
top):

PCLinuxOS Magazine

Available in the following desktops:
KDE Mate Xfce
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Inkscape Tutorial: Draw A Cartoon Turkey
by Meemaw

For the beak, draw a small triangle with a shade of
yellow fill and black stroke. I also grabbed the top
line and curved it a bit.

Rotate them around and duplicate once for the other
side, then place the wings.

Turkeys have a “beard” or snood under their beaks. I
drew this with the Bezier tool, moving the nodes to
edit it the way I wanted it, but you could use the
Pencil tool as well.

If you have the body and face the way you want
them, you could choose them all and Group them
(or not), but be sure and save your work. Now let’s
get busy on the feathers. To create the feather
shape, start with a long oval. When you get it drawn,
choose Path > Object to Path .

I found a fun tutorial the other day, and since
Thanksgiving is coming up soon for many of us, I
thought it would be fun to do a turkey. I’m sure you
have done something this easy already, but we’ll use
some of the skills we’ve learned over the years.
Open Inkscape and a new canvas, and start by
creating a couple of circles. Make the fill brown with
a darker brown or black stroke. You can create the
first circle and then use <CTRL> + D to duplicate it.
After you do that, make one of the circles smaller
than the other. Open your Align & Distribute
window and align the two circles vertically. Now you
have your body and head.

Now use the Nodes tool again to add a couple of
nodes to one end so we can make it a bit different.

Now draw two circles with white fill and black stroke
for eyes. Also, add a black circle to each. Use Align
& Distribute to line them up as well.
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Also, for wings, create a zig-zag with the Bezier tool.
Choose Path > Object to Path , and curve the lines
until you have 3 smooth curves. Fill and stroke it with
the same colors as the body.

For the finishing touch, use the Pen tool or Bezier
tool to draw a simple line down the middle of the
feather. I made mine a shade darker than the feather
color. Group these two when you’re finished, and
also move the point of rotation to the right side of the
feather.
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With the feather group selected, we’re going to Edit
> Clone > Create Tiled Clones.
Now, change the following settings:
Shift X Per column to -100%
Scale X Per column to 5%
Rotation Angle Per column to 10 degrees.
Rows, columns to 1 and 11
When the settings are set, click Create . You should
get the following:

We need a circular wedge to use for shading, so
position them as shown below. Select both of the
circles choose Path > Difference .

The shape you’ll get is a wedge that can fit at the
bottom right of the face. Give it an Opacity of about
50%. Make sure the beak and snood are brought in
front of the shadow.

Now, select the bunch of feathers, and group them.
Duplicate the group and flip the duplicate
horizontally. You can do this as many times as you
need to, in order to make the feathers as full as you
want. I think I made extra, but I like the result. You
will have to rotate them and line them up in the
center, then position them behind the body.

Do the same to the body. You can also add a drop
shadow to the grouped, finished turkey (right, top).
If you want to, you can add a background (right).
I hope you like the way yours turned out.

For the feet, simply use the Pen tool and draw a few
lines to make feet. Group them and duplicate, then
flip the duplicate horizontally. Position them at the
bottom.
We need to do some shading to finish. Draw a
couple of circles, or ungroup and duplicate one of
the ones you made for the head or body. I made one
just a little darker than the turkey color.
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Inkscape Tutorial: Creating A Pattern
by Meemaw
I found this tutorial a while back and thought it
looked fun. We’ll be making a wreath for the
holidays. By using repeating objects as markers, we
can create a wreath out of any shape. We’re going
to make a pattern first.
To start out, using the rectangle tool, draw a green
square. If you hold down <CTRL> and drag, it will be
a perfect square. We will use the square as a
background to our pattern to make sure there are no
blank spaces in our finished product.

them and duplicate them (<CTRL> + D ) to get as
many as you think you might need. Make them
different shades of green to give your wreath some
variety.
Group them over the square until you have them
arranged the way you want them. Select them all
and Group them (<CTRL> + G ). Now choose Object
> Objects to Marker to make this a marker. Don’t
be shocked, as it will take your pattern and put it in
markers, and it won’t show on your page any more.

To add to your wreath, select your circle with the
Nodes tool and click the Add nodes button or
double-click on your circle in the location you want a
node. Every node you add will add more of the
pattern, so just keep adding nodes until you get your
desired results. If your pattern doesn’t look big
enough (or too big), adjust your stroke size up or
down.
Choose the pencil tool and set these settings:
Mode: Bezier Path , Smoothing: 50, Shape:
Triangle in . Now create several short lines/triangles.
You can make several different lengths, then select

This will be a simple circular wreath, so draw a
perfect circle with the ellipse tool by holding down
<CTRL> and dragging your mouse. Also, choose
Path > Object to Path to convert your circle to
nodes. You will see 4 nodes.
With your circle selected, choose Fill and Stroke
and click the Stroke style tab. From here, you
should assign your custom object as a Start Marker
and Mid Marker (right, top).
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We need to add some finishing touches. Many
wreaths have berries or decorative balls on them. All
you need is a red circle, a white ellipse for a light
reflection and a dark green circle for the shadow.
You can also make some yellow or blue ones for
color variety.
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Many wreaths also have a bow on them. You may
have to draw this by hand , but I’m sure it will be
wonderful. Remember to add a drop shadow from
Filters > Shadow and Glows to give your creation
some depth.
Mine is finished, and I’m sure yours is beautiful.

Happy Holidays!
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