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From The Assistant Editor....
by Meemaw

make a Christmas card in Inkscape and LibreOffice.
This card is folded so you could enclose money in it
as a gift, and in addition, it has a 14-month calendar
for the recipient’s use.
I have separated the GIMP and Inkscape articles
into separate groups, but each group is in
chronological order. Just as a reminder, this issue
is ONLY available in pdf format, since all the
articles can be accessed in html form on the
magazine website, or found in the separate issues.
I really enjoy doing these articles, and as basic as
they are, I hope you are learning something from
them. At the very least, I have shown you some
handy tools that you can use on your own creations.
As I have said before, there are many others (some
in our very own forum) who are infinitely more
talented than I am, but at least I can show you a
couple of things to help you better use these
programs.

(Since I’m putting together this Special Edition, I
should probably write something….)
Hello!
These Special Editions are something I don’t do very
often, and do when I have time. I have a wonderful
family who include me in all their fun times, and
even at my age, I still have a part-time job (besides
the monthly issues of the magazine). Even as a
Mature Linux User, I have a job as a secretary in an
office not far from my home, and I don’t think I’ll
retire yet.
I am happy to bring you this special edition of the
graphics tutorials from the PCLinuxOS Magazine!
This is a compilation of all the graphics articles from
January, 2018 to December, 2020. It includes an
article by our own Jimlw1, who showed us how to
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It seems I never tire of reading or watching tutorials
about GIMP and Inkscape, and I’m happy to share
many of them with you. I still think it’s amazing how
truly versatile both of these programs are, and what
awesome things you can do with each. I have used
both programs in my job and in some of the projects
I have done for others - newsletters, flyers that
advertise upcoming events, postcards, classroom
worksheets and even placemats. Those of you that
use these programs know that the possibilities are
endless!
I hope you enjoy this third special edition. The fourth
will cover 2021 through 2023, and may be released
in late 2024.

The PCLinuxOS name, logo and colors are the trademark of
Texstar.
The PCLinuxOS Magazine is a monthly online publication
containing PCLinuxOS-related materials. It is published
primarily for members of the PCLinuxOS community. The
magazine staff is comprised of volunteers from the
PCLinuxOS community.
Visit us online at http://www.pclosmag.com
This release was made possible by the following volunteers:

Chief Editor: Paul Arnote (parnote)
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HTML Layout: YouCanToo
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I send you prayers for health, happiness and
prosperity for all.
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GIMP Tutorial: Create A Color Swirl
by Meemaw
I found a neat tutorial that only takes a few steps
and makes a swirl pattern that could be used for a
wallpaper or a fun background. I think it will be fun.

Duplicate the layer, naming the original one name
“fade black”. For this layer, set the layer mode to
Multiply. Rename the duplicate “light”.

Create a new image. I made mine 640×480, but you
can use any size. Choose Filter > Render > Clouds
> Plasma. You can change the pattern by clicking on
the New Seed button. When you get something you
like, apply the filter. Your result should look similar to
the image at center, top:
Now do Filters > Distorts
the following settings:

> Whirl and Pinch , using

Whirl angle: 130
Pinch amount: 1
Radius: 1

It should look like this now (right).
Create a new transparent layer.
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Choose the Blend tool, using white as foreground
color and black as background color and choosing
the shape: Radial .
Click and hold the mouse button and move from the
center of the image to one of the four corners. It
should now look like this (top, right):

Click the layer named light. Choosing Colors >
Brightness & Contrast, change the values to -65
(brightness) and +45 (contrast). Now apply Filters >
Distorts > Whirl and Pinch , using the following
settings:

Whirl angle: 130
Pinch amount: 0.8
Radius: 1

Set the layer mode for this layer to Dodge . Duplicate
the light layer to enhance the effect.
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GIMP Tutorial: Create A Color Swirl
Color balance. Using Color Balance, you might try
the following settings:

Shadows -30 / -30 / +30
Mids: -30 / +10 / 0
Highlights: 0 / 0 / 30

You can also leave out the black or white
background and make it semi-transparent, then use
it as an accent on something else, like a real quick
letterhead:

You can even make a wallpaper. I like mine a bit
darker, so I kept the black.

Now change to the background layer. Choose Filter
> Blur > Selective Gaussian Blur with the following
settings:

Radius: 50
Max. Delta: 70

You can export your project any time you are
satisfied with it. I chose to save it with the black
around the outside, but I also used Colors > Color
to Alpha and remove the black, then put a white
background behind it. I got this:

As always, you can get several effects, depending
on your settings. Hope you had a bit of fun with this
experiment!

Looking for an old article?
Can't find what you want? Try the
I actually liked it better before the blur, so I’m going
to undo that and leave it without the blur.
You could make it a single color using
Desaturate, then Colors > Colorize or
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GIMP Tutorial: Another Simple Animation
by Meemaw

one frame at a time. It will be a separate creation
from your beginning graphic. Now you can go to
Filter > Animation > Playback to view your
animation in GIMP. Clicking on Play will show you
what it looks like.

This one is a very quick and easy method for making
a specific animation. I know Valentine’s Day is long
gone, but the day I did this one was just a few days
before Valentine’s Day and I had just been playing
with some graphics for it, so I used one for this
tutorial. This graphic includes a heart design that the
very talented ms_meme gave me a few years ago. I
added my own text. When we are finished, our
animation will be a globe shape, with our selected
graphic mapped to the globe and spinning around.
(Bear in mind, if you are reading this in the PDF, the
globes won’t be spinning, but you can open the webbased html version and see the animations.)

When you have your starting graphic complete, go
to Filter > Animation > Spinning Globe . A window
will appear with some settings. I kept the defaults,
except for the number of frames, which I changed
from the default of 10 to my desired number of 15.

Create the graphic you want to use for your globe.
Be sure your image is complete before you do
anything else to it, and save your work as a GIMP
.xcf file. Since the process stretches the image out
over the surface of the globe, I made my graphic
smaller with a bigger background, on a square
canvas 800 x 800 px, as seen at center top.
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Close the playback window and click Export as…
When you put in your filename and choose .gif as
the extension, you will get an options window. Make
sure you check the box in front of As animation .
Click Export.

Click OK and your animation will be made. The more
frames you want, the longer it will take as it makes
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GIMP Tutorial: Another Simple Animation
Now you have a spinning globe that only took a few
minutes! I’m sure you can have fun with this.

DOWNLOAD

Mate Desktop

Screenshot Showcase

Posted by Mr_CrankyZombie on December 31, 2021, running KDE.
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GIMP Tutorial: Sphere Variations
by Meemaw
In the March issue, we created a spinning globe
which had text or an image on it. This time we’re
going to use a different GIMP filter to create another
globe, or sphere, with two different effects.

Now, Click on Filters > Map > Map Object. The
following window will appear. Choose Map to
Sphere and check Transparent background , and
Create new image (unless you want the sphere to
appear over your grid).

The result:

The first effect will be a “photo sphere.” The first time
I did this was with pictures of my grandchildren. This
time I am using sections of my favorite wallpapers
created by many of our PCLinuxOS family members.
I edited sixteen images, all 450 x 450 px, set into an
1800 x 1800 px grid.
Create a new image, 1800 x 1800 px. Grab three
guides from top and side and place them 450 px
apart to make a grid. Copy and paste your images
into your grid. It should look similar to the following;
Click on the Orientation tab and choose the
following rotations:
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You’ll see different parts of the sphere if you change
your rotation settings.
Our other variation is a spiral. Create a line of black
stripes.
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GIMP Tutorial: Sphere Variations
Select the black, then click Select > Grow and grow
the selection by 15 px. Create a new layer and
choose the Gradient tool, then fill the selection (in
the new layer) with a brushed aluminum gradient.
Then move it to the bottom and merge the layers.
Click Colors > Color to Alpha and choose white.
Choose a pattern to fill the black (I used a water
pattern) and use Bucket fill .

Crop it down so you have stripes clear to the edge
all around.

With a bit of planning, you can make the stripe
continuous. If you don’t rotate your stripes, it comes
out nice anyway.
Let your mind wander. The possibilities are endless!

Save your work.
Now click on Filters > Map > Map
choose the same settings as before.

Object,

and

Now choose the rotate tool, and rotate your stripes
-10 degrees.
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Long Awaited GIMP 2.10 Released
by Meemaw

the color icons. The added zing here is that you can
choose what size your icons are. In the drop-down,
choose “Guess icons size from the resolution”, “Use
the icon size from the theme”, or “Custom size”.
When you choose Custom size, the slider at the
bottom will activate and you can choose Small,
Medium, Large and Huge. If you need things a bit
bigger, this is great. The icon set in the image below
is the “Color” set.

• When higher than 8-bit per channel precision is
used, all channels data is linear.
• You can choose whether the gradient tool should
work in perceptual RGB, linear RGB, or CIE LAB
color space
Color Management has been revamped. In previous
versions, it was a plug-in, but now it’s a core feature.
When you start a new project in GIMP, you’ll find that
the Create New Image window has much more to
select. Just click on Advanced Options.

GIMP 2.10.0 was released on April 27th and
2.10.2 was released on May 20th.
GIMP has always been wonderful, but in the 2.10
version, many things have been corrected and
added. I’m sure this article will only scratch the
surface, but I wanted to give you some highlights of
the new version.
One of the newest things you’ll see when you
upgrade to GIMP 2.10 is that there are more themes
and more icons. When you first open it after
updating, GIMP will open with the Dark theme and
Symbolic icons, which are now the default. No
worries, you can open the Preferences and change
the theme and the icons. The themes are Dark,
Light, Grey and System. The icons are Legacy,
Color, Symbolic and Symbolic-inverted. Symbolic
and symbolic-inverted are the same design, but
Symbolic is grey (suitable for the dark theme) and
symbol-inverted is dark grey (suitable for a lighter
theme). Legacy icons are the traditional icons GIMP
has had forever, so you can use them if you decide
they are irreplaceable. I chose the light theme with
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GIMP’s big news is that GEGL is now being used
throughout the program. I know it is an image
processing library, but I really don’t understand it
very well, so I’ll quote from the release notes:

Here is what it boils down to:
• You now have both linear and perceptual versions
of most blending modes.
• There is now a linear version of the Color Invert
command.
• You can freely switch between the two at any time
via Image > Precision submenu.
• You can choose which mode is displayed in the
Histogram docker.
• You can apply Levels and Curves filters in either
perceptual or linear mode

Color space, Precision, Gamma and Color profile
are new choices. Until I learn a bit more, I’m sticking
with the defaults above (other than my choice of fill).
Layers and masks have many more choices to help
enhance your creation. Clicking on the layers dock,
you’ll see a “mode choice” button at the top with two
choices, Default and Legacy. Default is the new
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Long Awaited GIMP 2.10 Released
mode collection, and Legacy is the modes that were
in GIMP 2.8. You can see there are more choices in
Default.

Also, if you always want an alpha channel in your
layers, you can enable automatic generation of the
alpha channel in imported images upon opening
them. See Edit > Preferences > Image Import &
Export for ways to do this on Import.
The Transform menu has been extended and there
are a few more tools:

Unified Transform
Creating a new layer, you can also see that the New
Layer window has more choices:

You can use this tool to stretch a photo any direction
(rather than having to pull up different tools). As you
can see, there are more handles and the photo is
changed differently depending on which handle you
grab (and which way you move it).

Warp Transform
This tool will stretch a chosen part of your image (not
like the smudge tool). When I started, the egg yolk
was a circle.

PCLinuxOS Magazine
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Long Awaited GIMP 2.10 Released
Handle Transform
This tool will stretch or rotate an image while the
handle holds it in a specific spot. The circle in the
upper left corner is the handle.

Blend tool becomes Gradient tool
GIMP has renamed the Blend tool to Gradient tool
and changed its default shortcut to G. This is only
the start of the change!
The new tool pretty much makes the old Gradient
Editor dialog obsolete. Now you can edit the
gradient right where you drew it, on your creation,
adding and deleting stops and colors as you go.
You can even start with a pre-made gradient, then
develop it into a different one right there (center top).

Better selection tools
The Foreground Select tool is more selective now.
Two new masking methods are now available for
that.
The Select by Color and Fuzzy Select tools both
have a Draw mask option to display future selection
area with a magenta fill. The Fuzzy Select tool also

PCLinuxOS Magazine

got a Diagonal neighbors
diagonally neighboring pixels.

option

to

select

With the Free Select tool , closing the selection now
doesn’t make the selection automatically. Instead,
you still can tweak positions of nodes, then press
Enter, or double-click inside the selection, or switch
to another tool to confirm the selection.
The Intelligent Scissors tool now lets you remove
the last added segment with Backspace key, and
GIMP now checks, whether the first and the last
segments are distinct before closing the curve.

Digital painting improvements
GIMP 2.10 has many improvements requested by
digital painters. The one I noticed right away was the
MyPaint Brush tool . It has a number of different
brushes that GIMP didn’t have before, except in a
GIMP fork called GIMP-Paint (right, top).

Many of the tools have additional choices. From the
release notice:

The Smudge tool got updates specifically targeted in
painting use case. The new No erase effect option
prevents the tools from changing alpha of pixels.
And the foreground color can now be blended into
smudged pixels, controlled by a new Flow slider,
where 0 means no blending.
All painting tools now have explicit Hardness and
Force sliders except for the MyPaint Brush tool that
only has the Hardness slider.
Most importantly, GIMP now supports canvas
rotation and flipping to help illustrators checking
proportions and perspective.
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Long Awaited GIMP 2.10 Released
A new Brush lock to view option gives you a choice
whether you want a brush locked to a certain zoom
level and rotation angle of the canvas. The option is
available for all painting tools that use a brush
except for the MyPaint Brush tool.

Don’t know which filters are the new and improved?
Look for the icon in front of each filter. I think the big
G means it’s a new &/or improved version, and the
gear is the legacy filter, but I may be wrong.

New Symmetry Painting dockable dialog (click on

Windows > Dockable Dialogs > Symmetry
Painting ), enabled on per-image basis, allows to
use all painting tools with various symmetries
(mirror, mandala, tiling… ).

Exposure, Shadows-Highlights, High-pass,
Wavelet Decompose and Panorama Projection

are new filters aimed at photographers. I intend to
try each of them to see how awesome they are.
One of the things I found that is really great (at least
for me) is the split view on the new filters. Activating
split view (circled) allows you to see the difference
between what you started with and what you are
doing with the filter.

Many more changes are present. You’ll have to open
GIMP and see what you can find. I haven’t even
covered half of the improvements.
For further information, see the release notes:
https://www.gimp.org/release-notes/gimp-2.10.html

Looking for an old article?
Can't find what you want? Try the

PCLinuxOS Magazine's
searchable index!
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Available in the following desktops:
KDE LXQt Xfce
MATE Openbox
Enlightenment
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GIMP Tutorial: Create A User Bar
by Meemaw

A lot of people have userbars in their signatures, and
many of them are really wonderful! Ours are usually
made by one of our wonderful artists and donated
on the forum. However, they aren’t too difficult, so
let’s make one.
You can use any dimensions, but let’s use 300 pixels
wide x 50 pixels high. It doesn’t matter whether you
start with foreground or background color, because
we’re going to change it. Select your gradient tool.
Set your foreground and background color to
something that you like. Set the gradient to "FG to
BG". Click at one end of your bar and drag to the
other end to make your gradient. I went kind of
diagonally (top left to bottom right), but you can
make your gradient however you want.

you de-select the gray, click on Filters
Shadow and give it a 2 px drop shadow.

> Light &

Now add another layer and click on the ellipse tool.
Make an ellipse from one end to the other. Make it
stretch just under half way down the userbar. Fill it
with the color white.

change, then adding one last layer on the bottom,
filled with black.

Many of the people on the forum have made
userbars, and many of them are just awesome! This
one was simple, but with different effects (a striped
background, for example) or fancier text, I’m sure
yours can be just as wonderful.

A magazine just isn't a magazine
without articles to fill the pages.
Lower the opacity to around 50 to give the userbar a
3D effect.

If you want some sort of picture on it, add a
transparent layer and put it there. I added our wellknown PCLinuxOS Ring. Put whatever text you want
on this layer as well. While you’re at it, select the text
and add a layer behind it. Choose Select > Grow
and grow your text selection by 1 px, then fill it with a
dark gray. This will highlight your white text. Before
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If you have article ideas, or if you
would like to contribute articles to the
PCLinuxOS Magazine,
send an email to:

pclinuxos.mag@gmail.com

If you desire, you can put a black border around the
whole thing. The easiest way for me was to change
the Image > Canvas Size by 2 px, centering the

We are interested in general articles
about Linux, and (of course), articles
specific to PCLinuxOS.
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GIMP Tutorial: Editing Your Vacation Photos
by Meemaw

That has brightened up the colors a bit.

Everyone takes vacation photos, and I’m sure yours
are wonderful. We’ve seen some really great photos
in the forum as well, and I’m sure that yours are
among some of the great ones. If you don’t think
they are, and you’re wondering how to make
improvements to some of them, I’m going to show
you a few things you might do to make your photos
“pop.”
In the July, 2015 issue I did a short tutorial about
editing photos. This one expands on that a bit and
gives you more choices. In the earlier tutorial, I used
a photo I took at Monument Valley in southeast
Utah. I’m going to use a different one this time. This
one was taken in Colorado from an ATV trail.

underneath the histogram inwards towards the spot
where the curve starts extending upwards. This
helps to even out the light and dark areas of the
picture. Then, move the center arrow left or right
until you are satisfied with the result. This changes
the midtones. If you will check “Split view” at lower
right, you can see the changes in the left half of the
picture with the photo’s original appearance on the
right half.

The next thing we want to do is edit again using
Colors > Curves. When the window opens, you will
see the histogram again, but it doesn’t look quite the
same because you’ve already edited a bit. On top of
the histogram is a straight line from bottom left to top
right. You can use this line to fine tune the areas of
your photo. Pulling down on this line will darken
things and pushing up on it will lighten things.
Depending on which end of the line you move and
which way you move it, you can change the
darkness and lightness more than you would if you
quit at editing levels. Also, when you click on the
line, it will create a node which will stay when you
release it. Now you can click elsewhere and move
your line again to edit other aspects of your photo.
Lightening dark areas and darkening light areas may
improve your photo greatly. (Check “Split view” to
see what’s happening.)

The first thing you can do is adjust the Levels . Click
on Colors > Levels and you’ll get the histogram
showing the color graph (center, top).
As you can see there is a low spot on each end of
the histogram. Start by moving the arrows
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As you can see, my line ended up as an “S” shaped
curve. My photo looks a bit better, too.
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GIMP Tutorial: Editing Your Vacation Photos
Saturation is the intensity of the color in your photo.
If you click Colors > Saturation or Colors > HueSaturation , you can adjust the colors so they are
more intense. If your photo is dull, this is one of the
best ways to enhance it. Using Saturation is easier
because there is only one slider, but to fine tune
things, you could use Hue-Saturation as there are
many different settings. If there is a certain color you
want to emphasize, you can do it there.

The next thing you can do is adjust any color you
think shouldn’t be there. This uses Colors > Color
Balance.
One last thing you can do is use Sharpen or
Unsharp Mask to sharpen your photo, being careful
not to go too far, as your photo may end up with little
white halos on the edges of things. This is Unsharp
Mask that has been taken to excess:

In this one, you can edit three different ranges:
Shadows, Midtones and Highlights. You might
have to study your photo to see if your colors are the
way you want them. This is especially helpful if you
think your photo is too red or green (or if your photo
is old and has turned that reddish brown that some
of them turn). Again, click “Split view” to see what
you are doing.
I wanted just a little more green in my photo, so I
increased the green.

I used Hue-Saturation and set the saturation up to
30 (right, top).

Linux Docs
Linux Man Pages
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GIMP Tutorial: Editing Your Vacation Photos
In an article I read, it was summarized as follows:

• Adjust the dark/bright Input Levels sliders relative
to the histogram edges to improve contrast. Adjust
the mid-tones slider to settle on the overall
brightness.
• Apply a subtle curve adjustment (Curves) to
enhance any areas along the brightness scale we're
still not happy with.
• If you think there's a nasty tinge to your image,
balance it out using the Color Balance tool.
• Increase the master saturation and also adjust the
Saturation for any other colors you want to
emphasise further (or de-emphasise).
• Apply some Sharpen ing, being careful not to
make edges look too 'spikey'.

Before

My mountain photo looks better, in my opinion.

editing photos, their systems have slowed down a
lot. While it hasn’t happened to me, you could
experience some slowdowns. Some of it also
depends on your system capabilities (memory,
CPU), the size of your photo (bigger takes longer
and uses more resources), and what steps you are
performing. If you are just cropping your photo or
resizing it, you should be fine, but if you are using
some heavier filters, it may take a while. Also, the
status bar shows a completely different number than
your image size: it shows the amount of system
memory used by your image. I was working on an
image that had a file size of 2MB, but the status bar
showed 47MB! That’s the memory my system is
using while I edit the photo. I’m sure if the GIMP
developers get complaints, they will address it
quickly. I know there have already been a couple of
posts on our forum. Hang in there, guys, I know
they’ll fix it.

Does your computer run slow?
Are you tired of all the "Blue Screens
of Death" computer crashes?
Are viruses,
adware, malware &
spyware slowing
you down?
It might be too green for you, but as I remember the
trip, everything was very green and lush.
Oh, my Monument Valley photo from the last article?
I did it again and I think it looks even better. I’ll show
both so you can compare.

After
I can tell you that when you are there, the colors are
vibrant like in the second photo.
Following these steps has helped me immensely! I
hope they help you edit your photos like they helped
me. Your photos will look awesome, too!
By the way, we have a new version of GIMP as well,
version 2.10.6. Some people have told me that while
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Get your PC back
to good health
TODAY!
Get

Download your copy today! FREE!
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GIMP Tutorial: How To Add A Sepia Tone
by Meemaw
With photography what it is today, and photo
manipulation programs being so easy to use, it is
great to take a digital photo of something and then
see how you can manipulate your photo for the best
image possible.

While I’m sure this is very simple (I have never used
Photoshop), this can be done in GIMP, and with
fewer steps.
Open the photo in GIMP (of course). I’m using a cute
animal photo I found.

Most of the time, the photo is awesome just the way
it is, but sometimes, a black & white or sepia image
really pops as well. Google defines sepia as a
reddish-brown color associated particularly with
monochrome photographs of the 19th and early 20th
centuries. Since we’ve explored image enhancing,
changing a photo to sepia is just another
enhancement.
In an earlier magazine article, parnote discussed
tutorials for Photoshop & GIMP, which got us
discussing the tutorials, and which Photoshop
tutorials could be used in GIMP. At one of the links
he provided, I came across a Photoshop tutorial for
changing a photograph to sepia. It was a very simple
tutorial, and is shown below.

It should happen immediately.

Click on Colors

> Desaturate > Sepia.

Wow! That was fast! However, what if you don't like
the way it looks? Go click on Edit > Undo Sepia.
Now, you can do it a bit differently to allow yourself
to control the color. Go back to the Colors menu
and choose Desaturate > Desaturate . You will get a
photo in grayscale.

Here is a step-by-step for Photoshopping a photo to
get a sepia tone.
1. Open the image in Photoshop.
2. If the image is color, go to Image > Adjustments
> Desaturate and skip to step 4.
3. If the image is in grayscale go to Image > Mode
> RGB Color.
4. Go to Image > Adjustments > Variations.
5. Move the FineCoarse slider down one notch less
than the middle.
6. Click on More Yellow once.
7. Click on More Red once.
8. Click OK.

PCLinuxOS Magazine

You can now go back to the Colors menu and
choose Colorize , just a bit farther down in the main
Colors menu. Don’t be shocked if your photo turns a
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blue color, as that is just how the window comes up.
In the center of the Colorize window there is a color
button which should be the same color as your
photo is now. Click on that, and the Color window
will appear, and let you change the color to a sepia
(brownish) color. Feel free to play with the color in
the Color window before clicking OK.

Does your computer run slow?
If it looks the way you think it should, you are free to
quit adjusting and export your photo. If you think it
could use a bit more red or yellow, you can also click
on Colors > Color Balance and experiment there.
To add more of the colors on the right, click the up
arrow on the right end of each scale. To add more of
the colors on the left, click the down arrow.

Are you tired of all the "Blue Screens
of Death" computer crashes?
Are viruses,
adware, malware &
spyware slowing
you down?
Get your PC back
to good health
TODAY!
Get
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by Meemaw

when clicked the image is enlarged to fill the
screen. ” (Steve Reid)

There is so much in GIMP, and we have such fun
using it! When we first started, we learned a few tips
to make our work easier. In my visits to the GIMP
Learn Forum, I saw a thread called Absolute
Beginners Tips and thought I would illustrate a few
of the tips. You may know these already, but I hope
you can learn something new. I have added the
name of the person who posted it.

I already knew this, but it bears repeating. It’s really
easy to click on that corner icon and enlarge your
image to the size of your work area.

“When having many layers in your work and you
need to see only a layer. You can close all of the
eyes less the layer needed by pressing Shift and the
layer eye at once. The same action to get to recover
the whole open eyes. ” (Issabella)

“When you save an . xcf, all the layers and paths you
have made are kept. This is good if you have done a
project that you might use again. Also you can play
with the layers and alter the images any way you
wish. ” (Pat625)
I have this .xcf file of some planets I did a few years
ago. I have changed it a couple of times, redoing the
planets when I wanted, but I have kept two of the
planet layers and the starry background. If I were to
merge those layers, I couldn’t edit the image nearly
as much as I can if I keep the layers intact. I can
always export any image I want to keep.

I have, at times, had so many layers in my creation
that I lost track of the one layer I need to be working
on, or see so much, I can’t concentrate on that one
layer. Hold down the Shift key, and click on the eye
on the left side of the layer you want to work on, and
the rest of them will disappear. I clicked on the eye
on the fifth layer down (while holding down the Shift
key) and now that is the only layer that is visible.

“One thing that you want to keep in mind is that if
you merge a layer, and you close the work or Gimp,
you won't be able to get that layer back. I don't know
if I explained clearly, any layer you merge or any
effect you put on a layer, you cannot roll it back
when you close Gimp. Even if you save your work. ”
(Conbagui)

“One that for me makes things a little easier is the
small icon at the extreme top right of your work area,
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Put another way, anything you do in GIMP can be
undone (even merging two layers), as long as GIMP
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is open. When you close GIMP, your undo history is
deleted and you can’t go back to anything you did
before you saved and closed GIMP.

“Hold down the mouse scroll wheel and you can pan
the canvas - by keeping it depressed and moving
the mouse. ” (RJKD)

“You can 'swap' layers between opened images
without destroying or 'losing' layers. You may wish to
practice this by creating two images open at the
same time each with 2 colored layers and by holding
down a left click of the mouse on any layer, drag it
over the other image to activate it and release the
mouse - now your first image still has 2 layers, your
second has three. ” (RJKD)

Well, now, I have learned something else as well!!! If
you are zoomed into your image and want to move
to another area, just press your scroll wheel down
and hold it, then move your mouse. Your canvas will
move and you can move anywhere on it you wish.
Make sure it’s your scroll wheel, because if you
forget and try to do it with your mouse button, you’ll
just move a layer that you probably don’t want to
move.

I didn’t know you could do this! I can see where it
would be helpful if you were working on something
tricky, and opened two versions of the same file by
saving it under a different filename, then opening the
original again as well. To illustrate though, I have
opened a photo of a local bike trail where I walk, and
also an image of the PCLOS pinwheel.

When you release your mouse button, the layer will
be in the image.

It’s amazing how much you can learn on forums! I
shouldn’t be surprised, judging by how much I have
learned in our own forum! I hope you have learned
something as well.

DONATE
Duplicating the layer on the pinwheel, I will grab one
layer and transfer it over to the photo. Click on the
layer image (in the layers dialog) and drag it over to
the tab with the other image. The image in your
workspace will change and the layer you are
dragging will be there.
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GIMP Tutorial: Easy Ball Bounce Animation
by Meemaw
As I’ve told everyone before, there are a couple of
sites I go to which help me learn about GIMP. One of
them is GIMP Chat and the other is GIMP Learn. A
while ago, I happened upon a fun tutorial on GIMP
Learn from one of the masters there, named
animicule. I thought it might be fun to do this one. It
is an animation of a bouncing ball, but only the ball
moving (and bouncing) from left to right. There was
no allowance for the ball’s change in shape when it
hits the bottom, but I’m sure that is easy to do.
I started by creating a “ball” in GIMP, 100 x 100 px,
with a transparent background.

You’re going to need copies of your ball layer, so
choose it, and click on Duplicate layer as many
times as you think you need. I made 20 copies, but
you can make more or less. If you have too many,
you can delete the ones you don’t use, and if you
need more, you can always make them later.
OK, here is where we make things a bit easier.
Instead of choosing each layer and moving it into
place separately, let’s link them and move everything
at once. In your layer dialog is a link function, shown
by the chain between the eye (making your layer
visible) and your layer name. You can click on each
one separately, but if you hold down your Shift key
and click on one, they will all be chosen.

layers, and unlink the next to the bottom layer, then
grab the stack and move them to where you want
your next ball to be.

Continue to move and unlink until you have them all
distributed.

We need a canvas for this ball to bounce on, so I
created a new file, using an 800 x 600 px preset
canvas, with a transparent background. I created a
new transparent layer, then copied and pasted the
ball onto it. While I could still move the ball, I moved
it to the upper left side of the canvas, then anchored
the ball to the layer.
In an animation, layers are played form the bottom
layer to the top, so we’ll move them this way. In my
file, the very bottom layer is blank (and can be
deleted if desired), so I’m going to click on that link
to undo it. Then grab your layers and move them
where you want the first ball to be. I moved mine
close to the top and a bit off the page so the ball
looks like it’s coming from off to the left. You have
moved your whole stack, so go to the bottom of your
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When you think you have them arranged, you can
choose Filters > Animation > Playback to see if it
looks the way you want it to look. Be aware that
when you play it back now, all your layers will show
up, even if you don’t want them that way in the final
product.

This is just to make sure each layer is positioned
where you want it. If not, you can choose each
individual layer and move it to your liking. Saving
this as a GIMP file will preserve your layers in case
you ever want to go back in and do anything. Now,
export as a .gif. One message you’ll get is this one:

This just means that since all of our layers were 800
x 600 px, and we’ve moved most of them, the layer
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boundaries have spilled off the right and bottom of
the canvas. Since the ball was close to the top left
corner, the rest of the layers are empty. We can
safely crop them off, so click Crop .
The next window you get is the export as GIF
window.

Of course, the first thing you choose is “As
animation”. Then put in the delay between frames
(100 ms is the default, and I have changed it to 200
ms here, which will make it slower). I also chose
“Loop forever” so it will play over and over until you
close it. To make sure your animation looks like one
ball bouncing, choose “One frame per layer
(replace)” in the Frame disposal line.

It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...

Have fun! The animation won’t show in the pdf, but
you can see it in here.
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by Meemaw

photo, I put the desaturated layer on top and used a
white mask, painting it with black to expose the color
photo below.

I was talking to some of the guys in PCLOS-Talk the
other day, and they were talking about GIMP, and
how they were wanting to understand masks. They
wanted to learn more about how they worked, and
told me that one of my future tutorials needed to
cover that.
In my research, I discovered that I had already done
a tutorial about masks in the August, 2013 issue, but
that’s been a while, so I will revisit the subject here.
As I said in the first article, a mask is a layer you can
add to your project to affect certain parts of it.
However, instead of being another layer, the mask is
attached to a layer and affects the pixels on that
layer. It’s used to block or show the pixels on the
layer it is part of, so your project is changed in some
way.
According to the online book, Grokking the GIMP,

layer masks are special layers that are only 8 bits
deep and that represent the alpha channel of an
image layer. Now I’m not quite sure I understand it

the same layer as the mask. In one of the projects, I
changed the mask itself to a gradient (grey to black,
so the top left of the photo was partially colored and
the bottom right was black & white like the
desaturated copy below), then painted the flower
with white to highlight it. Here is another example of
the first kind, using the tulips in my yard.

The dramatic effect above can be done with either a
black or white layer mask. You just have to place the
desaturated layer in a different spot.
I can also use this tool to quickly erase the
background from a photo that has just the picture I
want to use elsewhere. We went to an auto auction
a few years ago (just to look at the vehicles) and I
snapped this picture:

when stated that way, but it is a special layer that
can be manipulated to change the image.
To add a layer mask, open the image you want to
use. In the layers dialog, right click on the layer
where you want the mask. A menu will open , and
click on Apply Layer Mask. You’ll get the window
shown at center top:
In my first article, I reviewed a couple of methods of
using the layer mask to affect a photo. The first was
a black layer mask, which made the layer invisible,
showing the desaturated layer below. Then we
painted with white to show specific areas of color in
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In each instance I used a black layer mask and
painted it with white, essentially covering up the
layer then exposing selected areas of it.
A white mask does the opposite: it makes the layer
visible. Painting it with black hides that part of the
layer, revealing the layer below. On the following
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If I want to use only this truck in another project, I will
want to get rid of the background. Open it in GIMP,
and apply a white layer mask to this layer. Notice in
the image below that I have also selected it with the
Lasso tool. Go to Select > Invert to change the
selection to the background. The white blob in the
top left corner is what happens when I start painting
with the eraser, but if I use the paintbrush with black,
the background disappears (top right corner). When
it is exported, only the truck shows. An extra added
attraction is that if your hand slips and you run over
the truck, it doesn’t get erased, because it isn’t in the
selection.

You could also use another tip: if your object can be
outlined relatively easily with one of the selection
tools, you can then bucket fill your selection with
black instead of painting it in with the brush. I use
the Lasso or Intelligent Scissors most, but you can
also use the Paths tool. It is much faster and more
accurate than painting! I used that on the butterfly
photo, but the truck and the flower photos would be
a bit more difficult (because there are more detailed
edges). As you can see above, I didn’t outline the
truck very well. If I was going to use that in another
project I would have to be much more careful.
However, when I get the truck outlined correctly, I
can invert the selection, then bucket fill with black. If
you press Delete, the background will disappear, but
replaced with a white background (I started with a
jpg file, which doesn’t use transparency). Then you
could export it as a png.
When the online book was written there were only 3
choices in the Layer Mask window. Now there are 7,
and I’m still learning. The book says that the layer
mask will only work if the photo has an alpha
channel, and there is a choice to add one if needed.
We’ll revisit this again, but I need to learn more first.
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GIMP Tutorial: Pressed Text
by Meemaw
I saw this tutorial several months ago and thought it
was neat. It makes a text that looks sort of like it was
stamped into the background. I used the same
pattern as the original, so I’m going to also try it with
a different pattern to see how it changes.

letters are outlined. The next step is to fill the letters
with a pattern. Choose Bucket fill and change to
pattern fill. Choose the pattern named “Pine?”, and
fill the letters. Now, add a drop shadow using Filters
> Light and Shadow > Drop Shadow. (I used the
legacy drop shadow tool.) Make your drop shadow
offset 4 px.
The next step is to fill our letters again. However, we
want to leave that wood grain as a border, so go to
Select > Shrink and shrink it 3 px. Now, choose
your Bucket fill again, but change back to FG fill and
use a gray color. Your letters should now be gray
with a wood grain border.

So, let’s go through it. I made my drawing 800 x 600
and my text Verdana Bold Italic, size 120 px. I used
the name of everyone’s favorite distro, but use
whatever text you want.
When you get your text written, change to the move
tool and move it to the center of your canvas, then
right-click the text layer and choose Layer to image
size.

Now we can merge all our layers by clicking
> Flatten image.

Image

We’ll put the first of two gradients in now. Change to
the Gradients tool, and choose a radial gradient, FG
to transparent. Reverse the gradient as well, so the
transparency is on the “left”.

We’re going to add another drop shadow, but it will
affect the gray parts of the letters. Choose Select >
Invert so everything else is chosen, then choose
Filters > Re-Show Drop Shadow. Change the
offset back to 8 px and click OK. This puts the
shadow on the inside of the border.

Now, start in the center of your canvas and draw
your mouse pointer to the bottom right corner (next
page, top left).

Now, choose only your text by right-clicking the text
layer and choosing Alpha to selection . Now your
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Now, go to Select > None , then click on the
background layer and fill it with the same pattern.

The next step is to do a bump map on this creation.
Click on Filters > Light and Shadow > Lighting
Effects. Click on the Bump Map tab and click the
box that says Enable Bump Map . If our project had
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crop out whatever you don’t want. I chose to crop a
lot of my drawing, leaving just the text. Since it is
your project, you can choose how much or little to
crop.

multiple layers, we would be able to choose which
layer we wanted to use, but we only have one layer,
so just click OK.
Neat effect, isn’t it? I tried it again, using “Pastel
stuff” for the letters and “Rain” for the background. It
looks totally different. It may not appeal to everyone,
but this is just another example of what can be done.

Let’s add another gradient. If you click on your
gradient tool again, your settings should still be
there. Start in the center again and drag past the
corner.
If you’ve noticed, the drop shadow tool has left some
extra at the sides of the project. At this point you can
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GIMP Tutorial: Joined Photos
by Meemaw
I saw this tutorial on YouTube and it looked really
fun, so I’m going to share it. This is similar to the
“Out Of Frame Effect” tutorial I shared in the
November, 2014 issue. This one will make an image
look like it is spread across two photographs.

I am again using an image from a parade that my
town has every year.
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After loading your image into GIMP, right click on the
layer that shows the image (in the Layers toolbox)
and choose Add Alpha Channel . (We’ll have to
explore Alpha Channels soon.)

Now we’re going to create the border of our photo.
Go to Select > Shrink, and make it 25 pixels. Now
the smaller square is selected, so press the Delete
key to delete the white.

To start working on the photo frames, add a new,
transparent layer. In the Layers toolbox, make sure
that your transparent layer is selected, then choose
the Rectangle Select tool and draw a square.

Using the Bucket Fill tool, fill your square with
white. Now, with the square selected, go to Filters >
Light & Shadow > Drop Shadow and add a drop
shadow to the white square. I had to use the Drop
Shadow (legacy) to see it, but
you may not have any
problem.
With the drop shadow
complete, you may see that it
and your white square are in
two different layers. If they
are, right-click the drop
shadow layer and choose
Merge Down .

It’s starting to look like a photo. With that layer still
chosen, go to Select > None to de-select
everything. Now choose the Rotate tool, and click
on your photo frame. When the rotate window
comes up, press the mouse key in the angle setting
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until your frame is rotated the way you want, then
click on Rotate .

Now, choose the Move tool, to move this frame to a
different position. Drag it to wherever you want it, but
still overlapping the first frame. You also need to
decide which of your “photos” will be on top, and
make sure that layer is above the other. When I got
mine moved, I wanted the left frame on top, so I
raised that layer above the other with the arrow
buttons in the Layers toolbox.

rest of the picture quickly and easily. I’ve used this
trick many times since I learned it! Remember
though, it works that way only for straight lines.

Selecting your “frame” layers one at a time, choose
your Eraser tool, and carefully erase those parts of
the frames that are over the object you have in your
photos. You also want to erase that part of the
bottom frame that should be under the top photo.

If you haven’t saved your file, you should save it
now.
We want two photos, so duplicate the frame layer (it
should still be selected, so all you should have to do
is click on the Duplicate Layer button). You’ll see
another layer in the layers list but not another frame
in your picture yet. Change to the new layer, and
choose the Rotate tool again. We don’t usually set
every photo down in exactly the same position, so
rotate this one a bit differently than the first - maybe
even in the other direction - then click on Rotate .
Let’s really make them look like two photos on the
table. With your Eraser tool still active, choose the
layer that the photo is in, and erase the part of the
photo around the frames. There is a trick to erasing
that you might use: click the mouse at one corner of
a frame, but don’t hold it down. Go to the next
corner, hold down the Shift key, and click your
mouse there. You should see a straight line erased
between the places where you clicked your mouse. I
was able to do all the boundaries of the frames very
quickly using this method. After that, I made my
eraser tool much bigger, and was able to erase the
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At this point we want to add another transparent
layer (for a tabletop). Move it to the bottom, and
Bucket Fil l it with the color of your choice (I’m partial
to blue). You can also crop it down to a nice size
(next page).
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Save and export your image, and you’re finished!

Posted by Snubbi on January 1, 2022, running e25.
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GIMP Tutorial: Reflective Water Effect
by Meemaw
This is a tutorial for adding a water effect to a photo.
I saw two of them on YouTube - there are actually
many GIMP tutorials on YouTube, if you just search
for GIMP.
I grabbed a photo of the Grand Teton mountain
range from WikiMedia Commons. Most of these are
free-to-use images - however, you should check on
each photo to see if you need to credit the
photographer/artist. This one was taken by Michael
Gäbler.

alpha channel, and you deleted part of that layer,
you would see whatever background color you have
at that moment (mine would have been white).

I want to make a small border between the fill and
the photo, so go to Select > Shrink, and shrink your
selection about 7 pixels (although you can use
whatever looks good to you.)

For now, turn off the visibility of your bottom layer.
Then, with your top layer selected, choose your
Lasso Tool and outline the area in your top layer
photo that you want to change to water. I made mine
just the slightest bit wavy at the top, since lake
shores don’t usually run in a straight line.

Now, press the delete key. You’ll see everything
within the selection is gone and that part of your
photo is transparent.
The next thing you want to do is use your Bucket
Fill tool and fill this area with a grey. If it only fills a
few little bits of the selection, go to your tool settings
and choose “Fill whole selection”.
I also found a photo of some water we’ll use. There
is a little bit of water in the photo, but I want to make
more.
The first thing you want to do is duplicate your layer
(because we’ll need two). Then, you want to add an
alpha channel to your top layer by right-clicking the
layer and choosing “Add alpha channel”. An alpha
channel adds transparency to the layer, so if you
delete part of that layer, as we’re about to do, the
layer underneath shows through. If there was no
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Now my aim in leaving the small grey border was to
have a slight change between the vegetation and
the water, so the only border I need is the top one
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right next to the plants. Choose Select > None to
deselect the area, then use your Eraser Tool to
erase the sides and bottom lines.

can also check Split View, which shows a before
and after view of your screen, so you can compare.
When you see a reflection in the water, it is nearly
always wavy, except for those times that the water is
absolutely still, and then your reflection may still be
distorted. In the filter, Ripple, I used the following
settings: Amplitude - 6, Period - 240, and left
everything else at default. However, you can
experiment to see what you think looks best.

Now we’re going to start the reflection. Turn on the
visibility of your bottom layer, choose it, and select
Layer > Transform > Flip Vertically. Choosing the
Move Tool , move your layer up until the reflected
part at the bottom matches up pretty well. You can
see the border between them at the grey line.

Now we want to give the reflection a wavy effect, so
choose Filters > Distorts > Ripple . In this newer
version of GIMP, I hadn’t used Ripple yet, but it’s not
hard. Make sure that Preview is checked, and you
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Now that we have our reflection looking more
natural, we’ll add some actual water to the picture. I
saved a picture of water from another photo and will
use that.

Add a new white layer between the two layers you
have, and open the water picture. Copy and paste it
onto the new layer. You may also have to scale it to
make sure it will fill the area you have over the
reflected layer before anchoring it as well. Right now
it will completely cover the reflection you just worked
on. With that layer still chosen, go to the layer
attributes at the top of the layer list and set the
opacity down to about 20, but you may want to
experiment there as well. Now you can see the
reflection through the water.

Before you finish, you may want to crop your project
(I see some transparency at the bottom of mine).
Also, our grey line is still in the middle of the picture.
We want to smudge that just a bit to just make a
slight shadow between the scenery and the
reflection. You might have to zoom in to do that.
Every time I’m zoomed in, working on something, I
want to look past the edge of my project, and
sometimes GIMP won’t let me. However, see that
plus sign in the bottom right corner of your canvas?
Grab and hold that and move your mouse. GIMP will
move your photo however far you want to move it,
giving you a view of the edge (and past it) that you
want.

When you finish your image, and are satisfied with it,
save and export it. I did two… one with the border
between the picture and reflection, and one without
(next page). Do yours whichever way you like best.
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Screenshot Showcase

Posted by Ramchu on January 11, 2022, running KDE.
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GIMP Tutorial: Photo Filmstrip
by Meemaw
Last month, we saw a Repo Review of the program
PhotoFilmStrip, which allows you to create a
slideshow from your chosen photos. However, if you
want a single image that includes several photos,
you can create something like the following in GIMP.
I’ve seen this done by others but we’ve never
covered it in these tutorials, so I thought I’d do one.
In this tutorial, we can make a filmstrip out of several
photos we load, and use the Curve Bend filter to
make it something other than a straight rectangular
strip.

While you are here, you can reorder your photos into
the order you want them by moving the layers.
When you are satisfied, choose Filters > Combine
> Filmstrip. In the window, you can keep the
defaults and click OK. I unchecked the boxes
dealing with showing the numbers on the filmstrip.

Choosing the layer with the photos, and using the
Move tool, move the filmstrip to just above and to
the right of the center of the canvas.

I used 5 photos from a recent trip to the mountains.
You could use less or more, I’m sure. When you
have your photos selected, open GIMP and choose
File > Open As Layers. Your photos will open in
one GIMP project, and you’ll be able to see them in
the layers window (center, top).
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You’ll get a new project with the filmstrip. If you want
to, you can delete the first project with the photos
opened as layers (right, top).
To give yourself room to work, add a transparent
layer 2000px by 2000px. Then click Image > Fit
Canvas To Layers (right).

The openings in the filmstrip are still white and we
want them transparent like the background. First,
right click on the layer and choose Add Alpha
Channel . Click on the Select by Color tool and then
click on one of the white rectangles to select the
color white. Now, choose the eraser tool. We’re
going to start our eraser on one end of the filmstrip
and use that tip we learned a few issues ago. Click
on the end rectangle, then holding down the Shift
key, click on the rectangle at the other end to erase
them all. Merge your layers.
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We need to stretch out the first photo so it will look
right when we bend our filmstrip. With the Rectangle
Select tool, select the first photo, then choose the
Scale tool, and move the border of your selection to
the left so it’s just over twice the length that it was,
and click Scale .

Right click the floating layer and choose “To new
layer”. You can now delete the layer with the straight
filmstrip.

Make a copy of the filmstrip by clicking <CTRL> + C,
then <CTRL> + V. The copy is over the original, of
course, but in a floating layer. Flip the copy vertically,
then move it beneath the original, and then set the
opacity to about 40%.

The copy is now on a floating layer, so you should
anchor it.
Using the rectangle select again, select both
filmstrips, then click Filters > Distorts > Curve
Bend . You’ll get the first window below. In the center
you’ll see the setting “Curve for Border”. Click on
Upper first, and drag the left end of the line from
center to the shape you see in the second window
below. Then choose Lower, and drag the center line
to the lower shape (center).
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Let’s give this a background. Create a new
transparent layer and move it underneath your
filmstrip. Choose the Gradient tool, FG to BG, and
make your foreground black and your background
white. Start at the top of the top strip and drag to the
top of the bottom strip.

Click on OK. This filter takes a few seconds to work
depending on your system. Notice that this is also
put on a floating layer, and you can see the original
strip below the curved strip.

Let’s also make the reflection fade out a bit like it
should. Choose the filmstrip layer, right click it and
click Add Layer Mask. In the Add Layer Mask
window, make sure White is chosen. In the Layers
toolbox, click on the layer mask next to the filmstrip
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and using your gradient again, click from the bottom
of the window a little diagonally and up into the strip
a bit so the mask fades out the bottom part of the
strip. How far you go is up to you.

Screenshot Showcase
Now you can merge your layers, and crop your
creation, and you’re finished!

Posted by Alistair Einstein Izzard on January 3, 2022, running Trinity.
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GIMP Tutorial: Photo Editing Revisited
by Meemaw

You will see the photo turn so the horizon is straight,
plus crop a bit of the outside to compensate for the
rotation.

I recently found another tutorial about photo editing
which has some tips we know, plus some we don’t,
so I thought I’d share it.
We always want the photos we take to look their
best, so here are more tips.

Straighten the Horizon
Sometimes we shoot a photo “askew” for artistic
reasons, but most of the time we need it to be level.
Unless you have the uncanny ability to shoot
everything level automatically, it’s going to be off.
Luckily, it’s easy to fix. I actually did another tip for
this in an earlier article, but this method works better.
This barn photo was taken on one of my trips to
Colorado, USA. The horizon isn’t off much, but it will
look better when it’s straightened.

If it looks better to you, finish the job going to Image
> Crop to Content to remove any blank areas
around the corners of the canvas. If not, click Edit >
Undo and try again.

Cropping Photos in GIMP
We’ve done cropping before, but some of the tool
options should probably be explored.

You should also experiment with the composition
guides in the Tool options. This enables you to
overlay several grids (including the rule of thirds
grid) to aid with your crop.

Improve Exposure
If your photo is too light or dark, or contains
highlights where the brightest parts of the frame are
rendered as pure white with no detail, you need to
fix the exposure. I have a photo that’s too dark.

Select the Crop tool (Shift + C). Now click and drag
inside the image to draw the outline of your new
crop. You can hold the Shift key to maintain the
photo’s original aspect ratio, but if the tool is set to
retain the aspect ratio, you’re good.
Select the Measure Tool from the Toolbox. Click on
a point on the horizon in your image, drag your
mouse along the horizon line, then release the
mouse button. Now, under Tool Options , set
Clipping to Crop to result, then click Straighten .
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Just like the Rectangle Select tool, you can hold
your mouse in the corners or edges of the frame and
then drag in or out to correct. You can also click in
the middle of the frame and drag to reposition the
cropped area. Hit Enter to apply.
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Go to Colors > Exposure . In the dialog box that
opens, drag the Black level slider to the right to
darken the blacks in your image. Drag the Exposure
slider right to brighten the image, and left to darken
it.
Make sure Preview is checked to show the real-time
effect of your changes, and select Split view to see
the before and after effects in the same image.
When you’re satisfied, click OK to apply the change.
The black level slider gave me a result I didn’t like,
so I moved it back to zero. However, the exposure
slider, moved right, made a change I thought was
good. The right side is the original, and the left side
is the changed photo.

Image Size enter a new width for your image, in
pixels. Interpolation is usually set to Cubic (I think
it’s the default), which is the slowest but also the
best quality.

Ideally, you should only ever make your images
smaller. If you do need to make any of them bigger,
you should do it in increments of 10 percent, and
inspect the result carefully before doing another 10
percent.
If you want to resize your photos to print them, you
can use Image > Print Size instead. This window
will let you set the size you plan to print your photo.

One tower ofBishop Castle, in South Central Colorado, USA
If you’re working with JPEG files, you should be
careful with the exposure tweaks, because you can
risk introducing noise or otherwise degrading the
image.

Resizing Images
The last job in editing your photos is to resize them
correctly. If you know how big you want to make your
photo, click on Image > Scale Image , then under
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Hopefully, you have gotten a few more tips on
making your photos look their best!
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GIMP Tutorial: Photo Editing, Part 3
by Meemaw

parts of the picture until you find one that you’re
happy with.

In an ongoing effort to provide you with several ways
to tweak your photos, I have found a few more tips
that you can use in GIMP.

Tweaking Photo Colors in GIMP
Tweaking the colors of your photos can make
dramatic effects. Depending on what you do with
your photos, you might want vivid colors or subdued
colors.

Correcting White Balance
Sometimes your camera will react strangely to the
light conditions in the scene you want to photograph,
and the photo may have a blue (or strange) hue to it,
when the colors are obviously supposed to be
different. In the photo below, the blue sky almost
takes over the whole photo.

If you aren’t happy with the automatic results, there’s
always another way to do things in GIMP. Choose
Colors > Levels, and toward the bottom of the
window that opens, click on the middle eyedropper
icon. This will let you set a gray point in your image,
an area of neutral color off which all the other colors
will be based.

Click on Colors > Hue-Saturation . The Saturation
slider will boost your colors. Be careful because it’s
very easy to oversaturate your images. A good rule
is to set the saturation to a level that looks okay,
then just drop it back a little. Here, I set the
saturation up.

You can adjust the red, magenta, blue, cyan, green,
and yellow parts of your image separately by
choosing the color and using the Lightness slider.
Choose Colors > Auto > White Balance , and it
should be instantly corrected (center, top).
While it looks to me to be closer to the scene I
remembered when I took the photo, I’ll have to do
some more later. Similarly, you may not like the
results you get.
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With the eyedropper selected, find an area of gray in
the photo and click on it. The color of the whole
photo will update. The good thing about this is that
you can keep clicking different grays in different

You can make a sky look bolder and bluer by
focusing on the blue and cyan colors, and set the
Lightness slider to a darker level. To make grass
and foliage look greener and more vivid, increase
the Lightness level for green. Here, I’ve set the
lightness for green up a bit. It just increased the
green in the foreground (next page, top left).

Page 39

GIMP Tutorial: Photo Editing, Part 3

If you’re left with harsh edges around the areas of
color that you’ve adjusted, drag the Overlap slider to
the right to help blend them better.
After editing a bit more, I came up with this result.

Removing the Background
Sometimes, you shoot what you think is a perfect
shot, but the sky is one big blob of grey-blue. Let’s
remove the sky and replace it with something better.
Fortunately, you can remove the background in
GIMP, which enables you to replace the sky with
something a lot more interesting. In the photo below,
the sky is almost white with no color at all. I want to
replace it with something more colorful (center, top).
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As you can see, the sky has almost no color at all,
even after I used some of the above tweaks on it.
We’ll use one method of editing now. First, choose
Layer > Transparency > Add Alpha Channel . Now,
choose the Fuzzy Select tool, and click on the sky.
You may have to play with the threshold setting to
get only the sky, but you can click, then adjust and
click again. My threshold was 35, and I got the
following:

layer to the bottom of the layers. Export it to a new
file.

See the little dots across the tops of the trees?
Those dots and the dotted lines over the top are
moving, which means that’s your selection. Now
click on Delete . The sky will disappear (right, top).

Several other ways exist to remove a background
from a photo. We’ll soon explore others in upcoming
articles.

Now the only thing left is to add a transparent layer
and paste a different sky into it. Open your sky and
resize it to the width of your photo. Copy and paste it
on a newly created transparent layer, then move that
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GIMP Tutorial: Pattern Filters For Different Effects
by Meemaw

Filters > Render > Pattern > Linear Sinusoid

makes a sort of checkerboard pattern but more
abstract. Loads of settings will let you twist it to your
liking.

I was in GIMP the other day and got into the Render
filter. One of the subcategories is Pattern, and I
hadn’t explored much of that before. It turns out that
there are several items that could be useful.

Filters > Render > Pattern > Checkerboard makes
a checkerboard pattern that can also be edited for
size and color. In this version of GIMP, there are two
menu entries for checkerboard, the new one and the
“Legacy” one. The new one is a straight
checkerboard, but the legacy entry has a checkbox
called “Psychobilly”, which gives a different effect.

Filters > Render > Pattern > Grid

makes a grid

pattern, like graph paper.

Filters > Render > Pattern > Maze makes a maze.

You can make the size bigger or smaller. Clicking on
“New Seed” changes the maze. I’m not sure if each
maze is actually “solvable”, but the design looks
neat anyway.
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Filters > Render > Pattern > Spiral

makes two
different types - Linear and Logarithmic. You can
check “On-canvas controls” and you’ll get the
handles shown. On the linear, it’s just to control the
size of the stroke, but there are two on the
logarithmic, one for the stroke and one for how tight
you want the spiral. Be careful how far you move
your mouse! Your stroke could disappear!

Filters > Render > Pattern > Jigsaw

makes a
jigsaw puzzle with any picture you want. In version
2.10.18, Jigsaw is a legacy filter. In fact, there is a
new and a legacy filter for Checkerboard, Grid, Maze
and Sinus. The new version of these filters have
more settings for more variety. The new versions
have a “G” icon next to them, while the legacy
versions have a gear icon.

Sinus

is another abstract. You’ll see a new version
and a legacy version.

Filters > Render > Pattern > Qbist

is a sort of
abstract pattern generator. You get a grid where you
can choose something that you like. Every time you
click on one, the grid changes to another collection
close to the one you clicked. When you find one you
want, click on it and choose OK (right, top).
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Bayer Matrix is kind of like a checkerboard, except
that all the squares are different shades of gray,
which you can lighten, darken, resize and rotate.

Screenshot Showcase
Looks like we’ll be experimenting for a while!
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Posted by francesco_bat on February 10, 2022, running KDE.
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GIMP Tutorial: Blending Multiple Images
by Meemaw
I saw this the other day, and had thought about
combining some photos. I have grandchildren and it
seems like a neat way to show them at different
ages. However, I’m going to practice with other
photos. This is a pretty quick process.

To blend multiple images together, you will need to
erase the background of one of the top layers in
order to reveal what’s underneath. You can do this
very quickly using Masks .
Open your two images on separate layers in the
same file. What I did was to open my main image in
one layer, then created a white layer in the same
drawing. I then copied and pasted my other photos
to the bottom layer layer.
Select the top layer and click the Masks button at
the bottom of the Layers dock. When the window
comes up, leave the default - White (Full Opacity) ,
then click Add .
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Select the Brush tool and set the color to black.
Now start painting onto the top layer. Where you
paint black, the top layer will be erased and the
bottom layer will become visible.

If you make a mistake, change the brush color to
white. Now paint over the black areas of the mask
and that will make the top layer visible once again. If
it’s a stroke you just made, you can always undo it
using <CTRL> + Z.

Hint:

If you want your background color different,
you can always change that layer’s color by using
Bucket Fill before you open the photo for that layer.
In the photo above, I made my bottom layer blue so
it would show through around the photo. Remember
also, you can make a straight line with your brush by
holding down Shift and clicking each end of where
you want your line. GIMP will draw a straight line
between those two points.
I also did a sort of collage of some of our ATV riding
photos from last summer (top, right).
The hardest thing is remembering where your
photos are to uncover them! Have fun!

It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...
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GIMP Tutorial: Create A Mandala Using Your Name
by Meemaw

I haven’t been to some of my favorite sites for a
while, having other events that were keeping me
busy - you know, Life. However, I happened to go to
one of my favorite GIMP sites the other day - GIMP
Learn. I know I can always find something new to
learn, and that day was no exception. One of the
most talented people on the site, a lady named
Pat625, had posted a fine tutorial a while back, and I
was just now able to go through it. The actual tutorial
is here, and it is wonderful, so I thought I’d share it
with you.
Create a new file, 1,000 px X 1,000 px, with a white
background. Using the guides you can pull from the
left-side and top rulers, place them at 500 px. If you
will check the bar at the bottom of your window, you
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will see “Add Guide” and it will show you when your
guide is at 500 px. Your canvas will look like this:

Create a text box and put your name in it using a
fancy font. Pat625’s suggestion was Rothenburg
Decorative or Strassburg Fraktur, and included them
in her tutorial package. I used Rothenburg (it has
more swirls), but you could use any font you’d like.
The swirly ones make great mandalas! Depending
on how long your name is, your font size should
probably be between 100 and 150. Mine was 150
but could have been a bit more.

When you get it on the canvas, center it in the
background, and move it so the top of the text is just
touching the horizontal guide.

When you get it where it needs to be, right click the
text layer in the layer dialog and choose “Discard
Text Information” since we now need this to just be a
layer. Right click again and choose “Layer to Image
Size”.
Now we’ll use this layer to make our mandala.
Choosing the text layer, duplicate it by clicking on
Duplicate Layer in the Layers dialog. With the
duplicate chosen, click on the rotate tool (GIMP
2.10.22 groups the tools, so it may be in the
transform group depending on your version.) Put
your cursor in the middle of your layer and rotate it
180o. It will look like this now (next page, top left):
Now, right click the top layer and choose “Merge
Down”. NOTE - Keep the text layers separate from
the background (don’t merge all the way down.)
Duplicate the text layer, then rotate the duplicate 90o
(next page, center, left).
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Now we can give it a little flair. In Pat625‘s tutorial,
she had drawn two circles around her mandala. It
looks really neat, so let’s do it. Choose your ellipse
tool and in the toolbox, tick the boxes for “Expand
from center” and “Fixed aspect ratio” so we can
make the circle perfectly round. Starting in the
center, make the circle large enough for the text to
be just inside. We want an actual circle there, so
before you do anything else, choose Edit > Stroke
Selection . Make sure your foreground color is black,
then make your stroke 12 px.

Now, merge that layer down, then duplicate it again.
This time, rotate the new duplicated layer 45o. You
should end up with something that looks like this:

Before you do anything else, click Select > None .
That will deselect the ellipse you just used. Repeat
your circle again, using the ellipse tool, making this
one inside the first. When you do Edit > Stroke
Selection this time, make it 4 or 5 px. Merge down
until you have the drawing on the top layer, and the
background on the bottom layer. Remember to save
your work.

It already looks pretty neat! You can stop now,
export it in the format of your choice, and let a child
or grandchild color it if you wish. However, we can
also add some color to it before we’re finished.
Right click on the top layer and choose Alpha To
Selection . You will see the “walking ants”
everywhere you have any black. Make the black
layer invisible so you can see the result (next page,
top left).
Add a new layer on top of the other two. Now, click
on the Gradients tool, choose Radial gradient, and
whichever gradient you want. Starting from the
center, click and drag your mouse towards the
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Again, you can stop here and export, but I’ll show
you a couple more things you can do. One thing you
can do is to emphasize the colors of your mandala.
If your selection is still active (we did Alpha to
Selection earlier), create a new layer under the top
layer. Choose Edit > Stroke Selection again. Use
around 5 px for your stroke, and make it black. If you
want more black, make it 6 or 7 px.

outside. Remember, any time you don’t like the
result, you can always press CTRL + Z to undo it
and try again. I chose the Caribbean Blues gradient,
and I think I had to reverse it. In the mandala at the
first of the article, I used the Sunrise gradient.
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Another thing you can do, if you don’t want to fill the
background with color, is to add shadows instead.
Choose your mandala layer (the color layer) and go
to Filters > Light & Shadow > Drop Shadow.
Change your shadow, blur radius and opacity to
whatever looks good to you.

The first time I did this tutorial, the result was the first
image below. The second image below (next page,
top left) is the second try.
Another one is to bucket fill the background layer
with color. That’s easy. Just choose the background
layer, choose the bucket fill tool and a color you
want, and click.
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Screenshot Showcase
I hope you enjoyed this one. I thought it was fun!
Depending on the colors and extra effects, they all
look a bit different.

Posted by luikki on February 23, 2022, running KDE.
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Inkscape Tutorial: Create A Rose
by Meemaw
This tutorial is really fun, and
you end up with a pretty
clipart rose.
Draw a simple circle for the
top of the flower.

Use the Spiral tool to draw a spiral within the circle.
You may have to change the settings a bit. I
changed Turns to 2. You can always draw it outside
and drag it into the circle. The outer end of the curve
needs to be on the circle somewhere.

Select the circle and spiral and flatten them a bit.
While they’re still selected, click on Path > Object to
Path to convert them.
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To add character to our rose, let’s use tapered lines.
The first step is to draw a flat ellipse somewhere on
your page, then copy it to your clipboard.
Open the Path > Path Effect Editor. Select the
spiral, add a Pattern Along Path effect, and then
click Paste path (the clipboard) for the pattern
source. Since the ellipse was copied to the
clipboard, its shape will now be stretched along the
spiral.

Next, click on the Nodes tool and move the sides so
they are rounded.

Adjusting the stroke width to 6 will result in this (top,
right):
Now let’s do the rest of the flower. Using the Pencil
tool, with the shape changed to Triangle Out, draw
a triangle shape (right).
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We want a red rose, don’t we? However, you’ll
notice that you can’t fill this shape since it isn’t
closed. So, duplicate the tapered line, click on Path
> Remove Path Effect, and then change the color
of your new section to red.

To finish the flower, we need to draw the stem and
some leaves. Using the Pen tool with a Triangle In
shape, draw a very slightly curved line.

Move the colored section behind the tapered line,
and change the fill on the top circle to red as well.

Before I finish with the flower itself, I want to add
some detail. With the swirl in the center ending at
the bottom right side of the top, that’s naturally
where the petal edge should be, so I will use the
pencil tool again to add a line on top of the flower
that imitates the edge of the petal (center, top). To
easily move the flower, select all and group the
parts.
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The leaves are pretty easy. Use
the Pencil tool with a Triangle In
shape and draw a couple of
freehand lines. Increase the
Smoothing until you get the result
you want. Mine was 50. Draw
another line down the middle for
detail.

We’re finished! That was fun!
If you want to change the background that’s up to
you. Save and export your rose in whatever image
format you want. I made several for a Valentine’s
Day bouquet.

To color the leaf, do the same thing as you did with
the flower - create a copy and click on Path >
Remove Path Effect and change the fill to green.
Place the green section under the outline section.
You can make as many leaves as you want by
grouping the original (if you haven’t already),
duplicating it, flipping it horizontally and placing the
copies on the stem. You can also change the size or
rotate them to get the effect you want (top, right).
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by Meemaw

Duplicate your text and make the duplicate white. Put it behind the original, or put
your original off to the side, and bring back your black rectangle.

The other day I was reading the on forum and came across phorneker’s excellent
post about redesigning his website. When I clicked on the link to go to his
homepage, I thought his title text was very cool. This tutorial is to make
something similar to his.

Go to Filters > Blurs > Blur. When the window comes up change the blur radius
on each to 3. Click Apply. Then close the window.

This is a quick tutorial, easy to do but very striking. You can make this any size or
font you want, but it’s easier to reduce the size than it would be to increase it
(depending on the file format you are using). If you use it on something big, like a
wallpaper, you’ll want it big.
Open Inkscape and choose your canvas. I usually start with one the size of a
piece of US Letter-sized paper (1056 x 816 px), but I know folks who start with a
minimum of 1600 x 1200 px.
Start with a rectangle filled with black. It doesn’t have to cover the whole page
unless you want it to. Set it to the side, and change to the text tool. Decide on
your desired text and enter it in the font of your choice. I used a font called A&S
Speedway.

Now move your black text back, and make sure it’s on top. Choosing the black
text and the blurred text, use the Align and Distribute tool to center them both
ways.

You’re finished! You can group it all and export it.
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This makes a wonderful image, and you can change it up by changing the font or
the colors. Phorneker’s had a smaller blur radius, so you could use 2 instead of 3,
and it would be fine. This is a font called Patriot using blur radius 3, a red
background and blue text.

It's easier than E=mc2
It's elemental
It's light years ahead
It's a wise choice
It's Radically Simple
It's ...
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Inkscape Tutorial: Drawing Realistic-Looking Grass
by Meemaw
I saw this one a while back and it looked really fun!
We’ll be making a bunch of grass that looks realistic.
To do this we’ll have to start with a single blade of
grass.
Using the Pen tool, enable the Triangle out setting
and draw a straight line. Change to the Nodes tool
and widen the bottom of your line just a bit, then
curve the line a little (since grass is never absolutely
straight).

Before we go any
farther,
use
the
Gradient tool to
make a light green to
dark green linear
gradient.

OK, now it’s important that we change the
rotation location on our line. Generally
when you double-click an object, there’s a
small plus sign in the center of it. For this
project, we need to drag that plus sign to
the bottom of our line.
Since we want a whole bunch of grass, we’re going
to use an easy way to get it. Before we learned so
much about Inkscape, our first thought would be to
use <CTRL> + D and duplicate the heck out of that
single line. However, making them all look different
would be loads of work. So instead of that, we will
use Tiled Clones again.
Select your single blade of grass and go to Edit >
Clones > Create Tiled Clones. The first thing you
should do is click on Reset at the bottom of the
window to make sure that no previous settings are
still there. Then, we want the following settings:

The tutorial I read said to make two or three of
these. You can just export, or duplicate one of the
blades of grass and do it again. To make things
easier, group each bunch of grass together so it will
be easier to move. Flip one so they aren’t all going
the same direction. I made three, grouped each one,
then centered the three horizontally and vertically
aligned the bottoms.

After all that I moved them to the bottom of my page.
Put a blurry green rectangle behind your grass to
make it look like it is really thick.

Shift - X - Per column - -85% (This is Minus 85)
Scale - Y - Randomize - 10%,
Rotation Angle - Randomize 10%
Rows - 1, Columns - 475.
Now click Create .

This can be exported by itself. All you have to do is
select your grass, and choose Export Selection. You
should probably export it as a .png to preserve the
transparency. Now, if you are making a scene that
requires grass, you have it covered. Easy, huh?

You’re done!
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Inkscape Tutorial: Drawing A Tree
by Meemaw
I found this tutorial in the same place as the grass
tutorial we did a couple of months ago. This is to
make a tree easily, rather than trying to draw one by
hand.

Open Inkscape and click on Extensions > Render >
Random Tree. You’ll see a dialog box like the one
below.
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There are only two settings: Initial size and
Minimum size. Set those to 100 and 4 respectively.
Check the Live preview box and look at what you
get. You can try again by unchecking the Live
preview box and rechecking it (bottom, left).
I decided on this one:

Open up the Fill & Stroke dialog and change the
Stroke to a color green with a width of about 40px.
Set the Join to Miter so it’s still jagged, like trees
are.

Select your tree and click on Path > Stroke to Path .
This will convert your tree into a much more simple
shape, because we’re going to change it.
We’re going to deal with the leaves and the trunk
separately so, using the Pen tool, draw a shape
around the trunk.

Select both the tree and the shape you just drew
and use Path > Division . You should get something
that looks like the tree below. Change the trunk to a
brown color of your choice.
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Now, with the cut we just made, our leaves look way
too straight on the bottom. To fix this, copy and paste
the leaf bunch and then flip it vertically.

Now, to make it more realistic, copy the entire tree
top and flip it horizontally and give it a slightly darker
green color. You can also rotate it and/or change the
size. Send it to the bottom of your drawing to give it
some depth.

Now place the two leaf sections together, one on top
of the other. You can then group them, or you can
select both leaf objects and do a Path > Union to
merge them. I also lengthened the trunk as well. It’s
your creation, so it’s up to you.

Now we also want to add a shadow to the tree trunk.
Copy the tree top and tree trunk. Give the tree top
copy a black fill with a 50% opacity. Leave the tree
trunk in position as we’ll be clipping it for a proper
shadow.
Move the tree trunk on top of the shadow, select
them both, and click on Object > Clip > Set. What
you will end with is a shadow of the tree top on the
trunk (right, top).
Click on your tree top and bring it back to the front. I
also moved the trunk down just a little, and
shortened up the tree top so the shadow is visible
(right).

PCLinuxOS Magazine

To add some finishing touches, I grouped all the tree
pieces, duplicated the tree, changed the size of the
duplicate and flipped it horizontally. Then I moved it
elsewhere on the page. In addition, I put in some sky
and some of the grass we made a couple of months
ago (next page, top left).
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Screenshot Showcase
The last step is to export the drawing in the format of
your choice.

I’m sure your creation is wonderful! I hope you had
fun with this!

The PCLinuxOS Magazine
Created with Scribus
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Page 56

Inkscape Tutorial: How To Vectorize A Bitmap
by Meemaw
OK, say I’m creating a magazine cover and I just
HAVE to use a certain piece of clipart. The problem
is, when I enlarge it to the size it needs to be, it gets
all fuzzy. For example, maybe I’m doing something
for New Year’s, and want to use this noise maker
clipart:

Well, look at it now, kinda grainy and the edges
aren’t as smooth as the smaller image… is there
anything we can do about that? We could vectorize
it.
Vectorizing it means that we will convert it from a
bitmap to a scalable vector image, which can be
resized without losing any quality. Scalable Vector
Graphics are defined in a text file rather than with
pixels, like many other graphics formats. When you
enlarge a pixel graphic (the image up above is a
png), the pixels enlarge, which allows the image to
lose quality and get grainy. An svg, on the other
hand, is described using an xml text file. The text will
be exactly the same no matter how big you enlarge
the image, so it definitely has advantages.

The first time will be a single scan, which will give us
a black & white image (just for illustration). Make
sure Brightness Cutoff is chosen (and check Live
Preview if you want). You might have to play with
the settings, but the default is pretty good, or you
could go up to 0.500. Click OK. The svg will appear
over the original, but I moved it to the right.

So, can we convert this grainy thing to an svg? Yes!
Let’s do it!
However, for what I’m doing, it needs to be bigger:
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Open your image in Inkscape. Select your image,
and click Path > Trace Bitmap . You’ll see a window
like this:

The black and white image can be saved as an svg.
(Rats! I wanted a color image!) OK, let’s do it again,
and do multiple scans. In your Trace Bitmap window,
choose Colors down under Multiple scans . Also, at
the bottom, uncheck Smooth , as it seems to
improve the quality. The selected image on the right
is the trace. This can now be saved as an svg.
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Look at the difference when I enlarge them both.
The png is on the left. You can see how the png is
fuzzy, but the svg isn’t.

Linux Docs
Linux Man Pages

Screenshot Showcase
While the colors aren’t exact (probably the person
running the program rather than the program itself),
they are very close, and the drawing edges are
much smoother when the image is enlarged.
While this particular image was fairly easy, I have
found a few that are much harder. I think it’s a matter
of finding the right settings for the image you are
using. If your image has a highlight on it, things are
a bit harder. I did this globe as well. As you can see,
the highlighted area looks choppy now, even with
the number of layers increased to 30. I’ll have to
experiment with the settings more, but it seemed to
smooth out when I increased the layers.

I hope this will prove useful to you. I thought it was
fun besides. Your newly made svg’s can be made as
big as you need for your artwork.
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Posted by tuxlink on March 4, 2022, running KDE.
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Inkscape Tutorial: Snowflakes And Christmas Trees
by Meemaw

When you finish that, select all of them and move
them aside. This is also a good time to save your
work, if you haven’t done so already. We’ll make the
tree now.

I found a tutorial the other day that I thought was
really fun! When we are finished, we will have a pile
of snowflakes plus a decorated tree. We’ll do the
snowflakes first.

Select the Polygon tool and choose the Star shape.
Now, change your settings to the following: Corners
- 3, Spoke Ratio - .380. Hold the Control key down
while you drag to create this triangle shape. Fill it
with a green color.

Using the Pen tool, draw a vertical line.
Make the Stroke 8 or 10 with a Square
cap.
Draw a V shape similar to what is below.
Make sure you center it on the first line,
then group the two shapes using Object
> Group or the Group button on the
toolbar..

We’re going to duplicate this object
several times to make our snowflake.
Remember, the rotate tool is shown
when you click on an object a second
time. Make sure you move your
center of rotation to the bottom
before you start.
With the object selected, choose Control+D to
duplicate it, then grab a rotation handle, and hold
Control as you rotate to snap the angle (center,
top).
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Repeat this duplicate/rotate method until you have a
full snowflake shape. It can have 6 “sides” or eight.
Select all pieces and group them together.

With the triangle still selected, click on Path >
Object to Path to create some nodes. Choose the
Nodes tool and select the middle nodes on all
sides, then click Make nodes symmetric.

You can simply change these to white (or really light
blue) and duplicate your snowflakes to make a
background. You can add a blue rectangle to the
background as well.

This curved the paths and will allow you to adjust
them to look more like a tree. You want to pull the
bottom down and the sides out a bit (top left, next
page).
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ones. Now, use Align & Distribute to center all the
tree parts, then group them.

We’re going to create a shadow. First, duplicate
(Control+D ) the triangle shape. Then, using the Pen
tool , draw a simple curved line over this new
triangle. Select both the triangle and the line, then
choose Path > Division to make the cut.

Position the shadow shape over the original triangle
(using Object > Align and Distribute to align the
right sides will make this much easier). It will be
easier to work with if you group these two pieces
together.
Now, select the Rectangle tool
and draw a small, brown,
rectangle for the tree trunk. Click
on Path > Object to Path to
adjust this rectangle so it looks
more like a tree trunk.
We will need to create a shadow
for the tree trunk, just like we did
on the tree. Draw your line over
the duplicated tree trunk, click Path > Division , and
change the color of the one piece. Position it under
the tree, so it looks like it should.

You should end up with two shapes – grab the
shadow shape on the right and delete the rest.
Change the color to a darker green to make it look
like a shadow.
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We’ve created our tree part, so now we can
duplicate it at least twice, resize, and position the
three or four pieces for our tree. As you go down,
make each piece larger (since trees are smaller at
the top) and put the lower ones behind the upper
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This tree needs some ornaments. Click on the
Polygon tool again and change your settings to a 5
pointed star with a spoke ratio of .550 and .140
rounded, filled with yellow.

Now for some round ornaments. Create a red circle
and a white oval for a reflection.
This is optional, but I’m going to draw a pot to put
the tree in. Draw a couple of ovals over each other
with the Ellipse tool . Click Object to Path on both
of these.

Position the pot, tree and trunk and group them all.

To make the pot shape, select the Nodes tool ,
select the side and bottom nodes on the bottom
ellipse, and then click Add nodes . You will get
another node in between each of the ones you
selected.
Again, we will put a shadow on the ornament. Do it
the same way as above.

Select the three bottom nodes, click on the center
one, and drag them down to create the pot (center,
top).
Just like we did on the tree and trunk, duplicate the
pot and create the shadow (center).
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To be a little more realistic, we’ll need a shadow
behind the ornament on the tree, using the same
shadow color as we used on the tree. In this case,
it’s just as easy to draw a circle the same color as
the tree shadow, duplicate and place behind the
ornaments that need shadows.

When you are finished with the tree and ornaments
you can always group the whole bunch.

All that’s left to do is add your snowflake background
to finish the scene. I also added a drop shadow to
the tree. I think it looks great! It was fun as well!

You can get a lot more creative with the snowflakes,
but I’ll let you play with that yourself.
Have a Merry Christmas, or whatever holiday you
celebrate this time of year.
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Inkscape Tutorial: Some Useful And Fun Extensions
by Meemaw
I saw a neat tutorial the other day that outlined
several useful extensions in Inkscape. Khadis did a
calendar article in January 2015 and another article
in February of 2016 describing a few of them, but I
thought I would review a few more. In creating your
masterpiece, you never know what will be useful in
making your work more efficient.

Restack
Suppose you have worked really hard arranging
some objects, and suddenly decide they would look
better if they were reversed? Restack can help.
Select your objects and click Extensions > Arrange
> Restack. In the following image, I stacked the top
row left to right (left-most is on the bottom), and then
I selected them all and duplicated them. I then
moved the duplicates below the originals and did the
restack on them. Notice that they are stacked from
right to left (right-most is now on the bottom).

In the presets, there is a setting called Radial
Outward , so I thought I’d try that with some
Valentine’s hearts that were on the cover of our
February, 2018 issue. You see that radial outward
places the center object on the bottom, and stacks
both ways from there (center, top).
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Barcodes
Khadis’s article showed how to create a QR code. In
Extensions > Render > Barcode, you are able to
generate two other types, Classic and Data Matrix,
shown here. The Classic barcodes have several
kinds, depending on how much and what kind of
information you need it for (written at the bottom of
the barcode). The Data Matrix looks a bit like a QR
Code, and is for the text Inkscape.

Grids
In this extension, you can generate different types of
grids using Extensions > Render > Grids .
Cartesian, Isometric and Polar grids (top, center and
bottom at right) can be generated as well as the
standard grid that looks like graph paper.
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Interpolate
While I can’t think of very many uses for this
extension, it is kinda fun! I’m sure someone more
talented than I can create a wonderful wallpaper with
it. If you have two paths, click on Extensions >
Generate from Path > Interpolate. If your object
are different, the extension seems to form a path of
one object changing to the other.

Interpolation steps

lets you choose how many
intermediate objects you have, and Interpolation
method causes the program to shape the
intermediate objects differently. Use 1 or 2,
whichever looks best to you. Live preview lets you
see what the result is before you apply (when you’re
satisfied, remember to click Apply so your
interpolation will stay after you close the window).

Fractalize

Podcasts For
Linux & BSD

Another fun extension is found at Extensions >
Modify Path > Fractalize. It kinda destroys the
edges and shape of a smooth object, as shown
here. I used the stacked circles, duplicated and then
fractalized them.
Remember, you have to have two items, and you
have to make them paths using Path > Object to
path . Make sure they are both chosen, then choose
Interpolate using the menu directions above. You’ll
get the following window.

The lower your Smoothness number is, the rougher
your creation. The number for the fractal below was
0.1.
I left the Exponent at 0.0, but you can choose other
numbers, even negative ones. Different Exponent
settings makes the mid steps smaller and places
them closer together on one end or the other.

There are many more extensions in Inkscape! We’ll
probably see more in the future.
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Inkscape Tutorial: Stylized Text
by Meemaw
I came across this tutorial a few weeks ago. This is
another method for decorative text, and pretty fun. I
also chose it because it includes keyboard shortcuts
for customizing your text. In some instances, rotating
and moving individual letters will give your text a
different look that works better for your project than
straight text would.
Open a new page, then choose your font and do
your typing. Fat or heavy text will work better for this
- I used a font called Flubber.

Rotation

can be performed on each letter
individually. Alt-[ and Alt-] can be used for counter
and clockwise rotation around the lower left
character anchor point.

Adjusting baselines will move the lines of
closer together. Alt-Up and Alt-Down are

Grab the handle and pull it out, making the text look
heavier. Change the colors on the two different text
items, so you can see what you’re doing. As you can
see below, the white text is the original, and the blue
is the offset text.

text
the
keyboard shortcuts. Note that your anchor will be the
first character in the text to the right of the cursor, so
adjusting the first character will shift the entire line
up or down accordingly.
I chose to space the letters out just a bit, rotate a
few of the letters, and adjust the baseline on most of
them. Playing with my text produced this:
Select the original text object and give it a stroke of
another color that works with your palette. It’s your
project, so pick the colors you like, and colors that
complement each other. Do the same with the outset
text.

Filters >
Shadows and Glows > Drop Shadow to add your
Choose the outset object and use

drop shadow. Choose your original text and do the
same. You can see two samples below.
Now we need to move &/or rotate the individual
characters. You can easily use the keyboard
shortcuts as described below. Note that your cursor
will have to be placed to the left of whichever letter
you want to change, and if there are more letters in
that line, your change may affect them all.

Next, select your text, then use the Linked Offset
tool from the Path menu. This will create the single
node handle to drag outward. Do not change your
original text to a path.

Manual tracking is the distance between each
letter. Using Alt-Right or Alt-Left, you can apply a
shift of one unit left and right. Shift-Alt-Left and
Shift-Alt-Right will apply a shift of ten units each
direction.
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Inkscape Tutorial: Create An Avatar
by Meemaw
An avatar is the graphical representation of
someone, often used in social networks, forums,
games etc. Usually, a 2D-avatar is a square image
which has a small size (100x100px, 64x64px). I’m
going to create an avatar for myself, and you can do
the same. We'll start with simple objects like circles,
ellipses, rectangles and squares.

Create an ellipse and edit its nodes, so that looks
like an ear. Duplicate it (Ctrl+D ) and flip it
horizontally. Place both ears in the middle of the
head.
To create the neck, draw a rectangle, convert it to a
path and place two lower nodes closer to each other.
An easy way is to select them and press Ctrl+<
repeatedly.

There are a couple of useful features in Inkscape
that can help you create avatar easily:

View > Icon Preview will let you preview the page

or selected objects as an icon in different resolutions
(16x16px/24x24px/32x32px/48x48px
and
128x128px). Here’s what I get:

Create shoulders with the rectangle tool and make
the top nodes smoother. Make the shoulders
narrower than normal to focus the viewer's attention
on the head.
In our shape collection above, we see that one is
darker than the rest… that is a duplicate I made of
the neck. Using that duplicate along with the original,
you can create a “separation” between the head and
neck in the form of a shadow.

Create a circle using the circle tool. Convert the
circle to path using Path > Object to Path . Edit the
path by the nodes to make it look like a human
head.
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It shows the icons for several sizes on the right, and
will show on the left what you get if you try to make
your icon any bigger. It will show you how your
creation looks in icon size, to help you determine
how you want to proceed, as far as detail and how
much to include. For example, you could zoom in
and concentrate on the face and omit the shoulders.

View > Duplicate Window will open a new window

with the same document in which you are working.
Editing the original document will duplicate the
changes in the second one. However, you can make

Page 66

Inkscape Tutorial: Create An Avatar
changes in both windows. This feature can be useful
when working in Inkscape as a whole, not just for
this project.

and give them the desired shape, then group them.
If there are a large number of unnecessary nodes,
go to Path > Simplify or just press Ctrl+L after
selecting the path.

Next, work on the facial features..
Also, many head elements are symmetrical and we
can make things much easier. Simply create only
one eye, duplicate it (Ctrl+D ) and flip horizontally.
You can also use your Bezier tool to shape some
hair for yourself, and edit the nodes to shape it the
way you want. I made a couple of shapes in
blending colors, because the light gives everyone’s
hair different highlights (and I also have a big gray
streak in the front). Stack them however they look
correct. This will also give depth & some shading to
your avatar.

In the tutorial I read, the next step was to add color,
but I’ve been coloring everything as I went along.
The next step here is to add some extra detail, like
highlights where needed, and even jewelry if you
want it. I added some eye shadow (I wear a kind of
golden beige, so it really doesn’t show all that
much), highlights in my eyes and on my lips and
hair, and edited the neckline of my shirt to add a
necklace. It’s easy! We’ve used this extension
before. Create one bead with the Ellipse tool, then
draw a necklace path with the Bezier tool. Use the
Pattern along Path extension by clicking Extensions
> Generate from Path > Pattern along Path. Make
sure that you place the bead on top, otherwise the
extension won’t work correctly. To see the result
before you apply, make sure you click Live Preview.
You can make the highlights the same way. (Make
earrings to match!)

Now apply them to your avatar in the places desired.
Mine is pretty simplistic, but it might be close to what
I look like. Note: I’m terrible with facial features!
However, just because I made my avatar similar to
myself doesn’t mean you have to. You can make
yours look like anything or anyone … it’s your
creation!

Usually eyes have an almond shape and are at the
same level with the top edges of the ears. Create an
ellipse and edit the nodes to get it the shape you
want. Create two circles for iris and pupil.
Draw an eyebrow with Bezier curve in “Triangle in”
shape mode. Convert the object to path and smooth
needed nodes.
Draw a lash line with Bezier curve in “Ellipse” shape
mode. Separate lashes can be easily done with
Bezier curve in “Triangle in” shape mode. You can
arrange them the way you want and then group
them.

You should get one object consisting of many beads
along the path.
All that’s left is some fine tuning, like shadows on the
face. Add more details to the hair — most of this can
be done with lines using the Bezier tool. After that,
add shadows under the eyes, a seam/opening on
the shirt and pink highlights on the lips if you haven’t
already done it. How involved you want to get is
entirely up to you. Now export
your avatar! You can export an
icon sized avatar as well. This one
is 128 x 128.

Add details to the ears by using Bezier curve in
“Ellipse” shape mode. Convert both objects to path
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Inkscape Tutorial: Rubber Stamp
by Meemaw
I saw this the other day! It’s a quick and easy way to
create text that looks like it was made with a rubber
stamp.
Create your page, then draw a circle (remember, to
keep your circle perfectly round, you should press
the <Ctrl> key while you draw). Duplicate the circle
and make the duplicate a bit smaller. Also, make the
Stroke size a bit bigger for the inner circle.

Make sure all items are paths (for text, choose Path
> Object to Path and for circles choose Path >
Stroke to Path ). Select all, then choose Path >
Union .
With the Calligraphic tool , draw randomly over the
figure, covering nearly all of it. Select all and choose
Path > Intersection . As you can see, the part
covered with the Calligraphic tool is the part that’s
visible afterwards.

Change the color to whatever you want, then apply a
slight Gradient to it. For a more natural look, you can
add a bit of Gaussian Blur.
Now create your text using the Text tool . Format it
however you want, then place it in the center of the
circles. You can use Align and Distribute to center
everything.
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Inkscape Tutorial: Five Inkscape Essentials
by Meemaw
I found this tutorial while I was looking for some
technical information about Inkscape, and I thought
maybe there were more than just me who didn’t
know some of these methods. As I’ve said before, I
don’t know everything about Inkscape, so I’m
constantly searching for articles or tutorials to
expand my knowledge (I believe I actually only know
enough to be dangerous!)

We wanted a larger area erased, so we’ll adjust the
stroke width. While you have the line chosen, click
on Path > Stroke to Path . Then, go to your
Properties window and adjust the stroke size to
however wide you want. I made mine 12 but you can
make it any size.

Yikes! That’s not what I wanted at all! Using the
eraser added about 100 nodes to our simple circle. It
also looks really rough.

Erasing in Inkscape
Every time I chose the eraser tool in Inkscape, I was
disappointed because it didn’t work like I thought it
should. Just goes to show what I just said about not
knowing everything. Technically, you can’t “erase”
with vector design. Everything is based on points
and lines, so you’ll actually have to add/change the
points in order to give the illusion of erasing. Let’s
see how we do this using a circle:

With both the circle and the line selected, go to Path
> Difference complete your erasing. This looks
much smoother than the first try.

The best way to erase in Inkscape is to use boolean
path operations. Instead of the eraser, we’ll be using
the Pen tool to draw a line similar to the previous
eraser scrub. The good thing about this is that you
can adjust your nodes before you erase.
On the next page you can see the difference in the
two methods. The one on the left was done with the
eraser tool and the one on the right was done with
the pen tool and Path > Difference.

Eraser tool, change the mode to Cut
out from objects, and set the brush Width: 25.
Choose the

Erase across your circle.
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You can change the color of your line (or make it
transparent) so it’s not visible in your project. To
move your text easily to where you want it, you
should group the text and line as well.

Select the image and the rectangle (making sure the
rectangle is on top) and click on Object > Clip >
Set. Everything within the rectangle will be visible,
and everything else will be invisible. What makes
this nice is that you don’t have to stop, open another
program, and crop your image there - you can stay
in Inkscape.

Cropping an object

Curving Text
Sometimes in your graphics creation, you want
something that’s not just straight text, but you want it
to have some shape to it. You can draw a line to
illustrate the curve you want your text to have, but
what to do next? Fortunately, I found out, this is fairly
easy in Inkscape.
Create your text, configuring it however you want,
then draw a line with the bezier tool, and edit the line
so it has the curve you need.

Sometimes you want to use a certain object but it
needs to be cropped. In other programs, you just
draw the rectangle and choose “Crop”, but Inkscape
doesn’t work that way, so we’ll have to do it
differently.
Import the object you want to use, and size it down
to the size you want. I have an image of a penguin I
want to use for a Christmas project, but I only want
the head, so I will import the image, then draw a
rectangle (or even a circle) over the area I want to
use. I made the rectangle a little transparent so I
could see what I was cropping.

Merging Layers
The first thing you need to know is that merging
layers in Inkscape doesn’t work like it does
anywhere else - so let’s look.
I have drawn some rectangles and circles in two
layers. The rectangles are in layer 1 and the circles
are in layer 2, above layer 1. Open the Layers
toolbox to get started.

Select the text and the curve, then click on
Put on Path .

Text >

Make sure both of the layers you want to merge are
unlocked. Select them all and use <CTRL>+X to cut
them (next page, top right).

PCLinuxOS Magazine

Page 71

Inkscape Tutorial: Five Inkscape Essentials
Now, choose Path > Trace Bitmap and you’ll get a
menu. Brightness cutoff 0.450 is default, so I left it
there, then clicked OK. You might play with the
settings if it’s too dark or too light. I’m sure that it
depends on the photo.

Now we have a couple of choices: we can paste
<CTRL>+V our objects to an existing layer, or create
a new one. I chose to paste them all on layer 1. I will
then delete layer 2 since it has nothing on it.

Tracing A Photo
This one might not be used so much, but it looked
fun, so I left it in the list. We’ll use Trace Bitmap to
trace a photo.
Import your photo and make sure it’s selected. I
used a photo of our favorite editor and his lovely
wife.

The generated vector drawing will be lying on top of
the original photo, but you can grab it and move it.
Here, I have moved it to the right of the original
photo.

LINUX IS OUR PASSION

A magazine just isn't a magazine
without articles to fill the pages.

Of course, now that it’s a vector drawing, you can do
all sorts of different things to it if you wish, even
changing the color.

If you have article ideas, or if you
would like to contribute articles to the
PCLinuxOS Magazine,
send an email to:

pclinuxos.mag@gmail.com

We are interested in general articles
about Linux, and (of course), articles
specific to PCLinuxOS.
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Inkscape Tutorial: Fun With The Bezier Tool
by Meemaw

If you click - drag - click - drag, you will get curves.

One of the tools we use a lot is the Bezier tool. It
draws lines, of course (that’s how I make the word
find answer sheet), but depending on the settings, it
does tons more.This time we will just play with this
tool a bit to see what it can do.
When you choose the Bezier tool
, a settings
bar appears at the top (just like with many of the
other tools). From left to right, you have five Mode
buttons (Regular Path, Spiro Path, BSpline, Series
of straight lines and Paraxial lines) and the
dropdown has your shape choices, from None to
Last applied.

you can go to the Path Editing tool
and edit
these paths, even widening the triangle end. Notice
the handle on the corner of the end. When you
hover over it, it will turn red. Grab it and pull
perpendicular to the line and it will widen.

Remember, any curve you draw can be edited with
the path editing tool. If you don’t like the curve you
drew, before you end it, you can backspace and
delete one node at a time until you get back to
where you want. If you start a line by mistake while
you’re trying to do something else, you can do the
same thing. Also if you finish a line before you want
to, you can click on the end and continue, or even
click and draw another line that connects to the end
of the one that wasn’t finished.
If you are trying this stuff, you should now have
several lines. Let’s move on…

The regular path does just what it says it does:
draws paths - straight lines. The difference is what
shape you choose. In the image below, from top to
bottom, the lines are drawn from left to right, and
shapes are None, Triangle in, Triangle out and
Ellipse. These are just lines drawn with one starting
point and one ending point (center, top).
Notice that the top one is the same width throughout
(Shape - None). The next one is wider at the left side
than at the right (Triangle in), and the third is wider
at the right end (Triangle out). Finally, the last is
wider in the center (Ellipse). After you draw these,
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Instead of using the regular path mode, choose the
Spiro tool.
If you draw your lines with a click - move mouse click - move mouse, you can make zig-zag patterns.

Click - move mouse - click - move mouse… your line
should curve by itself, and depending on the shape,
be wider somewhere. Below you can see None,
Triangle in, Triangle out and Ellipse. With a little
practice, you can make a very nice swirl (next page,
top left).
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The next mode will draw a series of straight lines:

of fork, with the fill purple and the stroke black. Then
I copied it to the clipboard. Choosing many of the
modes, and choosing From clipboard as the shape,
I am able to make designs using the “fork” shape I
copied. Below, from top to bottom, are Paraxial,
Spiro, two regular lines, and BSpline, plus the
original “fork”.

These lines can be used for all sorts of things, but
I’m going to start a kind of flourish that could be
used to decorate other artwork.

Amazingly enough, this mode can do something
else as well. If you hold down the <CTRL> key and
click … click .. click … you will end up with a series
of dots (one for each click).
The last mode, called Paraxial lines, draws
perpendicular lines no matter where your mouse
goes:

In a different example, Bend from clipboard uses
the “fork” and actually makes it follow the curve I
drew using Spiro.

I’m also going to describe a few more things that can
be done with this tool.

BSpline

mode will do a different kind of curve. All
you have to do is draw an angle with a couple of
lines… click - move
mouse - click - move
mouse - click. The red
path here is the path I
drew, and the blue
curve is what was
made by the BSpline.
You’ve probably noticed that I haven’t said anything
about the next two shapes. They use objects that
you create and copy to the clipboard. I made a kind
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Playing with all these tools and then editing and
stacking the curves, I came up with the flourish
above, and made another later. They are both on the
next page.
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DOWNLOAD

Mate Desktop

Screenshot Showcase
I’m sure your holiday decorations will be even
fancier now!

Posted by Meemaw on April 28, 2022, running Xfce.
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Inkscape Tutorial: Triangle Campfire
by Meemaw

Shift

I saw this tutorial a few days ago and it looked fun.
Using triangles and the Tiled Clones tool, we’re
going to create a campfire.

Shift X: Per Column: -50%, Randomize: 50%
Shift Y: Per Row: -150%, Randomize: 50%

Rotation

Angle: Randomize: 100%

It’s still a bit square, so let’s remove some of the
clones. Using your Eraser tool, set to Delete
objects, just drag your cursor around to delete some
of those triangles at the top. I also deleted a few at
the bottom to round it off. It should look more like a
fire when you’re finished.

Blur & Opacity

Opacity: Per Row: 1%

Color

Initial Color: (Click on the color swatch at the top,
choose RGB at the top, and put in these settings: R
255, G 228, B 0 then close the color window.
Then in the main settings for that section: H: Per
Row: -0.5%
Finally, change rows and columns to width and
height: 200px wide and 300px tall, and click Create .
You should have ended up with something like this.
Now it looks a bit more like a fire, but it needs some
wood.
First, choose your Bezier tool and draw a tiny
triangle. Make it about 30px by 20px.
Now set the
well.

Fill to Unset, and remove the stroke as

With your tiny triangle selected, click on Edit >
Clone > Create Tiled Clones. If you’ve used the
Create Tiled Clones window, you should probably
click the Reset button at the bottom before you start,
because Inkscape saves your last settings.
The following settings should give us a nice flame
effect:
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Inkscape Tutorial: Triangle Campfire
Using the Rectangle tool and the Bezier tool, I drew
some pieces of wood and placed the fire on them. To
finish, I added a shadow under the campfire.

Screenshot Showcase

The Tiled CLones tool is kinda touchy at times, so
make sure you’ve reset your settings before you
begin. It’s pretty fun! We’ll have to explore this tool
more.

Donate NOW
Posted by brisvegas on May 31, 2022, running Mate.
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Inkscape Tutorial: Create A Website Background
by Meemaw
I saw this the other day. This tutorial uses Inkscape
to create a simple website background using
repeating stripes.

We’re going to make it 200px by 200px. In
Document Properties, on the Page tab, choose the
custom size and enter 200px in height and width.
Select the Grids tabs and create a grid with the
following settings (center, top). If you haven’t done
this before, you select Rectangular grid (it’s the
default) and click New. These settings must be
default, because I didn’t have to change anything.
We also need to activate the Snapping toolbar (View
> Show/Hide > Snap Controls Bar) and enable
snapping, snap nodes/handles, and snap to grids as
shown at right.
Now we’ll use the Pen tool to draw some boxes
(bottom, center). The snapping should make this
much easier.
Continue the boxes as shown at top right. These
have to be exact for the pattern to match up.
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When you finish drawing all of your sections, select
them all and remove the Stroke, but add a black fill
with 6.0 Opacity.

Hope this helps you design an awesome website!
That’s it! You are finished, but for adding the color
you want to use for your webpage background.

Screenshot Showcase

To see how it looked, I went to my seldom-used blog
and chose the blue one as a new background. While
it doesn’t exactly match another item, I can see that
the pattern is good and matches up wonderfully
(center, top).

DOWNLOAD

Mate Desktop
PCLinuxOS Magazine

Posted by sam2fish on May 27, 2022, running Xfce.
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Inkscape Tutorial: Draw A Rope
by Meemaw

With the path selected, open up the Path Effects
dialog by clicking Path > Path Effects , Click the +
button, and choose the Pattern Along Path option
from the dialog. It will add the Pattern Along Path
effect. Note, however, that nothing will change yet.
the Pattern Copies dropdown to Repeated , and
mark the Pattern is vertical checkbox.
I have changed the Spacing value because the
shapes weren’t touching each other. The number is
going to be a negative number, but will vary widely
depending on the size of your image. If a setting of
-1 doesn’t change your path much, try a much larger
number. My setting turned out to be -10. Change
your value until the rope edges line up fairly cleanly.

I saw this tutorial recently, and thought of an
advertisement that I had done for my job. It was an
ad for a rodeo book, so I wanted it to have a western
theme, including a rope. The art department at the
main office did it for me, but with this tutorial, I might
be able to do it myself next time using the Pattern
Along Path effect. Let’s get started.
Using the pen tool in Inkscape,
draw a shape that will make up the
part of our rope that will be
repeated.
Next, create the shape that you
want to apply to your rope. This
can be any shape. In this example,
I just used a simple curve.

Now, select your shape, and copy it to the clipboard
with Edit > Copy or Control+C. Once copied to the
clipboard, select your path again, and in the Path
Effects dialog, press the Link to Path on Clipboard
button (it’s the last button in the Pattern Source
section, with the tiny lock on it).

The spacing is pretty close, but when you zoom in
on the shapes, they may not fit perfectly. Using the
original shape, adjust the nodes until you can see
that the shapes fit together better.

After doing this, your path should look different —
the shape will be stretched out over the length of the
path (right, top).
Well, that doesn’t look like a rope! Let’s change
some settings. With the path still selected, change
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Inkscape Tutorial: Draw A Rope
The key here is that the outside edges line up neatly.
Don’t worry too much about the inside edges. The
result should look something like this:

your rope. Here, I took out a couple of shapes and
rotated the middle section.

Depending on what shape you use, you can make
all sorts of shapes with your length of rope!

My finished rope looks like this:

You can also select your path and tweak the shape
of it if you want. Once you are happy with the shape,
convert it to a path with Path > Object to Path.
NOTE: Once you do this, you can’t change the
shapes anymore.

Support PCLinuxOS! Get Your Official

PCLinuxOS

You can also break your path into individual shapes
with Path > Break Apart, and set the fill colour and
stroke to what you want. Once you set the fill colour,
the inside overlaps will be covered up. You can also
experiment with moving around different sections of
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Introducing Inkscape 1.0
by The Inkscape Team

Smoother performance & first native macOS
application
This latest version is available for Linux, Windows
and macOS. All macOS users will notice that this
latest version is labelled as 'preview', which means
that additional improvements are scheduled for the
next versions. Overall, 1.0 delivers a smoother,
higher performance experience on Linux and
Windows, and a better system integration (no more
XQuartz!) on macOS.

Smoother performance, HiDPI support, new &
improved Live Path Effects & native macOS app
After a little over three years in development, the
team is excited to launch the long awaited Inkscape
1.0 into the world.
Built with the power of a team of volunteers, this
open source vector editor represents the work of
many hearts and hands from around the world,
ensuring that Inkscape remains available free for
everyone to download and enjoy.
In fact, translations for over 20 languages were
updated for version 1.0, making the software more
accessible to people from all over the world.

Freestyle drawing users can now mirror and rotate
the canvas, and test out Xray and Split-view
modes. The new PowerPencil mode of the Pencil
tool provides pressure-dependent width and it is
finally possible to create closed paths. Inkscape now
allows you to vectorize line drawings , too, in the
new unified Trace Bitmap dialog. New path effects
that will appeal to the artistic user include Offset,
PowerClip and PowerMask LPEs.

So many new bells and whistles
One of the first things users will notice is a
reorganized tool box, with a more logical order.
There are many new and improved Live Path
Effect (LPE) features. The new searchable LPE
selection dialog now features a very polished
interface, descriptions and even the possibility of
marking
favorite
LPEs.
Performance
improvements are most noticeable when editing
node-heavy objects, using the Objects dialog, and
when grouping/ungrouping.

A major milestone was achieved in enabling
Inkscape to use a more recent version of the
software used to build the editor's user interface
(namely GTK+3). Users with HiDPI (high resolution)
screens can thank teamwork that took place during
the 2018 Boston Hackfest for setting the updatedGTK wheels in motion.
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Canvas flexibility & more for freestyle drawing

The Split View mode allows to easily edit and preview your
drawing

Duplicate guides, Corners & Hairlines for
technical drawing

The new Live Path Effects Selection dialog

Users who work on technical drawings will
appreciate being able to create a duplicate guide ,
aligning grids to the page, the Measure tool's path
length indicator and the inverted Y-axis, which
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makes coordinates match between the SVG code
and the Inkscape user interface. Potential favorite
new LPEs might be Corners (Fillet/Chamfer) for
even rounding / cutting of path corners, Ellipse from
Points for construction of circles and ellipses and
Measure Segments for architectural plans and
other real-world object measuring. A new
functionality with the Circle Tool means it can create
closed arcs (fillets ) with the click of a button. When
it comes to SVG and CSS, Inkscape 1.0 can make
use of SVG2 vector hatches , and can render and
export hairlines .

and a colorful checkerboard background are now
available. Inkscape 1.0 even features an extension
for creating interactive mockups to simulate user
interaction with an app in the web browser for
presentations to clients and usability testing.

Switching themes on-the-fly
Alignment of objects on cavas with a new set of alignment
handles

Customizable themes, icons, fonts & UI
Even rounding or blunting of corners by a specified radius with
the Corners Live Path Effect

PDF export, text & document fixes for designing
Designers will appreciate being able to export PDFs
with clickable links and metadata. They can enjoy
new palettes and mesh gradients that work in the
web browser, as well as the handy on-canvas
alignment for objects. When it comes to wrangling
text in Inkscape, variable font support, browsercompatible flowed text, simplified, yet powerful
line-height settings will make that a joy. New
templates for different screen sizes, margin guides
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For users interested in customizing their user
interface, Inkscape 1.0 allows for plenty of tinkering.
From menus and toolbars to page sizes and custom
font directories, there is lots to discover. Choose
from your installed themes to give Inkscape a dark
or bright interface, and select one of the available
icon sets, which include customizable single-color
icons and the newly-designed multicolor icon set.
The new dialog for saving the current file as a
template, with keywords and title, allows you to
always have the template you need available.

The PCLinuxOS Magazine
Created with Scribus

Some fundamental changes
The extensions system has undergone some
fundamental changes in version 1.0. Over the
years, Inkscape users have become used to working
with third-party extensions, such as various ones
used for laser cutting and exporting to file formats
which are not a native part of Inkscape. While
outreach to extension developers was undertaken
as Inkscape migrates towards Python 3 and a more
logical and fully tested extensions API (now hosted
in a separate repository), not all third-party
extensions have been brought forward to be
compatible yet. This will mean that 1.0 may not

allow some users to continue with their normal
extensions workflow.

For more details on specific updates in Inkscape
1.0, check out the Release Notes.
Download Inkscape 1.0 now!

Or, wait until the
package reaches the PCLinuxOS repository, and
install it via Synaptic.

Page 83

Inkscape Tutorial: Inkscape 1.0 New Features
by Meemaw

You’ll notice the handles are different now. The ones
in the corners align the objects to that corner. The
ones on the sides, top and bottom are to align left
and right, top and bottom. The square in the center
is the align center. Clicking the square aligns
horizontally to center. If you hold down the Shift key,
it aligns to center vertically.

Custom Inkscape Themes
May 4, 2020
“After a little over three years in development, the team is
excited to launch the long awaited Inkscape 1.0 into the
world.
Built with the power of a team of volunteers, this free and
open source vector editor represents the work of many
hearts and hands from around the world, ensuring that
Inkscape remains available free for everyone to download
and enjoy.”
Finally! Inkscape 1.0 is out!
Reading the release notes, we can see that there
are several new features. I’m going to review just a
few.

On-Canvas Alignment
On-canvas alignment allows you to use many
alignment options on the fly, rather than opening
another window with Align & Distribute. To enable
this, open Object > Align and Distribute and toggle
the on-canvas button, located just under the word
Align in the tool window. After that, the window won’t
need to be opened.
Clicking the selection 3 times shows the handles
(click 1 is select/resize, click 2 is rotate, and click 3 is
align)

Earlier, there were only one or two ways to
personalize certain things on your Inkscape
interface, without actually hazarding a trip to root
and file alteration. Now you can just go to Edit >
Preferences, select the Interface drop down, and
select Theme . Here you can change the entire way
Inkscape looks and adjust icon themes and sizes
separately.

Live Path Effects Makeover!
The live path effects tool has been changed
considerably.
If you want to tinker around with these, select Path >
Path Effects to bring up the menu. Then just select
any path and hit the “+” icon to Add Path Effect,
which brings up this window shown below.

Rotate the Entire Canvas
Nice! A cool feature I never knew I wanted. While
pressing <SHIFT> + <CTRL> , scroll with your
mouse to rotate the canvas to your desired angle.
The bottom right corner of your window now has a
box labeled “R” that shows your angle of rotation
(center, top).
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In previous versions, the window only had a list of
the live paths you could choose. Now they are in a
different window that shows a sample of the effect,
so you know you are getting the right one. In the box
above, you can see three different ways to display
the effects (top center of window). You can choose
icons, smaller icons or a list (which has icons on the
left end of the description).

More Compact Tool Controls Bar

things stacked. With the Split View and the X-ray,
you can see them and it will be easier to grab the
one you want and edit it, without having to use trial
and error to grab what you want or unlayer objects
to find the correct one. Split view divides your page
in half and shows one side as it is, and the other
side with just the frames of your objects without the
colors. The line can be moved left & right or up &
down using your mouse. X-ray view puts a resizable
transparent circle on the drawing that lets you look
past all the color and only at the frames of each
object.

Some control buttons that have been mutually
exclusive (e.g. right-aligned, left-aligned, justified)
have been combined into drop-down lists, so they
now take up less space.

X-ray view is found in the View menu or can be
activated by pressing <Alt> + 6 . The circle that you
use can be made larger or smaller by pressing Edit

> Preferences > Rendering > Rendering XRay
radius.
Snapping

In Edit > Preferences > Behavior > Snapping , a
new option was added to disable snapping in new
documents or files that are opened with Inkscape for
the first time. It’s a checkbox saying Enable
snapping in new documents.

Context menu
The menu that appears after a right-click on the
canvas has been extended at the bottom with the
following items, which makes locking/unlocking and
hiding/unhiding individual objects much easier:
• Hide selected objects
• Unhide objects below (the mouse cursor)
• Lock selected objects
• Unlock objects below (the mouse cursor)

Pinch-to-zoom
On supported hardware (trackpad, touchpad, multi-

touch screen), the canvas can be zoomed with the
two-finger pinch gesture. My laptop touchpad
doesn’t work, but you should try yours. My daughter
has an older Wacom Bamboo (CTH-661) and the
pinch-to-zoom works when it’s connected to my
husband’s laptop running PCLinuxOS Xfce.

Split View and X-ray Modes
Both of these tools make it easier to see what you
have in your drawing, especially if you have several
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Center Page in Window
Split view is found in the View menu or can be
activated by pressing <Ctrl> + 6 .

You might have noticed a new tool up in the toolbar
with the Zoom buttons (Zoom to fit selection in
window, Zoom to fit drawing in window, and Zoom to
fit page in window). Now there is also a tool that
allows you to center your zoomed object in the
window.
If you have zoomed in on
an object, you can center
that in your window
without altering the zoom
you have.
It looks like we’re all going to be doing some
experimentation. This isn’t the limit of the new
features!
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by Meemaw

would be easier to flip the whole canvas than to try
to select everything and flip it.

Inkscape 1.0 came out a bit ago, and I thought I’d
show you a few more of the new features.

Y-Axis Inversion
In this version of Inkscape, the zero measurements
on the canvas are now in the UPPER left hand
corner of the window, rather than the lower left as it
has always been. This makes it more compatible
with other programs that use the svg file format. You
can change it back in Settings.

The tool also has a new option to only measure
selected objects when using click-and-drag.

Calligraphy Tool

Canvas Mirroring
The canvas can now be flipped horizontally or
vertically, to make sure that your drawing is
absolutely straight, and looks good either way. You
can access it from View > Canvas orientation >
Flip horizontally / Flip vertically as shown below. I
didn’t do anything very fancy but you can see it can
be flipped easily. If you had done a very involved
project but wanted to flip to see if it looked good, it
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A new option to add dots has been added to the tool.
Click in place without moving the mouse to create a
dot, and use Shift + Click to create a larger dot.

Measurement Tool
Hovering over a path with the tool now displays the
length, height, width, and position of the path. If you
hover over a group, it will show the width, height,
and position of the group. Holding Shift switches to
showing info about the parts of the group (top, right).

New Live Path Effects
The new window lists the Live Path Effects (LPE) in
alphabetical order, so if you don’t see some of these,
scroll down.
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Dashed Stroke LPE
This new LPE creates uniformly dashed paths,
optionally by subdividing the path's segments, or
including dashes that are symmetrically wrapped
around corners.

Inkscape has so many more features! I hope you’re
exploring!

Measure Segments LPE
This new path effect adds DIN and custom style
measuring lines to "straight" segments in a path
(center).

Linux Training
Courses & Classes

PCLinuxOS Magazine

Offset
Use this to add an offset to your paths, shapes and
groups (right). Compared with the 'Dynamic Offset'
available from the menu, this allows you to:

Donate NOW

• define the offset distance numerically and to
choose the unit, for example, to offset an object
by 3 mm.
• keep sharp corners sharp (or to make them round,
or beveled, if you want to), by using different
methods for calculating the corners (right, center).
• same on-canvas control handle for changing the
offset when using the node tool .
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by Meemaw

At center bottom I saved the settings I always
change to in Inkscape when I’m working on a cover.
I also checked the box to make it the default
template so it opens when I create a new document.
If you have designed a postcard and the basic
settings for all your postcards are the same, you
could save it as a postcard template.

I had just a few more features I wanted to cover,
from Inkscape 1.0. The release notes are here.

Trace Bitmap

Eraser

A new dialog for vectorizing images is now available
from Path > Trace Bitmap . It has the previously
separate Trace pixelart and also a tab for centerline
tracing.

I don’t have a drawing tablet, but I know that many
do, so I thought I’d include this.

Saving the current file as a template
A new entry for saving the current file as a template
has been added to the File menu. You need to
specify a name for it, and optionally, you can add the
template's author, a description and some keywords.
A checkbox allows you to set the new template as
the default template.

Fonts
Load additional fonts
Inkscape can now load fonts that are not installed on
the system. Inkscape has always loaded additional
fonts from its own share folder (in PCLinuxOS it’s
user/share/inkscape/fonts)
and
the
user's
configuration folder (~/.config/inkscape/fonts). Now
you can set other folders in Preferences (see Tools
> Text > Additional font directories). This is good
if you don’t want to install every single font to your
system. You can just put them in another folder
(~/Fonts or something similar) and add that folder in
your Inkscape preferences (center, top).
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• Added option to control eraser width with a
pressure sensitive input device.
• Added thinning, caps, and tremor options (as used
for calligraphy tool).
• New option to erase as clip, which allows the User
to non-destructively erase parts of various types
of elements, including raster images and clones.
Also, from the Release Notes-

“Custom Icon Sets
Icon sets no longer consist of a single file containing
all icons. Instead each icon is allocated its own file.
The directory structure must follow the standard
structure for Gnome icons.
If you would like to create or convert your own icon
set to the new format, please compare the 'hicolor'
and 'Tango' icon theme folders, in your Inkscape
installation's 'share' directory for suitable examples
and check out our guide to making a new multicolor
icon theme.
As a side effect of a bug fix to the icon preview

Page 88

Inkscape 1.0 New Features: Part 3
dialog, custom UI icon SVG files need to be updated
to have their background color alpha channel set to
0 so that they display correctly (see Issue #1661989
(lp)). ”
Inkscape just gets better and better!

Looking for an old article?
Can't find what you want? Try the

PCLinuxOS Magazine's
searchable index!
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Posted by tbschommer, on June 22, 2022, running KDE.
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Inkscape Tutorial: Create A Custom Calendar
by Jimlw1 (with a tiny bit of help from Meemaw)
In this forum post, Jimlw1 wrote:

I don't have an article, but I have designed a Money Holder in LibreOffice Draw
[may be of interest to MeeMaw] that my wife and I use every Christmas for gift
money to family members. It also has a tiny calendar that I make [needs to be
copied and rotated to make a full page of next year’s Calendar for cardstock
printout]. The calendar for printout is made in Inkscape.

sides), one for each starting day. Using these, he creates a month at a time,
putting in the day and month names as well as the year. In order, he creates the
frame for the month, adds the text box for the month and year, then one for the
weekdays, and then adds the correct date box he created for that month (editing
out the dates he doesn’t need, like the 31st in a month with only 30 days). Then,
he groups those together to make one month.

While reviewing his artwork, I remembered that Khadis described how to make a
calendar in the January, 2015 issue. However, Jim’s is a bit different. With
Khadis’s summary of the extension Calendar (found in Extensions > Render >
Calendar), I found that the calendar could only be made for one year. In Jim’s
project, he makes a calendar for 14 months, including December of this year plus
January of 2022, so as to overlap calendars (in case you don’t get a new
calendar right away for 2022). That also allows him to make a 4 x 4 grid and add
some graphics. It also allows him more flexibility in his design. Let’s mess with it
a bit.

Note that each finished month is 2.5 x 2.0 inches (6.35 x 5.08 cm). I’m sure it was
an arbitrary choice to make sure they were all uniform. Since he’s going to put
this on a tri-fold sheet of cover stock to make a money gift card, he needs to
make it small. We know it will end up smaller, but we also know by now that
graphics look better when they are sized down rather than up . You could probably
make them any size that is easy for you, as long as they are ALL the same size.

In Jim’s calendar project, he has text boxes with the dates already laid out (at the
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At this point it might be good to use Align and Distribute to make sure they are
all lined up the way you want them. Jim had 16 rectangles (including a couple of
holiday images), all the same size, and wanted them all touching, in a 4 x 4 grid.
After getting it just the way he wanted it, he exported the calendar page as an
image (next page, top left).
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Inkscape Tutorial: Create A Custom Calendar
His document has items added which can be changed for your card.
Here is mine:

That looks awesome! If you just wanted the calendar, you’re finished. However,
Jim still wanted the tri-fold money card, so his next step was to open a document
in LibreOffice Draw.
Now, Jim used Landscape orientation to make his card, but I changed mine to
portrait. Since it’s your project, you can do it any way that makes sense to you.
Insert any text or images to dress up your card. Here is Jim’s:
I rotated the text and images so that, when it’s folded, the text and the calendar
are all the same orientation.

We’re finished! This is a project that you can customize for yourself. If you want to
use our documents, they can be accessed here.
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