Previous Page
PCLinuxOS Magazine
Article List
Next Page

From The Chief Editor's Desk

Well, I've gone and done it. I've upgraded my first computer to 64 bit PCLinuxOS. I wish I could say that it was an easy, smooth transition, but I would be lying. I suck at lying, so I typically don't. To be honest, it was anything BUT smooth.

It started out smooth enough. It took me a few days to get Xfce setup the way I wanted that worked with my workflow. I chose to upgrade the computer I use for production of the magazine, and chose a time in the early mid-half of the month, hoping to avoid having my production machine out for the count for an extended period of time. I hoped that by doing it earlier in the month, I'd have time to fix any issues before the magazine deadline -- and the end of the month magazine production crunch time -- hit.

But, it didn't work out that way. Nope. No siree.

Ironically, Meemaw also upgraded one of her computers to 64 bit PCLinuxOS, too. She did hers a little earlier in the month. But the irony doesn't end there. We both experienced a problem where neither of us could access the internet, despite our wireless indicators saying we had an outstanding, high quality connection. Plus, we experienced it at about the very same time.

Meemaw's problem was resolved by upgrading to a newer kernel, making her problem relatively short lived. When she told me about the newer kernel fixing her problem, I had high hopes that it would resolve my problem, as well. But I wasn't as lucky.

As similar as our mutual problem seemed to be, it turned out to have very different causes. My computer inexplicably "locks up." I've attributed it to a possible heat problem, although I'm not 100% sure about that. Prior to the onset of problems, the computer had "locked up" and the only way to regain access to the computer was to do a hard power reset. This may have caused some open inodes to remain, causing a possible disk problem. A reinstallation did not fix it, initially, so I reinstalled again, asking the installer to scan the drive media for bad sectors. I also stripped off all of my important files from my /home directory to a USB hard drive, so that I could just reformat the entire hard drive.

Success! It worked ... until I added one of my custom bash scripts back into the mix.

Several years ago, when I was first learning bash scripting, I wrote a program (script) called "Touchpad Toggle." It's simple enough. It simply toggles the touchpad on or off. A modified version of my original script is in the PCLinuxOS repository, as -- you guessed it -- "Touchpad Toggle."

A few months ago, forum member The Chief was seeking a solution that automatically enabled/disabled the touchpad, based on whether or not a USB mouse was connected to the laptop. It caused me to revisit Touchpad Toggle, because what he was asking for was what my ultimate goal was. With a few more years of bash scripting under my belt (I'm nowhere near expert, though), coming up with the solution was much easier than I anticipated. It worked perfectly, except for one thing: it took out my connection to the internet. However, it worked perfectly for The Chief and others. So, some unique state must exist between my particular combination of hardware and the notification area that causes my internet access to disappear whenever a bash script messes with the notification area or pops up a notification. The connection between the hardware, internet connection and notification area is so weird that I cannot even fathom an explanation as to why my internet disappears.

I even tried using the modified version of Touchpad Toggle from the repos, but it also behaved similarly, knocking out my internet access. All because the modification placed an icon in the notification area of the panel. The repo version of Touchpad Toggle works perfectly for Meemaw on her computer, albeit on a computer with a much different hardware profile. The ONLY version of Touchpad Toggle that worked on this particular computer is my original version, which is a version that does nothing at all to the notification area. Instead, it uses a dialog box that appears on the screen to alert you when the touchpad state has been toggled.

Now that I finally have everything working as it should, I'm a bit gun shy about trying anything that might upset the apple cart again, if you know what I mean. But then, I am curious to explore the issue further to see if I can pin down the culprit that knocks my internet out. I wonder if it's net_applet, since Meemaw has switched to using wicd in place of net_applet. But others use net_applet with my script without issue. The script also has no deleterious effects when used with a wired internet connection, even with net_applet managing the wired connection. It also makes me curious if it's a peculiarity with the ralink driver for the wireless adapter on this particular computer. Maybe it's the call to the command that returns the status of and alters the status of the touchpad, because even my "safe" version of the Touchpad Toggle script will knock me offline from time to time. And that ONE command is what is common between the four versions of the script that I've tried. These are the types of things that drive programmer types insane while trying to figure them out.

My experience upgrading this one laptop to 64 bit has also made me somewhat reluctant to upgrade my other capable computers to the 64 bit version of PCLinuxOS. I know that I will eventually have to do so, but it does cause some consternation and reluctance. Coming fresh off of this endeavor, the others can wait a while to be upgraded.

So, until next month, I bid you peace, happiness, serenity and prosperity ... and sanity!

Previous Page              Top              Next Page